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Preface

Welcome to the Microsoft Official Academic Course (MOAC) program for Microsoft Office 2016. 
MOAC represents the collaboration between Microsoft Learning and John Wiley & Sons, Inc. 
publishing company. Microsoft and Wiley teamed up to produce a series of textbooks that deliver 
compelling and innovative teaching solutions to instructors and superior learning experiences for 
students. Infused and informed by in-depth knowledge from the creators of Microsoft Office and 
Windows, and crafted by a publisher known worldwide for the pedagogical quality of its products, 
these textbooks maximize skills transfer in minimum time. Students are challenged to reach their 
potential by using their new technical skills as highly productive members of the workforce. 

Because this knowledgebase comes directly from Microsoft, architect of the Office 2016 system 
and creator of the Microsoft Office Specialist (MOS) exams, you are sure to receive the topical 
coverage that is most relevant to students’ personal and professional success. Microsoft’s direct 
participation not only assures you that MOAC textbook content is accurate and current; it also 
means that students will receive the best instruction possible to enable their success on certifica-
tion exams and in the workplace. 

THE MICROSOFT OFFICIAL ACADEMIC COURSE PROGRAM 
The Microsoft Official Academic Course series is a complete program for instructors and institutions 
to prepare and deliver great courses on Microsoft software technologies. With MOAC, we rec-
ognize that, because of the rapid pace of change in the technology and curriculum developed by 
Microsoft, there is an ongoing set of needs beyond classroom instruction tools for an instructor 
to be ready to teach the course. The MOAC program endeavors to provide solutions for all these 
needs in a systematic manner in order to ensure a successful and rewarding course experience for 
both instructor and student—technical and curriculum training for instructor readiness with new 
software releases; the software itself for student use at home for building hands-on skills, assess-
ment, and validation of skill development; and a great set of tools for delivering instruction in the 
classroom and lab. All are important to the smooth delivery of an interesting course on Microsoft 
software, and all are provided with the MOAC program.
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Book Tour

Pedagogical Features
The MOAC courseware for Microsoft Office 2016 system are designed to cover all the learning 
objectives for that MOS exam, which is referred to as its “objective domain.” Many pedagogical 
features have been developed specifically for Microsoft Official Academic Course programs. 

Presenting the extensive procedural information and technical concepts woven throughout the 
textbook raises challenges for the student and instructor alike. Following is a list of key features 
in each lesson designed to prepare students for success on the certification exams and in the work-
place: 

• Each lesson begins with a Lesson Skill Matrix. More than a standard list of learning objec-
tives, the skill matrix correlates each software skill covered in the lesson to the specific MOS 
exam objective domain. 

• Every lesson opens with a Software Orientation. This feature provides an overview of the soft-
ware features students will be working with in the lesson. The orientation will detail the general 
properties of the software or specific features, such as a ribbon or dialog box; and it includes a 
large, labeled screen image.

• Concise and frequent Step-by-Step instructions teach students new features and provide an 
opportunity for hands-on practice. Numbered steps give detailed, step-by-step instructions to 
help students learn software skills. The steps also show results and screen images to match what 
students should see on their computer screens. 

• Illustrations: Screen images provide visual feedback as students work through the exercises. 
The images reinforce key concepts, provide visual clues about the steps, and allow students to 
check their progress. 

• Knowledge Assessment: Provides questions from a mix of True/False, Fill-in-the-Blank, and 
Multiple Choice, testing students on concepts learned in the lesson.

• Projects: Provide progressively more challenging lesson-ending activities. 
• Online files: The student companion website contains the data files needed for each lesson. 
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Instructor Support Program

The Microsoft Official Academic Course programs are accompanied by a rich array of resources 
that incorporate the extensive textbook visuals to form a pedagogically cohesive package. These 
resources provide all the materials instructors need to deploy and deliver their courses. Resources 
available online for download include: 

• The Instructor’s Guides contain Solutions to all the textbook exercises as well as chapter 
summaries and lecture notes. The Instructor’s Guides are available from the Instructor’s Book 
Companion site. 

• The Solution Files for all the projects in the book are available online from our Instructor’s 
Book Companion site.

• A complete set of PowerPoint presentations is available on the Instructor’s Book Companion 
site to enhance classroom presentations. Tailored to the text’s topical coverage and Skills Ma-
trix, these presentations are designed to convey key concepts addressed in the text. 

• The Student Data Files are available online on both the Instructor’s Book Companion site and 
for students on the Student Book Companion site.

Student Support Program

COPYING THE PRACTICE FILES
Your instructor might already have copied the practice files before you arrive in class. However, 
your instructor might ask you to copy the practice files on your own at the start of class. Also, if 
you want to work through any of the exercises in this book on your own at home or at your place 
of business after class, you may want to copy the practice files.  
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1

LESSON SKILL MATRIX

Skills Exam Objective Objective Number

Working in the Access Interface Display objects in the Navigation Pane.
Change views.

1.3.4
1.3.5

Selecting Tools and Commands

Defining  Data Needs and Types Change field data types. 2.4.5

SOFTWARE ORIENTATION

The Access Opening Screen

Before you begin working in Microsoft Access 2016, you need to be familiar with the primary user 
interface. In the next section, you will be asked to open a new blank desktop database in Access. 
When you do so, a screen appears that is similar to the one shown in Figure 1-1.

Quick access toolbar Tab

Navigation Pane

Message Bar

Microsoft Office Access Help Ribbon

Status BarWork area

When you create a blank database in Access, the opening screen provides you with a workspace in 
which to build a database. Being familiar with the screen elements helps you understand import-
ant tools and information. The elements and features of your screen may vary if default settings 
have been changed or if other preferences have been set. 

Figure 1-1

Opening screen for new 
blank Access database 
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GETTING STARTED 
A database is a tool for collecting and organizing information. For example, as a database, a 
phone book organizes a large amount of data—names, addresses, and phone numbers—so you 
can access it by name in alphabetic order. Even a grocery list is a simple type of database. A com-
puterized database management system (DBMS), such as Access, enables you to easily 
collect large volumes of data organized into categories of related information. This type of data-
base allows you to store, organize, and manage your data, no matter how complex it is, and then 
retrieve and present it in various formats and reports. Using a DBMS to organize data gives you 
the power to manipulate, view, and report the data in ways that other applications like spread-
sheets and word processing documents cannot. As with any program, however, the first tasks are 
the most basic. This section shows you how to start Access and open an existing database. 

Starting Access
Access 2016 runs on the Windows 7 and later operating systems, and the steps to start Access 
differ depending on the version of Windows you have installed on your system. 

When you start Access, a start screen with several options related to creating a database appears. 
The Access startup screen allows you to create a new, custom web app database, a blank desktop 
database, a database from a template, open a recent database (if you have already created one), or 
search online for templates. 

Take Note A web app database is a type of database that was introduced in Access 2013. It allows you to share 
the database with others as a Microsoft SharePoint app (an application on a network-based service 
that allows for collaboration) in a web browser or through Office 365 (a subscription-based version 
of Office provided on the web).

In Office 2016, you can sign into an Office application using your Microsoft or Organizational 
account. You can easily create a Microsoft account when you sign up for a Microsoft web service 
such as OneDrive, Xbox Live, Outlook.com, or other Microsoft service. An Organizational ac-
count is an account that your workplace or school would use to connect you to a Microsoft service. 
Once you sign in, your sign-in information will appear in the upper-right corner of each of the 
Office 2016 applications. This account information includes your name, email address, and user 
icon. You can use the Switch account command beside your user icon to sign in as a different user. 

Microsoft enables you to sign into Office to make it easier for you to access and share your doc-
uments from virtually anywhere. You can open and save your documents using OneDrive, a free 
cloud-based file sharing service that can be accessed from any Internet-connected computer. Sign-
ing into Office also allows access to your personalized application settings and themes, and will 
even remind you where you left off in your document.

In this exercise, you learn to start Access from both Windows 10 and Windows 8 systems.

STEP BY STEP Start Access in Windows 10

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary.

1. Press the Windows key on the keyboard to display the Start menu.

2. Click All apps, point to Access 2016 (see Figure 1-2), and then click Access 2016 to start 
Access and display its Start screen (see Figure 1-3).
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Click to access
Open dialog box

Create a new 
desktop database

Create a new  custom web 
app database

Search online for 
templates

User account sign-in 
information

Microsoft
templates

Take Note If you preferred the Windows start screen from Windows 8, you can configure it to appear on 
Windows 10. Click Start, Settings, Personalization, and Start. Turn the Use Start full screen op-
tion to On.

PAUSE. LEAVE Access open to use in the next exercise.

Figure 1-2

Open Access 2016

Figure 1-3

The Access startup screen

Clip art courtesy of Microsoft
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STEP BY STEP Start Access in Windows 8

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary.

3. When starting Windows 8, if the Windows 8 Start screen doesn’t appear, press the 
Windows key on the keyboard to display it. 

4. If necessary, scroll to the Access 2016 tile. 

5. Click the Access 2016 tile. The Access startup screen opens.

PAUSE. LEAVE Access open to use in the next exercise.

Take Note The Microsoft Office 2016 System, including Access 2016, is not compatible with Windows XP 
and earlier Microsoft Windows operating systems.

Opening an Existing Database 
When you open an existing database, you access not only your previously entered and saved data, 
but also the elements you created to organize that data. In this exercise, you open a database that 
is in the beginning stages of development.

The Open Other Files command on the Access startup screen displays the Open screen. From 
there, you can choose to open a recent file, a file on your OneDrive location, This PC, or you can 
Add a Place or Browse for a file. The This PC command allows you to find files stored locally in a 
folder on your computer or on some type of removable media, or on a network drive. The Add a 
Place command allows you to set up network locations like OneDrive or an Office 365 SharePoint 
location. The Browse button opens the Open dialog box.

The left-hand pane of the Open dialog box lists the available locations for files, such as a folder, 
drive, or network/Internet location. Click the location, and the folders will be displayed in the 
folder list. From this list, you can double-click the folder you want to open. When you find the 
file you want, double-click the filename to open it or click it once to select it and then click the 
Open button.

STEP BY STEP Open an Existing Database

GET READY. The Access startup screen should be on the screen from the previous 
exercise.

1. Click the Open Other Files command on the left side of the Access startup screen. The 
Open screen appears, as shown in Figure 1-4.

2. Click Browse, navigate to the data files for this lesson, and then select 
StudentInformation.accdb, as shown in Figure 1-5.

3. In the Open dialog box, click the Open button. The existing database opens.

Take Note Your figures might look slightly different depending upon which folder you have stored your files.

Take Note As part of the Access 2016 security model, when you open a database outside of a trusted location 
or the database contains active content (content that can be misused by an unscrupulous person 
to cause harm to your computer), a Message Bar appears warning you that certain content has 
been disabled. If you know you can trust the database, click Enable Content. You can trust the 
databases downloaded from the book companion website, so click Enable Content on the Message 
Bar for all databases in this book.

PAUSE. LEAVE the database open to use in the next exercise.
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If you open a file in a multi-user environment such as a SharePoint drive, other users can read and 
write to the database as well; therefore, you may want to open the database with other options. 
Click the down arrow next to the Open button to view these options:

• Open: Opens with default access.
• Open Read-Only: Opens with only viewing ability and not editing ability. Others can still 

read and write.
• Open Exclusive: Opens so that the database is only available to you. Others will receive a 

message that the file is already in use.
• Open Exclusive Read-Only: Opens with only viewing ability and not editing ability. Others 

can only view and not edit the database.

Figure 1-4

The Open screen

Figure 1-5

The Open dialog box
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Take Note Each time you start Access 2016, you open a new instance, or copy, of Access. You can only open 
one database at a time in a single instance of Access. In other words, you cannot start Access, 
open one database, and then open another database—not without first closing the first database. 
However, you can open multiple databases at the same time by double-clicking another database’s 
icon. For example, to open two Access databases, start Access, open the first Access database, and 
then open a second Access database by double-clicking its database icon in File Explorer (referred 
to as Windows Explorer in previous versions of Windows).

WORKING IN THE ACCESS INTERFACE
The Access 2016 user interface was designed to help you find the commands you need quickly so 
that you can successfully perform your tasks. In this lesson, you will begin using the Navigation 
Pane, exploring the Ribbon and Backstage view.

SOFTWARE ORIENTATION

Navigation Pane

By default, the Navigation Pane, shown in Figure 1-6, appears on the left side of the Access screen 
each time you create or open a database.

Opens Navigation
Pane menu

Shutter Bar  
Open/Close button

Expand or collapse 
group

Double-click database 
object to open it

Search bar

Figure 1-6

Navigation Pane
The Navigation Pane enables you to open, copy, and delete tables and other database objects. It 
also lists all the objects in your database, including: tables (the most basic database object that 
stores data in categories), queries (allow you to search and retrieve the data you have stored), 
forms (control data entry and data views and provide visual cues that make data easier to work 
with), and reports (present your information in ways that are most useful to you). You learn 
more about managing database objects (such as forms, queries, and reports) in later lessons of this 
book. 
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Using the Navigation Pane
Before you can create a database, you need to understand its most basic elements. This section in-
troduces you to some of the elements in a database that help you organize data and navigate using 
the Navigation Pane, object tabs, and different views.

STEP BY STEP Use the Navigation Pane

GET READY. USE the Student Information database that is still open from the previous 
exercise.

1. In the Navigation Pane, double-click Students to display the table in the Access work 
area.

2. Click the down arrow next to All Access Objects at the top of the Navigation Pane to 
display the menu, as shown in Figure 1-7.

Categories Groups that relate to the selected category

Take Note The Navigation Pane divides your database objects into categories, and those categories contain 
groups. The default category is Object Type, which groups database objects by their type—tables, 
forms, reports, and so on. You can change the category to Tables and Related Views, which groups 
the objects in a database by the tables to which they are related. You can also change the category 
to one of several other views as shown in Figure 1-7.

3. Click Tables and Related Views. The default group in this category is All Tables, which 
appears in the menu at the top of the Navigation Pane. Notice the Students table and 
all other objects related to it are displayed under the Students object tab. 

4. Click the down arrow next to All Tables at the top of the Navigation Pane to display the 
menu again and then click Object Type to return to the original view.

5. Right-click in the white area of the Navigation Pane to display a shortcut menu. Click 
View By and then click Details.

6. The database objects are displayed with details. Click the right side of the Navigation 
Pane and drag to make it wider so all the information can be read, as shown in Figure 
1-8.

Figure 1-7

The Navigation Pane menu
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Click and drag 
to enlarge
Navigation 

Pane

Details
displayed

7. If the search bar does not appear at the top of the Navigation Pane, right-click the All 
Access Objects header of the Navigation Pane. On the shortcut menu, click Search Bar. 
A search bar is now displayed at the top of the Navigation Pane. 

8. Right-click in the white area of the Navigation Pane, click View By and then click List in 
the shortcut menu to display the database objects in a list again.

9. Click the Shutter Bar Open/Close button to collapse the Navigation Pane. Notice it is 
not entirely hidden, as shown in Figure 1-9.

Navigation 
Pane collapsed

Figure 1-8

Widening the Navigation Pane

Figure 1-9

The Navigation Pane collapsed
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10. Click the Shutter Bar Open/Close button to expand the Navigation Pane again.

PAUSE. LEAVE the database open to use in the next exercise.

Using Object Tabs
When you create a database in Access, all the objects in that database—including forms, tables, 
reports, queries—are displayed in a single window separated by tabs. Tabs help keep open objects 
visible and accessible. To move among the open objects, click a tab. To close a tab, click its Close 
button. You can also right-click a tab to display the shortcut menu, which you can use to save, 
close, close all, or change views. In this exercise, you practice opening and displaying object tabs. 

STEP BY STEP  Use Object Tabs

GET READY. USE the Student Information database that is still open from the previous 
exercise.

1. In the Navigation Pane, double-click Student Details. A new object tab opens to display 
the form.

2. In the Navigation Pane, double-click All Students. A new object tab opens to display 
the All Students report tab along with the other two tabs, as shown in Figure 1-10.

3. Click the Close button on the report tab to close it. 

Object tabs Close button on the report tab

4. Right-click the Student Details tab to display the shortcut menu. This menu allows you 
to save the object, close the object, close all object tabs, or change the object view.

5. Click Close to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 1-10

A tab showing a report along 
with the other two tabs
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Changing Views
Each database object can be viewed several different ways. The main views for a table are Data-
sheet View and Design View. Datasheet View can be used to perform most table design tasks, so 
you will probably use it most often. A datasheet is the visual representation of the data con-
tained in a table or of the results returned by a query. A query is simply a question you can ask a 
table or another query.

To change the view, on the Home tab, click the down arrow on the View button and then choose 
a view from the menu. When you change views, the commands available on the Ribbon change 
context to match the tasks you will be performing in that view. 

STEP BY STEP Change Views

GET READY. USE the Student Information database you used in the previous exercise. The 
Students table should be displayed in the Access work area.

1. On the Home tab, in the Views group, click the down arrow on the View button.

2. Click Design View. The table is displayed in Design View, as shown in Figure 1-11. 
Notice that the Design tab is now displayed on the Ribbon.

View button Design tab

3. On the Design tab, in the Views group, click the down arrow on the View button and 
then click Datasheet View.

4. On the Ribbon, in the Table Tools group, click the Fields tab to display the contextual 
commands for that view.

PAUSE. LEAVE the database open to use in the next exercise.

SELECTING TOOLS AND COMMANDS
A command is a tool (such as an icon, a button, or a list) that tells Access to perform a specific 
task. Each tab provides commands that are relevant to the kind of task you are performing. Many 
of the tools and commands for working with Access are accessible through the Access Ribbon. In 

Figure 1-11

The table shown in Design 
View
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addition to the Ribbon, Access also offers tools and commands on the File menu (also known as 
Backstage view), a Quick Access toolbar, and a status bar (refer to Figure 1-1). In this section, 
you explore the Ribbon, which displays groups of common commands arranged by tabs. 

Using the Ribbon
The Ribbon is located across the top of the screen and contains tabs and groups of commands. 
It is divided into several tabs, which organize tasks according to similar commands you’d like to 
perform on a database. The Ribbon is contextual, which means it offers you commands related to 
the object that you are working on or the task that you are performing.

Some groups have a dialog box launcher, which is a small arrow in the lower-right corner of 
the group that you click to launch a dialog box or task pane that displays additional options or 
information. Some commands on the Ribbon have small arrows pointing down. These arrows 
indicate that a menu is available that lists more options from which you can choose.

In the next exercise, you will practice using the Ribbon.

STEP BY STEP  Use the Ribbon

GET READY. USE the Student Information database that is still open from the previous 
exercise.

1. Click the Home tab to make it active. As shown in Figure 1-12, the Ribbon is divided into 
groups of commands. Notice the dialog box launcher in the lower-right corner of the 
Clipboard group.

Active tab Dialog box launcher

Figure 1-12

The Ribbon and dialog box  
launcher

2. Click the Create tab to make it the active tab. Notice that the groups of commands 
change.

3. Click External Data and then click Database Tools to see the commands available on 
those tabs.

4. Click the Home tab.

5. On the Students Object tab, click the ID column header in the table to select the ID 
column.

6. Click the dialog box launcher in the lower-right corner of the Text Formatting group. 
The Datasheet Formatting dialog box appears, as shown in Figure 1-13.

Figure 1-13

The Datasheet Formatting 
dialog box
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7. Click Cancel to close the dialog box.

8. Double-click the Home tab. Notice the groups are hidden to give you more screen 
space to work with your database.

9. Double-click Home again to display the groups.

10. Click File and then click Close to close the database. Access appears with no database 
open. 

Troubleshooting If you click the Close button (the X in the upper-right corner), Access closes and you will have 
to reopen it for the next exercise. 

PAUSE. LEAVE Access open to use in the next exercise.

Take Note You can customize the Ribbon to have greater control over the commands that appear on it by 
turning off tabs and groups you rarely use, moving and/or duplicating groups from one tab to 
another, creating custom groups, and even creating custom tabs.

Using the Backstage View
Microsoft introduced Backstage view in Office 2010. The Backstage view (Figure 1-14) dis-
plays when you click the File tab from an open database and contains a menu of options and 
commands that allows you to access various screens to perform common tasks with your database 
files—such as creating a new database, opening, saving, printing, closing, and changing user ac-
count settings and options. You can click several options and commands to view related screens 
containing various options and commands used to create and manage your database. The Back 
button returns you to the Access database workspace.

View Save As commands Create new databases  Back button 

Figure 1-14

Backstage view
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The following is an overview of the options in the Backstage view:

• Info: Default view. Use this option to view the current database file path and view and edit da-
tabase properties. Compact and repair the database and encrypt the database with a password 
to restrict access.

• New: Use this option to create a new database from scratch or from available templates.
• Open: Use this option to open an existing database and view a list of recently accessed data-

bases.
• Save: Use this option to return to the open database window where objects can be saved.
• Save As: Use this option to save the current database object (such as a table, query, form, or 

report) as a new object or save the database in another format that is compatible with earlier 
versions of Access. You can save the database to a document management server for sharing or 
you can package the database and apply a digital signature. 

• Print: Use this option to quick-print to a printer, open a dialog box from which to choose print 
options, or preview your document before printing.

• Close: Use this option to close the open database but keep the Access application open.
• Account: Use this option to view and modify user account settings, change application back-

ground and theme, add a service, manage your Office 365 account, update office, and learn 
more about Access. 

• Options: Use this option to customize language, display, proofing, and other settings.
• Feedback: Opens the Windows Feedback dialog box, which allows you to provide feedback to 

Microsoft and explore other users’ feedback.

STEP BY STEP Use the Backstage View

GET READY. START Access if it’s not already running. 

1. Click the File tab. Backstage view opens.

2. Click Open and then navigate to the StudentData database from the data files for this 
lesson. 

3. Click File again. Backstage view now displays a menu of options down the left side of 
the window and information about the currently opened database.

4. Click the New option to view the options and commands available.

5. Click the Save As option to view more options and commands.

6. Select Access Database (*.accdb) if it’s not already selected. 

7. Click the Save As button in the right pane under the Save Database as area to save 
the Student Data file as StudentData-final. Click Yes in the dialog box that appears 
informing you that the objects will be closed. 

8. Select the location to save the file and then click Save. The new database file opens 
automatically.

9. Select File again to re-open Backstage view.

10. Click the Print option to view more options and commands.

11. Click the Account option to view the options and commands shown in Figure 1-15.

12. Click the Options option to view more options and commands.

13. Click the Cancel button to close the Access Options dialog box and return to the Access 
workspace.

PAUSE. LEAVE the database open to use in the next exercise.
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DEFINING DATA NEEDS AND TYPES 
To create a database that achieves your goals and provides you with up-to-date, accurate informa-
tion, you need to spend time planning and designing it.

When planning a database, the first step is to consider the purpose of your database. You need to 
design the database so that it accommodates all your data-processing and reporting needs. You 
should gather and organize all the information that you want to include, starting with any existing 
forms or lists, and think about the reports and mailings you might want to create using the data.

Once you have decided how the information will be used, the next step is to categorize the infor-
mation by dividing it into subjects such as Products or Orders, which become the tables in your 
database. Each table should only contain information that relates to that subject. If you find your-
self adding extra information, create a new table.

In a database table, data is stored in rows and columns—similar in appearance to a spreadsheet. 
Each row in a table is called a record. Each column in a table is called a field. For example, if 
a table is named “Student List,” each record (row) contains information about a different student 
and each field (column) contains a different type of information about a student, such as last name 
or email address.

Once you have decided to create a Student List table, you need to determine what information you 
want to store in the table—such as age, birthdate, or tuition. Organize each piece of information 
into the smallest useful part—for example, use First Name and Last Name instead of just Name 
if you want to sort, search, calculate, or report using either a first name or a last name (or both). 
These pieces of information will eventually become your fields (columns), and each record (row) 
will then contain complete information about each student.

For each table, you will choose a primary key. A primary key is a column that uniquely identi-
fies each row, such as Student ID Number. In the case of our Student List table, the primary key 
(Student ID Number) uniquely identifies each student.

Figure 1-15

The Account options
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Reviewing Database Fields
Reviewing preexisting database fields can give you an idea of the type of information that you 
can store in a database. In this exercise, you open a database that is further along in the process 
of being developed and view the fields in a form to see what a more advanced database looks like.

STEP BY STEP Review Database Fields

GET READY. USE the StudentData-final database that is still open from the previous 
exercise. 

1. On the Student List form, click the ID for record 5 to display the Student Details dialog 
box for Sharon Hoepf, as shown in Figure 1-16.

2. Click the Guardian Information tab and then click the Emergency Information tab. Each 
field on each tab is an example of the type of information that could be contained in a 
database table. 

3. Click Close to close the Student Details dialog box.

PAUSE. LEAVE the database open to use in the next exercise.

Defining and Modifying Data Types for Fields
When designing the database, you set a data type for each field (column) that you create to 
match the information it will store. A data type controls the type of data a field will contain—
whether it is text, number, date/time, or some other type of data. When defining table fields, it is 
important to define them as specifically as possible. For example, if you are using a number, you 
should determine whether you need to use the Currency data type, the Calculated data type, or 
the Number data type. Or, if you need to store large amounts of text, you may need to use the 
Long Text data type (up to 64,000 characters) instead of the Short Text data type (255 characters). 
Sometimes you may also need to modify data types for preexisting fields. 

Access provides 11 data types, each with its own purpose. Table 1-1 describes the types of data 
that each field can store.

Figure 1-16

The Student Details dialog box

Clip art courtesy of Microsoft
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Data Type Example Description

Short Text Last Name: D’Amato
Street: 1234 Landau Ave.

The most common data type for fields. Can store up 
to 255 characters of text, and numbers (or a 
combination of both).

Long Text Comments: Student will 
make monthly payments on 
the 15th of each month of 
$247.

Stores large amounts of text—up to 1 gigabyte (GB) 
—but only the first 64,000 characters of text, and 
numbers (or a combination of both) will be visible on 
the screen.

Number Age: 19
Grade: 95.5

Stores numeric data that can be used in mathematical 
calculations.

Date/Time Birthday: September 5, 1972 Stores date and/or time data.

Currency Registration Fee: $50.00 Stores monetary data with precision to four decimal 
places. Use this data type to store financial data and 
when you don’t want Access to round values.

AutoNumber Student ID: 56 Unique values created by Access when you create a 
new record. Tables often contain an AutoNumber 
field used as the primary key.

Yes/No Insurance: Yes Stores Boolean (true or false) data. Access uses 1 for 
all Yes values and 0 for all No values.

OLE Object Photo Stores images, documents, graphs, and other objects 
from Office and Windows-based programs.

Hyperlink Web addresses Stores links to websites, sites or files on an intranet or 
Local Area Network (LAN), and sites or files on your 
computer.

Attachment Any supported type of file You can attach images, spreadsheet files, documents, 
charts, and other types of supported files (up to 2 GB 
per record) to the records in your database, much like 
you attach files to email messages.

Calculated FullName: John Derenzo Stores an expression based on two or more fields 
within the same table.
Example using concatenation operator (&):
   First: John
   Last: Derenzo
FullName stored as: [First]&” “&[Last]

Take Note Some of the available data types in Access 2016 can only be chosen in table Design View and not 
from the Data Type drop-down menu on the Ribbon. You will learn more about table Design 
View in Lesson 9. 

When you create a new field in a table and then enter data in it, Access 2016 automatically tries 
to detect the appropriate data type for the new column. For example, if you type a price, such as 
$10, Access recognizes the data as a price and sets the data type for the field to Currency. If Access 
doesn’t have enough information from what you enter to detect the data type, the data type is set 
to Short Text. In this exercise, you practice reviewing and modifying data types.

Take Note The Short Text data type and the Long Text data type each has unique properties and size limits, 
depending on whether you’re using them in a desktop database or an Access web app. 

Table 1-1

Types of data stored in fields
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STEP BY STEP Review and Modify Data Types for Fields

GET READY. USE the StudentData-final database that is still open from the previous 
exercise.

1. CLOSE the Student List form.

2. In the Navigation Pane, in the Students group, double-click Students: Table to open it.

3. Click the Date of Birth field header.

4. On the Ribbon, click the Fields tab. Notice in the Formatting group that the Data Type is 
Date/Time.

5. In the Format box, click the down arrow to display the menu of formatting options for 
that type, as shown in Figure 1-17.

6. Click the Last Name header. Notice that the Data Type is Short Text and that no 
formatting options are available for that data type.

7. Scroll to the right and then click the Address header.

8. In the Data Type box, click the down arrow and then click Short Text to change the data 
type. 

Take Note Be aware that changing a data type might cut off some or all of the data in a field; in some cases, 
it might remove the data entirely.

9. Scroll to the far right and then click the Click to Add column header. In the Data Type 
drop-down list that appears, select Yes/No (see Figure 1-18). Once you click Yes/No, 
notice the name of the column header, Field1, is highlighted.

Figure 1-17

Format options for the Date/
Time data type
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10. Rename the field by typing Additional Contact Info on File?. Press Enter and then click 
the Additional Contact Info on File? header.

11. On the Ribbon, in the Formatting group, click the down arrow in the Format box to 
display the menu of formatting options for the Yes/No data type.

12. Click outside the menu to close it.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note The Number data type should be used only if the numbers will be used in mathematical calcula-
tions. For numbers such as phone numbers, use the Short Text data type.

Defining Database Tables
Tables are the most basic organizational element of a database. Not only is it important to plan 
the tables so they will hold the type of data you need, it’s important to plan how the tables and 
information will be connected. In this exercise, you view a visual representation of the relationship 
between two tables.

In a simple database, you might have only one table. Most databases, however, will have more 
than just one table. The tables you include in a database will be based on the data available. For 
example, a database of students might have a table for contact information, a table for grades, and 
a table for tuition and fees.

In database applications like Access, you can create a relational database. A relational database 
stores information in separate tables and these tables are connected or linked by a defined relation-
ship that ties the data together.

STEP BY STEP Define Database Tables

GET READY. USE the StudentData-final database that is still open from the previous 
exercise.

1. On the Database Tools tab, in the Relationships group, click Relationships to display a 
visual representation of the relationship between the Students and Guardians tables, 
as shown in Figure 1-19.

Figure 1-18

The Click to Add menu options
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2. CLOSE the Relationships tab.

3. CLOSE the Students tab.

4. CLOSE the Student List tab.

STOP. CLOSE the database and Access.

An important principle to consider when planning a database is to try to record each piece of 
information only once. Duplicate information, or redundant data, wastes space and increases 
the likelihood of errors. Relationships among database tables help ensure consistency and reduce 
repetitive data entry.

As you create each table, keep in mind how the data in the tables are related to each other. Enter 
test data and then add fields to tables or create new tables as necessary to refine the database. The 
last step is to apply data normalization rules to see if your tables are structured correctly and make 
adjustments as needed. Normalization is the process of applying rules to your database design 
to ensure that you have divided your information items into the appropriate tables.

Database design principles include standards and guidelines that can be used to determine if your 
database is structured correctly. These are referred to as normal forms. There are five normal 
forms, but typically only the first three are applied, because that is usually all that is required. The 
following is a summary of the first three normal forms:

• First Normal Form (1NF): This form divides each field according to its smallest meaningful 
value, removes repeating groups of data, and creates a separate table for each set of related data.

• Second Normal Form (2NF): With this form, each non-key column should be fully depen-
dent on the entire primary key. Create new tables for data that applies to more than one record 
in a table and add a related field to the table.

• Third Normal Form (3NF): Use this form to remove fields that do not relate to, nor provide a 
fact about, the primary key.

Before normalizing a database and defining fields for the efficient storage of data in tables, it’s 
important to know where your data will come from. Data can be brought into an Access database 
in a number of ways, including linking and importing. When defining tables, you have to decide 
whether data should be linked to or imported from external sources. When you import data, Ac-
cess creates a copy of the data or objects in the destination database without altering the source. 
Linking lets you connect to data from another source without importing it, so that you can view 
and modify the latest data in both the source and destination databases without creating and 
maintaining two copies of the same data thereby reducing redundant data. Any changes you make 
to the data in the source are reflected in the linked table in the destination database, and vice versa. 
You find out more about normalizing tables in Lesson 9.

Figure 1-19

A relationship between tables
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Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Record a. Row in a database table

2. Field b. Database object that asks a table a question

3. Query c.  Database object that simplifies the process of entering, editing, 
and displaying data 

4. Form d. Column in a database table 

5. Data type e. Kind of information a field contains

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. Any list you make for a specific purpose—even a grocery list—can be 
considered a simple database.

T F 2. By default, the Navigation Pane appears on the right side of the Access screen 
each time you create or open a database.

T F 3. Forms, queries, and reports are examples of database objects.

T F 4. In a database table, data is stored in rows and columns—similar in appearance 
to a spreadsheet.

T F 5. An important principle to consider when planning a database is to try to record 
each piece of information as many times as possible for easy access.

Projects

Project 1-1: Using the Navigation Pane

As a busy editor at Lucerne Publishing, you use Access to organize and manage your task list. In 
this project, you will use the Navigation Pane to organize your task list.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Task List from the data files for this lesson and then SAVE it as Task List-final.

2. To display the Navigation Pane, click the Shutter Bar Open/Close button.

3. Click the Contacts group header in the Navigation Pane to display those database 
objects.

4. Click the Supporting Objects group header to display those database objects.

5. In the Supporting Objects group, double-click Tasks to open that table.

6. In the Tasks group, double-click Tasks by Assigned To to open that report and view 
data taken from the Tasks table.

7. In the Navigation Pane, click the Tasks Navigation header to display the menu and then 
click Object Type. Notice that the Objects are now displayed by type, such as Tables, 
Queries, Forms, and Reports.

8. SAVE and then CLOSE the database.

PAUSE. LEAVE Access open for the next project. 
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Project 1-2: Creating a Database and Selecting Data Types

You are a volunteer for the Tech Terrace Neighborhood Association that holds an annual March 
Madness 5K Run. In the past, all data has been kept on paper, but you decide it would be more 
efficient to create a database. In this project, you will create a database and select data types.

GET READY. LAUNCH Access if it is not already running.

1. Click File, click New, and then double-click Blank desktop database. 

2. In the Blank desktop database screen that appears in the center of the screen, type 
Runners-final in the File Name box. Click Create.

3. Click Click to Add, select Short Text, and then type Runner Number.

4. Click Click to Add, select Short Text, and then type First Name.

5. Click Click to Add, select Short Text, and then type Last Name.

6. Click Click to Add, select Number, and then type Age.

7. Click Click to Add, select Short Text, and then type First Race?.

8. Click Click to Add, select Number, and then type Previous 5K Time.

9. Click the First Race header and then change the Data Type to Yes/No. 

10. SAVE and then CLOSE the object.

11. Rename Table 1 to Runners.

12. Click OK.

CLOSE the database and then EXIT Access. 
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Skills Exam Objective Objective Number

Creating a Database Create databases using templates.
Create new databases.
Create a database by using import 
objects or data from other sources.

1.1.2
1.1.1
1.1.3

Creating a Table Create tables from templates and 
application parts.
Create new tables.

2.1.5

2.1.1

SOFTWARE ORIENTATION

Getting Started with Microsoft Access

The Access startup screen shown in Figure 2-1 provides options for opening an existing database, 
and creating a new blank database or a new database from a template. This is the default view after 
starting Access. 

Click to
access Open

dialog box

Microsoft 
templates

Create a new blank 
desktop database

Create a new  custom 
web app database

Featured 
template options

Search online 
for templates

Figure 2-1
The Access startup 
screen

Clip art courtesy of Microsoft
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CREATING A DATABASE
In Access 2016, the process of creating a new database is easier than ever. You can create a data-
base using one of the many available templates (ready-to-use databases that contain all of the 
tables, queries, forms, and reports needed for performing specific tasks) or by creating a new blank 
database.

Using a Template to Create a Database
Access offers a variety of templates to help get you started. Some templates are immediately avail-
able for your use because they are built into Access whereas others can be easily downloaded from 
the Internet. There are built-in and online templates are available that you can use to track issues, 
manage contacts, and keep a record of expenses. Some templates contain a few sample records to 
help demonstrate their use. You can use templates as-is or you can customize them to better suit 
your needs. In this exercise, you use one of the many available templates to create a database.

STEP BY STEP Use a Template to Create a Database

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary. LAUNCH Access to display the startup screen.

1. On the top of the startup screen window, in the Search for online templates search box, 
type personal, and then press Enter.

2. In the list of Personal templates that appears in the middle of the startup screen results 
pane, click Home inventory. A preview screen of the selected template appears in 
the center of the startup screen, as shown in Figure 2-2. Close the Home inventory 
template preview screen.

Information about selected template displayed

3. In the search box, type assets and then press Enter. 

4. In the Assets template results list, click the Updated: Asset tracking database. The 
Updated: Asset tracking template preview screen appears.

5. In the Desktop asset tracking template preview screen, click in the File Name box and 
then replace the default file by typing Assets, as shown in Figure 2-3.

Figure 2-2

The Home inventory template 
preview screen
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Key new file name Navigate to a location to save the database

Move to next template in search results listing

Take Note If you do not add an extension to your database file name, Access does it for you—for example, 
Access.accdb.

6. Click the folder icon to the right of the File Name box. The File New Database dialog 
box appears. 

7. Navigate to the location where you want to save the file and then click OK.

Take Note You should save your files in a separate directory from where your data files are stored. This will 
ensure that you don’t overwrite the original data files with your updated files. 

Take Note Unless you choose a different folder, Access uses the following default location in Windows Server 
2008/2012, and Windows 7 and later to store your databases: c:\Users\<user name>\Documents

8. Click the Create button at the bottom of the preview pane. The preview pane indicates 
that the template is being downloaded. When the download is complete, the preview 
pane closes.

9. Access creates and then opens the Assets database, as shown in Figure 2-4. Because 
this database was downloaded from Office.com (a trusted source), click Enable 
Content on the Message Bar. Getting Started and Access Help windows may appear, 
which contain helpful videos and links about using the Asset tracking database. CLOSE 
these windows, if necessary, to return to the Assets database with the Asset List form 
active. 

Figure 2-3

The File Name box and folder 
icon
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10. Click to place the insertion point in the first cell of the Item field and then type Canon 
EOS Rebel T3i. Press Enter.

11. Click the Shutter Bar Open/Close Button, if necessary, to display the Navigation Pane 
to see all the objects in the database.

12. Click File and then click Close to close the database. 

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Blank Database
If you have existing data, you may decide that it is easier to create a blank database rather than 
using a template because it would require a lot of work to adapt your existing data to the template’s 
defined data structure. When you create a new blank database, Access opens a database that con-
tains a table where you can enter data, but it creates no other database objects. By default, Access 
creates a primary key field named “ID” for all new datasheets and sets the data type for the field 
to AutoNumber. In this exercise, you create a new blank database.

STEP BY STEP Create a Blank Database

GET READY. START Access if it’s not already running. 

1. Click the File tab to open the New screen in Backstage view.

Take Note The New screen appears in the Backstage view after you click on the File tab when no database 
is open. When a database is open, the File tab takes you to the Info screen in the Backstage view.

2. In the templates section of the New screen, click the Blank desktop database icon. A 
Blank desktop database screen appears in the center of the screen, as shown in Figure 
2-5.

Figure 2-4

The Assets template database
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3. In the File Name box, type BlankDatabase.

4. If you want to save the file in a location other than the one shown beneath the File 
Name box, click the folder icon to the right of the File Name box and browse to a 
different location.

5. Click Create button create the blank database. Access creates the database and then 
opens an empty table named Table1 in Datasheet view.

Take Note At this point, you could import data from other sources, such as an Excel spreadsheet or another 
Access database, to populate this database. You simply create your new database as you just did, 
and then use the import commands on the External Data tab as discussed in Lesson 14. 

PAUSE. LEAVE the database open to use in the next exercise.

With the insertion point placed in the first empty cell of your new, blank database, you can begin 
typing to add data. Entering data in Datasheet view is very similar to entering data into an Excel 
worksheet, except that data must be entered in related rows and columns, starting at the upper-left 
corner of the datasheet.

The table is structured through rows and columns, which become meaningful as you enter ap-
propriate data. Any time you add a new column to the table, Access defines a new field for that 
column’s data. You do not need to format your data by including blank rows or columns, as you 
might do in an Excel worksheet, because that just wastes space in your table. The table merely 
contains your data. All visual presentation of that data will be done in the forms and reports that 
you design later.

Take Note A database has to be saved first before any objects like tables, queries, forms or reports can be 
added to it. For example, you cannot create a table first and then create the database to hold it.

CREATING A TABLE 
It is easy to create a new table by using the Application Parts gallery and Quick Start. 
Application Parts were introduced in Access 2010 and consist of predefined templates that 
you can add to an existing database to help extend its functionality. Another way to create a table 
is to copy the structure of an existing table and then paste it into the database. You can copy a 
database object and paste it into the same database or into a different database that is open in 
another instance of Access.

Using the Application Parts Gallery and Quick Start
The Templates group on the Create tab contains the Application Parts gallery that you can use to 
insert predefined templates. Application parts vary from a single table to a collection of database 
objects like tables, forms, and reports. The Application Parts gallery consists of two categories: 

Figure 2-5

A Blank desktop database 
screen
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Blank Forms and Quick Start. The Blank Forms category contains a collection of form parts that 
allows you to add predefined forms to a database. The Quick Start category of these templates 
contains a collection of predefined objects arranged by parts for tracking things such as com-
ments, contacts, and issues. In this exercise, you will quickly create a table using the Application 
Parts gallery and Quick Start.

STEP BY STEP Create a Table Using the Application Parts Gallery and Quick Start

GET READY. USE the BlankDatabase database that is still open from the previous exercise. 

1. On the Create tab in the Templates group, click the Application Parts button to display 
the gallery shown in Figure 2-6.

2. In the Quick Start section of the gallery, click Comments. If you are prompted to close 
all open objects before instantiating this application part, click Yes in the dialog box 
that appears. Notice the Comments table appears as a new object in the Navigation 
Pane.

3. Click the Enable Content button on the Message Bar to trust the database if necessary.

4. In the Navigation Pane, double-click Comments to display the newly created table with 
fields for comments. CLOSE the Comments table by clicking the Comments table Close 
button.

5. OPEN the Application Parts menu and then click Contacts. 

6. In the Create Relationship dialog box that appears, select the There is no relationship 
option button and then click Create. A new table is created along with supporting 
forms and report objects, as shown in Figure 2-7.

Figure 2-6

The Application Parts gallery



Lesson 2 28

Newly created Tables, 
Forms and Report 
objects

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Table from Another Table
Another way to create a table is to copy the structure of an existing table using the Copy and Paste 
commands. In this exercise, you copy the structure of an existing table to create a new table.

STEP BY STEP Create a Table from Another Table

GET READY. USE the BlankDatabase database that is still open from the previous exercise. 

1. On the Navigation Pane, right-click the Comments table database object and then 
select Copy from the shortcut menu.

2. Right-click in a blank area of the Navigation Pane and select Paste from the shortcut 
menu. The Paste Table As dialog box appears, as shown in Figure 2-8. Notice the 
default name, Copy Of Comments, in the Table Name box.

3. In the Paste Options section, select the Structure Only option button to paste only the 
table’s structure.

4. Click OK. The new table appears at the end of the list of database table objects in the 
Navigation Pane.

Figure 2-7

New table, forms, and reports 
for contacts
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5. Double-click Copy Of Comments to open the new table. Notice that the structure of the 
new table is the same as the table from which it was copied, as shown in Figure 2-9.

New copied table Duplicated structure

6. Click File and then click Close to close the database. 

PAUSE. LEAVE Access open to use in the next exercise.

When you create a copy of a table by copying and pasting, you can re-create just the table’s struc-
ture or both its structure and data. Access also provides you with a third option that appends data 
to an existing table. If this option is chosen, Access will attempt to append the table’s records to 
another table you specify.

As you learned in Lesson 1, a relational database stores information in separate tables that are con-
nected or linked by a defined relationship that ties the data together. When you add a new table 
to an existing database, that new table stands alone until you relate it to your existing tables. For 
example, say you need to track orders placed by a distributor. To do that, you add a table named 
Distributor Contacts to a sales database. To take advantage of the power that a relational database 
can provide—to search for the orders placed by a given contact, for example— you must create a 
relationship between the new table and any tables that contain the order data.

Figure 2-8

Paste Table As dialog box

Figure 2-9

New table copied from 
existing table



Lesson 2 30

SAVING A DATABASE OBJECT 
Access automatically saves data that you have entered any time you add an Application Part like a 
Quick Start template, move to a new record, close an object or database, or quit the application. 
But you will need to save the design of a table, or any other database object, after it is created. 
Additionally, you can use the Save Object As command in the Backstage view to create a duplicate 
of a database object (like a table, query, or report) by specifying an alternate name. You can even 
save objects in other formats such as the Adobe Portable Document Format (PDF) or XML Paper 
Specification (XPS), which helps you share data with others who may not have Access installed. 
Lastly, you can even save some objects as other compatible object types. For example, you can save 
a table as a new report which will, by default, include all table fields.

Saving a Table
When you save a new table for the first time, give it a name that describes the information it 
contains. You can use up to 64 characters (letters or numbers), including spaces. In this exercise, 
you save a database table, and then use the Save Object As command to create a duplicate of the 
same table. 

STEP BY STEP Save a Table

GET READY. START Access if it’s not already running. 

1. From the File tab, click the New command and then click the Blank desktop database 
icon; a Blank desktop database screen appears in the center of the screen.

2. In the Blank desktop database screen’s File Name box, the default name should be 
Database1. If not, replace the default name by typing Database1.

3. If you want to save the file in a location other than the one shown beneath the File 
Name box, click the folder icon and browse to a different location.

4. Click the Create button. A new blank database appears with the default table labeled 
Table1 displayed.

5. Click to place the insertion point in the cell under the Click to Add field and then type 
Sample Data.

6. Right-click on the Table1 tab to display the shortcut menu and then click Save. The 
Save As dialog box appears.

7. In the Table Name box, type Sample Table.

8. Click OK to close the dialog box and return to the table, which now is labeled Sample 
Table.

9. Click the File tab to display the Backstage view.

10. Click Save As to display the Save As screen.

11. Under the File Types heading, click the Save Object As command.

12. Click the Save As button. 

13. In the Save As dialog box that appears, type Backup of Sample Table in the area under 
“Save ‘Sample Table’ to:” as shown in Figure 2-10.
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Save Object As command
Save Object As  New table name  

in Save As dialog boxSave As button 

14. Click OK.

15. Notice the new table object named Backup of Sample Table in the Navigation Pane.

16. The Backup of Sample Table should now be open. Notice the table contains the same 
row you created in the Sample Table table. 

17. CLOSE the Backup of Sample Table.

STOP. CLOSE the database and then EXIT Access.

Figure 2-10

Save As dialog box on Save 
As screen



Lesson 2 32

Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1. Entering data in Datasheet view is very similar to entering data in a(n) ____________.

2. The ____________ contains predefined templates included in two categories: Blank 
Forms and Quick Start.

3. One way to create a table is to copy the ____________ of an existing table and paste it 
into the database.

4. When you add a new table to an existing database, that new table stands alone until 
you ____________ it to your existing tables.

5. The ____________ category in the Application Parts gallery contains a collection of 
predefined database objects for tracking comments, contacts, and issues.

Multiple Choice
Select the best response for the following statements.

1. In Access, a template is which of the following? 
a. A database to manage contacts
b. Where a database is stored
c. Two tables linked together
d. A ready-to-use database

2. When you create a new blank desktop database, Access opens a database that 
contains which of the following?
a. One of each type of database object
b. A table
c. Sample data
d. A template

3. The Templates group commands are located on which of the following tabs?
a. Home
b. Create
c. Database Tools
d. Datasheet

4. To copy a table, you must first select it in which of the following?
a. The Clipboard
b. Microsoft Office Online
c. The Navigation Pane
d. Datasheet view

5. When you paste a table, which of the following dialog boxes is displayed?
a. Table Structure
b. Copy Table
c. Paste Data
d. Paste Table As
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Projects

Project 2-1: Creating a Database

In this project, you want to use Access to store, organize, and manage the contact information for 
the wholesale coffee suppliers used by Fourth Coffee, where you work as a buyer for the 15 stores 
in the northeast region. Use a template to create a database for the contacts.

 GET READY. LAUNCH Access.

1. In the Search for online templates box, type Call tracker to find Call tracker database 
template and press Enter.

2. Select the Call tracker database template.

3. Type Call tracker in the File Name box.

4. If necessary, click the folder icon and choose a different location for the file.

5. Click Create to create and open the database. Click Enable Content, if necessary.

6. Click the Shutter Bar Open/Close Button to open the Navigation Pane.

7. Click the Supporting Objects header in the Navigation Pane to display the database 
objects in that group.

8. Right-click the Customers table under the Customers header to display the menu and 
click Copy.

9. Right-click in the white area of the Navigation Pane and click Paste.

10. In the Paste Table As dialog box, type Customers Structure.

11. Select the Structure Only option button (the table contains no record data so choosing 
Structure Only will have the same effect as choosing Structure and Data).

12. Click OK.

13. Select the Customers Structure object and drag it up to the Customers area to move it 
from Unassigned Objects to Customers. 

14. Click File and then click Close to close the database. Changes are saved automatically. 

PAUSE. LEAVE Access open for the next project.
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Project 2-2: Adding Tables to a Database

In this project, you are a regional manager for a franchise restaurant chain and you want to keep 
track of restaurant locations and customer comments. You decide to create a database to store the 
necessary information as well as add some tables to the database.

GET READY. LAUNCH Access if it is not already running.

1. In Backstage view, on the New tab (or on the Startup screen, if Access is initially 
launched), click the Blank desktop database icon.

2. In the Blank desktop database screen that appears in the center of the screen, type 
Restaurants in the File Name box.

3. If necessary, click the folder icon and choose a different location for the file.

4. Click the Create button.

5. Right-click the Table1 tab and click Save.

6. In the Save As dialog box, type Locations.

7. Click OK.

8. Click the Create tab, open the Applications Parts gallery, and then click Comments.

9. Click Yes to close all open Objects.

10. In the Create Relationship dialog box that appears, click the Cancel button.

11. Click Enable Content.

12. Rename the Comments table to Uptown Comments.

13. Copy the structure of the Uptown Comments table to create a new table.

14. Name the new table Downtown Comments. Changes are saved automatically.

EXIT Access.
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LESSON SKILL MATRIX

Skills Exam Objective Objective Number

Navigating Among Records Navigate specific records. 1.3.1

Entering, Editing, and Deleting Records Add records.
Update records.
Delete records.

2.3.2
2.3.1
2.3.3

Working with Primary Keys Set the primary key. 1.2.2

Finding and Replacing Data Find and replace data. 2.3.5

Sorting and Filtering Data and Setting Field 
Viewing Options within a Table

Sort records.
Filter records.
Hide fields in tables.

2.3.6
2.3.7
2.2.1

Understanding Table Relationships Enforce referential integrity.
Set foreign keys.
Create and modify relationships.
View relationships.

1.2.3
1.2.4
1.2.1
1.2.5

NAVIGATING AMONG RECORDS 
Database tables can be very large, and contain useful information that can be manipulated in dif-
ferent ways. When a table contains many records and fields, it is important to be able to navigate 
among them. 

Navigating Using the Keyboard
Access users who prefer using the keyboard to navigate records can press keys and key combi-
nations to move among records in Datasheet view. In Datasheet view, you can navigate among 
records using the up, down, left, and right arrow keys to move to the field you want. You can also 
use the Tab key to move from field to field in a record and from the last field in a record to the first 
field of the next record. If you prefer to use the mouse, you can move among records by clicking 
the navigation buttons, which you will do in a later exercise. However, in this exercise, you use the 
keyboard to navigate among records.

Table 3-1 lists keys and key combinations for moving among records.
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Commands Results

Tab or Right Arrow Moves cursor to the next field

End Moves cursor to the last field in the current record

Shift+Tab or Left Arrow Moves cursor to the previous field

Home Moves cursor to the first field in the current record

Down Arrow Moves cursor to the current field in the next record

Ctrl+Down Arrow Moves cursor to the current field in the last record

Ctrl+End Moves cursor to the last field in the last record

Up Arrow Moves cursor to the current field in the previous record

Ctrl+Up Arrow Moves cursor to the current field in the first record

Ctrl+Home Moves cursor to the first field in the first record

STEP BY STEP Use the Keyboard to Navigate among Records 

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and LAUNCH Access.

1. OPEN Fourth Coffee from the data files for this lesson.

2. Click the File tab and then click the Save As option on the left side of the Backstage 
view.

3. Click the Save As command. The Save As dialog box appears. Type Fourth Coffee-final 
in the File name box. Find the location where you will save the solution files for this 
lesson and then click Save.

4. Click Enable Content.

5. In the Navigation Pane, double-click Coffee Inventory: Table to open the table.

6. Notice that the first cell of the first record is selected.

7. Press the Down Arrow key to move down to the next row. Notice that the first cell is 
selected.

8. Press the Right Arrow key to move to the Product Name field.

9. Press the Tab key to move to the next cell.

10. Press the Tab key to move to the next cell.

11. Press the Tab key to move to the next row.

12. Press Ctrl+Down Arrow to move to the first field of the last record.

PAUSE. LEAVE the database open to use in the next exercise.

Table 3-1

Keyboard Commands for 
Navigating Records
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SOFTWARE ORIENTATION

Record Navigation Buttons

The record navigation buttons are displayed at the bottom of the screen in Datasheet view, as 
shown in Figure 3-1. 

First record

Current record box Next record Add new (blank) record

Search boxPrevious record Last record Filter indicator

Click the First record, Previous record, Next record, Last record, and New (blank) Record buttons 
to go to those records. (Your ability to click these may differ based on the number of records in the 
database you have open.) Type a record number into the Current Record box and then press Enter 
to go to that record. Type data into the Search box to find a match in the table. The Filter Indica-
tor shows whether a filter has been applied to the table, which will be covered later in this lesson. 

Using Navigation Buttons
Access users who prefer to use the mouse can use the navigation buttons at the bottom of Data-
sheet view to move among records. In this exercise, you use these buttons to navigate among 
records.

STEP BY STEP Use Navigation Buttons

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise.

1. Click the First record button. The selection moves to the first record.

2. Click the Next record button. The selection moves to the next record.

3. Select and then delete the number 2 in the Current Record box. Type 5 and then press 
Enter. The selection moves to the fifth record.

4. Click the Search box to position the insertion point. Type sunrise into the Search box. 
Notice that the selection moves to the first occurrence of the word Sunrise.

5. Press Enter. The selection moves to the next occurrence of the word Sunrise.

6. Click the New (blank) record button. The insertion point moves to the first column and 
last row of the table.

PAUSE. LEAVE the database open to use in the next exercise. 

Figure 3-1
The Record Navigation 
buttons
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SOFTWARE ORIENTATION

Records Group, Record Selector Box, and Record Shortcut Menu

There are a few ways you can enter record data, delete data from individual fields of records, and 
insert and delete entire records, using the Records group, Record Selector box, and commands 
in the Record shortcut menu (accessed by right-clicking on the Record Selector box), shown in 
Figure 3-2. 

Record Shortcut menu Records group

New recordRecord Selector box

Use the commands in the Records group and the Record shortcut menu, as well as the Record 
Selector box (a blank square to the left of a record), to assist you in entering record data and in-
serting and deleting records.

ENTERING, EDITING, AND DELETING RECORDS 
Keeping a database up-to-date and useful is an ongoing process. You can easily enter data by 
positioning the insertion point in the table cell where you want to add data and begin typing. To 
insert a new record, select any record in the table and then click the New button on the Home tab 
in the Records group. You can also click the Record Selector box, right-click the selected record, 
and then select New Record from the shortcut menu. A new record is added to the end of the table. 
Select existing data to edit or delete it. 

Entering, Editing, and Deleting Records
After you enter data and move to a new field, Access automatically saves the data in the table. Each 
field in a table is formatted with a specific data type, so you must enter that kind of data in the 
field. If you do not, you will get an error message. To delete information from an individual field 
of a record, highlight the field data and then press the Delete key or click the Delete button on 
the Home tab in the Records group. If you change your mind after you delete information from a 
field, you can undo the action by clicking the Undo button on the Quick Access Toolbar. In this 
exercise, you enter a new record as well as edit and delete existing records.

Figure 3-2
Records Group, Record Selec-
tor Box, and Record Shortcut 
Menu
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You can delete an entire record or several records at once from a database. Just select the row or 
rows using the Record Selector box, and then press the Delete key or click the Delete button on 
the Home tab in the Records group. You can also right-click and select Delete Record from the 
shortcut menu. After you delete a record, you cannot undo it. 

STEP BY STEP Enter, Edit, and Delete Records

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise.

1. The insertion point should be positioned in the first field of the new, blank row at 
the bottom of the datasheet. Notice the asterisk in the Record Selector box, which 
indicates that this is a new record, ready for data.

2. Type 21905 and then press Tab. Notice that the asterisk has changed to a pencil icon, 
indicating that the record is being edited.

3. Type Hazelnut and then press Tab.

4. Type 30 and then press Tab. 

5. Type 09252016 and then press Enter.

6. Highlight sunrise in the Search box and then type Kona to locate the Kona record.

7. Click Kona in the record to position the blinking insertion point there. Delete Kona, type 
Hawaiian, and then press Tab.

8. Click the Undo button on the Quick Access Toolbar. Notice Hawaiian disappears and 
Kona reappears. 

9. Press Tab. Type 08212016 and then press Tab.

10. Click the Record Selector box to the left of the Product ID field of the first record, 20051.

11. On the Home tab, in the Records group, click the Delete button drop-down arrow. 
Select Delete Record from the menu (see Figure 3-3). Click Delete Record.

12. A dialog box appears asking if you are sure you want to delete the record. Click Yes. 

13. Notice that the Undo button on the Quick Access Toolbar is not available because you 
cannot undo a record deletion. CLOSE the table.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note You should be cautious when deleting record data. You cannot undo the deletion of a record.

WORKING WITH PRIMARY KEYS 
As you learned in Lesson 1, a primary key is a column that uniquely identifies a record or row in a 
table. Customer IDs, serial numbers, or product IDs usually make good primary keys. Each table 

Figure 3-3

Delete menu
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should have a primary key, and some tables might have two or more. When you divide informa-
tion into separate tables, the primary keys help Access bring the information back together again.

Defining a Primary Key
You can define a primary key for a field in Design view by selecting the row that contains the field 
for which you want to assign a primary key and then clicking the Primary Key button on the Design 
tab in the Tools group on the Ribbon. When you create a new database, Access creates a primary key 
field named “ID” by default and sets the data type for the field to AutoNumber. If you do not have a 
field in an existing database that you think will make a good primary key, you can use a field with the 
AutoNumber data type. It does not contain factual information (such as a telephone number) about 
a record, and it is not likely to change. In this exercise, you define a primary key.

Once a primary key is defined, you can use it in other tables to refer back to the table with 
the primary key. When a primary key from one table is used in another table, it is called the 
foreign key. The foreign key is used to reference the data from the primary key to help avoid 
redundancy.

You can modify a primary key by deleting it from one field and adding it to another field. To re-
move a primary key in Design view, select the row and then click the Primary Key button on the 
Design tab in the Tools group on the Ribbon to remove it.

STEP BY STEP Define a Primary Key

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise.

1. In the Navigation Pane, double-click Order Summary: Table to open the table.

2. On the Home tab, in the Views group, click the bottom half of the View button, and 
from the menu that appears, select Design View.

3. Click the Row Selector box beside the Order ID row to select the row.

4. On the Design tab, in the Tools group, click the Primary Key button. The Primary Key 
button is highlighted. A key icon appears on the Order ID row to designate the field as a 
primary key (see Figure 3-4).

Primary Key button Indicates the field is the primary key

PAUSE. LEAVE the table open to use in the next exercise.

Figure 3-4

Primary Key



Working with Tables and Database Records 41

Defining and Modifying a Multifield Primary Key
In some cases, you may want to use two or more fields that, together, provide the primary key of 
a table. In Design view, select the rows you want to designate as primary keys and then click the 
Primary Key button. To remove multiple primary keys, select the rows, and then click the Primary 
Key button. In this exercise, you practice defining and modifying a multifield primary key.

Two or more primary keys in a table are called the composite key. Composite keys are useful 
in unique situations when a combination of data from two fields needs to provide a unique iden-
tifier in a table. For example, area code field data and phone number field data can be combined 
to create a unique combination of numbers that cannot be duplicated. Separate, neither the area 
code data nor the phone number data is unique and can be duplicated; however, together they 
form a unique set of numbers that cannot be duplicated. Likewise, a business can repeat both 
order identification number field data and customer identification number field data for multiple 
customers; however, these numbers become unique when combined resulting in a composite key 
for each customer.

STEP BY STEP Define and Modify a Multifield Primary Key

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. Be sure you are still in Design View on the Order Summary table. 

1. Press and hold the Ctrl key.

2. Click the Row Selector box beside the Paid row. Continue to hold down the Ctrl key and 
then click the Order ID Row Selector box. Both fields should be selected (see Figure 
3-5). If not, continue to hold the Ctrl key and then click the Paid Row Selector box 
again.

Both fields are 
selected

Figure 3-5

Primary Key row and another 
row selected
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3. On the Design tab, in the Tools group, click the Primary Key button. A key icon should 
be displayed beside both of the two selected fields. The combination of data from 
these two fields do not make a sensible composite key, and this designation will be 
removed.

4. With the rows still selected, click the Primary Key button again to remove the primary 
key designation from both fields. 

5. Click any field name to remove the selection.

6. Click the Row Selector box beside the Order ID row. Press and hold the Ctrl key and 
then click the Row Selector box beside the Customer ID row. Both fields should be 
selected.

7. On the Design tab, in the Tools group, click the Primary Key button. Both rows should 
have a key displayed beside them. The resulting composite key is more valid.

8. Click the Save button on the Quick Access Toolbar.

9. CLOSE the table.

PAUSE. LEAVE the database open to use in the next exercise.

FINDING AND REPLACING DATA 
A big advantage of using a computer database rather than paper and pencil for recordkeeping is 
the ability to quickly search for and/or replace data. You can access these features from the Find 
and Replace dialog box. The Find and Replace commands in Access work very much like those in 
Word and other Office applications. You can use the Find command to search for specific text in 
a table or to move quickly to a particular word or number in the table. You can use the Replace 
command to automatically replace a word or number with something else.

In the Find and Replace dialog box, type the text or numbers that you want to search for into the 
Find What box and then click Find Next to locate the record containing the data. If you want to 
replace the data, type the new data into the Replace With box and then click Replace or Replace 
All.

Take Note When replacing data, it is usually a good practice to click Replace instead of Replace All so that 
you can confirm each replacement to make sure that it is correct.

Finding and Replacing Data
The Find and Replace dialog box searches only one table at a time; it does not search the entire 
database. The Look In menu allows you to choose to search by field or to search the entire table. By 
default, Access searches the field that was selected when you opened the Find and Replace dialog 
box. If you want to search a different field, select the field while the dialog box is open; you do not 
have to close it first. In this exercise, you find and replace table data.

Remember these points when finding and replacing data in Access 2016:

• In the Match menu, you can specify where you want Access to look in a field. Select Any Part 
of Field for the broadest search.

• Sometimes, Access selects the Search Fields As Formatted check box. When it does, do not 
clear the check box, or your search probably will not return any results.

• Click the Match Case box to search for text with the same uppercase and/or lowercase capital-
ization of text.

• You can use wildcard characters such as a question mark or asterisk to find words or phrases 
that contain specific letters or combinations of letters. Type a question mark (?) to represent a 
single character—for example, typing b?t will find bat, bet, bit, and but. Type an asterisk (*) 
to represent a string of characters—for example, m*t will find mat, moment, or even medium 
format.



Working with Tables and Database Records 43

• If you type a wildcard character in the Replace With box, Access will insert that character just 
as you typed it.

STEP BY STEP Find and Replace Data

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. OPEN the Customers table.

2. On the Home tab, in the Find group, click the Find button. The Find and Replace dialog 
box appears with the Find tab displayed.

3. Click the Replace tab in the Find and Replace dialog box.

4. Type Elm into the Find What box.

5. Type Little Elm into the Replace With box.

6. Click the down arrow beside the Look in menu, and then select Current document if it 
is not already selected.

7. Click the down arrow beside the Match menu and then select Any Part of Field if it 
already is not selected to broaden the search (see Figure 3-6).

8. Click the Find Next button. Access searches the table, finds, and selects the word Elm.

9. Click the Replace button. Access replaces Elm with Little Elm.

10. Click the Find Next button. Access finds Elm in the new text that was just inserted.

11. Click Find Next again. Access displays a message saying that no more occurrences of 
the word have been found. Click OK.

12. Click Cancel to close the Find and Replace dialog box.

13. Press the down arrow to remove the selection and allow Access to save the change.

14. CLOSE the table.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note If you want to use the Find and Replace dialog box to search for characters that are used as wild-
cards, such as a question mark, you must enclose that character in brackets, for example [?]. Fol-
low this rule when searching for all wildcard characters except exclamation points (!) and closing 
brackets (]) where you would simply search for these without any surrounding brackets.

ATTACHING AND DETACHING DOCUMENTS 
Access 2016 allows you to attach documents, such as Word documents or photo files, to records in 
a database. For example, the human resources department of a large company could keep a photo, 
a resume, and employee evaluation documents with each employee record. These attached files 
can also be easily detached, if necessary. The Attachments dialog box allows you to manage the 
documents attached to records.

Figure 3-6

Find and Replace dialog box
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Take Note You cannot attach files to databases created in versions of Access prior to Access 2007. You cannot 
share attachments with a database created in these prior versions of Access.

Attaching and Detaching Documents
Before you can start attaching documents, you must create a field in a table and format it with 
the Attachment data type. You can add the field in Datasheet view or in Design view. Access dis-
plays a paper clip icon in the header row and in every record in the field along with a number in 
parentheses indicating the number of attached files in the field. In this exercise, you create a new 
field and format it with the Attachment data type, and then remove the attachment from your 
database records.

Double-click the record in the Attachments field to display the Attachments dialog box where 
you can add, remove, open, or save multiple attachments, such as images, documents, and spread-
sheets, for a single record. You can save attached files to your hard disk or network drive so that 
you can save changes to documents there before saving them to the database. 

Take Note You can attach a maximum total of 2 GB of data, but each individual file cannot exceed 256 MB 
in size.

If the program that was used to create the attached file is installed on your computer, you can open 
and edit the file using that program. For example, if you open a Word resume that is attached to 
a record, the Word program starts and you view the document in Word. If you do not have the 
program that was used to create a file, Access prompts you to choose a program you do have to 
view the file.

STEP BY STEP Attach and Detach Documents

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. OPEN the Order Summary table.

2. Click the header row of the Due Date field to select it.

3. In the Add & Delete group on the Table Tools Fields contextual tab, click the More 
Fields button. The More Fields menu appears (see Figure 3-7).

4. Click Attachment under Basic Types. The Attachment field is inserted in the table.

Figure 3-7

More Fields menu
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5. Double-click the first row of the Attachments field. The Attachments dialog box 
appears.

6. Click the Add button. Navigate to the data files for this lesson and select invoice100.
docx. Click Open. The document appears in the Attachments dialog box.

7. Click OK. The number of attachments in the first record changes to 1.

8. Double-click the attachment number in the Attachment field. The Attachments dialog 
box appears.

9. Click the Open button. The attachment, an invoice document, opens in Word.

10. Click the Close button to close the invoice document and return to Access.

11. Click the Access button on the taskbar, if necessary, to return to Access.

12. In the Attachments dialog box, click the Remove button and then click OK. The 
attachment is removed from the record.

13. CLOSE the Order Summary table.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note Once a field has been set to the Attachment data type, it cannot be converted to another data type.

SORTING AND FILTERING DATA AND SETTING FIELD 
VIEWING OPTIONS WITHIN A TABLE 
It is often helpful to display data in order, display similar records, or hide and freeze certain fields 
without affecting the preexisting data. Sorting allows you to order records. For example, an office 
contact list that displays employees in alphabetical order by last name would help the user find 
information for a particular employee quickly. If you wanted to view only the records of employees 
in a particular department, you could create a filter to display only those records. You could also 
hide or freeze certain fields. For example, in a table that has several fields, you can hide or freeze 
fields to help you concentrate on certain data.

Sorting Data within a Table
To sort data means to arrange it alphabetically, numerically, or chronologically. Sorting within a 
table displays all the records in the table in the order that you select. You can easily sort by one or 
more fields to achieve the order that you want. Access can sort text, numbers, or dates in ascending 
or descending order. Ascending order sorts data from beginning to end, such as from A to Z, 1 
to 10, and January to December. Descending order sorts data from the end to the beginning, 
such as from Z to A, 10 to 1, and December to January. In this exercise, you sort data using mul-
tiple fields, and then remove the sort.

To sort text, numbers, dates, or other data types in a column, you first need to select the column, 
and then click the Ascending or Descending button in the Sort & Filter group of the Home tab. 
You can also right-click a selected column and choose a Sort command from the shortcut menu. 
The available sort commands in the shortcut menu vary depending on the type of data in the 
column. For example, numbers are sorted largest to smallest or smallest to largest, text is sorted 
alphabetically A to Z or Z to A, Yes/No is sorted by cleared or selected, and dates are sorted newest 
to oldest or oldest to newest. 

You can also sort records on multiple fields. When you are using multiple fields, determine in 
which order you want them to be sorted. The primary sort field is called the outermost field. 
A secondary sort field is called an innermost field. For example, if you want to sort a contact 
list so that each employee’s last name is sorted primarily and first name is sorted secondarily, Last 
Name would be the outermost field and First Name would be the innermost field. In your com-
pleted sort, Smith, Lauren, would be listed before Smith, Mark, in an A to Z (ascending) sort. 
When designating the sort order, however, you select the innermost field first and choose the type 
of sort you want from the shortcut menu. Then select the outermost field and then select the type 
of sort that you want.
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After you sort one or more columns, Access inserts sort arrows in the header row to show that 
the field is sorted. These sort commands remain with the table until you remove them. When you 
want to remove a sort order, click the Remove Sort button from the Sort & Filter group on the 
Home tab. This removes the sorting commands from all the fields in the table. In a table with more 
than one sorted field, you cannot remove just one sort. 

STEP BY STEP Sort Data within a Table

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. OPEN the Customers table.

2. Click the header row of the Customer ID field to select it.

3. On the Home tab, in the Sort & Filter group, click the Descending button. The data 
is sorted from largest to smallest, as shown in Figure 3-8. The data is sorted and an 
arrow is inserted in the header row indicating that the data is displayed in descending 
sort order. 

Arrow indicating sorted data

Take Note The arrow points up or down depending on whether the data is sorted in ascending or 
descending order.

4. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The sort is 
removed from the Customer ID field.

5. Select the First Name field, right-click in the field to display the shortcut menu, and 
then click Sort A to Z. The data in the First Name field is sorted in ascending order.

6. Select the Last Name field. On the Home tab, in the Sort & Filter group, click the 
Ascending button. The data in the Last Name field is sorted in ascending order.

Figure 3-8

Sort & Filter group and sorted 
data
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7. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The sort is 
removed from both the First Name and Last Name fields.

8. CLOSE the table. If a dialog box appears asking if you want to save changes to the 
table, click No.

PAUSE. LEAVE the database open to use in the next exercise.

Filtering Data within a Table
A filter is a set of rules for determining which records will be displayed. When you apply a filter, 
Access displays only the records that meet your filter criteria; the other records are hidden from 
view. Once the filtered records are displayed, you can edit and navigate the records just as you 
would without a filter applied. Filters remain in effect until you close the object. You can toggle 
between views, and the filter settings will stay in effect. To make the filter available the next time 
you open the object, save the object before closing it. You can then reapply the filter the next time 
you open the object by clicking the Toggle Filter button in the Sort & Filter group on the Ribbon. 
In this exercise, you practice creating filters in several different ways.

STEP BY STEP Apply a Filter

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. OPEN the Coffee Inventory table.

2. Select the Product Name field. 

3. On the Home tab, in the Sort & Filter group, click the Filter button. A menu appears.

4. Point to Text Filters. A second menu appears. Select Contains (see Figure 3-9). Click 
Contains. 

5. The Custom Filter dialog box appears. Type Decaf and then click OK. Access filters 
the database to display only the records containing the word Decaf. A filter icon is 
displayed in the header row of the field.

6. Click the Toggle Filter button in the Sort & Filter group to display the records without 
the filter.

Figure 3-9

Filter menu with Contains 
selected
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7. In the second record in the Product Name field, double-click the word Decaf to select it.

8. Right-click the word Decaf to display the shortcut menu and then select Does Not 
Contain “Decaf” (see Figure 3-10). Click Does Not Contain “Decaf”. Notice that the 
records are filtered to show only those that do not contain the word Decaf.

9. Click in the Pounds field of the first record.

10. On the Home tab, in the Sort & Filter group, click the Filter button.

11. Click the check boxes to remove the check marks beside (Blanks), 30, 35, 40, and 50. 
Only the check mark beside 25 should remain.

Take Note You can also uncheck Select All, and then check 25.

12. Click OK. Access filters the records to show only those containing the number 25 in the 
Pounds field.

13. Click the Toggle Filter button.

14. In the second row of the Scheduled Order Date field, highlight 9/4/2016 by clicking and 
dragging the mouse. 

Take Note Notice a ‘#’ appears after the ‘9’ and the ‘4’ in the month and day parts of the selected date. This is 
a placeholder character that is part of the input mask field property for this field. This means that 
when data is entered in this field, it must follow a certain pattern. In this case, MM/DD/YYYY.

15. On the Home tab, in the Sort & Filter group, click the Selection button. 

16. Select On or After 9#/4#/2016. The data is filtered to show only those records with 
content in the Scheduled Order Date field that matches the filter selection.

17. In the seventh row of the Pounds field, select 30.

18. On the Home tab, in the Sort & Filter group, click the Selection button, and then select 
Less Than or Equal to 30. The records are filtered accordingly.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note Only one filter can be applied per column. When you apply a filter to a column that is already 
filtered, the previous filter is removed and the new filter is applied.

Figure 3-10

Shortcut menu with Does 
Not Contain “Decaf” option 
selected
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Take Note You cannot apply a case-specific filter. For example, filtering a table for “Decaf” will find all oc-
currences of the word “decaf” including “Decaf”, “decaf”, “deCaf”, etc.

Removing a Filter
After applying a filter, you may need to return to records not displayed by the filter. The Toggle 
Filter button lets you toggle between viewing the filtered records and viewing the table without the 
filter. Note that the purpose of this button changes accordingly—when the records are filtered, the 
button is used to remove the filter, and when the filter is removed the button is used to apply the 
filter. When you are finished using the filter, you can permanently remove it. In this exercise, you 
permanently remove the filter you previously applied.

STEP BY STEP Remove a Filter

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. Select the Pounds field and then on the Home tab, in the Sort & Filter group, click the 
Filter button. A menu appears.

2. Select Clear filter from Pounds.

3. On the Home tab, in the Sort & Filter group, click the Advanced button, and then select 
Clear All Filters from the menu.

4. SAVE and CLOSE the table.

PAUSE. LEAVE the database open to use in the next exercise.

Freezing/Unfreezing and Hiding/Unhiding Fields
Sometimes you may need to change the view of a table’s data to more efficiently find the informa-
tion you are looking for. For example, it may be helpful to freeze First Name and Last Name fields 
so you can keep them fixed on the screen and then horizontally scroll and view other pertinent 
fields, like E-mail or Telephone Number, to get a better view of your data. You can also hide those 
fields that may distract you from getting a better view of the data. For example, if you are interest-
ed in viewing just a person’s name and telephone number, you may decide to hide all fields except 
First Name, Last Name, and Phone Number. In this exercise, you practice freezing and unfreezing 
fields, as well as hiding and unhiding them.

STEP BY STEP Freeze/Unfreeze and Hide/Unhide Fields

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. OPEN the Customers table.

2. Select the Last Name field, and then on the Home tab, in the Records group, click the 
More button. 

3. Select Freeze Fields from the menu that appears. Notice that the Last Name field 
moves to the first field position in the table.

4. Click the Restore Down button (see Figure 3-11) on the application window. The 
Restore Down button now becomes the Maximize button. 

 

Figure 3-11

Restore Down button
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5. Press the Right Arrow key to scroll the table’s fields to the left, and stop when you 
reach the ZIP/Postal Code field. Notice that the Last Name field stays fixed as the other 
fields scroll.

6. Click the More button again and then select Unfreeze All Fields. Notice how the Last 
Name field remains in the table’s first field position. 

7. Press the Right Arrow key several times until the Last Name field scrolls off from view. 
Notice how the Last Name field moved with the other fields when the Right Arrow key 
was pressed several times.

Take Note Fields can be rearranged in Datasheet view by clicking on the field name headers and dragging 
them to where you want to move them.

8. Click the Maximize button on the application window.

9. Select the Customer ID field. Click the More button and then select Hide Fields. Notice 
the Customer ID field is now hidden from view (see Figure 3-12).

Customer ID field is hidden

Take Note To select more than one field to freeze or hide, hold down the Shift key while selecting 
 adjacent fields.

10. Click the More button and then select Unhide Fields. The Unhide Columns dialog box 
appears. Notice the check mark is missing from the Customer ID check box, signifying 
that it is hidden.

11. Deselect the check boxes next to all the other field representations except Last Name 
and Business Phone and then click the Close button in the Unhide Columns dialog box. 
Notice the only fields now displayed in Datasheet view are the Last Name and Business 
Phone fields. 

12. CLOSE the Customers table without saving the changes to the layout.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note You can save your table so it retains your formatting the next time you open it.

Figure 3-12

Hidden Customer ID field
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SOFTWARE ORIENTATION

Relationship Tools on the Ribbon

When you click the Relationships button on the Database Tools tab, the Relationships window 
appears and the Relationship Tools are displayed in the Ribbon (see Figure 3-13).

Removes tables and relationships 
from the display but does not 

delete them
Close Master 
View button

Displays all database 
relationships and 

tables

Displays all the relationships and 
related tables for the selected table

Modifies existing 
relationships

Creates a relationship 
report you can print

UNDERSTANDING TABLE RELATIONSHIPS
As you have already learned, most databases have more than one table. Creating relationships 
among these tables allows Access to bring that information back together again through objects 
such as reports and queries so that you can display information from several tables at once. It is 
much easier to create effective reports and queries when you start out with well-defined table re-
lationships.

Defining Table Relationships
You define a table relationship in the Relationships window. To create that relationship, you place 
common fields in tables and define the relationships between the tables. Common fields used in 
different tables do not have to have the same names, but they usually do. They must have the same 
data type, though. In this exercise, you use a table that already has a primary key field to create a 
relationship with another table.

You can create three types of relationships in Access tables: one-to-one, one-to-many, and 
many-to-many.

In a one-to-one relationship, both tables have a common field with the same data. Each record in 
the first table can only have one matching record in the second table, and each record in the second 
table can have only one matching record in the first table. This type of relationship is not common, 
because information related in this way is usually stored in the same table.

A one-to-many relationship is more common, because each record in the first table can have many 
records in the second table. For example, in a Customers table and an Orders table, one customer 
could have many orders. The Customer ID would be the primary key in the Customers table (the 
one) and the foreign key in the Orders table (the many).

In a third type of relationship, called a many-to-many relationship, many records in the first table 
can have many records in the second table.

Figure 3-13
Use the Relationship Tools 
to define and modify table 
relationships
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STEP BY STEP Define Table Relationships

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. On the Database Tools tab in the Relationships group, click the Relationships button. 
The Relationships view appears with the Customers table represented.

2. Click the Show Table button in the Relationships group under the Relationship Tools 
Design tab. The Show Table dialog box appears (see Figure 3-14).

3. Select Order Summary and then click Add.

4. Click Close. The Customer table and Order Summary table are represented in 
Relationships view.

5. Click the Customer ID primary key field in the Customers table, drag it to the Customer 
ID field of the Order Summary table, and then release the mouse button. The Customer 
ID field represents the common field between the two tables. The Customer ID field of 
the Order Summary table is now set as the foreign key. The Edit Relationships dialog 
box appears (see Figure 3-15).

Figure 3-14

Show Table dialog box

Figure 3-15

Edit Relationships dialog box
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6. Select the Enforce Referential Integrity, Cascade Update Related Fields, and Cascade 
Delete Related Records check boxes.

7. Click Create. A relationship line representing the one-to-many table relationship of the 
Customers and the Order Summary tables is displayed. You just created a one-to-many 
relationship between these tables using Customer ID, the common field. The one-to-
many relationship type signifies that each customer record in the Customers table can 
have many order records in the Order Summary table.

PAUSE. LEAVE the database open to use in the next exercise.

Modifying Table Relationships
A table relationship is represented by the line that connects the tables in the Relationships window. 
To modify the relationship, you can double-click the line to display the Edit Relationships dialog 
box or delete the line to delete the relationship. The Edit Relationships dialog box allows you to 
change a table relationship. You can change the tables on either side of the relationship or the fields 
on either side. You can also perform actions like enforcing referential integrity and choosing cas-
cade options. In this exercise, you delete the relationship you previously created, and then recreate 
and edit the relationship to enforce referential integrity.

Referential integrity is an option that you can select in the Edit Relationships dialog box to 
prevent orphan records. An orphan record is a record in one table that references records in anoth-
er table that no longer exist. For example, when referential integrity is enforced, Access will not 
permit a Customer ID value as the foreign key in the Order Summary table that does not have a 
matching Customer ID value as the primary key in the Customers table. In this way, referential 
integrity ensures your tables contain logically related data. If an operation that violates referential 
integrity is performed once this option is selected, Access will display a dialog box with a message 
stating that referential integrity is being violated and will not permit the operation. You can also 
choose one or both types of cascade options—cascade update related fields or cascade delete relat-
ed records—in the Edit Relationships dialog box once referential integrity has been selected. For 
example, if the cascade update related fields option is selected, Access will update the Customer 
ID value in the Order Summary table if the Customer ID value in the Customers table is updated. 
This ability to update related fields automatically ensures consistent Customer ID values in the re-
lated tables. Similarly, if the cascade delete related records option is selected, Access will delete all 
Customer ID records from the Order Summary table if the related Customer ID record is deleted 
from the Customers table; therefore, preventing orphaned records. When you enforce referential 
integrity between tables, the line connecting the tables becomes thicker. The number 1 is also 
displayed on the line on the one side of the relationship and an infinity symbol (∞) appears on the 
other side to represent the “many” field values that can be included in this side of the relationship.

To remove a table relationship, you must delete the relationship line. You can select the line by 
pointing to it and clicking it. When the relationship line is selected, it appears thicker. Press the 
Delete key to delete the line and remove the relationship or right-click the line to display the 
shortcut menu.

STEP BY STEP Modify Table Relationships

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. Right-click the center section of the relationship line connecting the two tables. A 
shortcut menu appears (see Figure 3-16).
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Troubleshooting If you click on the horizontal line near the 1 or the infinity symbol, you will get a different 
menu (Show Table, Show All, Save Layout), so be sure to click the center line to get the correct 
menu.

2. Select Delete. A message appears asking if you are sure you want to delete the 
relationship. Click Yes. The line disappears.

3. Select the Customer ID field in the first table. Drag the mouse to the Customer ID field 
in the second table and release the mouse button. The Edit Relationships dialog box 
appears.

4. Click the Create button. A line appears, creating the relationship.

5. Double-click the center section of the relationship line. The Edit Relationships dialog 
box appears again, listing the tables and the Customer ID fields on each side.

6. Click the Enforce Referential Integrity box and then click OK. The line appears thicker, 
with the number 1 beside the first table and the infinity symbol (∞) beside the second.

PAUSE. LEAVE the database open to use in the next exercise.

Viewing and Printing Table Relationships
You may want to print a table relationship to save for your records or to discuss with a colleague. 
The Relationship Report command makes this easy. When you choose to print the relationship 
report, the Print Preview tab appears with options for viewing and printing the report. The Page 
Size group controls margins and page size; the Page Layout group controls page orientation and 
printing options; the Zoom group controls viewing options; and the Data group controls all as-
pects of data exporting. After you make any changes to the layout of the report, click the Print 
button to start printing. After printing the report, you can choose to save it. In this exercise, you 
view and print table relationships without saving the relationship report.

STEP BY STEP Print Table Relationships

GET READY. USE the Fourth Coffee-final database that is still open from the previous 
exercise. 

1. In the Tools group of the Relationship Tools Design tab, click the Relationship Report 
button. The report is created and the Print Preview tab appears (see Figure 3-17). 

Figure 3-16

Edit/Delete shortcut menu
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2. Click the Print button. The Print dialog box appears, allowing you to select the printer 
you want to use.

3. Click OK to keep the default settings, and then print the report or click Cancel to not 
print the report.

4. Click the Close button to close the Relationships for Fourth Coffee-final tab. A message 
appears asking if you want to save changes to the report. Click No.

5. CLOSE the Relationships tab.

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Foreign key a.  Prevents orphan records to ensure that records do not 
reference other records that no longer exist

2. Composite key b. A primary key from one table that is used in another table

3. Referential integrity c.  A set of rules for determining which records will be 
displayed

4. Filter d. The secondary sort field in a multifield sort

5. Innermost field e. Two or more primary keys in a table

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. You can use the Navigation buttons to search for data in a table.

T F 2. After you delete a record, you can click the Undo button to bring it back.

T F 3. The Find and Replace dialog box searches all the tables in a database at one 
time.

T F 4. The outermost field is the primary sort field in a multifield sort.

T F 5. In a one-to-many relationship, each record in the first table can have many 
records in the second table.

Figure 3-17

Print preview of Relationship 
Report
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Projects

Project 3-1: Adding and Editing Records

In this project, you are working as an intern for Woodgrove Bank. Part of your job is helping your 
supervisor organize a charity event. Use an Access table to create a contacts list that your supervi-
sor will use to make calls to local businesses requesting sponsorships and donations for the event.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Charity Event database from the data files for this lesson and then SAVE the 
database as Charity Event-final.

2. OPEN the Contacts table.

3. Enter the records shown in the following table: (Do not type the hyphens when entering 
the Business Phone data). 
17 Company Last Name First Name Business Phone
17 Trey Research Tiano Mike 469-555-0182
18 Fourth Coffee Culp Scott 469-555-0141
19 Wingtip Toys Baker Mary 972-555-0167

20 Margie’s Travel Nash Mike 972-555-0189

4. Click the bottom half of the View button and then click Design View.

5. Select the ID row. On the Design tab, in the Tools group, click the Primary Key button.

6. Save the design of the table, and then return to Datasheet view.

7. On the Home tab, in the Find group, click the Find button. The Find and Replace dialog 
box appears. Type 0177 into the Find What box.

8. Select Current document from the Look In menu, and then select Any Part of Field in 
the Match menu.

9. Click the Replace tab and then type 0175 into the Replace With box.

10. Click Find Next and then click Replace.

11. Click Cancel to close the dialog box.

12. Select the Lucerne Publishing record.

13. On the Home tab, in the Records group, click the Delete button. Click Yes to delete the 
record.

14. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 3-2: Sorting and Creating Relationships

The four kindergarten classes at the School of Fine Art have adopted one boy and one girl “angel” 
from the community. Children from the classes may purchase holiday gifts for their angels. In this 
project, you are an office assistant at the school and you are working with the Angel Project staff 
to organize information about each angel.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Angels from the data files for this lesson and then SAVE the database as Angels-
final.

2. OPEN the List table.

3. Select the Gender field. On the Home tab, in the Sort & Filter group, click the 
Ascending button.

4. Select the Age field. On the Home tab, in the Sort & Filter group, click the Descending 
button.

5. On the Home tab, in the Sort & Filter group, click the Remove Sort button.

6. In the Gender field, select the M in the first record.

7. On the Home tab, in the Sort & Filter group, click the Selection button and then select 
Equals “M”.

8. On the Home tab, in the Sort & Filter group, click the Toggle Filter button.

9. Select the Wants field. On the Home tab, in the Sort & Filter group, click the Filter 
button. 

10. Select Text Filters from the menu, select Contains from the next menu, type Bike in the 
Custom Filter dialog box, and then press Enter.

11. On the Home tab, in the Sort & Filter group, click the Advanced button, and then select 
Clear All Filters from the menu.

12. SAVE and CLOSE the List table.

13. Open the Contact Information table.

14. Type the following new records:
Last  First Parent’s    Zip Home 
Name Name Name Address City State Code Phone
Wright Steven Kevin 2309 Monroe St Marietta GA 34006 770-555-0142

Cook Cathan Patrick 1268 Oak Dr Marietta GA 34006 770-555-0128

15. Change to Design view. Remove the primary key from the Home Phone field and define 
the ID field as the primary key.

16. SAVE the design and return to Datasheet view.

17. Select the ID field and sort it in ascending order.

18. On the Database Tools tab, in the Relationships group, click the Relationships button.

19. Create a one-to-one relationship between the ID field of the List table and the ID field of 
the Contact Information table.

20. SAVE the Relationships view and then CLOSE it.

CLOSE the database and then EXIT Access.
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Modifying Tables and Fields 4
SKILL SUMMARY

Skills Exam Objective Objective Number

Modifying a Database Table Add table descriptions.
Rename tables.
Delete database objects.

2.2.3
2.2.4
1.1.4

Creating Fields and Modifying  
Field Properties

Change field sizes.
Using input masks.
Set default values.
Change field captions.
Add validation rules to fields.
Add fields to tables.
Delete fields.

2.4.4
2.4.8
2.4.7
2.4.3
2.4.2
2.4.1
2.4.9

MODIFYING A DATABASE TABLE
After a table has been created, you may need to modify it. You can make many changes to a ta-
ble—or other database object—using its property sheet. You can also rename or delete a table, but 
keep in mind that such a change could possibly break the functionality of the database, because in 
a relational database the various components work together.

Modifying Table Properties
You can set properties that control the appearance or behavior characteristics for an entire table 
in the table’s property sheet. Sometimes it is necessary to describe the purpose of a table by mod-
ifying the table’s Description property since others who view your table may require more infor-
mation about its purpose. Other table properties are more advanced and used less often. In this 
exercise, you modify the description property for a table. 

STEP BY STEP Modify Table Properties

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN the Events database from the data files for this lesson and then SAVE the 
database as Events-final.

Take Note Don’t forget to click Enable Content here. We stop indicating it as a separate step from this point 
on but always click Enable Content when prompted.

2. In the Navigation Pane, double-click Events to open that table.

3. On the Home tab, in the Views group, click the bottom half of the View button and then 
click Design View from the menu that appears.

4. On the Design tab, in the Show/Hide group, click Property Sheet. The Property Sheet 
pane appears on the right of the Access window (see Figure 4-1).
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Property sheet pane

5. Place the insertion point in the property box for Description.

6. Press Shift+F2 to open the Zoom dialog box to provide more space.

7. Type Most popular events for 2016.

8. Click OK.

9. Click the Close button on the Property Sheet pane to close it.

10. Click the File tab and then click Save to save the design changes you have made to the 
table.

11. Click  the Close button to close the table.

PAUSE. LEAVE the database open to use in the next exercise.

Table 4-1 lists the available table properties on the Property Sheet and what they control.

Figure 4-1

Property Sheet pane displayed
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Table Property Use This Table Property To

Subdatasheet Expanded Specify whether to expand all subdatasheets when you open the table.

Subdatasheet Height Specify whether to expand to show all available subdatasheet rows 
(default) when opened or to set the height of the subdatasheet window to 
show when opened.

Orientation Set the view orientation, according to whether your language is read 
left-to-right or right-to-left.

Description Provide a description of the table.

Default View Set Datasheet as the default view when you open the table.

Validation Rule Supply an expression that must be true for you to add a record or change 
a record.

Validation Text Enter text that appears when a record violates the Validation Rule 
expression.

Filter Define criteria to display only matching rows in Datasheet view.

Order By Select one or more fields to specify the default sort order of rows in 
Datasheet view.

Subdatasheet Name Specify whether a subdatasheet should appear in Datasheet view, and, if 
so, which table or query should supply the rows in the subdatasheet.

Link Child Fields List the fields in the table or query used for the subdatasheet that match 
this table’s primary key field(s).

Link Master Fields List the primary key field(s) in this table that match the child fields for the 
subdatasheet.

Filter On Load Automatically apply the filter criteria in the Filter property (by setting to 
Yes) when the table is opened in Datasheet view.

Order By On Load Automatically apply the sort criteria in the Order By property (by setting 
to Yes) when the table is opened in Datasheet view.

Order By On Provide an alternate method to the Order By On Load property by 
automatically applying the sort criteria in the Order By property when set 
to −1 (Yes).

Renaming a Table
To rename a table or other database object, you must first close it. In the Navigation Pane, locate 
and right-click the object that you want to rename and then click Rename on the shortcut menu 
that appears. Or, select the table in the Navigation Pane, press F2, type a new name, and then 
press Enter. Think carefully before you rename a table. If existing database objects, such as queries 
or reports, use data from that table, the name modification might break the functionality of the 
database. In this exercise, you create a new table and then rename it using the shortcut menu. 

STEP BY STEP Rename a Table

GET READY. USE the Events-final database that is still open from the previous exercise.

1. On the Create tab, in the Templates group, click the Application Parts button and then 
click Comments to create a new table.

2. In the Create Relationship dialog box that appears, select There is no relationship and 
then click Create.

3. OPEN the Comments table, right-click Comments in the Navigation Pane, and then 
select Rename from the shortcut menu. A dialog box appears that states that you can’t 
rename the database object ‘Comments’ while it’s open. Close the dialog box.

Table 4-1

Table Properties



Modifying Tables and Fields 61

4. CLOSE the Comments table.

5. Right-click Comments in the Navigation Pane to display the shortcut menu.

6. Click Rename. The table name is now selected for renaming (see Figure 4-2).

Type new 
table name

7. Type Event Comments and then press Enter. The table has been renamed.

PAUSE. LEAVE the database open to use in the next exercise.

Deleting a Table
Deleting an entire table is not a complex process; however, remember that when you delete an 
entire table you might break the functionality of your database. Although you will be asked to 
confirm the deletion of a table, you can always undo the action. In this exercise, you delete a table.

To delete a table or other database object like a report, form, or query, right-click it in the Naviga-
tion Pane and click Remove or Delete. Or, select the table in the Navigation Pane and then press 
Delete.

Figure 4-2

Table name selected for 
renaming
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STEP BY STEP Delete a Table

GET READY. USE the Events-final database that is still open from the p revious exercise.

1. Right-click the Event Comments table in the Navigation Pane and then click Delete.

2. A confirmation message appears. Click Yes to delete the table.

Take Note If the table was related to one or more additional tables, Access would ask if you wanted to delete 
those relationships before deleting the table.

PAUSE. LEAVE the database open to use in the next exercise.

SOFTWARE ORIENTATION

Field Properties

Some field properties are available in Datasheet view, but to access the complete list of field prop-
erties you must use Design view. An example of field properties for a table in Design view is shown 
in Figure 4-3.

Field properties for selected fieldSelected field

CREATING FIELDS AND MODIFYING FIELD PROPERTIES
A field has certain defining characteristics such as a name that uniquely identifies the field within 
a table, and a data type that is chosen to match the information to be stored. Every field also has 
an associated group of settings called properties that define the appearance or behavior of the field. 
In this section, you learn how to create fields and modify field properties.

Access uses the field property settings when you view and edit data. For example, the Format, 
Input Mask, and Caption properties affect how your information appears in table and query data-
sheets. In addition, any controls on new forms and reports that are based on the fields in the table 
inherit these same property settings by default.

Figure 4-3
Field properties
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Setting Field Properties
You can control the appearance of information, prevent incorrect entries, specify default values, 
speed up searching and sorting, and control other appearance or behavior characteristics by set-
ting or modifying field properties. For example, you can format numbers to make them easier to 
read, or you can define a validation rule that must be satisfied for information to be entered in a 
field. In this exercise, you set the Required field property in Datasheet view and both the Default 
Value and Field Size field properties in Design view.

To set a field property in Datasheet view, open the table in Datasheet view. Click in the field 
for which you want to set the property. In the Field Validation group on the Table Tools Fields 
contextual tab, select the Unique check box to require the values in the field to be unique for all 
the records in the table. Or, select the Required check box to make this a required field, where all 
instances of this field must contain a value. In the Properties group, select the Field Size property 
box to define the text length for a field, which limits the number of characters allowed for input. 

You can also select other field properties like Default Value, and Name & Caption. The Default 
Value property allows you to specify a value to automatically assign to a field when new records 
are added. This is useful if you have data that consistently repeats. The Name & Caption property 
allows you to specify a new field name and the associated caption for that field. The caption is what 
appears as column names in tables, and as labels in queries, forms, and reports. Keep in mind that 
Access will show field names as the column names and labels when no caption property value is 
specified. The field name is what Access uses to reference the field behind the scenes and when you 
view the field names in Design view. 

You can set a few of the available field properties in Datasheet view, but to access all of the avail-
able field properties, you must open the table in Design view. For example, you can modify the 
Field Size property in both Datasheet and Design views, but you can only modify the Text Align 
 property—which allows you to specify the default alignment of text within a field—in Design 
view.

To set field properties in Design view, open the table in Design view. In the upper portion of the 
table design grid, click the field for which you want to set properties. The properties for this field 
are displayed in the lower portion of the table design grid.

Click the box for the field property you want to set. Alternatively, you can press F6 and then move 
to the property using the arrow keys. Type a setting for the property or, if an arrow appears at the 
right side of the property box, click the arrow to choose from a list of settings for the property. 
Table 4-2 lists the available field properties and what they control. Remember that the properties 
available depend on the field’s data type.



Lesson 464

Field Property Use This Field Property To

Field Size Set the maximum size for data stored as a Short Text, Number,  
or AutoNumber data type.

Format Customize the way the field appears when displayed or printed.

Decimal Places Specify the number of decimal places to use when displaying numbers.

New Values Set whether an AutoNumber field is incremented or assigned a random 
number.

Input Mask Display editing characters to guide data entry.

Caption Set the text displayed by default as the column name in tables and labels for 
forms, reports, and queries.

Default Value Automatically assign a default value to a field when new records are added.

Validation Rule Supply an expression that must be true whenever you add or change the 
value in this field.

Validation Text Enter text that appears when a value violates the Validation Rule.

Required Require that data be entered in a field.

Allow Zero Length Allow entry (by setting to Yes) of a zero-length string (“”) in a Short Text, 
Long Text, or Hyperlink field.

Indexed Speed up access to data in this field by creating and using an index.

Unicode Compression Compress text stored in this field when a large amount of text is stored. 

IME Mode Specify an Input Method Editor, a tool for using English versions of Windows.

IME Sentence Mode Specify the type of data you can enter by using an Input Method Editor.

Append Only Retain a history of all data changes (by setting to Yes) of a Long Text field.

Text Format Choose Rich Text to store text as HTML and allow rich formatting. Choose 
Plain Text to store only text.

Text Align Specify the default alignment of text within a field or control.

Precision Specify the total number of digits allowed, including those both to the right 
and the left of the decimal point (when decimal Field Size property is set 
using Number data type).

Scale Specify the maximum number of digits that can be stored to the right of the 
decimal separator (when decimal Field Size property is set using Number 
data type).

Expression Specify the expression used for the Calculated data type to generate a value.

Result Type Specify the data type to be used to store the value generated by the 
Expression field property for the Calculated data type.

STEP BY STEP Set a Field Property in Datasheet View and Design View

GET READY. USE the Events-final database that is still open from the previous exercise.

1. Double-click the Events table in the Navigation Pane to open the table in Datasheet 
view, if it is not already open.

2. Click the Location column header to select that field.

3. Click the Required check box in the Field Validation group on the Table Tools Fields 
contextual tab. This setting determines that a value must be entered in the Location 
field for all records in the table.

Table 4-2

Available Field Properties
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4. On the Home tab, in the Views group, click the bottom half of the View button and then 
click Design View.

5. In the Field Name column in the middle portion of the table design grid, click in the 
Location cell.

6. In the Default Value row in the lower portion of the table design grid, click in 
the property box and then type To Be Announced to specify a value that will be 
automatically entered in this field for new records.

7. In the Field Name column in the upper portion of the table design grid, click in the Title cell.

8. In the Field Size row in the lower portion of the table design grid, select 150 in the 
property box and then type 175 to change the maximum number of characters you can 
enter in the Title field. 

9. Press Enter.

PAUSE. LEAVE the database open to use in the next exercise.

Defining Input Masks
You use an input mask whenever you want users to enter data in a specific way. An input mask 
can require users to enter dates in a specific format, for example, DD-MM-YYYY, or telephone 
numbers that follow the conventions for a specific country or region. An input mask is helpful 
because it can prevent users from entering invalid data (such as a phone number in a date field). 
In addition, input masks can ensure that users enter data in a consistent way. In this exercise, you 
specify that the dates in the Start Date field be entered in Medium Date format, following the 
required pattern, 27-Sept-69.

You can add input masks to table fields by running the Input Mask Wizard or by manually enter-
ing masks in the Input Mask field property.

STEP BY STEP Define Input Masks for Fields

GET READY. USE the Events-final database and Events table that is still open from the 
previous exercise.

1. In the Field Name column in the upper portion of the table design grid, click in the Start 
Date cell.

2. Click the Input Mask property box in the lower portion of the table design grid to 
display the Input Mask Wizard button (...) on the far right of the cell.

3. Click the Input Mask Wizard button. A message box appears asking if you want to save 
the table now.

4. Click Yes to close the message box and display the Input Mask Wizard (see Figure 4-4).

Figure 4-4

Input Mask Wizard
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5. Click Medium Date to select the DD-MON-YR date format and then click Next. The next 
screen in the Input Mask Wizard appears. If you wanted to change the input mask, you 
would do so here. You can also test entering the values in the Try It text area.

6. Click Next to accept the default settings in this screen and display the final Input Mask 
Wizard screen.

7. Click Finish. The input mask appears in the Input Mask row (see Figure 4-5).

Input mask for Start 
Date field in Input 
Mask row

PAUSE. LEAVE the database open to use in the next exercise.

Allowing Zero-Length Strings in a Field
When the Allow Zero Length field property is set to Yes, you can enter zero-length strings in a 
field. A zero-length string contains no characters; you use the string to indicate that you know 
no value exists for a particular field. This recognition of a nonexistent value actually represents a 
string. You enter a zero-length string by typing two double quotation marks with no space between 
them (“”). In this exercise, you modify the Allow Zero Length property for the Description field.

Figure 4-5

Input Mask row
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STEP BY STEP Allow Zero Length

GET READY. USE the Events-final database and Events table that is still open from the 
previous exercise.

1. In the Field Name column in the upper portion of the table design grid, click in the 
Description cell.

2. Click the Allow Zero Length property box in the lower portion of the table design grid 
to display the down arrow on the far right of the cell.

3. Click the down arrow to display the menu.

4. Click Yes.

PAUSE. LEAVE the database open to use in the next exercise.

Setting Data Validation Rules
Validation rules help ensure that your database users enter the proper types or amounts of data. 
A validation rule is an expression that limits the values that can be entered in the field. The 
maximum length for the Validation Rule property is 2,048 characters. For example, if the field 
contains a date, you can require that the date entered in the field be later than June 4, 1977. 
Validation text specifies the text in the error message that appears when a user violates a vali-
dation rule. For example, the error message could say “Please enter a date that is later than June 4, 
1977.” The maximum length for the Validation Text property is 255 characters. In this exercise, 
you modify the Validation Rule and Validation Text properties for the End Date field.

Data can be validated in several ways, and you will often use multiple methods to define a valida-
tion rule. Each of the following can be used to ensure that your users enter data properly:

• Data types: When you design a database table, you define a data type for each field in the 
table, and that data type restricts what users can enter. For example, a Date/Time field accepts 
only dates and times, a Currency field accepts only monetary values, and so on.

• Field sizes: Field sizes provide another way to validate text. For example, if you create a field 
that stores first names, you can set it to accept a maximum of 15 characters. This can prevent a 
malicious user from pasting large amounts of text into the field. It could also prevent an inex-
perienced user from mistakenly entering a first, middle, and last name in a field designed only 
to hold a first name.

• Table properties: Table properties provide very specific types of validation. For example, you 
can use the Order By property to select one or more fields to specify the default sort order of 
rows in Datasheet view.

• Field properties: You can also use field properties, such as the Validation Rule property to 
require specific values, and the Validation Text property to alert your users to any mistakes. 
For example, entering a rule such as .1 and ,100 in the Validation Rule property forces users to 
enter values between 1 and 100. Entering text such as “Enter values between 1 and 100” in the 
Validation Text property tells users when they have made a mistake and how to fix the error.

STEP BY STEP Set Data Validation Rules

GET READY. USE the Events-final database and Events table that is still open from the 
previous exercise.

1. In the Field Name column in the upper portion of the table design grid, click the End 
Date cell.

2. Click the Validation Rule property box in the lower portion of the table design grid to 
display the Expression Builder button (...) on the far right of the cell.

3. Click the Expression Builder button to display the Expression Builder dialog box (see 
Figure 4-6).
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Click to open the Expression Builder

4. Select the number 1900 and replace it by typing 2016.

5. Click OK.

6. Click the Validation Text property box in the lower portion of the table design grid.

7. Select the number 1900 and then replace it by typing 2016. The property boxes should 
look like those shown in Figure 4-7.

PAUSE. LEAVE the database open to use in the next exercise.

Entering Captions
The Caption property field specifies the text displayed by default as column names in tables and 
in labels for forms, reports, and queries. The maximum length for the Caption property is 255 
characters. If you do not specify a caption to be displayed, the field name is used as the label. In 
this exercise, you set the Caption property for the Location field.

STEP BY STEP Enter Captions

GET READY. USE the Events-final database and Events table that is still open from the 
previous exercise.

1. In the Field Name column in the upper portion of the table design grid, click the 
Location cell.

2. Click the Caption property box in the lower portion of the table design grid.

3. Type Venue. The caption property has now been set to Venue and will display as a 
column name in table Datasheet view, as well as labels for forms, reports, and queries.

Figure 4-6

Expression Builder button and 
dialog box

Figure 4-7

Modified Validation field 
properties
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Take Note To change an existing caption, simply follow the same steps as you would for entering a caption. 
Overwrite the existing caption with the new caption. 

PAUSE. LEAVE the database open to use in the next exercise.

SOFTWARE ORIENTATION

Add & Delete Group

When creating fields in table Datasheet view, you use the Add & Delete group on the Table Tools 
Fields contextual tab, which is shown in Figure 4-8. You can use these commands to add fields 
with associated data types, add Quick Start fields, insert lookup columns, and delete columns. 

Add a field (column) with data type indicated Delete a column

Creating Fields
Fields can be created in different ways. You can add fields to a table in Design view, or add fields in 
Datasheet view using the Click to Add column or Add & Delete group. Sometimes it is easier to 
choose from a predefined list of fields than to manually create a field. Access includes a quick and 
easy way for you to add fields to a table using the Add & Delete group on the Table Tools Fields 
contextual tab, which includes a collection of fields with associated data types and built-in Quick 
Start fields that can save you considerable time. In this exercise, you add fields to a table using both 
the Click to Add column and the Add & Delete group.

The last column in a table in Datasheet view has a Click to Add column, which you can use to 
add a field simply by clicking on the Click to Add column header and choosing a data type from 
the menu that appears. Rename the field by right-clicking the column header, choosing Rename 
Field from the menu, and typing a new name. You can also type information directly in a column. 
Access will try to automatically determine the field data type by the data entered.

A Quick Start field is a predefined set of characteristics and properties that describes a field, 
including a field name, a data type, and a number of other field properties. Quick Start fields 
allow you to quickly add commonly used single fields or several related ones. For example, using 
Quick Start fields, you can choose from a variety of fields including “Status” to quickly add a field 
named Status with built-in options like Not Started, In Progress, and so on, or you can choose the 
“Address” Quick Start to quickly include related fields like City, State, and Zip Code. 

To create a new field in table Datasheet view, you can simply choose from commonly used fields in 
the Add & Delete group, or click the More Fields button to access a menu with a greater variety of 
field types. To create a new field using Quick Start, click the More Fields button and then choose 
a Quick Start from the menu.

Figure 4-8
Add & Delete group
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STEP BY STEP Create Fields

GET READY. USE the Events-final database and Events table that is still open from the 
previous exercise.

1. On the Home tab, in the Views group, click the bottom half of the View button and 
then click Datasheet View. Save the table, if required. If you get a message about data 
integrity, click Yes.

Take Note Whenever you add or modify field validation rules for fields that contain data, the data may violate 
these new rules. You can allow Access to test the data against the rules and inform you if there are 
any violations.

2. Scroll to the right of the Events table to display the last column and then click the Click 
to Add header. Click Yes/No from the menu of available data types that appear. You are 
going to add a new field with the Yes/No data type in which you can indicate whether 
events will have on-site staff. A new field named Field1 is added, and the Click to Add 
column becomes the last column in the table.

3. Right-click the Field1 column header to display the shortcut menu and then click 
Rename Field.

4. Type On-site staff? as the column name.

5. Click the More Fields button in the Add & Delete group on the Table Tools Fields 
contextual tab. The More Fields menu appears (see Figure 4-9).

Figure 4-9

More Fields button and menu
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6. In the Quick Start category, scroll down if necessary and click Status. A new Quick 
Start field named Status, in which you now have options to indicate the status of an 
event, appears to the left of the On-site staff? field.

7. Click the Status field drop-down box button to view the available options, and then 
select Not Started (see Figure 4-10). Click Not Started.

PAUSE. LEAVE the database open to use in the next exercise.

Deleting a Field
Before you delete a column from a datasheet, remember that doing so deletes all the data in the 
column and that the action cannot be undone. For that reason, you should back up the table be-
fore you delete the column. Before you can delete a primary key or a lookup field, you must first 
delete the relationships for those fields. In this exercise, you learn how to use the shortcut com-
mands to delete two fields from an Access 2016 table.

To delete a field in Datasheet view, select the column, right-click, and then click Delete Field from 
the shortcut menu. Or, on the Table Tools Fields contextual tab in the Add & Delete group, click 
the Delete button. You will see a confirmation message asking if you are sure you want to delete 
the column and all the data. Sometimes you may see an additional confirmation message warning 
you about potential issues when deleting fields. You should always be cautious when deleting fields 
from a table.

STEP BY STEP Delete a Field

GET READY. USE the Events-final database and Events tablet that is still open from the 
previous exercise.

1. Click the column header for the Attachment field, located between the Description field 
and the Status field.

2. Right-click the column header to display the shortcut menu and then click Delete Field. 
In the dialog box that appears, click Yes.

3. In the confirmation message that appears, click Yes. The field is deleted.

4. Click the column header for the Status field.

5. Right-click in the column to display the shortcut menu and then click Delete Field. In 
the message box that appears, click Yes to delete the Status field.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 4-10

Status field drop-down box 
options
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Creating Multivalued Lookup Fields
In Office Access 2016, you can create a multivalued lookup field that allows you to select 
more than one choice from a list—without having to create a more advanced database design. You 
can create a field that holds multiple values, such as a list of employees that you have assigned to a 
particular event. Use the Lookup Wizard to create multivalued fields. The Lookup Wizard guides 
you through the process of creating a field or lookup column that can “look up” data that exists 
in one or more tables to automate the complexity of manually relating tables. In this exercise, you 
create a multivalued lookup field using the Lookup Wizard in Datasheet view.

Use a multivalued lookup field when you want to store multiple selections from a list of choices 
that are relatively small. This is useful if you want to limit the choices a user can select to store in 
a table field to prevent erroneous data from being entered. For example, you can create a multival-
ued lookup field to assign only those employees who work in your department to a specific task. 
Limiting the choices a user can make to enter into a field helps protect the validity of your data. 

Take Note You can also create lookup columns that allow for a single selection of a value.

STEP BY STEP Create a Multivalued Lookup Field

GET READY. USE the Events-final database and Events table that are still open from the 
previous exercise.

1. Place the insertion point in the first cell of the table. Click the More Fields button in the 
Add & Delete group on the Table Tools Fields contextual tab and then click the Lookup 
& Relationship button. The Lookup Wizard appears.

2. Click Next to accept the default setting (I want the lookup field to get the values from 
another table or query) and display the next screen in the Lookup Wizard. Notice you 
have a choice of two tables to provide the values for the lookup field you are creating. 
The first table, Employees, should already be selected for you.

3. Click Next to accept the default settings and display the next screen in the Lookup 
Wizard. The Available Fields scroll box contains all the fields of the Employees table, 
two of which you will select since they contain the values you want to eventually look 
up.

4. In the Available Fields list, select Last Name and then click the > button to move it to 
the Selected Fields box.

5. In the Available Fields list, select First Name and then click the > button to move it to 
the Selected Fields box. The results are shown in Figure 4-11.

Figure 4-11

Lookup Wizard, third screen 
with options moved



Modifying Tables and Fields 73

6. Click Next to accept your settings and display the next screen in the Lookup Wizard. 

7. Click the down arrow in the first box and then click Last Name. This will sort the 
Lookup column in alphabetical order by Last Name. 

8. Click Next to accept your selection and to display the next screen in the Lookup Wizard.

9. Click Next to accept the default selection and to hide the primary key column to ensure 
only relevant and meaningful data displays in the lookup column later. The final screen 
of the Lookup Wizard displays. 

10. In the What label would you like for your lookup field? box, type Coordinator. This will 
create a new label named Coordinator for your column.

11. Select the Allow Multiple Values check box to allow for the multiple selections of 
values. The completed dialog box is shown in Figure 4-12.

12. Click the Finish button. A new column named Coordinator appears after the ID field. 
Click the down arrow in the first cell to display the list of names (see Figure 4-13).

Figure 4-12

Lookup Wizard, final screen

Figure 4-13

Lookup column list
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13. Click Flood/Kathie and Mares/Gabe on the list and then click OK to choose those 
multiple values for the field.

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1.  ___________ or ___________ a table could possibly break the functionality of the database.

2. A(n) ___________ contains no characters, and you use it to indicate that you know no 
value exists for a field.

3.  ___________ specifies the text in the error message that appears when users violate a 
validation rule.

4. A(n) ___________ is a predefined set of characteristics and properties that describes a 
field.

5. You should always consider ___________ a table before deleting a column.

Multiple Choice
Select the best response for the following statements or questions.

1. To rename a table or other database object, you do which of the following?
a. Save it
b. Close it
c. Edit it
d. Open it

2. Which of the following is not a field property?
a. Column Template
b. Field Size
c. Caption
d. Allow Zero Length

3. Which field property requires users to enter data in a specific format?
a. Validation Text
b. Default Value
c. Required
d. Input Mask

4. Which of the following is not a way to validate data?
a. Data type
b. Field sizes
c. Filtering
d. Field properties

5. Which type of field allows you to select more than one choice from a list?
a. Attachment
b. Multivalued
c. Caption
d. Validation
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Projects

Project 4-1: Adding a Lookup Column and Modifying Field Properties

In this project, you are employed in the customer service department at City Power & Light. Each 
call that is received is recorded in an Access database. Because you know how to modify tables and 
fields, your supervisor asks you to add a lookup column to the Calls table to record the customer 
service representative who receives the call. Your supervisor also asks you to make some modifica-
tions to the field properties in the Calls table of the customer service database.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Customer service from the data files for this lesson and then SAVE the database 
as Customer service-final.

2. In the Navigation Pane, double-click the Calls table to open it. Place the insertion point 
in the first cell of the table, if necessary.

3. On the Table Tools Fields contextual tab, in the Add & Delete group, click the More 
Fields button and then click the Lookup & Relationship button. The Lookup Wizard 
appears.

4. Click Next to display the next screen in the Lookup Wizard.

5. Select Table: Employees and then click Next.

6. In the Available Fields list, select First Name and then click the > button to move it to 
the Selected Fields box.

7. In the Available Fields list, select Last Name and then click the > button to move it to 
the Selected Fields box.

8. Click Next to display the next screen in the Lookup Wizard.

9. Click the down arrow in the first box and then click Last Name.

10. Click Next to display the next screen in the Lookup Wizard.

11. Click Next again to display the final screen in the Lookup Wizard.

12. In the What label would you like for your lookup field? box, type Service Rep.

13. Click the Finish button. A new column named Service Rep appears as the second 
column of the table.

14. Click the down arrow and then select Clair/Hector from the list.

15. Change to Design view.

16. Display the Lookup field properties for the Service Rep field.

17. Change the Allow Multiple Values property to Yes and then confirm the change.

18. Display the General field properties for the Call Time field.

19. Change the Validation Rule property so that the value must be greater than 1/1/2000.

20. Change the Validation Text property to say Please enter a value that is later than 
1/1/2000.

21. Display the General field properties for the Caller field.

22. Change the Field Size property to 60.

23. Display the General field properties for the Notes field.

24. Change the Allow Zero Length property to Yes.

25. Type Comments in the Default Value property. 

26. SAVE the table. If a data integrity message appears, click No.

27. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 4-2: Changing List Items

In this project, you are the owner of Fourth Coffee, a growing company that is converting all of 
its data from spreadsheets to Access. You directed an intern to create a database with tables to be 
used to track inventory. You want to make some modifications to these database tables before you 
enter information in the database. 

GET READY. LAUNCH Access if it is not already running.

1. OPEN Fourth Coffee from the data files for this lesson and then SAVE the database as 
Fourth Coffee-final.

2. Open the Coffee Beans table and create a new Lookup field as the last field in the table 
that uses the Country field in the Countries table. Specify an Ascending sort order for 
the records in this field. 

3. Rename the field Origin. 

4. In Datasheet view, change the name and caption of the Current Value field to Market 
Value.

5. In Datasheet view, change the name and caption of the Acquired Date field to 
Acquisition Date.

6. Create a Yes/No field as the last field in the table named Stocked with a caption named 
In Stock?.

7. In Design view, create an input mask for all fields that use the Date/Time data type. 
Choose Medium Date as the input mask and accept all default values.

8. SAVE the table.

STOP. CLOSE the database and EXIT Access.
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SKILL SUMMARY

Skills Exam Objective Objective Number

Creating Forms Create a form.
Save a form.
Apply a theme.

4.1.1
4.1.3
4.3.4

Sorting and Filtering Data within a Form Sort records by form field. 4.3.3

SOFTWARE ORIENTATION

Forms Group

The Forms group (see Figure 5-1) is located on the Create tab in the Ribbon and can be used to 
create a variety of forms.

 

Creates a simple 
form

Creates a new blank 
form in Design view

Creates a new 
blank form in 
Layout view

Creates a new form 
using the Form 

Wizard

Figure 5-1
Forms group on the Create tab

CREATING FORMS 
A form is a database object that you can use to enter, edit, or display data from a table or query. 
You can use forms to control access to data by limiting which fields or rows of data are displayed 
to users. For example, certain users might need to see only certain fields in a table. Providing 
those users with a form that contains just those fields makes it easier for them to use the database. 
Think of forms as windows through which people see and reach your database in a more visually 
attractive and efficient way.

You can create forms in several different ways, depending on how much control you want over the 
form’s design. You can quickly create forms that include all fields in a table through a single mouse 
click using the Form tool, or you can control the number of fields you’d like to include on the 
form as well as the layout of the form using the Form Wizard. You have the most flexibility with 
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the amount and placement of fields on the form when you use Layout or Design view, with Design 
view giving you the greatest control over field placement and properties. You can quickly apply a 
chosen theme to the form to modify its color and font scheme using the Themes command. Fi-
nally, you can delete any form by simply using the Delete command. In this section, you practice 
creating forms using a variety of these skills. You also delete a pre-existing form.

Creating a Simple Form and Deleting a Form
You can use the Form tool to create a form with a single mouse-click. When you use this tool, 
all the fields from the underlying data source are placed on the form. Access creates the form and 
displays it in Layout view. You can begin using the new form immediately, or you can modify it 
in Layout view or Design view to better suit your needs. You can also delete a form to remove it 
permanently from the database. In this exercise, you use the Form tool to create a simple form and 
use the Delete command to delete a form.

To use the Form tool to create a simple form, first click in the Navigation Pane on the table that 
contains the data you want to see on the form. On the Create tab, in the Forms group, click Form. 

To save a form design, click the File tab and then click Save. Type a name in the Form Name box 
and then click OK. After you save your form design, you can run the form as often as you want. 
The design stays the same, but you see current data every time you view the form. If your needs 
change, you can modify the form design or create a new form that is based on the original. You 
can also permanently delete the form or any preexisting forms from the database by using the 
Delete command in the Records group of the Home tab. You can delete a form if you erroneously 
created it or simply want to unclutter the database.

STEP BY STEP Create a Simple Form and Delete a Form

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN the Graphic Art database from the data files for this lesson and then SAVE the 
database as Graphic Art-final. 

2. In the Navigation Pane, click the Photo Exhibit table. This is the table for which you will 
create a form.

3. On the Create tab, in the Forms group, click the Form button. Access creates the form 
and displays it in Layout view (see Figure 5-2). Your form may be slightly different.

4. Click the File tab and then click Save. The Save As dialog box appears.

Figure 5-2

Simple form
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Take Note You can use the record navigation buttons at the bottom of a form to navigate among the form’s 
records, just as you used them to navigate among records in a table in Lesson 3.

5. Click OK to accept the Photo Exhibit form name suggested by Access. The form name 
appears in the Navigation Pane.

6. Click the Close button on the Photo Exhibit form to close it.

7. In the Navigation Pane, click the Photo Info form. This is a form that you no longer 
need.

8. In the Records group, click the Delete button arrow and then click the Delete command 
on the menu that appears.

9. Click Yes on the dialog box asking you if you want to permanently delete the Photo Info 
form. The form is now permanently deleted from the database.

Troubleshooting In step 7, don’t double click the form. If you do, the form opens and you can’t delete the form 
when it is open.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Form in Design View
When you click the Form Design button, a new blank form is created in Design view. Design 
view gives you a more detailed view of the structure of your form than Layout view. The form is 
not actually running when it is shown in Design view, so you cannot see the underlying data while 
you are making design changes. In this exercise, you create a new blank form in Design view and 
manually add fields to it.

You can fine-tune your form’s design by working in Design view. To change to Design view, right-
click the form name in the Navigation Pane and then click Design view. You can also use the View 
button on the Home tab of the Ribbon. You can add new controls—used to enter, edit, and find 
information—and fields to the form by adding them to the design grid. Plus, the property sheet 
gives you access to a large number of properties that you can set to customize your form.

STEP BY STEP Create a Form in Design View

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click the Form Design button. A new blank form 
is created in Design view (see Figure 5-3).

Figure 5-3

New blank form in Design view
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2. On the Form Design Tools Design contextual tab, in the Tools group, click the Add 
Existing Fields button. The Field List pane appears.

3. Click the Show all tables link, and then the expand button to the left of the table name. 
The available fields display from the Photo Exhibit table (see Figure 5-4).

Expand button expanded Table name

Available 
fields

4. In the list of fields, double-click Artist to add it to the form.

5. Double-click Image Title to add it to the form.

6. Double-click Price to add it to the form. Your form should look similar to Figure 5-5.

7. Click the File tab and then click Save.

8. In the Save As dialog box, type Photo Label and then click OK.

9. On the Design menu, in the Views group, click the lower half of the View button and 
then click Form View to display the form in Form view (see Figure 5-6).

Figure 5-4

Field List pane with expand 
button and available fields

Figure 5-5

Fields inserted in Design view
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10. Click the Close button on Photo Label to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Form in Layout View
If other form-building tools do not fit your needs, you can use the Blank Form tool to create a 
form. The Blank Form tool creates a new form in Layout view. This can be a very quick way to 
build a form, especially if you plan to put only a few fields on your form. Click the Blank Form 
button to quickly create a new blank form in Layout view. This allows you to make design changes 
to the form while viewing the underlying data. In this exercise, you use the Blank Form tool to 
create a form in Layout view.

On the Create tab, in the Forms group, click the Blank Form button. Access opens a blank form 
in Layout view and displays the Field List pane. To add a field to the form, double-click it or drag 
it onto the form. In Layout view, you can make design changes to the form while it is displaying 
data.

STEP BY STEP Create a Form in Layout View

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click the Blank Form button. A new blank form is 
created in Layout view.

2. Click the Show all tables link in the Field List pane to show the Photo Exhibit table 
name, if necessary. 

3. If necessary, click the expand button next to the Photo Exhibit table name to show a list 
of fields related to the table, and then double-click Image Title to add it to the form. 

4. Double-click Dimensions to add it to the form.

5. Double-click Media to add it to the form. Your form should look similar to Figure 5-7.

6. Click the File tab and then click Save.

7. In the Save As dialog box, type Image Info and then click OK.

8. Click the Close button to close the Field List.

9. Click the Close button on Image Info to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note To add more than one field at a time after adding at least one other field, press Ctrl and click sev-
eral fields, and then drag them all onto the form at once.

Figure 5-6

Form view
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Using the Form Wizard
Another method of building a form is to use the Form Wizard tool. The Form Wizard allows 
you to select the fields that will appear on the form, choose the form layout (which determines the 
positioning of controls, objects, and data on a form), and also choose a predefined style, if desired. 
In this exercise, you use the Form Wizard to create a datasheet form. A datasheet form looks very 
similar to the table upon which it is based and provides a way to enter data using columns and 
rows.

STEP BY STEP Use the Form Wizard

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click the Form Wizard button. The Form Wizard 
appears (see Figure 5-8).

Move selected field

Move all fields

Figure 5-7

Fields inserted in Layout view

Figure 5-8

Form Wizard
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2. Click the >> button to move all the fields from the Available Fields box to the Selected 
Fields box.

3. Click the Next button to move to the next page in the Form Wizard

4. Click Datasheet as the layout for the form. Form layouts help determine the positioning 
of controls, objects, and data on a form.

5. Click the Next button to move to the final page in the Form Wizard.

6. Type Photo Details as the title of the form.

7. Click the Finish button. A datasheet form appears (see Figure 5-9).

8. Click the Close button on Photo Details to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note To include fields from more than one table on your form, do not click Next or Finish after you 
select the fields from the first table on the first page of the Form Wizard. Instead, repeat the steps 
to select another table and then click any additional fields that you want to include on the form 
before continuing.

Applying a Theme
The Themes command applies a predefined color and font scheme to a form or report. A theme 
modifies a form by controlling the color and fonts of its text. In this exercise, you apply a Theme 
to a form.

To apply a theme, first change to Layout view. On the Form Layout Tools Design contextual tab, 
in the Themes group, click the Themes button to view a gallery of theme styles from which to 
choose. You can point to each option to see the name of that format and a live preview before it is 
applied to the form.

Figure 5-9

Datasheet form
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STEP BY STEP Apply a Theme

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. Double-click the Image Info form in the Navigation Pane to open it.

2. On the Home tab, in the Views group, click the lower half of the View button and then 
click Layout View on the View menu.

3. On the Form Layout Tools Design contextual tab, in the Themes group, click the 
Themes button. A gallery of themes appears (see Figure 5-10).

4. Click the Integral theme (fourth item in the first row) to apply it to the form. Notice how 
the form’s text has changed (see Figure 5-11).

5. Click the Close button on Image Info to close the form. 

PAUSE. LEAVE the database open to use in the next exercise.

Figure 5-10

Themes gallery

Figure 5-11

Form in Layout view with 
Integral theme applied
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SORTING AND FILTERING DATA WITHIN A FORM 
Sorting data in a form can help make it much more effective and easy to use. Sorting helps users 
review and locate the records they want without having to browse the data. To find one or more 
specific records in a form, you can use a filter. A filter limits a view of data to specific records 
without requiring you to alter the design of the form. You also can use a tool called filter by form 
to filter on several fields in a form or to find a specific record.

Sorting Data within a Form
You can sort data in the Form view of a form. The order that is chosen when a form is designed 
becomes that object’s default sort order. But when viewing the form, users can sort the records in 
whatever way is most useful for them. You can sort the records in a form on one or more fields. In 
this exercise, you sort data in a form in ascending order.

STEP BY STEP Sort Data within a Form

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. Double-click the Photo Label form in the Navigation Pane to open it in Form view.

2. Right-click the Price field to display the shortcut menu.

3. Click Sort Smallest to Largest. The form is sorted by price from smallest to largest. 
The record with the smallest price is displayed first.

4. Click the Next record button on the record navigator at the bottom of the form. 
Continue clicking through all the records to see the records in order according to price.

5. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The records 
have resorted back to their original order.

6. Click the Close button on Photo Label to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note You cannot sort on a field that contains attachments. Also, when sorting on a field with the Yes/No 
data type, a value of “Yes” is considered “Selected,” and when sorted in ascending order, appears 
at the top of the list. A value of “No” is considered “Cleared,” and when sorted in ascending order, 
appears at the bottom of the list.

You must identify the fields on which you want to sort. To sort on two or more fields, identify the 
fields that will act as the innermost and outermost sort fields. Right-click anywhere in the column 
corresponding to the innermost field and then click one of the sort commands. The commands 
vary based on the type of data that is in the selected field. Repeat the process for each sort field, 
ending with the outermost sort field. The records are rearranged to match the sort order.

The last-applied sort order is automatically saved with the form. If you want it automatically 
applied the next time you open the form, set the Order By On Load property of the form to Yes. 
Remember that you cannot remove a sort order from just a single field. To remove sorting from all 
sort fields, click Remove Sort on the Home tab in the Sort & Filter group.

Filtering Data within a Form
Common filters are built into every view that displays data. The filters available depend on the 
type and values of the field. When you apply the filter, only records that contain the values that 
you are interested in are included in the view. The rest are hidden until you remove the filter. In 
this exercise, you filter form data using common filters.

Filters are easy to apply and remove. Filter settings remain in effect until you close the form—even 
if you change to another view. If you save the form while the filter is applied, it will be available 
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the next time you open the form. To permanently remove a filter, on the Home tab, in the Sort & 
Filter group, click the Advanced button and then click Clear All Filters.

STEP BY STEP Filter Data with Common Filters

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. Double-click the Photo Exhibit form in the Navigation Pane to open it in Form view.

2. Right-click the Media field to display the shortcut menu, click Text Filters, and then 
select Contains, as shown in Figure 5-12. Click Contains to display the Custom Filter 
dialog box. 

3. In the Media contains box, type print and then click OK.

4. Click the Next record button on the record navigator at the bottom of the form. 
Continue clicking to see the five records that contain the word “print” in the Media 
field.

5. Right-click the Price field to display the shortcut menu and then click Number Filters.

6. Click Less Than to display the Custom Filter dialog box.

7. In the Price is less than or equal to box, type 500 and then click OK.

8. Click the Next record button on the record navigator at the bottom of the form. 
Continue clicking to see the three photos that use print media and are less than $500.

9. On the Home tab, in the Sort & Filter group, click the Advanced Filter Options button 
and then click Clear All Filters.

PAUSE. LEAVE the database open to use in the next exercise.

Using Filter by Form
Although only a single filter can be in effect for any one field at any one time, you can specify a dif-
ferent filter for each field that is present in the view. In addition to the ready-to-use filters for each 
data type, you can also filter a form by completing an action called filter by form. Filter by form 
is useful when you want to filter several fields in a form or if you are trying to find a specific record. 
Access creates a blank form that is similar to the original form; you then complete as many of the 

Figure 5-12

Media field text filters
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fields as you want. When you are finished, Access finds the records that contain the specified val-
ues. In this exercise, you filter by form.

To use filter by form, open the form in Form view and make sure the view is not already filtered 
by verifying that either the Unfiltered icon or the dimmed No Filter icon is present on the record 
selector bar. On the Home tab, in the Sort & Filter group, click Advanced and then click Filter By 
Form. Click the down arrow in a field to display the available values.

Enter the first set of values on the Look for tab at the bottom of the page and then click the Or tab 
and enter the next set of values. Each time you click the Or tab, Access creates another Or tab; so 
you can continue to add additional filter values. Click the Toggle Filter button to apply the filter. 
The filter returns any record that contains all of the values specified on the Look for tab, or all of the 
values specified on the first Or tab, or all of the values specified on the second Or tab, and so on.

STEP BY STEP Use Filter by Form

GET READY. USE the Graphic Art-final database that is open from the previous exercise.

1. On the Home tab, in the Sort & Filter group, click the Advanced Filter Options button 
and then click Filter By Form. A form filter appears.

2. Place the insertion point in the Dimensions box and then click the down arrow on the 
right to display the list of options shown in Figure 5-13.

3. Click 30 X 40.

4. Click the Or tab at the bottom of the form.

5. Place the insertion point in the Dimensions box, click the down arrow and then click 12 
X 28.

6. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the 
filter. The records containing either the dimensions 30 X 40 or 12 X 28 are displayed 
(see Figure 5-14).

Figure 5-13

Form filter field options
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7. Click the Next record button on the record navigator at the bottom of the form to see 
the second record in the form filter results.

8. On the Home tab, in the Sort & Filter group, click the Toggle Filter button again to 
remove the filter, click the Advanced button and then click Clear All Filters.

9. Click the File tab and then click Close.

STOP. CLOSE the database and then EXIT Access.

Take Note If you want a field value to operate as a filter that is independent of other field values, you must 
enter that value on the Look for tab and each Or tab. In other words, the Look for tab and each 
Or tab represents an alternate set of filter values.

Figure 5-14

Form filter results
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Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Form Design button a.  Useful when you want to filter on several fields in a form 
or if you are trying to find a specific record

2. Blank Form button b. Creates a simple form with a single mouse-click

3. Filter by form c. Quickly creates a new blank form in Layout view

4. Form tool d. Quickly creates a new blank form in Design view

5. Common filters e. Built into every view that displays data

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. Forms can be used to control access to data, such as which fields or rows of 
data are displayed. 

T F 2. To access the Theme options, first change to Form view.

T F 3. You cannot remove a sort order from just a single field.

T F 4. The filters available depend on the field’s data type and values.

T F 5. When using the Form Wizard, you can only include fields from one table.

Projects

Project 5-1: Creating, Sorting, and Filtering Forms

In this project, you are the manager at Southridge Video. To expand the store, you have recently 
started taking used games in trade. You store information about each title in an Access database. 
You decide to create some forms to help you use the database more efficiently. Next, when a cus-
tomer comes in and asks about game publishers and the availability of a particular game, you sort 
and filter data in the forms you created to get the information that you need.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Games inventory from the data files for this lesson and then SAVE the database 
as Games inventory-final.

2. In the Navigation Pane, double-click Games: Table to open the table.

3. On the Create tab, in the Forms group, click the Form button to create a simple form 
and display it in Layout view.

4. Click the File tab and then click Save.

5. In the Save As dialog box, click OK to accept the Games form name suggested by 
Access.

6. Click the Close button for Games to close the form.

7. On the Create tab, in the Forms group, click the Form Design button to create a new 
blank form in Design view.

8. On the Form Design Tools Design contextual tab, in the Tools group, click the Add 
Existing Fields button to display the Field List pane.

9. Click the Show all tables link in the Field List pane, if necessary.

10. Click the expand button next to Games to list the available fields, if necessary.
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11. Double-click Title to add it to the form.

12. Double-click Rating to add it to the form.

13. Double-click Platform to add it to the form.

14. Click the File tab and then click Save.

15. In the Save As dialog box, type Game Rating and then click OK.

16. Click the Close button to close the Field List.

17. On the Design contextual tab, in the Views group, click the lower half of the View 
button and then click Form View to display the form in Form view.

18. Click the Close button for Game Rating to close the form.

19. In the Navigation Pane, double-click the Games form to open it.

20. Right-click the Publisher field to display the shortcut menu.

21. Click Sort A to Z to sort the form by publisher name in alphabetic order.

22. Navigate to record 3, titled Marvel: Ultimate Alliance.

23. Right-click the Title field and then click Contains “Marvel: Ultimate Alliance”.

24. Click the Next record button on the record navigator at the bottom of the form to see 
all the versions of the game with that name.

25. On the Home tab, in the Sort & Filter group, click the Remove Sort button, click the 
Advanced down arrow and then click Clear All Filters.

26. CLOSE the database.

PAUSE. LEAVE Access open for the next project.

Project 5-2: Applying a Theme 

In this project, your brother owns Wingtip Toys and recently started keeping a list of the store 
inventory in an Access database. He wants to add a form to the database and asks for your help. 
Add a simple form with a theme, and then show him how to sort and apply filters.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Toy inventory from the data files for this lesson and then SAVE the database as 
Toy inventory-final.

2. In the Navigation Pane, double-click Inventory: Table to open the table.

3. Use the Form tool to create a simple form.

4. Format the form using the Organic theme option.

5. SAVE the form as Inventory.

6. Sort the form’s In Stock field from Largest to Smallest.

7. Sort the Description field from A to Z.

8. Run a filter that finds all the records where the Price field is between $50 and $100.

9. Clear all sorts and filters.

10. Create a filter by form to find all the records that have two items in stock.

CLOSE the form, CLOSE the database, and then EXIT Access.
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SKILL SUMMARY

Skills Exam Objective Objective Number

Creating Reports Create a report based on the query or table.
Create a report by using a wizard.
Create reports in Design view.

5.1.1 
5.1.3
5.1.2

Applying a Theme Apply a theme. 5.3.8

Working with Reports Group and sort fields. 5.2.1

SOFTWARE ORIENTATION

Reports Group

The Reports group is located on the Create tab in the Ribbon, as shown in Figure 6-1.

Creates a 
simple report

Creates a blank report 
in Layout view

Starts the Report 
Wizard

Figure 6-1
Reports group

Use the Reports group of commands to create reports. 

CREATING REPORTS
A report is a database object that is used to organize and display data pulled from tables and 
queries. You can create a report using the Report button, Report Wizard button, Report Design 
button, and Blank Report button, depending on the amount of customization desired. You can 
also create labels using the Labels button. After creating a report, you can instantly apply a Theme 
to create a professional look. You can also sort and filter data in a report to display the records to 
suit your needs.
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Creating a Simple Report and Deleting a Report
You can use Access 2016 to create simple or complex reports. When creating a complex report, 
you might spend quite a bit of time choosing which fields you want to include from various tables 
or queries. That is fine when you need such a report, but when you need a simple display of all 
the fields in a table or query, use the Report button to create a simple report. You can also delete a 
report to remove it permanently from the database. In this exercise, you use the Report button to 
create a simple report and delete a report using the Delete command.

Reports are commonly used as formatted hard copies of table or query data. You can modify a 
report’s design, but you cannot add or edit data in a report. The purpose of a report is to allow 
users to view data, not edit it. For example, a supervisor might ask you to create a sales report that 
is filtered to show only one region’s sales. The supervisor does not need to edit the data, just view it.

A report’s record source is the table or query that provides the data used to generate a report. 
Before you can create a report, you need to define the record source by clicking in the Navigation 
Pane on the table or query on which you want to base the report. Then, click the Report button 
and a report is automatically generated based on the table or query you selected.

You can modify a report’s design, print, or save and close a report. You should save a report’s design 
if you are likely to use it again. To save a report, click the Save button on the File tab or in the 
Quick Access Toolbar. If you click the Close button without saving, Access will display a dialog 
box asking if you want to save it. Once it is saved, the report is listed in the Navigation Pane. You 
can open it and modify it in the future or create a new report based on the original. The next time 
you run the report, the design will be the same, but the data will be different if the data in the 
table or query has been updated.

You use the Delete command in the Records group on the Home tab to permanently delete a 
report from the database. You can delete a report if you erroneously created it or if you want to 
unclutter the database by removing reports that you no longer use.

STEP BY STEP Create and Delete a Report 

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN AlpineSkiHouse from the data files for this lesson and then SAVE the database 
as AlpineSkiHouse-final.

2. In the Navigation Pane, click the Rooms table to select it. This is your record source.

3. On the Create tab, in the Reports group, click the Report button. The report appears in 
Layout view, as shown in Figure 6-2. Notice the Report Layout tools that appear in the 
Ribbon.
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4. Click the Room ID header to select it. Position the pointer over the right border until 
you see a double-sided arrow. 

5. Click and drag, resizing the column to remove excess white space. Your screen should 
look similar to Figure 6-3.

6. Click the Save button on the Quick Access Toolbar. The Save As dialog box appears 
with Rooms in the Report Name box. Click OK. Notice that the Rooms report is listed in 
the Navigation Pane.

7. Click the Close button to close the Rooms report.

8. In the Navigation Pane, click the Reservations report to select it.

9. On the Home tab, in the Records group, click the Delete button arrow and then click the 
Delete command on the menu that appears.

Figure 6-2

Simple report

Figure 6-3

Report with resized columns
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10. Click Yes on the dialog box asking you if you want to permanently delete the 
Reservations report. The report is now permanently deleted from the database.

PAUSE. LEAVE the database open to use in the next exercise.

Using the Report Wizard
You are probably already familiar with the way a “wizard” works. The Report Wizard displays a 
series of questions about the report you want, and then it creates the report for you based on your 
answers. The Report Wizard knows what makes a good report, so the questions are designed to 
help you create a professional report with little effort. The Report Wizard is usually the easiest way 
to create a report when you want to choose which fields to include. It guides you through a series 
of questions and then generates a report based on your answers. If you want to skip steps such as 
Sorting or Grouping in the Report Wizard, click the Next button to go to the next screen. You 
can click the Finish button anytime it is available to create the report with the choices you have 
specified. In this exercise, you use the Report Wizard to create a report based on the Rooms table.

The Report Wizard allows you to include fields from more than one table or query. You can click 
the double right arrow button (>>) to include all the fields in the report or click the single right 
arrow button (>) to move them one at a time. Likewise, you can click the double left arrow button 
(<<) to move all the fields out of the report or the single left arrow button (<) to move them one 
at a time.

You can specify group levels, such as grouping all of the first-floor rooms together and all of the 
second-floor rooms together if creating a room report. You can also choose up to four fields on 
which to sort data in ascending or descending order. On the layout screen, you can choose from 
various layouts, such as stepped, block, or outline, all of which indent fields and records in differ-
ent ways to make the report clearer to read. You can also choose to display the report in portrait 
or landscape orientation. Access provides a wide variety of design styles from which to choose. On 
the last screen of the Report Wizard, you can type a name for the report and choose to preview or 
modify the report.

STEP BY STEP Use the Report Wizard

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. On the Create tab, in the Reports group, click the Report Wizard button. The first 
screen of the Report Wizard appears.

2. Select the Rooms table in the Tables/Queries menu.

3. Click the >> button to move all the fields into the Selected Fields list.

4. Click the Room ID field to select it and then click the < button to move it back to the 
Available Fields list. Click the Next button.

5. Click the Location field to select it and then click the > button to add it as a grouping 
level, as shown in Figure 6-4.
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6. Click the Next button.

7. Select Room Name from the fields menu to sort in ascending order and then click the 
Next button.

8. In the Layout section, click the Outline button. In the Orientation section, click the 
Landscape button as shown in Figure 6-5. Click Next.

9. Type Rooms Wizard as the title of the report.

10. Click Finish. The Rooms Wizard report appears on the screen, as shown in Figure 6-6.

11. CLOSE the report. Notice that the new report is listed in the Navigation Pane.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 6-4

The Report Wizard Grouping 
screen

Figure 6-5

The Report Wizard Layout 
screen
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Creating a Report in Design View
When you want a customized report, you can create it in Design view, which offers you many 
options for creating the report exactly the way you want it. Design view gives you the most options 
for creating a report, because it shows you the underlying structure of the report. It also provides 
you with more design tools and capabilities. In this exercise, you create a report in Design view by 
adding and moving fields.

In Design view, a report is displayed on a design grid with sections. Table 6-1 lists the sections.

Section Name Description

Report header This section is printed once at the beginning of every report. This is a good 
place to include a logo, a date, or information that might normally appear on a 
cover page.

Page header This section is printed at the top of every page of a report, so it is a good place 
to include the report title.

<Group> header This section is printed at the beginning of a group. (The name of the grouping 
field replaces <Group>.) It is a good place to include the group name. 

Detail This section includes the body of the report. It is printed once for every row in 
a record source.

<Group> footer This section is only printed at the end of a group that contains summary 
information for the group. (The name of the grouping field replaces <Group>.)

Page footer This section is printed at the bottom of every page of a report, so it is a good 
place to include information such as a page number.

Report footer This section is printed once at the end of every report. It is a good place for 
report totals.

To add fields to the report design, you can display the Field List pane (if it is not already displayed) 
by clicking the Add Existing Fields button. Double-click a field in the Field List to add it to the 
design grid or drag the field to a location on the grid. If you need to move a field on the grid, click 
the field to select it, position the pointer on the border until you see a four-sided arrow, and then 

Figure 6-6

The Report Wizard report

Table 6-1

Design view sections



Creating Reports 97

drag it to the new location. To change the size of a field, position the pointer on the border until 
it turns into a two-sided arrow, and then drag to resize the field.

The field name and field data are in two separate boxes. Most of the time you will move both box-
es together; however, to move one box separately from the other, position the pointer on the box 
border’s selection handle, and then drag the box to the new location. 

To see what your report will look like, click the bottom half of the View button in the Views group 
and then select Report View from the menu.

STEP BY STEP Create a Report in Design View

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. If necessary, click the Rooms table in the Navigation Pane to select it.

2. On the Create tab, in the Reports group, click the Report Design button. A new blank 
report is displayed in Design view, as shown in Figure 6-7.

Page header 
section

Detail 
section

Add Existing 
Fields button

3. If the Field List pane is not already displayed, click the Add Existing Fields button on 
the Design tab in the Tools group. The Show All Tables link appears.

4. Click the Show all tables link and then the plus (+) box beside Rooms to display the 
fields in the table, as shown in Figure 6-8.

5. Double-click Room ID. The field is inserted onto the design grid.

6. Double-click Room Name, Bed Size, and Rate to add them to the design grid.

7. Click the Close button on the Field List pane.

Figure 6-7

New blank report in Design 
view
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8. Click the Bed Size label. The border around the label changes to orange, indicating that 
it is selected. Position the insertion point over the top of the border until the pointer 
changes to a four-sided arrow. 

9. Click and drag the label to position it about one-half inch to the right of the Room ID 
field and release the mouse button. The field is moved along with the label.

10. In the same manner, move the Rate label and field to position it below the Bed Size 
field. Your screen should resemble Figure 6-9.

11. Click the Room ID field to select it. Position the mouse pointer on the square handle in 
the middle of the right-side border. Click and drag the field to the left to decrease the 
size by about one-quarter inch.

12. On the Ribbon, in the Views group, click the bottom half of the View button and then 
select Report View from the menu. The report is shown in Report view. Scroll down to 
see all the records.

Figure 6-8

Field List pane

Figure 6-9

Moved fields
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13. Click the Save button on the Quick Access Toolbar.

14. Type Report Design in the Report Name box and then click OK.

15. CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note You can add more than one field to a report design at once only after at least one other field has 
been added. Hold down the Ctrl key and click the fields you want and then drag the selected fields 
onto the report.

APPLYING A THEME 
A theme applies a set of predefined fonts, colors, and design to a report. You can apply a theme to 
any report in Layout view or Design view. The Themes gallery displays a variety of designs. After 
you click the design you want, it is applied to the report. This instant formatting can quickly give 
your report the professional look you want. 

Applying a Theme
To apply a theme, on the Report Layout Tools Design contextual tab, in the Themes group, click 
the Themes button to display the Themes gallery. You can select a design from the list displayed 
or browse for saved themes. You can also customize and then save a theme based on the current 
report. You can click the Colors button and choose a color scheme from the menu to update the 
currently applied theme’s colors and even create new theme colors. You can also click the Fonts 
button and choose a font scheme to update the currently applied theme’s fonts and create new 
theme fonts. In this exercise, you apply a theme to the Rooms report and modify the fonts.

STEP BY STEP Apply a Theme

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. Double-click the Rooms report in the Navigation Pane to open it.

2. On the Ribbon, in the Views group, click the bottom half of the View button and then 
select Layout View from the menu.

3. On the Report Layout Tools Design contextual tab, in the Themes group, click the 
Themes button. The Themes gallery of predefined report themes appears.

4. In the Office section, click the Integral design. The format is applied to the report.

5. In the Themes group, click the Fonts button. Select Cambria from the menu, as shown 
in Figure 6-10. Click the font and the new Font theme is applied. (Be sure to select the 
Cambria font and not the Office 2007-2010 Cambria font.)

6. SAVE the report.

PAUSE. LEAVE the report open to use in the next exercise.
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WORKING WITH REPORTS 
Reports help group and summarize data in different ways. However, after a report is created, you 
can use Layout view as well as Report view to help locate data. For example, you can use Layout 
view to easily sort field data one at a time, or perform more complex sorts using the Group, Sort, 
and Total pane. You can also use Layout view to filter data and view only those records based on 
the criteria you specify, and use Report view or Layout view to find data based on any term you 
specify.

Grouping and Sorting Data within a Report
Sorting organizes data into a particular sequence, such as alphabetic order or from smallest to 
largest numbers. For example, you can sort a customer list in alphabetic order by last name or by 
customer ID number. You can sort data by clicking the buttons on the Ribbon, right-clicking and 
choosing commands from the shortcut menu, or by using the Group, Sort, and Total pane. In this 
exercise, you sort data in a report using the Ribbon, the shortcut menu, and the Group, Sort, and 
Total pane.

Sorting data in a report is similar to sorting in a table. In Layout view, select the field you want 
to sort and then click the Ascending or Descending button on the Home tab in the Sort & Filter 
group. Click the Remove Sort button to remove the sort order. You can sort as many fields as you 
like one at a time.

You can also easily sort data by right-clicking in a field and choosing the type of sort you want 
from the shortcut menu. The sort commands in the shortcut menu vary depending on the type of 
data in the field. For text, you will choose Sort A to Z or Sort Z to A; for numbers, you will choose 
Sort Smallest to Largest or Sort Largest to Smallest; and for dates, you will choose Sort Oldest to 
Newest or Sort Newest to Oldest.

Figure 6-10

The Fonts menu with Cambria 
font chosen
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The Group, Sort, and Total pane gives you more sorting options. You can use the pane to specify 
the sort order or to view the results of sorting using the shortcut menu. To specify a sort, click the 
Add a Sort button and then select a field from the pop-up menu. Click the drop-down menu to 
specify the type of sort you want. Click the More Options button to display additional commands 
for creating detailed sorts. Click the Less Options button to return to the basic sorting options.

To delete a sort in the Group, Sort, and Total pane, click Delete at the end of the sort line.

STEP BY STEP Group and Sort Data within a Report

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. On the Home tab in the Views group, click the bottom half of the View button. Select 
Layout View from the menu.

2. Click the Room Name header.

3. On the Home tab, in the Sort & Filter group, click the Ascending button. The column is 
sorted in ascending alphabetic order.

4. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The Sort is 
removed.

5. Right-click the Room Name header. The shortcut menu appears.

6. Select Sort Z to A. The column is sorted.

7. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The Sort is 
cleared.

8. On the Report Layout Tools Design contextual tab, in the Grouping & Totals group, click 
the Group & Sort button. The Group, Sort, and Total pane appears at the bottom of the 
screen, as shown in Figure 6-11.

9. Click the Add a sort button in the Group, Sort, and Total pane.

10. Select Room Name from the select field list. Notice that the field was sorted in 
ascending order by default and a line was added describing the sort.

11. Click the down arrow beside with A on top and then select with Z on top from the 
menu. The field is sorted in descending order.

Figure 6-11

Group, Sort, and Total pane
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12. Click the More Options button in the Sort line. Notice the options available for 
customizing a sort (see Figure 6-12).

13. Click the Delete button. The sort is cleared.

14. In the Grouping & Totals group on the Ribbon, click the Group & Sort button. The 
Group, Total, and Sort pane is removed.

15. SAVE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Filtering Data within a Report
A filter displays only data that meets the criteria you have specified and hides the rest. It does not 
modify the table data or the design of the report. After you remove a filter, all the records are 
displayed again. Filtering data in Layout view of a report is very similar to filtering data in a table. 
You can apply common filters using the commands in the Sort & Filter group or by right-clicking 
a field and choosing a filter from the shortcut menu. The filters available on the shortcut menu 
vary depending on the type of data in the field. Only one filter can be applied to a field at a time. 
However, you can specify a different filter for each field. In this exercise, you filter a report using a 
custom filter, and filter by selection.

You can toggle between filtered and unfiltered views using the Toggle Filter button. To remove a 
filter from a field, right-click in the field and then select the Clear filter from field name command. 
To remove all filters permanently, select the Clear All Filters command on the Advanced menu in 
the Sort & Filter group.

Take Note If you save a report (or other object) while a filter is applied, it will be available the next time that 
you open the report. If you want to open the report and see the filter already applied, set the Filter 
On Load property setting to Yes.

You can also filter by selection in a report. If you want to view only the reservations for 12/13/16, 
select that date in the Check-in field and then click the Selection button. That date will appear in 
the menu, so that you can choose Equals 12/13/16, Does Not Equal 12/13/16, and so on. You can 
also access these commands on the shortcut menu by right-clicking the value.

Take Note If you need to apply a filter that is not in the common filters list, you can write an advanced filter 
using the Advanced Filter/Sort command on the Advanced menu. You need to be familiar with 
writing expressions, which are similar to formulas, and be familiar with the criteria that you spec-
ify when designing a query.

STEP BY STEP Filter Data within a Report

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. Click the Location header to select it.

2. On the Home tab, in the Sort & Filter group, click the Filter button. A menu appears.

3. Select Text Filters and then click Begins With. The Custom Filter dialog box appears.

Figure 6-12

More sort options
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4. Type 1 into the Custom Filter dialog box and then click OK. The data is filtered to show 
only the rooms on the first floor.

5. Click the Toggle Filter button on the Ribbon. The report returns to its unfiltered state.

6. In the Bed Size field, click King in the second row.

7. On the Home tab, in the Sort & Filter group, click the Selection button, and then select 
Equals “King” from the menu. The data is filtered to show only the rooms with King-
sized beds.

8. Right-click the Bed Size header. A shortcut menu appears. Notice that the Equals 
“King” filter and the other filters from the Selection menu are also available in the 
shortcut menu (see Figure 6-13).

9. Select Clear filter from Bed Size from the menu. The filter is cleared.

10. CLOSE and SAVE the report. 

PAUSE. LEAVE the database open to use in the next exercise.

Finding Data within a Report
When you want to quickly locate records in a report, you can use the Find command, which 
searches all the records of the report for any term you specify. Sometimes, you may need to quickly 
find records within a report while in Report view or Report Layout view. To accomplish this, you 
can use the Find command in the Find group on the Home tab. In this exercise, you locate data 
in Report view by using the Find command.

The Find command was overviewed for tables in Lesson 3. Like the Find command in table 
datasheet view, once clicked, the Find dialog box appears where you can enter search criteria, set 
options for where you would like Access to look for the data, and set data matching and other 
search options. You can quickly locate records that match your search term and view multiple 
occurrences; however, remember that you cannot modify record data from within a report, so you 
cannot replace the record data that is found. 

Figure 6-13

Shortcut menu
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Take Note You cannot use the Find command when you are in Report Design view; however, you can use it 
in tables, forms, and queries.

STEP BY STEP Find Data within a Report

GET READY. USE the AlpineSkiHouse-final database that is open from the previous 
exercise.

1. Double-click the Rooms report in the Navigation Pane to open it.

2. On the Home tab, in the Find group, click the Find button. The Find dialog box appears 
(see Figure 6-14).

3. Type King in the Find What drop-down box.

4. Click the Find Next button. Access highlights the first occurrence of ‘King’ in the 
report. Continue clicking the Find Next button until Access reports that it has finished 
searching the records. 

5. Click OK and then click Cancel to close the Find dialog box.

6. CLOSE the report and the database.

STOP. EXIT Access.

Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Report a. A list of available fields for adding to a report 

2. Field List pane  b.  A database object that is used to organize and display data from 
tables and queries

3. Detail c. The way a report is displayed in Design view

4. Theme d. The section of a report that includes the body of the report

5. Design grid e.  A predefined format that you can apply to any report in Layout 
view

Figure 6-14

Find dialog box
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True/False
Circle T if the statement is true or F if the statement is false.

T F 1. A simple report contains all the records in a table or query.

T F 2. You can edit the data in a report.

T F 3. Layout view gives you the most options for creating a report, because it shows 
you the underlying structure of the report.

T F 4. You can save a filter with a report.

T F 5. The Toggle Filter button removes a filter permanently.

Projects

Project 6-1: Creating a Report and Applying a Theme

In your job at Fourth Coffee, you are responsible for maintaining the coffee inventory. In this 
project, you will create a report to view the inventory and prepare for the next order, and then you 
will apply a theme to the report.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Coffee from the data files for this lesson and then SAVE the database as Coffee-
final.

2. Click the Coffee Inventory Table in the Navigation Pane to select it.

3. On the Create tab, in the Reports group, click the Report Wizard button. The first 
Report Wizard screen appears.

4. Click >> to move all the fields to the Selected Fields list and then click Next.

5. On the grouping screen, click the Scheduled Order Date field, click the >, and then click 
Next.

6. On the sorting screen, click the active down arrow on the menu, select Pounds, and 
then click Next.

7. Keep the defaults as is on the layout screen, and then click Next.

8. Click Finish. The report is created.

9. CLOSE the report.

10. In the Navigation Pane, double-click the Coffee Inventory report you just created to 
open it.

11. On the Home tab, click View, select Layout View, and then resize the label columns and 
field boxes so all text and data appear completely in them.

12. On the Report Layout Tools Design contextual tab, in the Themes group, click the 
Themes button.

13. In the Office category, select the format named Retrospect.

14. SAVE and then CLOSE the report.

15. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 6-2: Creating a Report in Design View and Filtering a Report

The manufacturing department at Wingtip Toys needs summary information about each toy in 
inventory. In this project, you will create a report in Design view that will display the requested 
information, and then filter the report.

GET READY. LAUNCH Access if it is not already running.

1. OPEN WingtipToys and then SAVE it as WingtipToys-final.

2. Click the Inventory table in the Navigation Pane to select it.

3. On the Create tab, in the Reports group, click the Report Design button.

4. On the Design tab, in the Tools group, click the Add Existing Fields button, if necessary, 
to display the Field List pane.

5. Add and position the fields from the Inventory table onto the design grid as shown in 
Figure 6-15. Adjust the Description field width as shown.

6. Apply the Ion Boardroom theme to the new report.

7. Change to Layout view.

8. Sort the report in ascending order by the Description field.

9. Click the first row of the In Stock field, which contains the number 10.

10. Filter by selection to display the toys with 10 or fewer items in stock.

11. Click the In Stock field header and sort the field in ascending order.

12. Clear all sorts.

13. Clear all filters.

14. Find and cycle through all occurrences of the word, Car.

15. Clear the filter.

16. SAVE the report as Toy Summary and then CLOSE the report.

CLOSE the database and then EXIT Access.

Figure 6-15

Report layout
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SKILL SUMMARY

Skills Exam Objective Objective Number

Creating a query Run a query.
Save a query.
Rename a query.
Create a multi-table query.

3.1.1
3.1.6
3.2.1
3.1.5

Modifying a query Hide fields.
Create a parameter query.

3.2.4
3.1.3

Sorting and filtering data within a query Sort data within queries. 3.2.5

CREATING A QUERY
A query is a set of instructions used for working with data. Creating a query is similar to asking the 
database a question. Running a query performs these instructions and provides the answers. You 
can sort, group, or filter the results that a query returns. There are several different types of queries. 
Basic queries can be used to extract useful information from one or more tables in the database, 
while more advanced queries can be used to manipulate data in tables (for example, create, copy, 
modify, delete, or find duplicate or unmatched table data). 

A select query is the most basic type of Access query. It creates subsets of data that you can use 
to answer specific questions or to supply data to other database objects such as forms and reports. 
The data is displayed in Datasheet view without being changed. A query is a powerful and versatile 
database tool. Queries differ from sort or filter commands because they can be saved for future use 
and can utilize data from multiple tables or other queries.

Creating a Query from a Table 
A query can get its data from one or more tables, from existing queries, or from a combination of 
the two. The tables or queries from which a query gets its data are referred to as its record source. 
When one table provides the information that you need, you can create a simple select query using 
the Query Wizard. You can also use a query to find records with duplicate field values in a single 
table. You can delete a query to remove it permanently from the database and rename a query 
if you want to modify the previous name. In this exercise, you create a simple select query that 
searches the data in a single table and rename the query. You also delete a pre-existing query using 
the Delete command.

The Queries group on the Create tab contains the commands used to create queries. The Query 
Wizard button launches the Query Wizard, which helps you create a simple query, a crosstab que-
ry, a find duplicates query, or a find unmatched query. The Query Design button creates a new, 
blank query in Design view. 

To create a simple select query, click the Query Wizard button in the Queries group on the Cre-
ate tab. Click Simple Query Wizard and then click OK. Specify the table you want to use as the 
record source and the fields that you want to show. Name the query and then click Finish. When 
you close the query, it is automatically saved. You can also save a query as a PDF, XPS, or as a 
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Query, Form, or Report using the Save As Object option. You find out more about Saving Objects 
as other file types in Lesson 13.

To run a query after it has been created, simply double-click it in the Navigation Pane to open it 
in Datasheet view and see the results.

You can also permanently delete a query from the database by using the Delete command in the 
Records group on the Home tab. You can delete a query if you erroneously created it or simply 
want to unclutter the database by removing preexisting queries you no longer use.

Finally, you can rename a query by right-clicking on it in the Navigation Pane, choosing the Re-
name command from the shortcut menu that appears, and typing in the new name.

STEP BY STEP Create a Simple Query

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN the Northwind file from the data files for this lesson and then SAVE the database 
as Northwind-final.

2. On the Create tab, in the Queries group, click the Query Wizard button. The New Query 
dialog box appears, as shown in Figure 7-1.

3. Click Simple Query Wizard and then click OK. The Simple Query Wizard appears, as 
shown in Figure 7-2.

Figure 7-1

New Query dialog box and 
Query buttons
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4. In the Tables/Queries drop-down list, Table: Employees should be selected by default. 
If it is not, select it.

5. Under Available Fields, double-click Last Name, First Name, E-mail Address, Mobile 
Phone, and Position to move them to the Selected Fields box.

Take Note To remove a field from the Selected Fields box, double-click the field. This moves it back to the 
Available Fields box.

6. Click the Next button. The second screen in the Simple Query Wizard appears.

7. Name the query Employees Contact Query and then select Open the query to view 
information if it is not already selected.

8. Click the Finish button to accept the default selection and complete the query. The 
Employees Contact Query is displayed, as shown in Figure 7-3. The results show all of 
the records, but show only the five fields that you specified in the Query Wizard.

Figure 7-2

Simple Query Wizard

Figure 7-3

Simple select query
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9. Click the Close button on the Employees Contact Query window to close the query.

10. In the Navigation Pane, double-click the Employees Contact Query to run it. The query 
results are displayed in Datasheet view.

11. Click the Close button on the Employees Contact Query window to close the query.

12. In the Navigation Pane, right-click the Employees Contact Query to select it.

13. On the shortcut menu that appears, click the Rename command.

14. In the query name box, type Employees Contact Info Query to rename it and then click 
Enter. The query has been renamed.

15. In the Navigation Pane, click the Marketing Employees query to select it.

16. On the Home tab, in the Records group, click the Delete button arrow and then click the 
Delete command on the menu that appears.

17. Click Yes on the dialog box asking you if you want to permanently delete the Marketing 
Employees query. The query is now permanently deleted from the database.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Find Duplicates Query
As a general rule, duplicate data should be eliminated from a database whenever possible to min-
imize redundancy and increase accuracy. The first step in this process is finding duplicate data. 
Two or more records are considered duplicates only when all the fields in your query results con-
tain the same values. If the values in even a single field differ, each record is unique. In this exer-
cise, you use the Find Duplicates Query Wizard to find duplicate records. 

You can also use the Find Duplicates Query Wizard to find records that contain some matching 
field values. You should include the field or fields that identify each record uniquely, typically the 
primary key. The query returns matching records where the values in the specified fields match 
character for character. 

STEP BY STEP Create a Find Duplicates Query

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button. The New Query 
dialog box appears.

2. Click Find Duplicates Query Wizard and then click OK. The Find Duplicates Query 
Wizard appears.

3. Click Table: Industry Friends and then click Next. The next screen in the Find 
Duplicates Query Wizard appears.

4. Double-click Last Name, First Name, and E-mail Address to move them to the 
Duplicate-value fields box. These are the fields that you think may include duplicate 
information.

5. Click Next to display the next screen in the Find Duplicates Query Wizard. This screen 
asks if you want to show other fields of the duplicate record besides just the ones with 
the duplicate data.

6. Double-click Company and Referred By to move them to the Additional query fields 
box, as shown in Figure 7-4.
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7. Click Next to display the final screen in the Find Duplicates Query Wizard.

8. Name the query Duplicates for Industry Friends and then click Finish. The query 
showing duplicate records in the table is displayed, as shown in Figure 7-5.

9. Click the Close button on the Duplicates for Industry Friends tab to close the query.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Query from Multiple Tables
If the data you need is spread out in more than one table, you can build a query that combines 
information from multiple sources. You can also create a query that finds records in one table that 
have no related records in another table. When you need to include multiple tables in your query, 
you can use the Simple Query Wizard to build a query from a primary table and a related table. 
The process is similar to creating a query from a single table, except that you include fields from 
additional tables. In this exercise, you create a simple query to display related data from two tables.

Sometimes using data from a related table helps make the query results clearer and more useful. 
For example, in this activity, you could pull the name of the industry friends and the employee 
who referred them from one table. But to get additional information about the referring employ-
ees, you need to pull data from the related Employees table.

Figure 7-4

Find Duplicates Query Wizard, 
Additional query fields

Figure 7-5

Duplicates for Industry Friends 
query
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Before creating a query from multiple tables, you must first ensure that the tables have a defined 
relationship in the Relationships window. A relationship appears as a line connecting the two 
tables on a common field. You can double-click a relationship line to see which fields in the tables 
are connected by the relationship.

STEP BY STEP Create a Query from Multiple Tables

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click Employees: Table to open the table.

2. On the Database Tools tab, in the Relationships group, click the Relationships button 
to display the table relationship, as shown in Figure 7-6. The Employees table has a 
defined relationship with the Industry Friends table as indicated by the relationship line 
connecting the two tables.

 

3. Click the Close button in the Relationships group on the Ribbon to close the 
Relationships window, and then click the Close button on the Employees tab to close 
the Employees table.

4. On the Create tab, in the Queries group, click the Query Wizard button to display the 
New Query dialog box.

5. Click Simple Query Wizard and then click OK to display the Simple Query Wizard.

6. In the Tables/Queries drop-down list, click Table: Industry Friends.

7. Under Available Fields, double-click Last Name, First Name, and Referred By to move 
them to the Selected Fields box.

8. In the Tables/Queries drop-down list, click Table: Employees.

9. Under Available Fields, double-click Position and E-mail Address to move them to the 
Selected Fields box.

10. Click the Next button to display the next screen. The Detail option should be selected 
by default.

Figure 7-6

Relationships for Employees 
table
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11. Click the Next button to display the final screen, and then click the Finish button to 
accept the default settings in this screen and display the query, shown in Figure 7-7. 
This query shows the name, position, and email address of the employee who referred 
each industry friend.

12. Click the Close button on the Industry Friends Query tab to close the query and then 
SAVE the query if prompted.

PAUSE. LEAVE the database open to use in the next exercise.

Finding Unmatched Records
To view only the records in one table that do not have a matching record in another table, you can 
create a Find Unmatched query. On the Create tab, in the Queries group, click Query Wizard, 
and then click Find Unmatched Query Wizard to start the wizard. In this exercise, you run a Find 
Unmatched query to display the employees who do not live in Stamford.

STEP BY STEP Find Unmatched Records

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button. The New Query 
dialog box appears.

2. Click Find Unmatched Query Wizard and then click OK. The Find Unmatched Query 
Wizard appears, as shown in Figure 7-8.

Figure 7-7

Industry Friends query
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3. Table: Employees is the default selection in this screen. This table will contain the 
records you’ll want to display. Click the Next button to display the next screen in the 
Find Unmatched Query Wizard.

4. Select Table: Stamford Employees to select the table that is related to the Employees 
table and contains the records you don’t want to display. Click the Next button to 
display the next screen in the Find Unmatched Query Wizard.

5. Click E-mail Address in the Fields in “Employees” list. Click E-mail Address in the Fields 
in “Stamford Employees” list. Click the <=> button to display them in the Matching 
fields box, as shown in Figure 7-9. These fields contain data that is in both tables.

6. Click the Next button to display the next screen in the Find Unmatched Query Wizard.

7. In the Available fields box, double-click Last Name, First Name, Position, and City to 
move them to the Selected fields box. 

8. Click the Next button to display the final screen in the Find Unmatched Query Wizard.

9. Click in the text box at the top of this screen, type Non-Stamford Employees to name 
your query, and then click the Finish button. The query is displayed, as shown in Figure 
7-10.

Figure 7-8

Find Unmatched Query Wizard

Figure 7-9

Find Unmatched Query Wizard, 
Matching fields
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10. Click the Close button on the Non-Stamford Employees tab to close the query.

PAUSE. LEAVE the database open to use in the next exercise.

SOFTWARE ORIENTATION

Query Tools Design Tab

By changing to Design view, you can access all the tools needed to modify your query on the 
Query Tools Design tab, shown in Figure 7-11. 

Performs actions 
specified

Selects and  
displays records

Creates a new table 
from the query

Updates data in an 
existing table

Deletes matching 
information

Displays records that 
contain the top or bottom 

numeric values

Defines parameters 
for a query

Adds records to an 
existing table

Creates a 
crosstab query

Shows/Hides 
column totals

Opens the property sheet to set 
the query’s properties

Figure 7-11
Query Tools Design tab

MODIFYING A QUERY 
A query can be modified in Design view, regardless of how it was created. You can add or remove 
a table, add or remove fields, or add criteria to refine query results.

Adding a Table to a Query
To add a table to a query, you must be in Design view. Run the query and then click Design View 
on the lower half of the View button. On the Query Tools Design tab, in the Query Setup group, 
click the Show Table button to display the Show Table dialog box. There is a tab that contains the 
tables in the database, a tab with the queries, and a tab that displays both. Select the object you 

Figure 7-10

Non-Stamford Employees query



Lesson 7116

want to add to the query and then click the Add button. If you add a second copy of a table to 
the query, it is indicated by a “1” in the title. In this exercise, you add additional tables to a query 
using the Show Table dialog box.

STEP BY STEP Add a Table to a Query

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. Double-click the Industry Friends Query in the Navigation Pane to open it.

2. On the Home tab, in the Views group, click the lower half of the View button and then 
click Design View. The query appears in Design view, as shown in Figure 7-12.

3. On the Query Tools Design tab, in the Query Setup group, click the Show Table button 
to display the Show Table dialog box.

4. Click Industry Friends and then click the Add button. A second copy of the Industry 
Friends table is added to the query, as indicated by the “1” in the title, as shown in 
Figure 7-13.

The 1 indicates a second copy of the table has been added to the query

5. Click Stamford Employees and then click the Add button. The table is added to the 
query.

6. Click the Close button in the Show Table dialog box.

7. Click anywhere in the Industry Friends_1 field list.

Figure 7-12

Query in Design view

Figure 7-13

Second copy of table in a query
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8. Press the Delete key to remove the table.

9. Click anywhere in the Stamford Employees field list.

10. Press the Delete key to remove the table.

11. Click the Close button on the Industry Friends Query tab to close the query. If a 
message asks you if you want to save the changes, click Yes.

PAUSE. LEAVE the database open to use in the next exercise.

Adding Criteria to a Query
Not all queries must include criteria, but if you are not interested in seeing all the records that 
are stored in the underlying record source, you can add criteria to a query when designing it. A 
query criterion is a rule that identifies the records you want to include in the query result. A 
criterion is similar to a formula. Some criteria are simple and use basic operators and constants. 
Others are complex and use functions, special operators, and include field references. Criteria can 
look very different from each other, depending on the data type of the field to which they apply 
and your specific requirements. You can also run a parameter query, in which the user inter-
actively specifies one or more criteria values. This is not a separate query; it extends the flexibility 
of another type of query, such as a select query, by prompting the user for a parameter value when 
it is run. In this exercise, you add criteria to queries to display certain records, use the Show check 
box, and create and run a parameter query that will prompt the user for a city name and display 
matching records.

To specify one or more criteria to restrict the records returned in the query results, open the query 
in Design view. Select the field and then type the condition that you want to specify in the Criteria 
row. To see the results, change to Datasheet view. The results will show each field, including the 
one where the criterion was specified.

Sometimes, you may want to show only certain fields (while hiding others) from the records that 
match the criterion to get a more concise view of the resulting data. In this case, deselect the Show 
row check box above the Criteria row for those fields you don’t want to display in the results. The 
fields that you choose not to show, except the field with the criterion, will be hidden from the 
results after you change to Datasheet view.

Table 7-1 shows some sample criteria and explains how they work. Table 7-2 shows the query re-
sults that are returned when a specific criterion is used.

Criteria Description

>25 and <50 This criterion applies to a Number field, such as 
Inventory. It includes only those records where the 
Inventory field contains a value greater than 25 
and less than 50.

DateDiff (“yyyy”, [BirthDate], Date()) > 21 This criterion applies to a Date/Time field, such as 
BirthDate. Only records where the number of 
years between a person’s birth date and today’s 
date is greater than 21 are included in the query 
result. 

Is Null This criterion can be applied to any type of field to 
show records where the field value is null. (A 
null value is a marker that a value does not 
exist for a field and is differentiated from a value 
that has been missed being entered by a user.)

Table 7-1

Criteria examples
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To Include Records That… Use This Criterion Query Result

Exactly match a value, such as 
Manager

“Manager” Returns records where the given field is set 
to Manager.

Do not match a value, such as 
Chicago

Not “Chicago” Returns records where the given field is set 
to a value other than Chicago.

Begin with the specified string, 
such as B

Like B* Returns records for the given field where 
the value starts with “B,” such as Boston, 
Bakersfield, and so on. 

Do not begin with the specified 
string, such as B 

Not Like B* Returns records for the given field where 
the value starts with a character other than 
“B.”

Contain the specified string, 
such as Sales 

Like “*Sales*” Returns records for the given field that 
contain the string “Sales.”

Do not contain the specified 
string, such as Sales

Not Like “*Sales*” Returns records for the given field that do 
not contain the string “Sales.”

STEP BY STEP Add Criteria to a Query

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click the Employees Contact Info Query to open it.

2. On the Home tab, in the Views group, click the lower half of the View button and then 
click Design View.

3. In the Criteria row of the Position field, type Like “*Manager”, as shown in Figure 
7-14, to display all records that end with the string “Manager” in the Position field (for 
example, Assistant Manager, Sales Manager, Product Manager, and so on.). 

 

4. On the Query Tools Design tab, in the Results group, click the lower half of the View 
button and then click Datasheet View. The query results display all records that end 
with the string “Manager” in the Position field. (You may have to increase the width of 
the Position field to completely view the data within it.)

Table 7-2 

Query result examples

Figure 7-14

Query criterion
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5. On the Home tab, in the Views group, click the lower half of the View button and then 
click Design View. 

6. In the Show row, under the First Name field, click the Show check box to deselect it. 
The First Name field data will not appear in the query results.

7. On the Home tab, in the Views group, click the lower half of the View button and then 
click Datasheet View. Notice that the First Name field doesn’t appear.

8. Click the Close button on the Employees Contact Info Query tab to close the query. 
When prompted to save, click Yes.

9. In the Navigation Pane, double-click the Non-Stamford Employees Query under the 
Employees section to open it.

10. On the Home tab, in the Views group, click the lower half of the View button and then 
click Design View.

11. In the Criteria row of the City field, type [City?]. This will create the parameter and 
require you to enter a city name when the query is run.

12. On the Home tab, in the Views group, click the lower half of the View button and then 
click Datasheet View. The prompt appears in the Enter Parameter Value dialog box.

13. Type Darien in the City? box.

14. Click OK. The records for non-Stamford employees who live in Darien are displayed in 
the results, as shown in Figure 7-15.

15. Click the Close button on the Non-Stamford Employees tab to close the query. When 
prompted to save, click Yes.

PAUSE. LEAVE the database open to use in the next exercise.

SORTING AND FILTERING DATA WITHIN A QUERY
Sorting and filtering data within a query allows you to display only the records you want and/or 
display records in a particular order.

Sorting Data within a Query
Sorting data in a query can help organize data efficiently and make it easier for users to review 
and locate the records they want without having to browse the data. Data can be sorted in the 
Datasheet view of a query. Right-click the field on which you want to sort and then click the sort 
order you want—ascending or descending—from the shortcut menu. The records are rearranged 
to match the sort order. In this exercise, you sort data using the Datasheet view of a query.

To sort by more than one field, on the Home tab, in the Sort & Filter group, click the Advanced 
button, and then click Advanced Filter/Sort to open a tab where you can specify more than one 
field by which to sort and the sort order.

Figure 7-15

Parameter query result
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STEP BY STEP Sort Data within a Query

GET READY. USE the Northwind-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click the Industry Friends Query to open it.

2. Right-click the Referred By field and then select Sort A to Z from the shortcut menu 
that is displayed. The field is sorted in alphabetical order from A to Z.

3. On the Home tab, in the Sort & Filter group, click the Remove Sort button. The sort 
order is removed from the Referred By field.

4. On the Home tab, in the Sort & Filter group, click the Advanced button, and then select 
Advanced Filter/Sort from the menu. An Industry Friends QueryFilter1 tab appears, as 
shown in Figure 7-16.

5. Click the Field cell in the first column, click the down arrow and then click Referred By 
on the drop-down menu.

6. Click the Sort cell in the first column, click the down arrow and then click Ascending on 
the drop-down menu.

7. Click the Field cell in the second column, click the down arrow and then click Last 
Name on the drop-down menu.

8. Click the Sort cell in the second column, click the down arrow and then click Ascending 
on the drop-down menu. Your screen should look similar to Figure 7-17.

Figure 7-16

Industry Friends QueryFilter1 
tab



Creating and Modifying Queries 121

9. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Apply Filter/Sort. The query is sorted by the Referred By field in ascending order and 
then by the Last Name field in ascending order.

10. On the Home tab, in the Sort & Filter group, click the Remove Sort button.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note The same tab is used to perform an advanced filter for the query.

Filtering Data within a Query
A filter limits a view of data to specific records without requiring you to alter the design of the 
underlying query. If the criteria are temporary or change often, you can filter the query results in-
stead of frequently modifying the query criteria. A filter is a temporary criterion that changes the 
query result without altering the design of the query. In this exercise, you filter data within a query.

To filter data within a query, click the field you want to filter. On the Home tab, in the Sort & 
Filter group, click the Filter button. The filters available depend on the type and values of the field. 
When you apply the filter, only records that contain the values in which you are interested are 
included in the view. The rest are hidden until you remove the filter by clicking the Toggle Filter 
button.

Figure 7-17

Advanced sort criteria
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STEP BY STEP Filter Data within a Query

GET READY. USE the Northwind-final database that is open from the previous exercise. 
The Industry Friends Query should be open.

1. Click the Position header to select the field.

2. On the Home tab, in the Sort & Filter group, click the Filter button. A menu appears on 
the field, as shown in Figure 7-18.

3. On the menu, click Text Filters and then click Contains on the submenu. A Custom 
Filter dialog box appears.

4. In the Position contains box, type Marketing and then click OK. The records are filtered 
to show only those results containing the word “Marketing” in the Position field. Adjust 
the fields to display the entire position name if necessary.

5. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to remove the 
filter.

6. Click the Close button on the Industry Friends Query tab to close the query and then 
click Yes to save changes when prompted.

7. Click the Close button on the Industry Friends QueryFilter1 tab to close the query.

STOP. CLOSE the database and then EXIT Access.

Figure 7-18

Filter menu
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Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1. A(n) ____________ is the most basic type of Access query.

2. The tables or queries from which a query gets its data are referred to as its____________.

3. Two or more records are considered ____________ only when all the fields in your query 
results contain the same values.

4. To view only the records in one table that don’t have a matching record in another 
table, you can create a ____________ query.

5. A(n) ____________ is a window that lists all the fields in the underlying record source or 
database object.

Multiple Choice
Select the best response for the following statements or questions.

1. Which of the following queries cannot be created using the Query Wizard?
a. Parameter query
b. Simple query
c. Find duplicates query
d. Find unmatched query

2. Which of the following statements best describes why queries are different from sort 
or filter commands? 
a. You can apply them to multiple fields.
b. You can save them.
c. You can modify them
d. You can use them on forms.

3. To find records that contain matching field values, you can create a query using which 
of the following wizards?
a. Find Matching 
b. Matching Fields
c. Duplicate Records
d. Find Duplicates

4. Before creating a query from multiple tables, you must first ensure that the tables have 
which of the following?
a. Unmatched records
b. A defined relationship
c. A filter applied
d. No related records

5. To add a table to a query, you must be in which of the following views?
a. SQL
b. Datasheet
c. Normal
d. Design



Lesson 7124

Projects

Project 7-1: Creating Queries

As the manager at Southridge Video, you have stored information in an Access database about 
each used game that the store has taken in trade. Now that you know how to create queries, you 
decide to create a select query to list the title, rating, and category, which are the fields that you 
most often need to view. Then you create a Find Duplicates query to determine if there are dupli-
cates.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Games from the data files for this lesson and then SAVE the database as Games-
final.

2. On the Create tab, in the Queries group, click the Query Wizard button to display the 
New Query dialog box.

3. Click Simple Query Wizard and then click OK. In the Tables/Queries drop-down list, 
Table: Games should be selected.

4. Under Available Fields, double-click Title, Rating, and Category to move them to the 
Selected Fields box.

5. Click the Next button. The second screen in the Simple Query Wizard appears.

6. Accept the default name Games Query, and then make sure Open the query to view 
information is selected.

7. Click the Finish button.

8. Click the Close button on the Games Query tab to close the query.

9. On the Create tab, in the Queries group, click the Query Wizard button.

10. In the New Query dialog box, click Find Duplicates Query Wizard and then click OK. 

11. Click Table: Games and then click Next. 

12. Double-click Title, Platform, and Publisher to move them to the Duplicate-value fields 
box.

13. Click Next to display the next screen.

14. Double-click Category to move it to the Additional query fields box. 

15. Click Next to display the final screen in the Find Duplicates Query Wizard.

16. Name the query Duplicates for Games and then click Finish to display the query 
showing duplicate records in the table.

17. Click the Close button on the Duplicates for Games tab to close the query.

18. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 7-2: Creating Multiple Table, Unmatched, and Parameter Queries

Information about each selection for the Fourth Coffee monthly coffee club is stored in an Access 
database. Information about regular coffee and decaf coffee is stored in separate tables. In your 
position as customer service rep, it would be useful to be able to query information from both 
tables. Next, you want to determine if there are any records in the decaf coffee table that don’t 
have a matching record in the regular coffee table; you decide to create a Find Unmatched query.

GET READY. LAUNCH Access if it is not already running.

1. OPE N Fourth Coffee Club from the data files for this lesson and then SAVE the 
database as Fourth Coffee Club-final.

2. OPEN the Regular Coffee: Table.

3. Open the Relationships window to ensure there is a relationship between the regular 
coffee and decaf coffee tables. Close the Relationships window.

4. Start the Query Wizard and then select Simple Query Wizard and then click OK.

5. In the Tables/Queries drop-down list, click Table: Regular Coffee.

6. Move the Name, Country, Month, and Type fields to the Selected Fields box.

7. In the Tables/Queries drop-down list, click Table: Decaf Coffee.

8. Move the Name, Country, Month, and Type fields to the Selected Fields box.

9. Click the Next button and name the query Coffee Query.

10. Click the Finish button.

11. Review the information in the query and then CLOSE it.

12. Start the Query Wizard, choose Find Unmatched Query Wizard, and then click OK.

13. Table: Decaf Coffee should be selected. Click Next.

14. Table: Regular Coffee should be selected. Click Next.

15. Click ID in the Fields in ‘Decaf Coffee’ list. Click ID in the Fields in ‘Regular Coffee’ list. 
Click the <=> button to display them in the Matching fields box, if they’re not already 
displayed.

16. Click the Next button.

17. Move the Name, Month, and Type fields to the Selected fields box.

18. Click the Next button.

19. Name the query Unmatched Month and then click the Finish button to display the 
query results.

20. Start the Query Wizard and create a simple query that contains all the fields in the 
Regular Coffee table. Click Next.

21. Click Next again. 

22. Name the query Regular Coffee Pounds Query and then click Finish. 

23. SAVE and then CLOSE the query.

CLOSE any open objects, CLOSE the database, and then EXIT Access.
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Using Controls in Reports and Forms8
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SKILL SUMMARY

Skills Exam Objective Objective Number

Adding controls Add report controls. 
Add form controls.
Insert headers and footers.
Insert header and footer information.
Insert images. (Forms)
Insert images. (Reports)
Modify data sources. (Forms)
Modify data sources. (Reports)
Manage labels. (Forms)
Add and modify labels. (Reports)
Move form controls.
Set form control properties.

5.2.3 
4.2.2
4.3.7
5.3.6
4.3.8
5.3.7
4.2.3
5.2.2
4.2.6
5.2.4
4.2.1
4.2.5

Defining control tab order Modify tab order. 4.3.1

Formatting controls Format report elements.
Insert backgrounds. 
Control report positioning.
Format a report into multiple columns.
Move form controls.
Add form controls.
Remove form controls.
Control form positioning.

5.3.4
4.3.6
5.3.3
5.3.1

4.2.1
4.2.2
4.2.4
4.3.5

Arranging control alignment, size, and position Control form positioning. 4.3.5

Adjusting page margins and changing page 
orientation for forms and reports

Configure print settings. 4.3.2
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SOFTWARE ORIENTATION

Design and Layout Tools for Reports and Forms

When you view a report in Design view, the Report Design Tools are displayed on the Ribbon. 
Similarly, when you view a report in Layout view, the Report Layout Tools are displayed on the 
Ribbon. Both the Report Design Tools and the Report Layout Tools contain a Design contextual 
tab with groups of tools that are nearly identical, except there are four additional commands on 
the Report Design Tools Design contextual tab: Tab Order, Subreport in New Window, View 
Code, and Convert Report’s Macros to Visual Basic. You can add controls to a report in both 
Design view and Layout view. The commands in the Controls, Header/Footer and Tools groups 
on the Report Design Tools Design contextual tab are shown in Figure 8-1. When you position 
the mouse pointer over a tool, Access displays the tool’s name as a ScreenTip. 

Displays the Field List pane Opens tab order dialog box

Text box button Controls group Header/Footer 
group

Opens  the Visual Basic for 
Applications program

When you view a form in Design view, the Form Design Tools are displayed on the Ribbon. Sim-
ilarly, and like reports, when you view a form in Layout view, the Form Layout Tools are displayed 
on the Ribbon. Both the Form Design Tools menu and the Form Layout Tools menu contain a 
Design contextual tab with nearly identical tools, except there are four additional commands on 
the Form Design Tools Design contextual tab: Tab Order, Subform in New Window, View Code, 
and Convert Form’s Macros to Visual Basic. Like reports, you can also add controls in form Lay-
out view. The commands in the Controls, Header/Footer and Tools groups on the Form Layout 
Tools Design contextual tab are shown in Figure 8-2. The procedures for adding controls to a form 
and a report are similar as well, which is why we cover them together in this lesson. 

Text box button Controls group Header/Footer 
group

Hyperlink button Launches the Field List pane 

Take Note Although you’ll be using the tools on the Report and Form Design Tools Design contextual tabs 
in this lesson, remember that the Report and Form Layout Tools Design contextual tabs have al-
most identical tools that can be used in Layout view. The majority of the instructions in this lesson 
apply to both form and report controls. 

Figure 8-1

Report Design Tools Design 
contextual tab

Figure 8-2
Form Layout Tools Design 
contextual tab
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ADDING CONTROLS 
A control is an object that displays data, performs actions, and lets you improve the look and 
usability of a form or report. Access uses three different types of controls: bound, unbound, and 
calculated.

Controls add functionality to a report or form. For example, you can add a logo control to a report 
to enhance the look of the report or a list box control to allow users to choose from a list of items. 
You can insert bound, unbound, and calculated controls using the tools in the Controls and Head-
er/Footer groups. The Use Control Wizards option, located in the Controls group, is helpful when 
creating some of the more complicated controls.

Adding Unbound Controls
An unbound control does not have a data source; it displays information such as lines, shapes, 
or pictures. Unbound controls are not connected to a field, but they display information that is 
important for reports and forms, some of which will appear in report and form header and footer 
sections, such as titles, dates, and page numbers. You can use the tools in the Controls group to 
add both bound and unbound controls, or you can use the Header/Footer group to add unbound 
controls to the header and footer sections of reports and forms. In this exercise, you will use the 
tools in the Header/Footer group to add unbound controls to the Report Header section.

Take Note The process for adding a control to a form and a report using the Header/Footer group is the same. 
Once shown how to add a control using the Header/Footer group to a report, you can add a sim-
ilar control to a form in the same manner.

STEP BY STEP Add Unbound Controls

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN Wingtip Inventory from the data files for this lesson and then SAVE the database 
as Wingtip Inventory-final.

2. Double-click the Toy Summary report in the Navigation Pane.

3. On the Home tab, in the Views group, click the lower half of the View button, and then 
select Design View.

4. On the Design tab, in the Header/Footer group, click the Logo button. The Insert Picture 
dialog box appears.

5. Navigate to the data files for this lesson and select Toys.jpg. Click OK. The picture is 
inserted in the Report Header section.

6. On the Design tab, in the Header/Footer group, click the Title button. The title control 
with the title Toy Summary is inserted in the Report Header section. The text in the title 
is selected.

7. Type Inventory Summary by Toy and then press the Enter key.

8. On the Design contextual tab, in the Header/Footer group, click the Date and Time 
button. The Date and Time dialog box appears, as shown in Figure 8-3.
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9. Click OK to accept the default date and time formats. The Date and Time controls are 
inserted in the Report Header section of the report, as shown in Figure 8-4.

Date and time controls

10. On the Design contextual tab, in the Header/Footer group, click the Page Numbers 
button. The Page Numbers dialog box appears.

11. In the Position section of the Page Numbers dialog box, select the Bottom of Page 
[Footer] option and then click OK. If necessary, scroll to the bottom of the report 
window. The Page number control is inserted in the Page Footer section near the 
bottom of the report.

12. Click the Save button on the Quick Access Toolbar.

PAUSE. LEAVE the report open to use in the next exercise.

Figure 8-3

Date and Time dialog box

Figure 8-4

Report Header shown in 
Design view

© mstay/iStockphoto
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Adding Bound Controls
A bound control uses a field in a table or query as the data source. Bound controls, such as text 
boxes, display information such as text, dates, numbers, pictures, or graphs from a field in a table 
or query.

You can bind a control to a field by moving it from the Field List pane or by using the Property 
Sheet. In this exercise, you will practice adding a bound control to a report by using the Field 
List pane, and adding an unbound control and then binding it by using the Controls group and 
Property Sheet, respectively.

When you bind a control to a field, you connect it to that field. The easiest way to create a bound 
control is to double-click or drag a field from the Field List pane to the report. Access creates the 
appropriate control, binds the control to the field, and then creates a label for the control. The 
control’s label appears on the left, and the control appears on the right, as shown in Figure 8-5.

Control label

Control

You can display the Field List pane by clicking the Add Existing Fields button in the Tools group 
on the Design contextual tab.

Another way to bind a control to a field is to first add an unbound text box to a report or form 
using the Controls group. Then, open its Property Sheet either by right-clicking and choosing 
Properties from the shortcut menu or by clicking the Property Sheet button in the Tools group on 
the Design contextual tab. On the Property Sheet, in the Data tab, click the down arrow beside 
the Control Source property and then select the field you want to display in the control. You can 
then change the default text in the control’s label to text that corresponds to the field to which the 
control is bound simply by clicking on the label and typing the new name.

Take Note The process for changing a control’s default label name for a report or a form is the same. Once 
shown how to change a label name for a report control, you can change a label name for a form 
control in the same manner.

Take Note The process for adding or removing a control to and from a form and a report is the same. Once 
shown how to add/remove a control to/from a report, you can add/remove a similar control to a 
form in the same manner.

When you click any button in the Controls group (except the Hyperlink and Insert Image but-
tons) the pointer changes to the move pointer with a plus sign (+). On the design grid, click where 
you want the upper-left portion of the control to start. Remember that a label will also be inserted, 
so leave enough space for the label. Click once to create a default-sized control, or click and drag 
the move pointer to create the size you want. 

Figure 8-5

Control label and control
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When you click the Hyperlink and Insert Image buttons in the Controls group, a dialog box 
appears requesting additional information before these unbound controls are created. For exam-
ple, the Insert Hyperlink dialog box asks to which file or location you would like to link and the 
corresponding hyperlink text to display on the form or report. Similarly, the Insert Image button 
displays a submenu with two selections: one that allows you to browse your computer for images 
to add to the report or form and one that allows you to view a gallery of images you have already 
included on your report or form so you can easily add them again. 

You can use the Controls group to add other unbound controls like lines and page breaks to forms 
and reports. For example, you may want to use the line control to visually separate controls on 
a form to help it look more aesthetically pleasing or use the Insert Page Break control to create a 
report’s title page by separating controls in the Report Header from the rest of the report. 

To move a control and its label simultaneously, select the control, position the mouse pointer over 
the orange selection border until you see a four-sided arrow, and then drag it to the new position.

To delete a control from the grid, select it, right-click the control to display the shortcut menu, 
and then choose Delete.

STEP BY STEP Add a Bound Control to a Report

GET READY. USE the Wingtip Inventory-final database and Toy Summary report that are 
open from the previous exercise.

1. On the Design contextual tab, in the Tools group, click the Add Existing Fields button. 
The Field List pane appears. Click the Show all tables link. The fields for the Inventory 
table appear.

2. Click the ID field and drag it to the right of the Price control, as shown in Figure 8-6.

ID field dragged here

3. Drag the In Production field to the design grid below the ID control.

4. Click Close on the Field List pane.

5. Click the ID field control until you see the orange border with selection handles on the 
borders and corners.

6. Right-click in the control and select Delete from the menu. The control and label are 
removed from the design grid.

7. Select the In Production control, right-click and then select Delete from the menu. 

8. On the Design contextual tab, in the Controls group, click the Text Box button. The 
mouse pointer changes to the move pointer with a plus sign (+) when you place it over 
the report.

9. Position the pointer under the Price control and then click to create the text box control 

© mstay/iStockphoto

Figure 8-6

Bound control dragged from 
the Field List pane
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as shown in Figure 8-7. If you need to move the control, select it and move the mouse 
pointer over the selection border until it appears as a four-sided pointer, and then click 
and drag it to the appropriate location. Notice that the word Unbound is shown in the 
control and the word Text and a number (depending on the number of controls you 
have created in this session) appear in the label.

10. Select the text box control if it isn’t already selected.

11. On the Design contextual tab, in the Tools group, click the Property Sheet button. The 
Property Sheet appears.

12. In the Data tab, click the down arrow on the Control Source row and then select the In 
Production field, as shown in Figure 8-8. Click In Production. Notice the control now 
displays the field name In Production, which means that it is now bound to the control.

13. Click Close on the Property Sheet.

14. Click the In Production control label (that says Text and a number) and then select the 
text in the label.

15. Type In Production: and then press Enter. Your screen should look similar to Figure 8-9.

Figure 8-7

Unbound control

Figure 8-8

Property Sheet pane
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16. Go to Report view to view your changes. When finished, change back to Design view.

17. Click the Save button on the Quick Access Toolbar.

PAUSE. LEAVE the report open to use in the next exercise.

Take Note The process for setting report control properties is the same for a form. Once shown how to set a 
report control property, you can set a form control property in the same manner.

Adding Calculated Controls
A calculated control is a control that displays the result of a calculation or expression. Cal-
culated controls can display calculations that are vital to the usefulness of a report or form. For 
example, when your company needs to know the amount of sales dollars generated by each toy in 
a product line, you can multiply the number of toys sold by the price and display the value in a 
report or form. Text boxes are the most popular choice for a calculated control because they can 
display so many different types of data. However, any control that has a Control Source property 
can be used as a calculated control. In this exercise, you will use the Expression Builder to add a 
calculated control to a report.

An expression in Access is like a formula in Excel. An expression consists of the following elements 
that are used alone or in combination:

• Identifiers: The names or properties of fields or controls
• Operators: Such as + (addition), - (subtraction), or * (multiplication)
• Functions: Such as SUM or AVG
• Constants: Values that do not change, such as numbers that are not calculated
To create a calculated control, you can either type an expression in the Control Source property 
box or use the Expression Builder, which is a feature that provides names of the fields and 
controls in a database, lists the operators available, and has built-in functions to help you create 
an expression. The intuitive Expression Builder includes IntelliSense, which presents you with a 
drop-down box of potential values as you’re typing an identifier or function name to create your 
expression.

Figure 8-9

Bound control
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STEP BY STEP Add a Calculated Control

GET READY. USE the Wingtip Inventory-final database and the Toy Summary report that 
are open from the previous exercise.

1. On the Design tab, in the Controls group, click the Text Box button.

2. Position the mouse pointer on the design grid and drag down and to the right to create 
and position a control the size of the one shown in Figure 8-10. Reposition as necessary 
to get it to match the figure. 

3. Select the text in the label and then type Investment:.

4. Select the control, right-click and then select Properties from the menu to display the 
Property Sheet if it isn’t already displayed.

5. On the Data tab, in the Control Source row, click the Build button (looks like three 
periods, …). The Expression Builder dialog box appears.

6. In the Expression Categories list, scroll down and double-click In Stock. The In Stock 
field is inserted in the expression box, as shown in Figure 8-11.

Figure 8-10

Text box control

Figure 8-11

Expression Builder dialog box
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Take Note All the list items in the Expression Categories on your screen may not match exactly to  
the figure shown.

7. In the Expression Elements section, click the Operators element, and then double-
click the * (asterisk) value in the Expression Values section to select the multiplication 
operator.

8. In the Expression Elements section, click the Toy Summary element, and then find and 
double-click the Price field in the Expression Categories section.

9. Click OK. The expression appears in the Control Source row of the Property Sheet as 
well as in the control box in the Detail section of the report, as shown in Figure 8-12.

Expression

10. Click Close on the Property Sheet.

11. Change to Report view and scroll through the report records to view the calculated 
totals.

12. Click the Save button on the Quick Access Toolbar.

13. CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note It is often easiest to add and arrange all the bound controls first, and then add the unbound and 
calculated controls to complete the design of the report.

Adding Controls Using a Wizard
It could take quite a bit of time to figure out how to set all the properties necessary to create option 
groups and combo and list boxes for a report or form. To speed up this task, Access 2016 includes 
wizards that help you create some of the more complicated controls. A Control Wizard can help 
you create controls such as command buttons, list boxes, combo boxes, and option groups. Some 
of these types of controls can modify underlying table data sources. For example, after you add a 
combo box to a form, you can use it to select a value to be stored in an underlying table field. In 
this exercise, you add a combo box to a form using the Control Wizard.

Figure 8-12

Expression in Control Source 
row
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Like other wizards you have used, a Control Wizard asks you questions about how you want the 
control to look and operate, and then it creates the control based on your answers. The Control 
Wizard’s button is a toggle button that you can click to activate and deactivate wizards on controls 
that use them.

STEP BY STEP Use the Control Wizard

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. On the Create tab, in the Forms group, click the Form Design button. A new, blank form 
is created, and the Field List pane is displayed. (If it isn’t, click the Add Existing Fields 
button in the Tools group on the Ribbon.)

2. If necessary, click Show all tables link in the Field List pane and then click the expand 
button next to Inventory to display the fields of the Inventory table.

3. Double-click the Description field to add it to the form.

4. Double-click the In Stock field to add it to the form.

5. Double-click the Price field to add it to the form.

6. Double-click the In Production field to add it to the form.

7. Select the In Production control that you just added, right-click it and then select Delete 
from the shortcut menu.

8. On the Design tab, click the More arrow in the Controls group, and then locate the Use 
Control Wizards command and make sure it is turned on, as shown in Figure 8-13. The 
image to the left of the command should be highlighted.

Control Wizards command selected  in Controls group  

9. On the Design tab, in the Controls group, locate and then click the Combo Box button. 
(Hover your mouse pointer over each control button to view its ScreenTip until you find 
the Combo Box button.)

10. Position the mouse pointer and drag to draw a rectangle, as shown in Figure 8-14.

Figure 8-13

Control Wizards command
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Combo box button

Draw rectangle

11. When you release the mouse button, the Combo Box Wizard appears. Click the button 
beside I will type in the values that I want and then click Next. 

12. In the empty cell below the Col1 header, type Yes. Continue typing values in the 
column as shown in Figure 8-15 using the down arrow key to move to the next row. (If 
you press Enter, the wizard advances to the next screen so be sure to use the down 
arrow key.)

13. Click Next.

14. Click the button beside Store that value in this field, click the down arrow to display the 
menu, and then select In Production.

15. Click Next.

16. Type In Production in the text box and reposition the control to fix spacing if necessary.

17. Click Finish. Your screen should look similar to Figure 8-16.

Figure 8-14

Drag to draw a custom control

Figure 8-15

Combo Box Wizard
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Take Note A combo box is also known as a drop-down control, because it is a combination of a text box with 
a list box that is hidden until you select the arrow next to the text box and it drops down.

18. Change to Form view, scroll through the records, and modify the In Production field by 
selecting an item in the combo box for one or more records.

19. SAVE the form as Inventory.

PAUSE. LEAVE the form open to use in the next exercise.

Adding Button Controls Using the Wizard
You can also use Control Wizards to add Button controls to forms. You create Button controls 
using the Command Button Wizard and assign the controls certain tasks that are created by 
macros. Macros are useful since they add additional functionality to a database by automating a 
series of tasks to create an action. For example, Button controls can be created on a form to per-
form many different actions, including moving to the next or previous record, displaying the Print 
dialog box, or closing the form. The code that enables this functionality is automatically created 
as a macro by the Command Button Wizard. In this exercise, you will create a Button control 
using the Command Button Wizard and use the View Code button to open the Visual Basic for 
Applications program.

You can further customize the function of database controls and even objects by viewing and 
modifying their code using a programming language called Visual Basic for Applications (VBA). 
You can click the View Code button in the Tools group of the Design tab to open the VBA 
program. The VBA program is built into Access and provides you with an interface to write and 
modify code associated with database controls and objects. You can really harness the power of 
Access 2016 by directly interacting with controls and objects via VBA. 

STEP BY STEP Use the Control Wizard to Add Button Controls

GET READY. USE the Wingtip Inventory-final database and the Inventory form that are 
open from the previous exercise.

1. Change to Design view, if necessary.

2. On the Design tab, in the Controls group, click the Button button (a rectangle with xxx 
in it).

Figure 8-16

Form with combo box control
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3. Position the mouse pointer on the design grid and drag down and to the right to create 
a control the size of the one shown in Figure 8-17.

Button button

Draw square

4. When you release the mouse button, the Command Button Wizard appears. In the 
Categories: section, click Form Operations, and in the Actions section, click Close 
Form. 

5. Click Next.

6. On the next screen, keep the default settings to have the button contain the Exit 
Doorway picture displayed in the dialog box. Click Next.

7. On the final screen, type Exit_Inventory_Form as the default button name and then 
click Finish. (The default button name indicated on your screen may differ depending 
on how many controls you have previously attempted to include.) Notice that the 
image on the Button control on the form has changed to the Exit Doorway picture, as 
shown in Figure 8-18.

Figure 8-17

Button control

Figure 8-18

Inventory Form in Design view
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8. Click the Save button on the Quick Access Toolbar.

9. Click the Button control on the form. On the Design tab, in the Tools group, click the 
View Code button. The Microsoft Visual Basic for Applications window appears, as 
shown in Figure 8-19. If you’re fluent in VBA, you can use this window to add VBA code 
to customize the function of this control.

10. Click the Close button on the Visual Basic for Applications window to return to Access.

11. Change to Form view and then click the newly created Close Form button to close the 
form. If a dialog box appears asking you if you want to save the changes to the form, 
click Yes. 

PAUSE. LEAVE the database open to use in the next exercise.

DEFINING CONTROL TAB ORDER 
When you are in Form or Report view, pressing the Tab key moves the selection, or focus, to the 
next field. Control tab order refers to the order in which the selection, or focus, moves from 
field to field in a form or report. When entering data in a form, it is helpful to set the control tab 
order to a sequence that matches the order of the data you are entering. It’s also helpful to set the 
tab order of a report to a logical field sequence when reviewing report records. This allows you to 
efficiently concentrate on meaningful data as you use the change of focus as a guide. In this exer-
cise, you will define form control tab order.

You change the tab order using the Tab Order dialog box, which is located in the Tools group of 
both the Report Design Tools and Form Design Tools Design tabs. The Tab Order dialog box lists 
each section of the report or form and the tab order of the fields in each section. Click the selection 
button to the left of each row in the Custom Order list to select the row. You can drag the rows 
into the tab order you want, from top to bottom. The Auto Order button places the fields in the 
order that they appear on the form or report—from top to bottom and left to right.

Figure 8-19

Microsoft Visual Basic for 
Applications window
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STEP BY STEP Define Control Tab Order

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. Double-click the Inventory form in the Navigation pane to open it in Form view.

2. Press the Tab key several times to see the order in which the controls are selected each 
time you press it. Notice that the tab order begins with the Description field, moves 
to the In Stock field, the Price field, the In Production field, and then the Close Form 
button. The tab order then continues to the next record in sequence and through the 
same fields as before.

3. Change to Design view.

4. On the Design tab, in the Tools group, click the Tab Order button. The Tab Order dialog 
box appears, displaying the tab order in the Custom Order list. Notice that the In 
Production combo box field is referred to as Combo10 since Access stores this name 
to use as a coding reference in Visual Basic for Applications. (You may have a different 
number, depending on how many controls you have had and removed previously on 
the form.)

5. Click the row selector to the left of the Combo10 field to select it.

6. Click and hold the row selector. The mouse pointer changes to a move pointer with an 
empty rectangle. Drag up a row and notice the black horizontal line moves with you. 
Drag up until the black horizontal line is in place at the top of the Description field; 
release the mouse button. The Combo10 field should be the first item in the list, as 
shown in Figure 8-20. 

7. Click the Auto Order button. The order of the fields automatically resets based on the 
order that they appear on the form or report.

8. Click the row selector to the left of the Combo10 field to select it. Click and hold the row 
selector and drag it up until the black horizontal line is in place above the In Stock field; 
release the mouse button. The Combo10 field should now be the second item in the 
list.

9. Click OK.

10. SAVE the form design.

11. Change to Form view.

12. Press the Tab key several times to see the new tab order.

13. CLOSE the form.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 8-20

New order in the Tab Order 
dialog box
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SOFTWARE ORIENTATION

Report Design Tools Format Tab

When you are working with reports, the Format tab is located in the Report Design Tools. It 
contains groups of commands used to format reports, as shown in Figure 8-21. 

When you are working with forms, the Format tab contains the same groups of commands and 
is available in the Form Layout Tools. Use these common formatting commands to change the 
display of controls and their labels in forms and reports. 

FORMATTING CONTROLS
Formatting professional-looking reports and forms not only projects a high-quality image, but 
it also improves the form or report’s readability. Display formatting allows you to refine the look 
of your reports and forms. You can change the font, font size, font color, alignment, and other 
attributes of text and numbers in controls and their associated labels. You can also change the 
background images of your reports and forms as well as change the shapes of certain controls. 
You can even apply Quick Styles to controls to quickly change their appearance or use conditional 
formatting to change the look of data when certain conditions are met.

Formatting Controls
You use many of the formatting tools that you have probably used before to format text, numbers, 
and objects in other Office programs, such as Word or Excel, to format the display of a control. In 
this exercise, you will format the display of controls on a report.

You can resize controls and their labels by clicking the resize handles, which are tiny squares locat-
ed on the borders and corners of a selected control or label. Click the label or field control you want 
to resize, position the mouse pointer over a vertical border handle to get a two-sided arrow, and 
then click and drag horizontally to increase or decrease its width. Similarly, position the mouse 
pointer over a corner of the label or field control’s border until you get a diagonal arrow, and then 
click and drag diagonally to increase or decrease its height and width. To move a control and its 
label simultaneously, select the control, position the mouse pointer over the orange selection bor-
der until you see a four-sided arrow, and then drag to the new position.

Controls on forms and reports display the format applied to the source table. However, you can 
change the display formatting for each control and label on a form or report. Your changes will 
only affect each control and the way the data appears. It does not change how users enter data or 
how data is stored.

Take Note You cannot apply visual formats to controls bound to Attachment and OLE Object fields. How-
ever, you can change the format of the label associated with the control.

Figure 8-21
Format tab in Report Design 
Tools
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You can format a control in Design view or Layout view using the commands in the Font group. 
You can change the font as well as the size, color, alignment, and background color of text. You 
can also add bold, underline, and italics. The Format Painter button copies formats so that you can 
easily apply the same formatting to another control.

The Background group allows you to insert a background image into your form or report or alter-
nate row colors to help make the form or report more visually appealing.

You can change the format of a number control using the Number group. You can format a num-
ber to include dollar signs, increase or decrease decimal places, add commas and percentages, or 
choose from a list of standard number formats by using the drop-down box in the group.

Lastly, you can also format controls using the commands in the Control Formatting group. You 
can apply Quick Styles, change the shape of a control, apply shape effects to quickly change the 
appearance of certain controls like button controls, and change the fill and outline color of con-
trols. You can even use conditional formatting to change the look of the data that appears in a 
control when certain conditions are met. 

Troubleshooting By default, text does not automatically wrap when it reaches the edge of a control box. It re-
mains on a single line and extends beyond the edges of the control. To enable text wrapping 
in a form or report, set the height to a non-default size and then change the CanGrow and 
CanShrink properties for the control to Yes. By default, a control’s label box will expand to 
include the entire label.

STEP BY STEP Format Controls on a Report

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. Double-click the Toy Summary report in the Navigation pane to open it and then 
change to Design view.

2. Click the In Stock control. Position the mouse pointer over the resize handle on the 
right border. The mouse pointer changes to a double-sided arrow. Using the horizontal 
ruler at the top of the report as a guide, drag to the left to resize the control until its 
right side is at the 1 3/4” mark.

3. In the same manner, reduce the width of the Price control until its right side is at the 
horizontal ruler’s 4” mark.

4. In the same manner, reduce the size of the Investment control until its right side is at 
the horizontal ruler’s 2 1/2” mark and its bottom is at the vertical ruler’s 1 1/2” mark.

5. Click the Description control to select it.

6. On the Format tab, in the Font group, click the Bold button. The Description control is 
bolded.

7. Click the arrow on the Font Size menu and select 12 from the menu. The font size 
becomes 12.

8. Click the In Stock control to select it.

9. On the Format tab, in the Font group, click the Center button. The In Stock text is 
centered in the control box. Your report should look similar to Figure 8-22.
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10. Click the Investment control that contains the formula you entered in an earlier 
exercise. 

11. On the Format tab, in the Number group, click the Apply Currency Format command.

12. Click the Price control.

13. On the Format tab, in the Number group, click the Apply Currency Format command.

14. SAVE the report.

15. Change to Report view to see the changes you’ve made. Notice the text formatting 
changes as well as the currency formats for the Investment and Price fields.

16. CLOSE the report.

17. Double-click the Toys By Quantity In Stock report in the Navigation pane and change 
to Design view.

18. In the Report Header section, click the Print Report Button control to select it.

19. On the Format tab, in the Control Formatting group, click the Change Shape button to 
display the menu. Click the Oval option. The Button control’s shape changes to an oval.

20. Click the In Stock Header. 

21. Click the Alternate Row Color menu and select Automatic, as shown in Figure 8-23. 
Click Automatic to apply it.

Figure 8-22

Report with display formatting 
applied

Figure 8-23

Alternate Row color
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22.  Click the Detail row. Click the Alternate Row Color menu and then select Automatic.

23. Change to Report View and see that the button has been changed and the rows are 
now separated by alternate colors.

24. SAVE and then CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Formatting Controls on a Form
In this exercise, you will learn how to format the display of controls on a form and include a back-
ground image.

STEP BY STEP Format Controls on a Form

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. Double-click the Inventory form in the Navigation pane to open it if it’s not open 
already and then change to Design view.

2. Click the Button control on the form. On the Format tab, in the Control Formatting 
group, click the Quick Styles button and then select Intense Effect – Aqua, Accent 5 
from the Theme Styles, as shown in Figure 8-24. Click the style to apply it; the Button 
control’s style changes to the chosen Quick Style.

3. Click the Description label to select it.

4. On the Format tab, in the Font group, click the Font Color button and then select Black 
from the Theme Colors menu. The Description label displays in black. Change the font 
color to black for the In Stock, Price, and In Production labels. 

5. On the Format tab, in the Background group, click the Background Image button, click 
the Browse command to locate the Winter Theme Background.jpg image file, and then 
click OK. Notice the form’s background image is now that of the image, as shown in 
Figure 8-25.

Figure 8-24

Quick Style gallery
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6. Change to Form view to see the changes you made.

7. SAVE and then CLOSE the form.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note The process for adding a background image to a form or a report is the same. Once shown how 
to add a background image to a form, you can add a background image to a report in the same 
manner.

Creating Conditional Formatting on Controls
Sometimes employees need a little help recognizing when inventory is low or when sales are high. 
Conditional formatting in forms and reports helps alert users to text or numbers that need atten-
tion so that important data is not overlooked. Conditional formatting changes the appear-
ance of a control or the value in a control when certain conditions are met. You can change the 
color of text or numbers in the control or the background color. In this exercise, you will create 
conditional formatting for a report field.

You can create conditional formatting based on a value or expression. For example, when the 
number of products in an inventory falls below 10 for a single product, you can set the conditional 
formatting so that Access will display the number in red or with a red background so that you and 
others will notice the low inventory number.

The easiest way to add or delete conditional formatting from a form or report is to use the Con-
ditional Formatting Rules Manager dialog box, which displays a list of the existing formatting 
rules, if any. 

Figure 8-25

Form with background image
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STEP BY STEP Create Conditional Formatting 

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. Double-click the Toy Summary report in the Navigation pane to open it, if necessary, 
and then change to Design view.

2. Click the In Stock control to select it.

3. On the Format tab, in the Control Formatting group, click the Conditional Formatting 
button. The Conditional Formatting Rules Manager dialog box appears.

4. Click the New Rule button. The New Formatting Rule dialog box appears. You will 
create a new rule based on criteria you will enter.

5. In the Edit the rule description section, keep Field Value Is in the first menu. Click the 
drop-down arrow to the right of between and scroll to the bottom of the list to select 
less than or equal to. Click in the empty text box and then type 10. Click the Bold 
button in the Preview section. 

6. Click the down arrow on the Background Color button and select Red from the menu 
that appears. The dialog box should look similar to Figure 8-26.

7. Click the OK button. A formatting rule for the In Stock field is added to the dialog box. 
Now, when the report is viewed in Report view, the value for the In Stock field will 
appear bold and the control background color will appear red if the formatting rule 
applies.

8. Click OK.

9. SAVE the report.

10. Change to Report view and scroll through the records to see the conditional formatting 
at work.

11. CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 8-26

New Formatting Rule 
dialog box
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SOFTWARE ORIENTATION

Arrange Tab

The Arrange tab, shown in Figure 8-27, is located in the Report Layout Tools as well as the Report 
Design Tools area of the Ribbon. It contains groups of commands for arranging the layout, align-
ment, size, and position of controls on a report. Use the commands on the Arrange tab to arrange 
controls on a report.

Similar to a report, the Arrange tab is displayed in both the Form Layout Tools and Form Design 
Tools area of the Ribbon. The buttons and commands on the Arrange tab are the same as the 
Arrange tab for reports, except for the Anchoring button located in the Position group. The Posi-
tion group, shown in Figure 8-28, contains an Anchoring button that helps position controls on 
a form when the containing window is resized. Use the commands on the Arrange tab to arrange 
controls on a form.

Arranging Control Layout 
After you have created a form or report, you can arrange the controls on it to fit the data or to best 
display the data. Access provides commands for arranging the layout, alignment, position, and size 
of controls. Control layouts align your controls horizontally and vertically to give your report 
or form a uniform appearance. The two types of control layouts are tabular and stacked. Controls 
are arranged vertically in a stacked layout, with a label on the left and the control on the right. 
Stacked layouts are contained in one report or form section. In a tabular layout, the controls 
are arranged in rows and columns like a spreadsheet, with labels across the top. Tabular layouts use 
two sections of a report or form. The labels are displayed in one section and the fields are arranged 
in the section below. In this exercise, you will arrange controls on a report using control layouts.

You can have more than one layout on a report. For example, you could have a tabular layout to 
create a row of data for each record, and then a stacked layout underneath with more information 
about the same record.

Access automatically creates tabular control layouts when you create a new report using the Report 
button or the Blank Report button on the Create tab. When you create a new form using the Form 
button or the Blank Form button, Access creates stacked control layouts.

On an existing blank report, you can create a new control layout by holding down the Shift key 
and then selecting the fields you want to include in the form or report from the Field List pane. On 
the Arrange tab, in the Table group, click the Stacked button or the Tabular button.

Figure 8-27
Arrange tab in the Report 
Layout Tools Ribbon

Figure 8-28
Position group on Arrange 
tab in the Form Design Tools 
Ribbon 
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You can change the entire layout of a report or form to the other layout by selecting all of the cells 
in the layout and then clicking the layout button you want—either Stacked or Tabular.

You can also split a control layout into two different layouts. Hold down the Shift key, select the 
controls you want to move to the new control layout and then click the Tabular or Stacked button.

STEP BY STEP Arrange Control Layout

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise.

1. Click the Inventory table in the Navigation Pane to select it.

2. On the Create tab, in the Reports group, click the Blank Report button. A new, blank 
report is created and the Field List pane is displayed. (If it isn’t, click the Add Existing 
Fields button in the Tools group on the Design tab.) 

3. Double-click the ID field to add it to the report. 

4. Double-click the Description field to add it to the report.

5. Double-click the In Stock field to add it to the report.

6. Double-click the Price field to add it to the report.

7. Press and hold the Shift key and then click each of the four controls to select them all. 
Be sure you select the controls and not the labels, as shown in Figure 8-29.

Selected controls  

8. On the Arrange tab, in the Table group, click the Stacked button. The controls and 
labels are arranged in a 2-column stacked layout.

9. On the Arrange tab, in the Table group, click the Tabular button. The controls and labels 
are arranged back in a tabular layout. The tabular format indents the position of the 
columns by default.

10. On the Arrange tab, in the Table group, click the Stacked button to change it back to a 
stacked layout, as shown in Figure 8-30.

Figure 8-29

Selected report controls
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11. SAVE the report as Stacked Report and leave it open for use in the next exercise.

PAUSE. LEAVE the database open to use in the next exercise.

By using the tools in the various groups on the Arrange tab, Access 2016 gives you even greater 
flexibility over arranging and controlling the cells in control layouts. 

You can add new rows and columns of cells above and below existing cell rows and to the left and 
right of existing cell columns using the tools in the Rows & Columns group. You can merge two 
cells into one, as well as split them vertically and horizontally using the tools in the Merge/Split 
group. The tools in the Move group can be used to reorganize cells by moving them up or down. 

You can adjust the location of information displayed in a control in relation to the control’s border 
with the Control Margins button in the Position group. You can choose the None, Narrow, Me-
dium, or Wide setting in the Control Margins menu.

The Control Padding button adjusts the amount of space between a label and its field control. The 
Control Padding menu contains choices for None, Narrow, Medium, or Wide padding.

The Position group also contains the Anchoring button and menu. The Anchoring button only 
appears in the Form Layout Tools and Form Design Tools Arrange tab in the Position group since 
the anchoring option is only available for forms and not reports. Anchoring can be used so that 
control sizes automatically increase or decrease when the Access window size is increased or de-

Figure 8-30

Stacked report
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creased. You may never have to anchor a control because you will most likely keep the Access win-
dow a consistent size. Anchoring is helpful when you want to control the position of the controls 
on a form when the Access window is increased. If anchoring is not applied, controls that contain 
more text than visible within the default size will remain the default size even when the Access 
window is made larger. When you anchor a field control in a layout, the newly anchored field and 
all the others grow when the Access window size is increased to display more field data, if applica-
ble. Anchoring is best used on fields that contain a large amount of text like those with the Long 
Text data type. For example, you can anchor a Notes field control to stretch down and to the right 
as you increase the size of the Access window. This allows you to see more text within the field 
control in the larger Access window, including text you’d normally not see if you didn’t anchor it. 
Field controls that are not anchored will remain the default size even if you increased the Access 
window size, hiding the excess text. Once a control is anchored, all other controls in the layout 
will behave the same way. You can only have one anchored control in a Stacked or Tabular layout, 
but many anchored controls with different anchoring options if they’re not in a specific layout.

Add, Move, and Remove a Control
When you want to add a new field from the Field List to an existing control layout, just drag the 
field from the Field List pane to the grid. To add it to the layout, select all the controls in the layout 
and the new control, and then click the Stacked or Tabular button to integrate the new field into 
the control layout. Removing a control from a control layout allows you to place it anywhere on 
the report or form without affecting the positioning of any other controls. Click the control you 
want to remove and then click the Remove Layout button in the Table group. The Remove Layout 
button is only available in the Table group in report or form Design view. In this exercise, you will 
add and move controls within a layout and remove a control from a layout.

STEP BY STEP Add, Move, and Remove a Control from a Layout

GET READY. USE the Wingtip Inventory-final database and Stacked Report report that are 
open from the previous exercise. 

1. Change to Report Design view, if necessary. 

2. Click the Show all tables link in the Field List pane, if necessary, to view all the available 
fields in the Inventory table.

3. Click the In Production field in the Field List pane. Drag it to the grid and place it in any 
location on the design grid to the right of the four controls. 

4. Press and hold the Shift key and then select the ID field control. Still holding the 
Shift key, select the Description, In Stock, and Price field controls so that all five (In 
Production, ID, Description, In Stock, and Price) are selected.

5. On the Arrange tab, in the Table group, click the Stacked button. The In Production 
control is added to the bottom of the stacked layout.

6. With all five controls still selected, click the Control Margins button on the Arrange tab 
in the Position group and then select Narrow from the menu. The text within the field 
controls and labels is formatted by the Narrow option.

7. On the Arrange tab, in the Position group, click the Control Padding button and select 
Medium from the menu. 

8. Click anywhere on a blank area of the design grid to deselect the field controls, select 
the In Production field control and then click Select Row in the Rows & Columns group. 
Notice the In Production label and field control are both outlined in orange. In the Move 
group on the Ribbon, click the Move Up button three times to move it under the ID label 
and field control, as shown in Figure 8-31.
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9. Click and drag the ID control out of the layout. It will not move out of the layout.

10. Click anywhere on a blank area of the design grid to deselect the field controls. Press 
and hold the Shift key and then select the Price label and control.

11. In the Table group on the Ribbon, click the Remove Layout button.

12. Click and drag the Price field control to the right of the ID field control, as shown in 
Figure 8-32.

13. SAVE the report and then change to Report view to view your changes.

Troubleshooting If the In Production text within the label is partially hidden, change to Design view and select 
the In Production control and label. On the Arrange tab, in the Position group, click the Con-
trol Margins button, select None from the menu, and then Save the report.

14. CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Arranging and Anchoring Controls
In this exercise you practice arranging controls within a layout using a variety of arrangement 
tools.

Figure 8-31

The new position of the 
In Production field

Figure 8-32

Price label and control moved 
out of the layout
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STEP BY STEP Arrange and Anchor Controls within a Layout

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise. 

1. Click the Inventory table in the Navigation Pane to select it.

2. On the Create tab, in the Forms group, click the Form button. A new form containing all 
the fields from the Inventory table is created in Layout view. Notice the stacked control 
layout is the default. 

3. Change to Design view.

4. Click the ID control to select it.

5. On the Arrange tab, in the Merge/Split group, click the Split Horizontally button. Click 
to the right of the ID field control and notice the orange border of the new column 
created after the split.

6. Click the In Production field control and drag it to the right of the ID field control to 
place it next to it. The In Production label and field control is now in the column. Your 
screen should resemble Figure 8-33. Notice the new additional space automatically 
created to the right of the other field controls. 

Take Note Access automatically creates a new column of placeholders in a layout when a field control is 
horizontally split and another field control is dragged into the placeholder created next to the 
horizontally split field control. 

7. Click the In Stock field control to select it. Press and hold the Shift key and then select 
the In Stock control label. 

8. On the Arrange tab, in the Move group, click the Move Down button once. The In Stock 
field control and label move to the bottom of the layout. 

9. Click the Description field control to select it. Press and hold the Shift key and then 
click the empty space below the Description field control to select the cell. Both the 
Description field control and cell below should be outlined in orange. 

10. On the Arrange tab, in the Merge/Split group, click the Merge button. The Description 
field control and cell have now merged into one, as shown in Figure 8-34.

Figure 8-33

In Production control next to 
ID control
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11. Click the In Stock field control to select it. On the Arrange tab, in the Rows & Columns 
group, click the Insert Below button twice. Two empty cells are added under the In 
Stock control. The In Stock field control should still be selected.

12. On the Arrange tab in the Rows & Columns group, click the Select Row button. Both 
the In Stock label and field control should be selected as well as an empty column 
created when we dragged the In Production field control to the right of the ID field 
control. 

13. On the Arrange tab, in the Move group, click Move Down twice to move the In Stock 
control to the last cell row at the bottom of the layout.

Take Note In Layout view, you can also use the tools on the Arrange tab to arrange controls within a layout 
for both forms and reports.

14. Click the Description field control to select it. On the Arrange tab in the Position 
group, click the Anchoring button and then select Stretch Down and Across from the 
Anchoring menu that appears. The Description field control as well as all the others 
will now automatically resize to display all their contained text, if necessary, when the 
Access window is made larger.

15. Click the In Stock field control and increase its height by positioning the pointer over 
the top-right corner of the control until a diagonal two-sided arrow appears, and then 
clicking and dragging upward until the text is no longer obstructed.

16. Change to Form view to display the new arrangement of the controls and resize the 
Access application window (not the form window) to see the controls stretch and 
shrink in conjunction with the window size.

17. SAVE the form as Modified Inventory Form and then CLOSE it. 

PAUSE. LEAVE the database open to use in the next exercise.

ARRANGING CONTROL ALIGNMENT, SIZE, AND 
POSITION
You can change the alignment, size, or position of controls and associated labels. Aligning, sizing, 
and positioning commands using the Arrange tab gives you more options for improving the look 
of controls and labels in forms and reports. The Sizing & Ordering group, which is available only 
on the Arrange tab in report or form Design view, has commands for aligning labels and controls 
to the grid (the intersecting horizontal and vertical lines and points that appear in Design view) 
to allow for precise position. For example, you can precisely align a group of controls and related 
labels using the Align To Grid command to ensure all the labels’ upper-left corners align to their 
nearest grid points. This helps you ensure the organization of your controls is consistent through-
out. In this exercise, you arrange the alignment, size, and position of controls and labels.

Figure 8-34

Description field control 
merged with cell
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You can align multiple controls and labels at one time so their left, right, top, and bottom borders 
are perfectly aligned to each other using the align left, right, top, and bottom commands.

Also in the Sizing & Ordering group, you can use the commands to adjust the size of controls 
and labels to Size to Fit, Size to Grid, Size to Tallest, Size to Widest, Size to Shortest, or Size to 
Narrowest.

Additionally, you can use the Bring to Front and Send to Back commands to move objects in 
front of or behind other objects. Also in the Sizing & Ordering group, you can use the commands 
to increase or decrease horizontal or vertical spacing using the Equal Horizontal, Equal Vertical, 
Increase Horizontal, Decrease Horizontal, Increase Vertical, and Decrease Vertical commands.

Finally, the Sizing & Ordering group contains toggle commands for showing or hiding the Grid 
and the Ruler and enabling or disabling Snap to Grid. This allows you to precisely arrange a label 
when you move the associated control by enabling Access to automatically align the upper-left 
corner of a label to its closest grid point. There are also Group and Ungroup commands that allow 
you to group several controls together so you can move or modify them all at once.

Take Note The process for arranging the control alignment, size, and position on a report is the same as for 
a form. Once shown how to arrange these for a form, you can arrange them for a report in the 
same manner.

STEP BY STEP Arrange Control Alignment, Size, and Position

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise. 

1. Click the Inventory table in the Navigation Pane to select it.

2. On the Create tab, in the Forms group, click the Form Design button. A new, blank 
form is created, and the Field List pane is displayed. (If it isn’t displayed, click the Add 
Existing Fields button in the Tools group on the Design tab.)

3. Double-click the Description field to add it to the form.

4. Double-click the In Stock field to add it to the form.

5. Double-click the Price field to add it to the form.

6. Double-click the In Production field to add it to the form.

7. Press and hold the Shift key and then click the Description, In Stock, and Price field 
controls to select them. The In Production field control should already be selected.

8. On the Arrange tab, in the Table group, click the Stacked button. The controls and 
labels are arranged in a stacked layout. 

9. Click on a blank space on the design grid, and then select the In Production field 
control and label.

10. On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button. In the 
Size category on the menu that appears, click To Fit. Notice all the field controls and 
labels are slightly resized in the layout based on the best fit of the text within the In 
Production field control and label since the layout forces all fields to conform to this 
action.

11. Select all the controls in the stacked layout (the labels and controls for the Description, 
In Stock, Price, and In Production controls).

12. On the Arrange tab, in the Table group, click the Remove Layout button.

13. All the controls and labels should still be selected. On the Arrange tab, in the Sizing & 
Ordering group, click the Size/Space button and then select To Fit from the menu that 
appears. Notice that all the field controls independently change their width to best fit 
their text since they are no longer part of a layout. Your screen should look similar to 
Figure 8-35.
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14. With the controls and labels still selected, on the Arrange tab, in the Sizing & Ordering 
group, click the Align button and then select Right from the menu that appears. The 
labels are right-aligned to the controls.

15. Click and drag the ID field from the Field List pane to any blank spot on the design grid 
above the Description field.

16. Select the ID label and control and in the Sizing & Ordering group, click the Align 
button, and then select Right from the menu that appears.

17. Press and hold the Shift key and then click both the labels and controls for all the 
controls. In the Sizing & Ordering group, click the Align button, and then select Left 
from the menu that appears. All the controls are left-aligned as a group. 

18. In the Sizing & Ordering group, click the Align button and then select Right from the 
menu that appears. All the controls are now right-aligned as a group. Your screen 
should look similar to Figure 8-36.

19. Select all the labels and controls, if necessary.

20. On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button and 
then select Equal Vertical from the Spacing category on the menu that appears. Notice 
that the vertical space between the controls is now equal.

21. Click any blank space on the design grid.

22. On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button and 
then select Grid from the Grid category on the menu that appears. The design grid 
disappears.

23. Click Size/Space and then select Grid again. The design grid appears.

Figure 8-35

Form Design view with 
controls

Figure 8-36

Form Design view with right-
aligned controls 
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24. Click any blank space on the design grid and drag to draw a box around the labels and 
controls so they are all selected, or press and hold the Shift key and then select each 
label and control.

25. On the Arrange tab, in the Sizing & Ordering group, click the Align button. In the menu 
that appears, click the To Grid button. Notice the control and labels slightly move. The 
upper-left corners of all the labels are now aligned to their nearest grid points. 

26. On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button. In the 
Grid category on the menu that appears, click the Ruler button. The rulers disappear.

27. Click Size/Space and then select Ruler again. The rulers reappear.

28. SAVE the form as Arranged Inventory Form.

29. CLOSE the Field List and the form. 

PAUSE. LEAVE the database open to use in the next exercise.

SOFTWARE ORIENTATION

Print Preview Tab

The Print Preview tab, as shown in Figure 8-37, has commands for viewing tables, queries, forms, 
and reports in a variety of ways so you can adjust their layout and view your changes before you 
print them. You can display the Print Preview tab by choosing an object you want to print from 
the Navigation Pane, and then selecting the Print Preview option on the File tab’s Print menu. A 
report already has a Print Preview option on its View menu, so you can simply select that option 
to take you to the Print Preview tab. Use the Print Preview tab to view and adjust data that ap-
pears on printed pages to create an effective print layout. For example, you can adjust margins and 
change the page orientation before printing to ensure data appears appropriately.

Displays the Print dialog box Displays the page vertically

Displays page 
size menu 

Displays margin 
size menu

Displays the page 
horizontally

Displays the Columns tab of 
the Page Setup dialog box  

ADJUSTING PAGE MARGINS AND CHANGING PAGE 
ORIENTATION FOR FORMS AND REPORTS
Forms and reports—and all other Access objects—can be printed to easily communicate data to others 
in a hardcopy format. The Print Preview tab provides options that allow you to adjust page margins 
and/or change orientation to ensure data fits appropriately on a page. When you are satisfied with the 
page layout, you can click the Print button to send the page to the printer. 

It may be easy to understand why you would want to print a report to share data with your colleagues, 
but Access also gives you the option of printing all other database objects. For example, you may want 
to print a table to view data in a datasheet format to which you’re more accustomed or print a form to 
share with a graphic design team so it can be aesthetically evaluated and redesigned. 

The Page Size group on the Print Preview tab contains commands for controlling page size and mar-

Figure 8-37
Print Preview tab
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gins. The Print Data Only checkbox gives you the option of printing only object data without the 
corresponding structure (like gridlines and borders). The Show Margins checkbox allows you to view 
an object’s margins on the preview of the object to help you better adjust them. 

The Page Layout group allows you to change the page orientation of an object, either by choosing the 
Portrait (vertical) or Landscape (horizontal) options. You can also change the layout of data by con-
verting it into any number of columns by choosing the Columns option. Lastly, the Page Setup option, 
when clicked, displays a dialog box with many of the same options that appear in the Page Size and 
Page Layout groups. In this exercise, you use Print Preview to adjust the page margins and change page 
orientation for forms and reports. 

Changes to an object’s print layout using Print Preview are automatically retained when you close Print 
Preview.

STEP BY STEP Adjust Page Margins and Change Page Orientation for Forms and Reports

GET READY. USE the Wingtip Inventory-final database that is open from the previous 
exercise. 

1. Click the Modified Inventory Form in the Navigation Pane and then click the File tab.

2. On the File tab, click the Print button to display the Print menu, with the options Quick 
Print, Print, and Print Preview.

3. Click the Print Preview command. The Print Preview screen appears with a preview of 
the form, as shown in Figure 8-38. Notice the form’s field borders exceed the width of 
the right margin.

4. In the Page Layout group, click the Landscape button to display the form in landscape 
view. Notice some of the form’s field borders still exceed the width of the right margin. 

5. In the Page Size group, click the Margins button. On the Margins menu that appears, 
click the Narrow option. The form’s field borders have been adjusted and should now 
be within the right margin. The print layout now appears complete. Your screen should 
resemble the form shown in Figure 8-39.

Figure 8-38

Form in Print Preview
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Troubleshooting If the borders are not within the right margin, change to Design view and resize the column 
to the right of the In Production field so it is at the 10½-inch mark. Save the form and return 
to Print Layout view. 

6. In the Close Preview group, click the Close Print Preview button to return to the Access 
database screen. 

7. Double-click the Toys By Quantity In Stock report to open it.

8. On the Home tab, in the Views group, click the lower half of the View button and then 
select Print Preview from the menu. The report is displayed in Print Preview. The Price 
field header and data in the last column exceed the width of the right margin. 

9. On the Print Preview tab, in the Page Size group, click the Margins button and then 
select Narrow from the menu that appears. The Price field header and data are now 
completely visible. 

10. On the Print Preview tab, click the Close Print Preview button to return to Report view.

11. CLOSE the reports.

STOP. CLOSE the database and then EXIT Access.

Figure 8-39

Form print layout
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Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Bound control a.  A control that displays the result of a calculation or 
expression

2. Calculated control b.  Help you create controls such as command buttons, list 
boxes, combo boxes, and option groups

3. Control Wizards c.  Controls that are arranged vertically with a label on the 
left and the control on the right

4. Conditional formatting d.  A control that uses a field in a table or query as the data 
source

5. Stacked layout e.  Used to change the appearance of a control or the value 
in a control when certain conditions are met 

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. The easiest way to create a bound control is to double-click or drag a field from 
the Property Sheet to the report.

T F 2. Display formatting can be applied to controls and labels in a form or report.

T F 3. You can change an entire control layout of a report or form from one type to the 
other.

T F 4. The Remove Layout command in the Table group removes a control from a form 
or report.

T F 5. You can use Print Preview to set the margins for a form or report.

Projects

Project 8-1: Refining a Report, and Creating and Refining a Form

In this project, you have learned a great deal about reports and forms while working as an ad-
ministrative assistant at the Alpine Ski House and you want to refine the basic report you created 
previously so you can display it proudly at the front desk. In addition, you want to create a form 
for reservation data and format it to your needs.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Alpine database and then SAVE it as Alpine-final.

2. Double-click the Report Design report to open it and then change to Design view.

3. Select all four controls in the report.

4. On the Arrange tab, in the Table group, click the Tabular button.

5. On the Arrange tab, in the Position group, click the Control Margins button and then 
select Narrow from the menu.

6. On the Arrange tab, in the Position group, click the Control Padding button and then 
select Medium from the menu.

7. On the Design tab, in the Header/Footer group, click the Title button. A title is inserted 
in the report header.

8. Type Alpine Ski House Rooms Report as the title and then press Enter.
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9. On the Design tab, in the Header/Footer group, click the Logo button. Navigate to the 
data files for this lesson and select Ski Lodge.jpg. Click OK.

10. On the Format tab, in the Background group, click the Background Image button. 
Navigate to the data files for this lesson and select Winter Theme Background.jpg. 
Click OK.

11. Press and hold the Shift key and then select all four controls (not control labels).

12. On the Format tab in the Font group, click the Font Color menu button. Select the dark 
blue color called Dark Blue, Text 2 in the first row and fourth column of the Theme 
Colors section.

13. Make sure all the controls are still selected. On the Arrange tab, in the Table group, click 
Remove Layout.

14. With the controls still selected, click and drag them up together and position them just 
below the Detail section bar. Alternatively, you can use the up arrow on your keyboard 
to move them up.

15. Scroll down and position the mouse pointer over the top of the Page Footer section bar. 
Drag the section bar up to position just below the controls. Your screen should look 
similar to Figure 8-40.

16. SAVE the report and then change to Print Preview.

17. Click the Landscape button in the Page Layout group on the Print Preview tab.

18. Click the Reservations: Table in the Navigation Pane to select it.

19. CREATE a new form using Design view.

20. Insert a title control. Change the title to Alpine Ski House Reservations Form.

21. Insert a logo control by navigating to the data files for this lesson and selecting Ski 
Lodge.jpg.

22. Add the following bound controls to the design grid: Customer ID, Room, Rate, Check-
In Date, Check-Out Date, and Notes.

23. Select all the controls and then apply the Stacked control layout.

24. Position the controls in the upper-left corner of the Detail section, remove the stacked 
layout and resize the Notes control, as shown in Figure 8-41.

Figure 8-40

Report design

© Tongshan/iStockphoto
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25. SAVE the form as Reservations Form.

26. Add an Option group control on the right side of the form. Use the Control Wizard to 
create the option box for the Credit Card on File field. 

27. Using the Option Group Wizard, add two Labels: one for Yes and the other for No. 
Set the value for Yes to -1 and the value for No to 0. Use option buttons, and label the 
control Credit Card on File. 

28. Add an unbound text box control below the Credit Card on File field.

29. Click the Property Sheet button on the Design tab and then click the Build button in the 
Control Source property.

30. Create an expression to subtract the Check-in Date from the Check-out Date.

31. Type Number of Nights as the label. (Note the default label number, such as Text##.)

32. Add an unbound text box control beside the Notes control.

33. Double-click the Property Sheet button on the Design tab and then click the Build 
button in the Control Source property.

34. Create an expression to multiply the Number of Nights (or Text##) by the Rate.

35. Type Rate Subtotal as the label.

36. Format the Rate Subtotal field control for Currency.

37. Align the new fields to the left, space to fit, and then change the controls and labels to a 
red font. Your screen should look similar to Figure 8-42.

38. SAVE the form as Reservations and then change to Form view to view your changes.

39. CLOSE the database.

PAUSE. LEAVE Access open for the next project.

Figure 8-41

Reservations form

© Tongshan/iStockphoto
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Project 8-2: Formatting a Report

Because you have increased your Access skills while working as an assistant coach for a youth soc-
cer team, you decide to improve the soccer roster you created at the beginning of the season. There 
have been a few changes anyway, so in this project, you will format an updated version.

GET READY. LAUNCH Access if it is not already running.

1. OPEN SoccerData from the data files for this lesson and then SAVE it as SoccerData-
final.

2. Double-click the Roster report in the Navigation Pane to open it and then change to 
Design view.

3. Press and hold the Shift key and then click all the labels in the Page Header section to 
select them.

4. On the Format tab, in the Font group, click the Bold button.

5. Select the title (Roster) and then type Soccer Roster.

6. On the Format tab, in the Font group, click the drop-down arrow to the right of the Font 
box and select Arial Black.

7. On the Format tab, in the Font group, click the Font Size menu and then select or type 
22.

8. On the Arrange tab, on the Size/Space menu in the Sizing & Ordering group, click the 
To Fit button.

9. Press and hold the Shift key and then click all of the controls in the Detail section. On 
the Arrange tab in the Sizing & Ordering group, select To Grid from the Align menu. 

10. Delete the report image.

11. On the Design tab, in the Header/Footer group, click the Logo button.

12. Navigate to the data files for this lesson and insert the Soccer.jpg file. Click the newly 
created logo control and drag the sizing border handles to increase the logo size until 
the soccer ball image can be seen clearly in the header.

13. SAVE the report and view it in Report view.

CLOSE the database and then EXIT Access. 

Figure 8-42

Revised Reservations form

© Tongshan/iStockphoto
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Advanced Tables9
SKILL SUMMARY

Skills Exam Objective Objective Number

Creating a Custom Table Create a table.
Configure fields to auto-increment.

2.1.1
2.4.6

Summarizing Table Data Add total rows. 2.2.2

CREATING A CUSTOM TABLE 
When a table template doesn’t suit your needs, you can create a custom table in Design view. In 
Design view, you can insert fields, set data types, and perform other advanced table design tasks.

Creating a Custom Table
Creating a table from scratch in Design view gives you maximum flexibility. You can do every-
thing you need to do to create the table in Design view, including adding fields, setting data types, 
defining field properties, and defining a primary key. As you create a table, you can also easily 
insert and delete rows in your table design. In this exercise, you create a new blank table and then 
add fields for the new table in Design view.

Creating a new field for a table in Design view includes typing the name in the Field Name col-
umn; choosing a data type from the menu in the Data Type column; and typing a description, if 
you want, in the Description column. Additionally, you can modify field properties in the Field 
Properties section of the design grid.

After you have completed your table design, you’ll need to save it. If you haven’t already defined a 
primary key, Access will prompt you to do so when you save the table.

STEP BY STEP Create a Custom Table in Design View 

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN Lucerne Publishing from the data files for this lesson and then SAVE the 
database as Lucerne Publishing-final.

2. On the Create tab, in the Tables group, click the Table Design button. A new blank table 
is created in Design view, as shown in Figure 9-1.
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New blank table Field Name column Data Type column Description column

Row selector Field Properties section Displays information about the 
location of the insertion point

3. Type ID in the Field Name column.

4. Press the Tab key to move to the Data Type column.

5. Click the down arrow in the Data Type column and then select AutoNumber from the 
menu. The AutoNumber data type will automatically number your records starting at 1.

6. Press the Tab key to move to the Description field.

7. Type Record Number and then press Tab again to move to the next blank field row.

8. Type Gross Sales and then press the Tab key.

9. Click the down arrow on the Data Type column and then select Currency from the 
menu.

10. Click in the Decimal Places row in the Field Properties section. Click the down arrow 
and then select 0 from the menu.

11. Enter the remaining fields, as shown in Figure 9-2, formatting each with the Currency 
data type and 0 decimal places.

Figure 9-1

Blank table in Design view
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0 decimal places  Down arrow

12. Click the row selector to the left of the ID field to select the row.

13. On the Design tab, in the Tools group, click the Primary Key button.

14. Click the Save button on the Quick Access Toolbar. The Save As dialog box appears.

15. Type Sales and then click OK.

PAUSE. LEAVE the database and Sales table open to use in the next exercise.

Inserting and Deleting Rows
When creating a custom table in Design view, you can insert and delete rows as needed using the 
Insert Rows and Delete Rows commands in the Tools group on the Table Tools Design contextual 
tab. When you click the Insert Rows button, a new row is inserted above the selected row. The field 
order from top to bottom in Design view will be displayed from left to right in Datasheet view. In 
this exercise, you insert and delete rows using the new table you created in the previous exercise.

STEP BY STEP Insert and Delete Rows in Design View

GET READY. USE the Lucerne Publishing-final database and the Sales table that are open 
from the previous exercise.

1. Click the row selector to the left of the Gross Sales field to select the entire row.

2. In the Tools group on the Table Tools Design contextual tab, click the Delete Rows 
button. The field row is deleted from the table.

3. Click the Undo button on the Quick Access Toolbar. The field row reappears.

4. In the Tools group on the Table Tools Design contextual tab, click the Insert Rows 
button. A blank row is inserted above the Gross Sales field.

5. In the Field Name column, type Area and then press the Tab key.

6. Press the Tab key again to accept the Short Text data type.

7. Leave the Description field blank and then press Tab again to move to the next field.

8. Click the Save button on the Quick Access Toolbar.

Figure 9-2

Custom Table in Design view
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9. Change to Datasheet view and enter the records shown in Figure 9-3 in the table. The 
ID field will be automatically generated, so just press Tab to get past it. 

10. SAVE and CLOSE the table.

PAUSE. LEAVE the database open to use in the next exercise.

USING THE TABLE ANALYZER 
The Table Analyzer is a wizard that performs the normalization process for you by examining a 
table design and suggesting a way to divide the table for maximum efficiency. The Table Analyzer 
helps you design efficient tables. The Table Analyzer will suggest primary keys for the new tables 
or will allow you to determine the primary keys. You can also have the wizard insert a unique 
identifier field. If it determines that a table has duplicate information, it can split a table into two 
more efficient tables for you, or you can choose to do it yourself. 

Using the Table Analyzer
The Table Analyzer is a wizard that examines a table and asks you a series of questions about the 
table to determine whether it should be divided into two or more tables. In this exercise, you use 
the Table Analyzer Wizard to analyze a table in the database.

Well-designed databases do not store the same data in more than one place. Redundant data stor-
age takes more disk space and increases the likelihood for data entry errors. In Lesson 1, you were 
introduced to the concept of normalization, which is the process of applying rules to a database 
design to ensure that you have divided your data into the appropriate tables.

In the Books table, contact information for authors has to be entered for each book the author 
wrote. The Table Analyzer Wizard will determine that a more efficient database would split the 
table into two tables: one with author contact information and one with book sales data.

In addition to analyzing the table, the Table Analyzer Wizard will also analyze the redundant data 
in a table and suggest corrections for records that should match. It will also give you the choice of 
whether to create a query, which is similar to the original table. Creating the query allows forms 
and reports that were created with the original table to continue to function properly. The original 
table may be renamed, but it will not be removed or altered.

Troubleshooting If you run the Table Analyzer before entering records in the table, you may get a message 
stating that you need to enter at least two records in the table to get a meaningful analysis.

Figure 9-3

Sales table
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STEP BY STEP Use the Table Analyzer

GET READY. USE the Lucerne Publishing-final database that is open from the previous 
exercise.

1. Double-click the Books table in the Navigation Pane to open it.

2. Scroll through the table to become familiar with the fields in the table. 

3. On the Database Tools tab, in the Analyze group, click the Analyze Table button. The 
Table Analyzer Wizard dialog box, screen 1, appears. This first dialog box provides 
more information about the types of problems the wizard will find. Click the two Show 
me an example buttons to read more about how duplicating information can lead to 
problems. 

4. Click the Next button. The Table Analyzer Wizard dialog box, screen 2, appears. This 
dialog box provides more information about what the wizard will do. Click the two 
Show me an example buttons to read more about how splitting the table is helpful.

5. Click the Next button. The Table Analyzer Wizard dialog box, screen 3, appears, as 
shown in Figure 9-4.

6. The Books table should be selected in the list; if it is not, select it. Click the Next button. 
The Table Analyzer Wizard dialog box, screen 4, appears.

7. The Yes, let the wizard decide button should be selected; if it is not, select it. Click the 
Next button. The Table Analyzer Wizard dialog box, screen 5, appears.

8. Scroll through each table. Notice that the Table2 box contains the Year, which should 
be in Table1 with the sales information. Click the Year field to select it. 

9. Drag the selected field to the Table1 box, positioning the horizontal black line below the 
Book Title field, as shown in Figure 9-5, and releasing the mouse button to place the 
Year field in its new location.

Figure 9-4

Table Analyzer Wizard, 
screen 3
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New location

Table names Rename Table button Tips button

 

10. Click the Table1 name to select it. Click the Rename Table button. If you receive a 
message stating that an expression you entered is the wrong data type for one of the 
arguments, click OK. The Table Analyzer Wizard dialog box appears.

Take Note You can also double click on the table name to rename it. 

11. Type Book Sales and then click OK.

12. Click the Table2 name and then click the Rename Table button. If you receive a 
message stating that an expression you entered is the wrong data type for one of the 
arguments, click OK. The Table Analyzer Wizard dialog box appears.

13. Type Author Contact Information and then click OK.

14. Scroll down to the bottom of the Book Sales table. Notice that the Lookup to Author 
Contact Information field was added.

15. Scroll through the Author Contact Information table. Notice that the Generated Unique 
ID field was added as a primary key. Click the Next button. The Table Analyzer Wizard 
dialog box, screen 6, appears, as shown in Figure 9-6.

Set Unique Identifier button

16. Click the ID field in the Book Sales table to select it. Click the Set Unique Identifier 
button. A primary key is inserted.

Figure 9-5

Table Analyzer Wizard, 
screen 5

Figure 9-6

Table Analyzer Wizard, 
screen 6
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17. Click Next. The Table Analyzer Wizard dialog box, screen 7, appears, as shown in Figure 
9-7.

18. Notice that the Table Analyzer Wizard has detected two similar records, one with an 
incorrect zip code and phone number. Click the down arrow in the first row of the 
Correction field and then select Leave as is. This is the correct record.

19. Click the down arrow on the second row of the Correction field and then select the 
Tomic correction from the menu, as shown in Figure 9-8, to replace the incorrect 
record. Click to select it.

20. Click Next. The final Table Analyzer Wizard dialog box appears.

21. The Yes, create the query option button should be selected. Click the Finish button.

22. A message saying that the wizard couldn’t rename your table because it’s open and the 
new query will be saved as Books_NEW appears. Click OK.

23. If Access Help appears on your screen, close it. Your screen should look similar to 
Figure 9-9.

24. SAVE and CLOSE all tables and queries.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 9-7

Table Analyzer Wizard, 
screen 7

Figure 9-8

Corrections to the new tables
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SUMMARIZING TABLE DATA 
It is often necessary to count or summarize data in a table, column by column. Tables that contain 
columns of sales figures or other numbers need to be summed, averaged, or counted to be more 
useful. The Total row makes these tasks easy. 

Summarizing Table Data
Much like the bottom row of a spreadsheet, the Total row is a feature in Access 2016 that makes 
it easy to sum, average, or count the values in a datasheet column. You can also find maximum 
or minimum values and use statistical functions such as standard deviation and variance. In this 
exercise, you summarize table data by inserting a Total row.

Aggregate functions are functions that calculate values across a range of data, such as in a 
column. You can use these functions in queries or in Visual Basic for Applications (VBA) code. 
Although you can still use those methods, the Total row saves you time by allowing you to choose 
one of these functions from a menu, applying it instantly. The Total row is a row inserted at the 
bottom of a table that provides a menu of functions for each column in the row.

Take Note You can also add a Total row to queries open in Datasheet view and to a split form open in Form 
view. You cannot add a Total row to a report, but you can use aggregate functions in reports using 
other methods.

Table 9-1 describes the aggregate functions available in the Total row and the data types that they 
work with.

Figure 9-9

New tables and queries 
created by the Table Analyzer 
Wizard
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Aggregate 
Function

Description Data Types

Average Calculates the average value for a column Number, Decimal, Currency, Date/Time

Count Counts the number of items in a column All (except multivalued list)

Maximum Returns the item with the highest value Number, Decimal, Currency, Date/Time

Minimum Returns the item with the lowest value Number, Decimal, Currency, Date/Time

Standard 
Deviation

Measures how widely values are dispersed 
from an average value

Number, Decimal, Currency

Sum Adds items in a column Number, Decimal, Currency

Variance Measures the statistical variance of all 
values in the column

Number, Decimal, Currency

As shown in the table, some functions only work with certain data types. For example, you cannot 
sum a column of text, so that function would not be available for a column with the Short Text 
or Long Text data type.

STEP BY STEP Insert a Total Row

GET READY. USE the Lucerne Publishing-final database that is open from the previous 
exercise.

1. Double-click the Book Sales table in the Navigation Pane to open it.

2. On the Home tab, in the Records group, click the Totals button. The Total row appears 
below the row with the asterisk (*) in the record selector box. 

3. Click the down arrow in the Book Title column of the Total row. Select Count from 
the menu. The number of records in the column is counted, and the number 11 is 
displayed.

4. Click the down arrow in the Domestic Sales column of the Total row and then select 
Sum from the menu, as shown in Figure 9-10. Click Sum to apply it.

5. Click the down arrow in the International Sales column of the Total row and then select 
Sum from the menu. 

6. SAVE the table.

7. On the Home tab, in the Records group, click the Totals button. The Total row is hidden.

8. On the Home tab, in the Records group, click the Totals button again. The Total row 
reappears.

Table 9-1 

Aggregate functions in the 
Total row
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Total row   Available functions for column

9. SAVE and CLOSE the table.

 STOP. CLOSE the database and then EXIT Access.

Take Note If you want to sort or filter data, Access will exclude the Total row by default.

Figure 9-10

Total row
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Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Aggregate function a.  The process of applying rules to a database design to ensure 
that you have divided your information into the appropriate 
tables 

2. Table Analyzer b.  An optional part of Design view where you can enter a field 
description 

3. Normalization  c. An aggregate function that counts the records in a column 

4. Count  d.  A wizard that performs the normalization process by 
examining a table design and suggesting a way to divide the 
table for maximum efficiency 

5. Description e. Function that calculates values across a range of data 

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. If you haven’t already defined a primary key, Access will prompt you to do so 
when you save the table in Design view.

T F 2. The row selector is located at the bottom of the table.

T F 3. The Table Analyzer does not remove the original table.

T F 4. The Table Analyzer gives you the choice of whether to create a query.

T F 5. You cannot delete a Total row, but you can hide it.

Projects

Project 9-1: Creating and Analyzing Tables

In this project, sales data for Fourth Coffee has just come in for the first quarter. The manager 
asks you to create a table that displays the sales for each of the five stores in your division. Note 
that each store is known by a three-digit number, such as 656. You also decide to use the Table 
Analyzer to check a table you created previously to make sure it is efficient.

GET READY. LAUNCH Access if it is not already running.

1. OPEN FourthCoffeeInventory from the data files for this lesson, and then SAVE the 
database as FourthCoffeeInventory-final.

2. CREATE a new table in Design view using the Table Design button on the Create tab.

3. Type ID as the first field name and then press the Tab key. Set the data type to 
AutoNumber.

4. Type Sales Month as the second field name and then press the Tab key. Keep the 
default data type.

5. Enter the remaining field names and data types, as shown in Figure 9-11. Set the 
primary key as shown.
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6. SAVE the table as Monthly Sales by Store.

7. Change to Datasheet view.

8. Enter the data as shown in the following table.

ID Sales Month Store Sales
1 January 651 $88,432.00
2 February 651 $97,798.00
3 March 651 $67,890.00
4 April 651 $59,098.00
5 January 656 $105,890.00
6 February 656 $96,789.00
7 March 656 $96,789.00
8 April 656 $87,890.00
9 January 660 $106,098.00
10 February 660 $77,998.00
11 March 660 $94,927.00
12 April 660 $84,123.00
13 January 662 $90,890.00
14 February 662 $67,223.00
15 March 662 $87,010.00
16 April 662 $74,280.00 

9. Insert a Total row.

10. Count the Sales Month field and sum the Sales field.

11. SAVE and CLOSE the table.

12. Double-click the Customers table in the Navigation Pane to analyze it.

13. On the Database Tools tab, in the Analyze group, click the Analyze Table button. The 
Table Analyzer Wizard dialog box appears.

14. Click Next to display the next Table Analyzer Wizard dialog box.

15. Click Next to display the next Table Analyzer Wizard dialog box.

16. The Customers table should be selected. Click Next.

17. The Yes, let the Wizard decide option button should be selected. Click Next.

18. A message is displayed that says the wizard does not recommend dividing the table. 
Click OK.

19. Click Cancel to close the Table Analyzer Wizard.

20. CLOSE the table and the database.

PAUSE. LEAVE Access open for use in the next project.

Figure 9-11

Monthly Sales by Store in 
Design view
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Project 9-2: Creating and Designing a Table

The owner of Wingtip Toys has given you yearly sales data for each of the company’s sales chan-
nels. In this project, you will create and design a table in which to store and total the data.

GET READY. LAUNCH Access if it is not already running.

1. OPEN WingtipToysInventory from the data files for this lesson, and then SAVE the 
database as WingtipToysInventory-final.

2. CREATE a new table in Design view using the Table Design button on the Create tab.

3. CREATE the table as shown in Figure 9-12.

 

4. SAVE the table as Yearly Sales and then change to Datasheet view to review the table 
you just created.

5. Change back to Design view.

6. Insert a blank row above the Catalog Sales field.

7. Type Yr as a new field with the Short Text data type.

8. Select the Yr field and then click the Primary Key button to designate the Year field as 
the new primary key.

9. Delete the ID field.

10. SAVE the table and then change to Datasheet view.

11. Enter data as shown in the following table.

Yr Catalog Sales Internet Sales Store Sales Other Sales
2014 $87,987.00 $109,897.00 $208,767.00 $23,987.00
2015 $57,984.00 $98,789.00 $197,098.00 $10,761.00
2016 $61,089.00 $78,907.00 $168,234.00 $9,125.00 

12. SAVE the table.

13. Insert a Total row.

14. Sum the Catalog Sales, Internet Sales, Store Sales, and Other Sales columns.

15. SAVE and CLOSE the table.

CLOSE the database and then EXIT Access.  

Figure 9-12

Yearly Sales table in Design 
view
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Skills Exam Objective
Objective 
Number

Creating Advanced Forms Create a form.
Add sub-forms.

4.1.1
4.2.7

Using Application Parts to Create Blank Forms Create a form from a template with application parts. 4.1.2

Creating and Modifying a Navigation Form Create and modify a navigation form. 1.3.2

SOFTWARE ORIENTATION

The Templates Group and the Forms Group 

The Application Parts button in the Templates group and the Navigation and More Forms buttons 
in the Forms group, all located on the Create tab, contain menus with commands for creating all 
types of forms—some of which you have already learned about in Lesson 5. Figures 10-1, 10-2, 
and 10-3 show the menus and commands you use to create advanced forms. 

Figure 10-1
Application Parts button and 
menu

Figure 10-2
Navigation button and menu
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CREATING ADVANCED FORMS 
Access provides tools to help you create forms quickly, including advanced forms with features 
that can improve the usability of your database. The Multiple Items tool creates a customiz-
able form that displays multiple records. A split form gives you two views of your data at the 
same time—in both Form view and Datasheet view. A subform is a form that is inserted into 
another form. 

Creating a Multi-Item Form
When you create a simple form using the Form tool, Access creates a form that displays a single 
record at a time. To create a form that displays multiple records but that is more customizable than 
a datasheet, you can use the Multiple Items tool. In this exercise, you create a multi-item form 
using the Multiple Items tool.

When you use the Multiple Items tool, the form that Access creates resembles a datasheet. The 
data is arranged in rows and columns, and you see more than one record at a time. However, a 
Multiple Items form gives you more customization options than a datasheet, such as the ability to 
add graphical elements, buttons, and other controls.

STEP BY STEP Create a Multi-Item Form

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN the Contoso database from the data files for this lesson and then SAVE it as 
Contoso-final.

2. In the Navigation Pane, double-click the Doctors table to open it.

3. On the Create tab, in the Forms group, click the More Forms button. On the menu that 
appears, click the Multiple Items button. Access creates the form and displays it in 
Layout view, as shown in Figure 10-4.

Figure 10-3
More Forms button and menu
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4. Scroll down to view the multiple records on the form.

5. Click the File tab and then click Save.

6. In the Save As dialog box, type Doctors Multiple and then click OK.

7. CLOSE the Doctors Multiple form and the Doctors table.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Split Form
Creating a split form allows you to see two views of your data at the same time—in Form view 
and in Datasheet view. The two views are connected to the same data source and are completely 
synchronized with each other. In this exercise, you create a split form.

Working with split forms gives you the benefits of both types of forms in a single form. Selecting 
a field in the Datasheet view of the form selects the same field in the Form view part of the form. 
When you add, edit, or delete data in the Datasheet view, the change is reflected in the Form view.

Table 10-1 lists some of the properties related to split forms that you can set on the Property Sheet 
to fine-tune your form. To change form properties, change to Design view, press F4 to display the 
Property Sheet, select Form from the drop-down list at the top of the Property Sheet, and then 
click the Format tab.

Figure 10-4

Multiple Items form in Layout 
view
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Property View(s) in which 
you can set the 
property

Description

Split Form 
Orientation

Design view Allows you to define whether the datasheet appears 
above, below, to the left, or to the right of the form.

Split Form Datasheet Design view or 
Layout view

If set to Allow Edits (and the form’s record source is 
updateable), Access allows edits to be made on the 
datasheet. If set to Read Only, Access prevents edits 
from being made on the datasheet.

Split Form Splitter 
Bar

Design view If set to Yes, Access allows you to resize the form and 
datasheet by moving the splitter bar that separates the 
two parts. If set to No, the splitter bar is hidden, and the 
form and datasheet cannot be resized.

Save Splitter Bar 
Position

Design view If set to Yes, the form opens with the splitter bar in the 
same position in which you last left it. If set to No, the 
form and datasheet cannot be resized, and the splitter 
bar is hidden.

Split Form Size Design view or 
Layout view

Allows you to specify an exact height or width (depend-
ing on whether the form is split vertically or horizontal-
ly) for the Form view of the split form. For example, 
type 1” to set the form to a height or width of 1 inch. 
Type Auto to set the dimension by other means, such as 
dragging the splitter bar in Layout view.

Split Form Printing Design view or 
Layout view

Allows you to define which portion of the form is 
printed when you print the form. If set to Form Only, 
only the form portion is printed. If set to Datasheet 
Only, only the datasheet portion is printed.

STEP BY STEP Create a Split Form

GET READY. USE the Contoso-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click the Sales Reps table to open it.

2. On the Create tab, in the Forms group, click the More Forms button. On the menu that 
appears, select Split Form. Access creates the form and displays it in Form view and 
Datasheet view at the same time, as shown in Figure 10-5.

Table 10-1

Properties related to  
split forms
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Form viewDatasheet view

3. Click the Next Record navigation button to display the next record in Form view.

4. In the Datasheet view on the bottom, place the insertion point in the Mobile Phone field 
for Nancy Buchanan. Notice that the same field is selected in the Form view at the top.

5. Change the number for Nancy Buchanan in the Mobile Phone field to 806-555-4489.

6. Click anywhere on the Form view above the datasheet and notice that the mobile 
phone number has been changed there as well.

7. On the Home tab, in the Views group, click the lower half of the View button and then 
select Design View.

8. Press F4 to display the Property Sheet.

9. Click Form in the drop-down list at the top of the Property Sheet, if necessary, and then 
click the Format tab.

10. Scroll down to the Split Form Orientation property, click the down arrow and then 
select Datasheet on Top (see Figure 10-6).

Figure 10-5

Split form
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Troubleshooting If all text for the properties is not visible, click the left border of the Property Sheet and drag 
to widen it.

11. Click the Close button to close the Property Sheet.

12. On the Home tab, in the Views group, click the lower half of the View button and then 
select Layout View. The split form is displayed with the datasheet on top, as shown in 
Figure 10-7.

Figure 10-6

Changing a property



Advanced Forms 183

13. Click the File tab and then click Save.

14. In the Save As dialog box, type Sales Reps Split and then click OK.

15. CLOSE the Sales Reps Split form and the Sales Reps table.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Subform
A subform is a convenient tool that allows you to view data from more than one table or query 
on the same form. A subform is a form that is inserted into another form. The primary form is 
called the main form, and the form within the form is called the subform. A form/subform 
combination is sometimes referred to as a hierarchical form, a master/detail form, or a parent/
child form. You can use the Form Wizard to help you create subforms quickly. For best results, 
all relationships should be established first. This enables Access to automatically create the links 
between subforms and main forms. In this exercise, you create a subform.

When working with a relational database, you often need to view data from more than one table or 
query on the same form. For example, you want to see customer data, as well as information about 
the customer’s orders at the same time. Subforms are a convenient tool for doing this. 

Subforms are especially effective when you want to show data from tables or queries that have a 
one-to-many relationship—the main form shows data from the “one” side of the relationship and 
the subform shows the data from the “many” side of the relationship.

Figure 10-7

Split form with datasheet  
on top
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STEP BY STEP Create a Subform

GET READY. USE the Contoso-final database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click Form Wizard.

2. In the first screen on the Form Wizard, click the down arrow in the Tables/Queries box 
and then click Table: Samples Given.

3. In the Available Fields box, double-click the Week Name, Sales Rep, Product, and 
Quantity fields to move them to the Selected Fields box.

4. Click the down arrow in the Tables/Queries box and then click Table: Doctors.

5. In the Available Fields box, double-click the Last Name, First Name, Specialty, and 
Hospital fields to move them to the Selected Fields box. The screen should look like 
Figure 10-8.

6. Click the Next button.

7. In the How do you want to view your data? box, click by Doctors. The Form with 
subform(s) option button should be selected, and the Form Wizard should look like 
Figure 10-9.

Figure 10-8

Form Wizard, screen 1

Figure 10-9

Form Wizard, screen 2
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8. Click the Next button.

9. Click the Tabular option button to select that as the layout for your subform.

10. Click the Next button. Access has suggested titles for the forms (Doctors and Samples 
Given Subform). Keep the default selection to open the form.

11. Click the Finish button to create the forms. The Doctors form appears with the Samples 
Given subform, as shown in Figure 10-10.

Main formSubform

12. In the Navigation Pane, double-click the Samples Given Subform to open it.

13. Scroll down and to the right, if necessary, to see the data contained in the records. 

14. CLOSE the Samples Given Subform and the Doctors form.

PAUSE. LEAVE the database open to use in the next exercise.

USING APPLICATION PARTS TO CREATE BLANK FORMS 
As you learned in Lesson 2, the Application Parts gallery consists of two categories, Blank Forms 
and Quick Start. The Blank Forms category contains a collection of 10 form parts that allow you 
to add predefined forms to a database. In this exercise, you create an Application Parts Blank Form 
and populate the form with bound controls using the Field List.

Application Parts Blank Forms are created as unbound forms and provide a prearranged control 
layout. They can also provide unbound command button controls, depending on what type of 
Blank Form you choose. These forms can also be easily populated with bound controls by using 
the Field List.

Application Parts Blank Forms differ from adding a form using the Blank Forms tool because you 
can add forms that automatically include command buttons that provide additional functionality, 
such as saving a record or closing a form. Using Application Parts Blank Forms, you can also easily 
add forms that do more than just display data from a record source. You can create unbound forms 
that display messages to a user or provide dialog boxes that prompt the user for an action. These 
unbound forms can be referenced through code using Visual Basic for Applications (VBA) to help 
provide a more functional database.

Figure 10-10

Doctors form with subform
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STEP BY STEP Use Application Parts to Create Blank Forms

GET READY. USE the Contoso-final database that is open from the previous exercise.

1. On the Create tab, in the Templates group, click the Application Parts button and then 
select 1 Right. A new form object named SingleOneColumnRightLabels appears in the 
Navigation Pane in the Unrelated Objects category.

2. Double-click the SingleOneColumnRightLabels form to open it. The form is displayed 
in Form view, as shown in Figure 10-11.

3. Change to Layout view and then press Shift while clicking on the label control 
placeholders titled Field1, Field2, Field3, and Field4 to select them all. Press the 
Delete key on the keyboard to delete the label controls. Also delete the label control 
placeholder that contains the red asterisk, which could be used to denote an important 
field, like a key field.

4. Click the Add Existing Fields button in the Tools group. The Field List pane appears. If 
necessary, click the Show all tables link. 

5. In the Field List pane, expand the Doctors table. 

6. In the Field List pane, click and drag each Last Name, First Name, Specialty, and 
Hospital field to the form and to the right placeholder of the original locations of the 
Field1, Field2, Field3, and Field4 label controls that you just deleted. 

7. Resize the label and field controls that you just added until your screen resembles 
Figure 10-12.

Figure 10-11

Blank Form in Form view
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8. Click the Form Title label, delete Form Title and then type Doctors.

9. Change to Form view and cycle through the records. Click the Save & Close button on 
the form to close the form. 

10. Click Yes in the dialog box prompting you to save design changes to the form.

11. Rename the SingleOneColumnRightLabels form to Doctors Blank Form.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING AND MODIFYING A NAVIGATION FORM 
The ability to create Navigation forms was introduced in Access 2010. A Navigation form 
includes a set of navigation tabs that you can click to display forms and reports. In this exercise, 
you create and modify a Navigation form.

As you learned in Lesson 2, you can create databases based on templates. When a database is 
created using a web database template, a Navigation form is used as the main interface within 
the database since the Navigation Pane cannot be viewed from within a web browser. However, 
Navigation forms can also be used from within the Access application window to simplify your 
interaction with database objects. For example, you can easily click a tab on a Navigation form to 
view a form to add, view, or edit data. Similarly, you can simply click a button on the Navigation 
form to work with reports. 

You create navigation forms by clicking the Navigation button in the Forms group on the Create 
tab. There are six Navigation form layouts from which to choose. Each layout includes a specific 
arrangement of tabs that can then be modified in Layout or Design view to access forms and re-
ports. In Layout view, you can click and drag form and report objects from the Navigation Pane 
to tabs to quickly add functionality to the Navigation form. You can also type a form or report’s 
name as the tab’s label and Access will automatically bind the associated form or report to that 
label. You can also work with Navigation forms using Design view to have the most control over 
design options, but you lose the ability to quickly add form and report objects by just clicking and 
dragging them to the tabs or modifying the labels.

Take Note You can also add fields from multiple tables to your Navigation form using the Field List pane in 
both Design and Layout views to allow for even greater customization.

Figure 10-12

Form with re-sized label and 
field control
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STEP BY STEP Create a Navigation Form

GET READY. USE the Contoso-final database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click the Navigation button and then click 
Horizontal Tabs. A new Navigation form appears in Layout view, as shown in Figure 
10-13.

2. Click and drag the Doctors form object from the Navigation Pane to the Add New tab 
near the top of the form. The form tab is renamed Doctors and all the Doctors form’s 
controls appear. A new [Add New] tab appears next to the Doctors tab. 

Take Note You cannot drag table objects from the Navigation Pane to the [Add New] tab.

3. Click and drag the Doctors Report object from the Navigation Pane to the [Add New] 
tab near the top of the form. The form tab has been renamed Doctors Report and all 
the Doctors report controls appear. A new [Add New] tab appears next to the Doctors 
Report tab. Your screen should resemble Figure 10-14.

Figure 10-13

Navigation form in Layout 
view
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4. Double-click the Doctors tab and then type Doctors Form to rename the tab.

5. Click the File tab and then click Save.

6. In the Save As dialog box, type Doctors Navigation Form and then click OK.

7. Change to Design View, and on the Doctors Form Tab Layout View, resize the columns 
in the Samples Given section so they all fit mostly in the window, as shown in Figure 
10-15.

8. Change back to Form View and view the changes. Your screen should look similar to 
Figure 10-16.

Take Note Simply click the control label and/or the control to view an orange box around them to resize ac-
cordingly. Shift+click the Control label and the control to select all of them to move them. 

Figure 10-14

Navigation form displaying 
Doctors report

Figure 10-15

The Samples Given section 
resized in Design View
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9. SAVE and CLOSE the Doctors Navigation Form.

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1. Creating a(n) ____________ form allows you to see two views of your data at the same 
time.

2. For best results, all ____________ should be established before creating a subform.

3. When creating a subform, the primary form is called the ____________ form.

4. A(n) ____________ form resembles a datasheet, but it gives you more customization 
options.

5. The views in a split form are connected to the same data ____________ and are 
completely synchronized with each other.

Multiple Choice
Select the best response for the following statements or questions.

1. Which of the following tools creates a customizable form that displays multiple 
records?
a. Query
b. Subform
c. Report
d. Multiple Items

2. Which type of form allows you to view data from more than one table or query on the 
same form?
a. Multi-item form
b. Split form
c. Subform
d. Navigation form

Figure 10-16

Samples Given in Form View
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3. A form/subform combination is sometimes referred to as which of the following?
a. Hierarchical form
b. Master/detail form
c. Parent/child form
d. All of the above

4. Which type of form already has a predefined layout and can automatically contain 
command buttons?
a. Multi-item form
b. Split form
c. Subform
d. Application Parts Blank form

5. Which type of form can be added to a database to simplify your interaction with 
objects preventing the need to use the Navigation Pane?
a. Subform
b. Blank form
c. Split form
d. Navigation form

Projects

Project 10-1: Creating Forms and Subforms

Information about each selection for the Fourth Coffee monthly coffee club is stored in an Access 
database. As purchasing manager, you use the database frequently and need to have several types 
of forms available to work with the data. In this project, you will create a multi-item form, a split 
form, and a subform that show this data.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Fourth Coffee Club from the data files for this lesson and then SAVE the 
database as Fourth Coffee Club-final.

2. CREATE a multi-item form for the Regular Coffee table.

3. Name the form Regular Coffee Multi and close it.

4. CREATE a multi-item form for the Decaf Coffee table.

5. Name the form Decaf Coffee Multi and close it.

6. CREATE a split form for the Regular Coffee table.

7. Name the form Regular Coffee Split and close it.

8. CREATE a split form for the Decaf Coffee table.

9. Name the form Decaf Coffee Split and close it.

10. On the Create tab, in the Forms group, click Form Wizard.

11. In the first screen on the Form Wizard, select Table: Regular Coffee in the Tables/
Queries box.

12. Move the Name field to the Selected Fields box.

13. Select Table: Orders in the Tables/Queries box.

14. Move the Order Date, Distributor, and Pounds Ordered fields to the Selected Fields box.

15. In the second screen of the Form Wizard, choose to view your data by Regular Coffee.

16. In the third screen of the Form Wizard, choose to view your data in tabular layout.

17. In the final screen of the Form Wizard, accept the default form names and then click 
Finish.

18. Navigate to the fourth record to see information about the orders placed to the 
distributors for River Road coffee.

19. CLOSE the form.

PAUSE. LEAVE the database open for the next project.
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Project 10-2: Using Application Parts to Create Forms and Creating Navigation Forms 

As purchasing manager for Fourth Coffee, you need to keep track of the Distributors you use for 
your coffee. In this project, you will create a form to add distributors and a navigation form that 
allows you to view both the distributors and the orders by distributors. 

GET READY. USE the Fourth Coffee Club-final database that is open from the previous 
project. 

1. On the Create tab, in the Templates group, click the Application Parts button and then 
select 1 Right. 

2. Double-click the new form named SingleOneColumnRightLabels in the Navigation 
Pane to open it. 

3. In Layout view, delete the placeholders Field1, Field2, Field3, and Field4 as well as the 
label control placeholder that contains the red asterisk.

4. Delete the very last row of the table.

5. Click the Add Existing Fields button in the Tools group, and expand the Distributors 
table. 

6. Click and drag the Company, Business Phone, and Web Page fields to the form. 

7. Resize the label and field controls as necessary.

8. Click the Form Title label, delete Form Title and then type Distributors.

9. Change to Form view and cycle through the records. Click the Save & Close button on 
the form to close the form. 

10. Click Yes in the dialog box prompting you to save design changes to the form.

11. Rename the SingleOneColumnRightLabels form to Distributors Form.

12. On the Create tab, in the Forms group, click the Navigation button and then click 
Horizontal Tabs. 

13. Click and drag the Distributors form object from the Navigation Pane to the Add New 
tab near the top of the form. 

14. Click and drag the Orders Subform object from the Navigation Pane to the [Add New] 
tab near the top of the form. 

15. Click Save and name the form Distributors and Orders Form.

STOP. CLOSE the form, CLOSE the database, and then EXIT Access.



Advanced Reports11

193

SKILL SUMMARY

Skills Exam Objective Objective Number

Defining Groups Group and sort fields. 5.2.1

Creating a Subform on a Report Add subforms. 4.2.7

Creating the Print Layout Print reports.
Print records. 
Change report orientation.

1.5.1 
1.5.2 
5.3.5

DEFINING GROUPS 
A group is a collection of records separated visually with any introductory or summary informa-
tion displayed with it. Reports can be grouped on fields or expressions. A grouping field is a 
field by which data is grouped. Grouping levels are the nested arrangement of the groups in a 
report. Access creates indented levels to show the groups from highest to lowest priority. You can 
change a group’s level in the Report Wizard by using the priority up and down arrows. Access 
allows you to specify as many as 10 grouping levels in a report. Groups can be nested so you can 
easily see the group structure. 

When data is arranged in groups, it is often easier to comprehend and it becomes more meaning-
ful. For example, if you want to see the sales performance for each region, it is easier to review 
this data if each region’s sales are grouped together. You can go a step further and specify another 
group level, such as salesperson. This allows you to group a report by region and by salesperson 
within each region. 

You can specify grouping intervals by using the Grouping Options button. Grouping intervals 
establish the way that records are grouped together. They can be very useful in arranging a large 
number of records in a group. You can group on the first character of a text field so that all of 
the records are visually separated alphabetically. You can specify a group interval of a day, week, 
month, or quarter on a date field. This is useful if you want to view the sales for each week in a 
report. You can also specify a custom interval.

Using the Report Wizard
You can easily specify groups with the Report Wizard when creating a new report. This is an easy 
and fast way to create a report with groups. The Report Wizard lets you specify how you would 
like data to be grouped as you create the report. You can also add grouping to an existing report 
using the Group, Sort, and Total pane. Grouping options let you further specify how you want the 
groups to appear in your report. In this exercise, you use the Report Wizard to specify grouping 
levels and create a report. 
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STEP BY STEP Use the Report Wizard

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN Messenger database from the data files for this lesson and then SAVE it as 
Messenger-final.

2. In the Navigation Pane, double-click the Corporate Sales table to open it.

3. On the Create tab, in the Reports group, click the Report Wizard button. The first 
Report Wizard dialog box appears.

4. Click the > button or double-click each item to move the Region (Borough), Sales 
Person Last Name, Company Name, and Contract Amount fields from the Available 
Fields list to the Selected Fields list.

5. Click the Next button. The second Report Wizard dialog box appears.

6. Select the Region (Borough) field and then click the > button to move it to the grouping 
levels box.

7. Select the Contract Amount field and then click the > button to move it to the grouping 
levels box.

8. Select the Sales Person Last Name field and then click the > button to move it to the 
grouping levels box.

9. Notice that the Sales Person Last Name field is the active field in bold type. Click the 
Priority up arrow to move the Sales Person Last Name field to the second level of 
grouping. Your screen should look similar to Figure 11-1.

10. Click the Grouping Options button at the bottom of the dialog box. The Grouping 
Intervals dialog box appears, as shown in Figure 11-2.

Figure 11-1

Second Report Wizard 
dialog box
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11. Click the down arrow on the first Grouping intervals menu to see the choices available. 
Select Normal from the menu and then click OK.

12. Click the Next button. The third Report Wizard dialog box appears. You can sort in 
either ascending or descending order and by up to four fields.

13. Click the down arrow on the Sort menu and then select Company Name to sort in 
ascending order by Company Name. 

14. Click the Next button. The fourth Report Wizard dialog box appears. You can choose 
from three different layouts for your report as well as two different orientations.

15. In the Layout section, click the Block option button, as shown in Figure 11-3. Keep the 
default orientation as Portrait and keep the selection so all fields fit on one page.

16. Click the Next button. The fifth Report Wizard dialog box appears.

17. Type Corporate Sales by Region/Salesperson as the title of your Report, replacing the 
default title of Corporate Sales1.

18. Click the Finish button to accept the settings. The Report Wizard creates the report, 
shown in Figure 11-4, with the groups you specified.

Figure 11-2

Grouping Intervals dialog box

Figure 11-3

Report Wizard dialog box, 
layout and orientation
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19. CLOSE the report and the table.

PAUSE. LEAVE the database open to use in the next exercise.

Adding Group Headers and Footers
You can add group headers and footers to a report using the Group, Sort, and Total pane. When 
you select a field from the Group On menu, the group header is added to the report. In this exer-
cise, you add group headers using the Group, Sort, and Total pane.

As you may remember from Lesson 6, a report is organized into sections. You can view sections 
of a report in Design view. The group header is the section of a report where the name of a 
grouped field is displayed and printed. Group headers take on the name of the group, so instead of 
seeing a group header named Group Header you will see [Fieldname] Header.

A group footer is the section of the report where the data in the group is summarized. It is 
optional. If you do not have any summary data, such as a total, you don’t need a group footer.

STEP BY STEP Use the Group, Sort, and Total Pane

GET READY. USE the Messenger-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click the Corporate Sales report to open it. Notice that 
the report is not arranged by groups.

2. Change to Layout view and close the Field List pane if it opens.

3. On the Design tab, in the Grouping & Totals group, click the Group & Sort button. The 
Group, Sort, and Total pane appears at the bottom of the screen, as shown in Figure 
11-5.

4. Click the Add a group button. Select Region (Borough) from the Group On menu. The 
report is now grouped on the Region (Borough) field.

Figure 11-4

Corporate Sales by Region/
Salesperson report
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Group, Sort, and Total pane

5. Click the Add a group button again and then select Sales Person Last Name from the 
Group On menu. The report is now also grouped on the Sales Person Last Name field.

6. Change to Design view. Your screen should look similar to Figure 11-6. Notice that there 
is a Region (Borough) Header for that group and a Sales Person Last Name header for 
that group. The Company Name and Contract Amount fields are arranged in the Detail 
section.

7. SAVE the report.

PAUSE. LEAVE the database and the report open to use in the next exercise.

Group On rows Detail section

Group headers

Figure 11-5

Group, Sort, and Total pane

Figure 11-6

Group headers in Design view
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Changing Grouping Options
After grouping data, Access gives you options for displaying grouped data. To display the grouping 
options in the Group, Sort, and Total pane, click More on the group level that you want to change. 
If you want to hide the grouping options, click Less. In this exercise, you use the Group, Sort, and 
Total Pane to change group options.

Grouping options include:

• Sort order: Choose ascending or descending
• Group interval: Change the way records are grouped together
• Totals: Add totals to fields
• Title: Change the label of a column heading or summary field
• With/without header: Add or remove the header section
• With/without footer: Add or remove footer section
• Do not keep group together on one page: Groups can be broken up by page breaks
• Keep whole group together on one page: Minimizes the number of page breaks in a group 

on one page
• Keep header and first record together on one page: Ensures a group header is not printed by 

itself at the bottom of a page
You can also click the Move up and Move down arrows at the end of the Group On row to change 
the priority of grouping levels. To delete a grouping level, click the Delete button at the end of its 
Group On row and Access will move the data to the Detail section of the report. However, if other 
controls are in the header, Access will warn you that these could be deleted.

The Hide Details command is a toggle button in the Grouping & Totals group on the Ribbon that 
hides data in the Detail section of the report. Click it again to display the data.

STEP BY STEP Change Grouping Options

GET READY. USE the Messenger-final database and Corporate Sales report that are open 
from the previous exercise.

1. Change to Layout view.

2. Click the Group On Sales Person Last Name row in the Group, Sort, and Total pane, 
and then click the More button to view the available grouping options.

3. Click the down arrow beside with a header section and then select without a header 
section from the drop-down menu, as shown in Figure 11-7.

4. Change to Design view. Notice that the Sales Person Last Name Header has been 
deleted from the grouping area.

5. Change back to Layout view.

Group on Sales Person Last Name row Move up Delete

Drop-down menu Move down
Figure 11-7

Group on Sales Person  
Last Name row
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6. Click the down arrow beside the without a header section (if the without a header 
section option doesn’t appear, click the More button) and then select with a header 
section from the drop-down menu. 

7. Click the Move up arrow at the end of the Group On Sales Person Last Name row. 
Notice that the Sales Person Last Name group is now the top level group in the report.

8. Click the Add a group button and then select Company Name from the menu. A new 
group level is added to the report.

9. On the Design tab, in the Grouping & Totals group, click the Hide Details button. The 
data in the Contract Amount field is hidden.

10. On the Design tab, in the Grouping & Totals group, click the Hide Details button. The 
data in the Contract Amount field is displayed.

11. Click the More button next to Group On Company Name in the Group, Sort, and Total 
pane.

12. Click the with A on top down arrow on the Group On Company Name row in the Group, 
Sort, and Total Pane and then select with Z on top from the drop-down menu. The sort 
order is changed from ascending to descending order.

13. Click the with Z on top down arrow and then select with A on top.

14. Click the Delete button on the right side of the Group On Company Name row in the 
Group, Sort, and Total pane. The row is deleted, as is the Company Name header 
section.

15. Change to Report view to see the report. Your screen should resemble Figure 11-8.

16. SAVE the report.

PAUSE. LEAVE the database and the report open to use in the next exercise.

CREATING AGGREGATE FIELDS 
Report data often contains numbers, such as sales figures, that need to be totaled. A report that 
lists sales for each month in a quarter but does not total all the sales for the quarter is incomplete. 
Aggregate fields use functions to provide summary information of such data. You can create 
an aggregate field by using aggregate functions to calculate data in a field. The aggregate functions 
you can use are Sum, Average, Count Records, Count Values, Maximum, Minimum, Standard 
Deviation, or Variance.

Figure 11-8

Corporate Sales report



Lesson 11200

Access 2016 provides a Totals command that lets you create an aggregate field that provides not 
only grand totals, but totals for groups in a report as well. You can also use the Group, Sort, and 
Total pane to add aggregate functions to fields. 

The Totals command is located on the Design tab, in the Grouping & Totals group, but you can 
also access it on the shortcut menu. In Layout view, just right-click the field you want to total and 
then select Total, which will be followed by the field name, from the shortcut menu. The Totals 
command adds a calculated control in the report footer where it displays the grand total. If you 
don’t already have group footers in your report, the Totals command adds group footers and cal-
culated controls to calculate the totals for each group.

Creating Aggregate Fields
You have a few more options when using the Group, Sort, and Total pane to create an aggregate 
field in a report. The Totals menu gives you options for choosing the field and type of function as 
well as options on how you want to display totals. You can display a grand total or group subtotals 
as a percentage of the grand total. You can also choose to show the subtotals in the group header 
or footer. In this exercise, you use the Group, Sort, and Total pane to create aggregate fields.

STEP BY STEP Create Aggregate Fields

GET READY. USE the Messenger-final database and Corporate Sales report that are open 
from the previous exercise.

1. Change to Layout view.

2. Click the Group On Sales Person Last Name row in the Group, Sort, and Total pane, 
and then click More.

3. Click the with no totals down arrow. The Totals menu appears.

4. Click the Total On menu down arrow and then select Contract Amount.

5. Click the Type menu down arrow and then select Sum if it isn’t selected already.

6. Point to the Show Grand Total box, as shown in Figure 11-9. Click the Show Grand 
Total check box. The menu disappears and the grand total appears in the Contract 
Amount column at the bottom of the report.

Figure 11-9

Totals menu
7. Click the Group On Sales Person Last Name row again, click More, and then click the 

with Contract Amount totaled down arrow.

8. Click the Total On menu down arrow, select Contract Amount, and then click the Show 
subtotal in group footer box. The settings are applied, and the subtotals are now 
shown in each group’s footer.

9. Select the Sales Person Last Name field header on the report.

10. On the Design tab, in the Grouping & Totals group, click the Totals button and then 
select Count Records from the menu.

11. Change to Report view. The total number of records appears at the bottom of the 
report.

12. SAVE the report.

PAUSE. LEAVE the database and report open to use in the next exercise.
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CREATING A SUBFORM ON A REPORT
As you learned in Lesson 10, a subform is a convenient tool that allows you to view data from more 
than one table or query on the same form. Similarly, a subform can be inserted into a report and 
used in the same way to view data on a report. The primary report is called the main report, and 
the form within the report is called the subform. In this exercise, you create a subform on a report 
by dragging a preexisting form from the Navigation Pane to a report in Design view.

When working with a relational database, it is sometimes helpful to view data from more than 
one table or query on the same report. Subforms can be effectively used on reports to show data 
from tables or queries that have a one-to-many relationship—the main report shows data from 
the “one” side of the relationship and the subform shows the data from the “many” side of the re-
lationship. For example, you can view the current contract data salespeople have with their clients 
(one side), while also viewing related estimated future contract amounts (many side) on the same 
report.

You can also filter the records that appear in a subform in the same way you would filter a form.

You can use the Subreport Wizard located in the Controls group on the Design tab to create a new 
subform to add to a report and include which fields you want to appear. The Wizard can also be 
used to include the fields from a preexisting form to use as a subform in a report or to establish a 
relationship between a report and a subform. 

If you already have a preexisting form in your database, you can simply drag the form object from 
the Navigation Pane to an appropriate section of the main report in Design view. For best results, 
all relationships should be established first. This enables Access to automatically create the links 
between subforms and main reports to effectively show related data. 

Take Note A subreport can also be added to a report in a similar way and serves a similar function as a 
subform. The determination to add a subform or subreport to a report depends mainly on what 
form or report objects you already have in your database and what additional data you want to 
communicate.

STEP BY STEP Create a Subform on a Report

GET READY. USE the Messenger-final database and Corporate Sales report that are open 
from the previous exercise.

1. Change to Design view.

2. Click and drag the Future Period Contract Projections form object from the Navigation 
Pane to the Report Detail section under the Company Name and Contract Amount 
controls. Your screen should look similar to Figure 11-10. 
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3. Change to Report View to view the Report and related subform, and cycle through the 
two records in the top subform using the record navigation buttons on the subform.

4. SAVE and CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING THE PRINT LAYOUT 
Reports are often created so records can be appropriately arranged, formatted, and shared with 
colleagues either by being displayed onscreen or printed. You can print a report from any view: 
Report, Layout, Design, or Print Preview. Print Preview displays a report as it will look when 
printed. You can display the Print Preview tab by choosing the Print Preview option on the File 
tab’s Print menu. It is helpful to preview a report before printing it. This allows you to make ad-
justments to the layout before clicking the Print button so you can make sure the report prints 
the way you want. The settings that you choose will be saved with the report, so you won’t have to 
select the same settings each time you print.

When you are confident your report will print correctly, you can click the Print button. The Print 
dialog box lets you select the printer, choose the number of copies you want to print, and specify 
which pages you want to print. If you don’t need to preview a report, you can skip Print Preview 
and then select Print or Quick Print on the File tab’s Print menu. The Print command displays 
the Print dialog box, but the Quick Print command sends the report directly to the printer. The 
report’s records are printed once you send the report to the printer. 

Using Print Preview to Create a Print Layout
The Print Preview tab has commands for printing, changing the page size and layout, zooming in 
or out to view the pages, and exporting report data to a variety of formats like Excel and Word. 
When you are finished previewing a report, you can click the Close Print Preview button to leave 
the view. In this exercise, you use Print Preview to create the print layout of a report.

Figure 11-10

Report and subform
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STEP BY STEP Create the Print Layout

GET READY. USE the Messenger-final database that is open from the previous exercise.

1. Right-click the Corporate Sales report in the Navigation Pane and then select Copy 
from the shortcut menu that appears.

2. Right-click in a blank area in the Navigation Pane and then select Paste from the menu. 
The Paste As dialog box appears.

3. In the Paste As dialog box, replace the name of the report in the Report Name field with 
Sales by Salesperson and then click OK.

4. Double-click the Sales by Salesperson report in the Navigation pane and then change 
to Design view. You want to remove the subform from the report and keep only the 
sales related to each salesperson.

5. In the Detail section, click the Future Period Contract Projections subform, as shown in 
Figure 11-11, and then press Delete on the keyboard to delete the subform.

6. On the Home tab, in the Views group, click the lower half of the View button and then 
select Print Preview from the menu. The report is displayed in Print Preview. Notice the 
large area of blank space between company names in the detail section.

7. On the Print Preview tab, in the Zoom group, click the Two Pages button. The first 
two pages of the report are displayed on the screen, as shown in Figure 11-12. Notice 
the second page has no report data on it. You need to correct these issues in Report 
Design view to ensure the report print layout is appropriate before printing. 

Figure 11-11

Future Period Contract Projec-
tions subform
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8. On the Print Preview tab, click the Close Print Preview button to return to Report 
Design view.

9. Click the Error Checking Options button next to the Report Header section title to view 
the Error Checking Options menu, as shown in Figure 11-13. Notice the menu text that 
states Report width is greater than page width. Click the Remove Extra Report Space 
menu option. The report’s width is automatically adjusted; however, the issue is not 
entirely corrected and the Error Checking Option button still appears. 

Error Checking Options 
button and menu 

10. Scroll to the bottom of the report, if necessary, and place the pointer over the top of the 
Sales Person Last Name footer until it turns into a two-headed vertical pointer. Click 
and drag the Sales Person Last Name Footer and place it below the Company Name 
and Contract Amount controls, as shown in Figure 11-14. This removes the excess 
blank space between company names in the Detail section.

Figure 11-12

Print Preview of Two Pages

Figure 11-13

Error Checking Options button 
and menu
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11. Change to Print Preview view. Notice the report layout still appears on two pages. The 
Remove Extra Report Space didn’t entirely fix the issue. The page number control is 
exceeding the width of the page in Design view as evident by the page numbering text 
appearing in the footer section of the second page. On the Print Preview tab, in the 
Page Layout group, click the Landscape button. The report is displayed in landscape 
orientation and the formatting appears correctly. 

12. On the Print Preview tab, in the Page Layout group, click the Portrait button. The report 
is displayed in portrait orientation again. 

13. On the Print Preview tab, in the Page Layout group, click the Page Setup button. The 
Page Setup dialog box appears. Notice it contains many of the same options that are 
available in the Page Layout group but also includes additional options and details that 
can be modified.

14. On the Print Options tab, change the Left margin from 0.333 to 0.25 (see Figure 11-15). 

15. Click OK. Notice that all the report data now fits and will print on two pages.

16. On the Print Preview tab, in the Zoom group, click the Zoom button arrow and then 
select 50% from the menu. 

Figure 11-14

Sales Person Last Name Footer

Figure 11-15

Page Setup dialog box
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17. Click the Close Print Preview button. You are back in Design view.

18. SAVE the report design and go back to Print Preview.

19. On the Print Preview tab, click the Print button. The Print dialog box appears. Click OK 
to print or click Cancel to close the dialog box. (Notice that you can access the Setup 
dialog box from here as well.)

20. CLOSE Print Preview and the report.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note You can add the Print Preview and/or the Quick Print command to the Quick Access Toolbar 
by clicking the Customize Quick Access Toolbar down arrow at the end of the toolbar and then 
selecting Print Preview or Quick Print from the menu.

USING THE LABEL WIZARD 
You can create labels for mailing, or other purposes, using the data in your Access databases. The 
Label Wizard helps you create a label-sized report that you can use to print labels. The Label 
Wizard asks you a series of questions about the labels you want and then creates the labels based 
on your answers. You can choose from a wide variety of sizes, including sizes to fit label sheets that 
you purchase at the office supply store or custom-created labels. 

Creating Labels Using the Label Wizard
You can create mailing labels or other types of labels from an Access table or query. Access allows 
you to choose the font name, font size, font weight, and text color for your labels. You can also 
choose to underline or italicize text in the label. The Sample box displays the choices you make. In 
this exercise, you use the Label Wizard to create labels.

You can select predefined label sizes that match popular manufacturer’s label sheets. These are 
listed by Product Number in the first Label Wizard screen. If you don’t know the manufacturer of 
your label sheets, you can choose a sheet with similar dimensions and with the correct number of 
labels across the sheet. If you don’t see the size you need, you can customize the size and create a 
new label using the Customize button.

As you add fields to the Prototype label, remember to use the Spacebar to add a space between 
fields and then press Enter to move to the next line. You can also type text directly in the Proto-
type label that you want to appear on each label.

You can sort the labels by one or more fields, such as zip code for bulk mailings. On the last Label 
Wizard screen, if you choose to see the labels as they will look when printed, they will be displayed 
in Print Preview. Choose Modify the label design to view the label report in Design view.

STEP BY STEP Use the Label Wizard

GET READY. USE the Messenger-final database that is open from the previous exercise.

1. Select the Clients table in the Navigation Pane.

2. On the Create tab, in the Reports group, click the Labels button. The first Label Wizard 
dialog box appears, as shown in Figure 11-16.

3. Scroll down in the Product Number box, select Avery USA 5160 and then click the Next 
button. The second Label Wizard dialog box appears.

4. Click the Font name: down arrow and scroll down to select Times New Roman. Notice 
the preview sample displays the new font.
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5. Click the Font size: down arrow and then select 9.

6. Click the Font weight: down arrow and then select Normal.

7. In the Text color section, click the Ellipses button to display the Color dialog box. 
Notice the options available, then click Cancel to close it.

8. Click the Next button. The third Label Wizard dialog box appears.

9. Select the Company Name field in the Available Fields list and then click the > button to 
place it on the Prototype label. Press Enter.

10. Type ATTN: and then press the Spacebar.

11. Select the Contact First Name field and then click the > button.

12. Press the Spacebar to insert a blank space between fields.

13. Select the Contact Last Name field and then click the > button. Press Enter.

Take Note Remember that you can also double-click the field to add it to the Prototype label section.

14. Select the Address field and then click the > button. Press Enter.

15. Select the City field and then click the > button. Type, (a comma) and then press the 
Spacebar.

16. Select the State field and then click the > button. Press the Spacebar.

17. Select the Zip field and then click the > button. Your screen should look similar to 
Figure 11-17.

Figure 11-16

First Label Wizard dialog box

Figure 11-17

Completed Prototype label
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18. Click Next. The fourth Label Wizard dialog box appears. It provides you with Sort by 
options.

19. Select the Zip field and then click the > button.

20. Click Next. The fifth Label Wizard dialog box appears.

21. Leave the default name, click the Modify the label design option button, and then click 
Finish. Your screen should look similar to Figure 11-18.

22. On the Home tab, in the Views group, click the lower half of the View button and then 
select Print Preview from the menu. Your screen should look similar to Figure 11-19.

23. Click the Print button. The Print dialog box appears. Click OK to print or click Cancel to 
close the dialog box. 

24. CLOSE Print Preview and then CLOSE the report.

STOP. CLOSE the database and then EXIT Access.

Figure 11-18

Label report

Figure 11-19

Label report in Print Preview
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Troubleshooting If Access displays a message warning you that some of your data may not be displayed, this 
means the controls on the label are too wide for the allotted space. If this happens, try reduc-
ing the size of the controls in Design view so that they fit in the space available for a single 
label or try reducing the page margins using Page Setup.

Take Note As an alternative to printing labels, you can print addresses directly onto envelopes. To do this, 
you will need to create a custom label instead of a predefined label and set the Label Type setting 
to Sheet Feed.

Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Group header a. A field that contains an aggregate function to calculate data

2. Group footer b. A field by which data is grouped

3. Grouping field c. The nested arrangement of groups in a report

4. Aggregate field d.  The section of a report where the name of a grouped field is 
displayed and printed

5. Grouping levels e.  The section of a report where the data in a group is 
summarized

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. Group headers take on the name of the group.

T F 2. The arrows at the end of a Group On row determine sort order.

T F 3. Average is an aggregate function.

T F 4. You must preview a report before you can print.

T F 5. Labels can be printed using reports.
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Projects

Project 11-1: Creating Address Labels, and Totaling and Printing Reports 

In this project, you need to send out confidential contract information to the authors in the Busi-
ness Books division. Create labels for the authors using the Author Contact Information table. You 
also need to finish the Book Sales report to show totals for Domestic and International Sales and 
make adjustments in Print Preview before printing.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Lucerne database and then SAVE it as Lucerne-final.

2. Select the Author Contact Information table in the Navigation Pane.

3. On the Create tab, in the Reports group, click the Labels button.

4. Select the C2242 label in the Product number box and then click Next.

5. Select Arial from the Font name menu and then select 9 from the Font size menu.

6. Click the Italic button and then click Next.

7. Type CONFIDENTIAL in all caps and then press Enter.

8. Type For Addressee Only and then press Enter.

9. Select the Author First Name field and then click the > button. Press the Spacebar.

10. Select the Author Last Name field and then click the > button. Press Enter.

11. Select the Author Address field and then click the > button. Press Enter.

12. Select the Author City field and then click the > button. Type , (a comma) and then 
press the Spacebar.

13. Select the Author State field and then click the > button. Press the Spacebar.

14. Select the Author Zip field and then click the > button.

15. Click Finish.

16. CLOSE the report.

17. Double-click the Book Sales report in the Navigation Pane to open it.

18. In Layout view, select the Domestic Sales field header.

19. On the Design tab, in the Grouping & Totals group, click the Totals button and then 
select Sum from the menu.

20. Select the International Sales field header.

21. On the Design tab, in the Grouping & Totals group, click the Totals button and then 
select Sum from the menu.

22. Select the Book Title field header.

23. On the Design tab, in the Grouping & Totals group, click the Totals button and then 
select Count Records from the menu.

24. On the Design tab, in the Views group, click the View menu and then select Print 
Preview from the menu.

25. On the Print Preview tab, change between Portrait and Landscape layout. Portrait looks 
better so click Portrait.

26. In the Page Size group, click the Margins button and then select Wide from the menu.

27. On the Print Preview tab, in the Zoom group, click the Zoom button arrow and then 
select Fit to Window.

28. SAVE the report.

29. On the Print Preview tab, in the Print group, click the Print button or click Cancel to 
close the dialog box.

30. CLOSE the report and then CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 11-2: Creating and Printing a Grouped Report 

In this project, your supervisor at Fourth Coffee asks you to create and print a report using the 
Monthly Sales by Store table. View the report in Print Preview to make sure the report is centered 
on the page before printing.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Fourth Coffee from the data files for this lesson and then SAVE the database as 
Fourth Coffee-final.

2. Select the Monthly Sales by Store table.

3. Use the Report Wizard to create a report that includes the Month, Store, and Sales 
fields.

4. Group by Store and create a Stepped layout.

5. Change to Design view to decrease the width of the Month and Sales columns and 
move the Sales column closer to the month.

6. Click the Group & Sort button to open the Group, Sort, and Total pane.

7. Click the Add a sort button and then select Sales from the menu. Sort from smallest to 
largest.

8. Change to Layout view.

9. Select the Sales column.

10. Click the Totals button and then select Sum from the menu.

11. SAVE the report.

12. Change to Print Preview.

13. Click the Zoom button arrow and then select Fit to Window.

14. Click the Margins button and then select Wide from the menu.

15. Click the Landscape button.

16. Click the Page Setup button.

17. Click the Print Options tab. In the Margins section, type 1 in the Top box, 1 in the 
Bottom box, 1.5 in the Left box, and 1.5 in the Right box.

18. Click OK.

19. Click the Print button and then click OK to print the report or click Cancel to close the 
dialog box.

20. SAVE and CLOSE the report.

STOP. CLOSE the database and then EXIT Access.
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Advanced Queries12
SKILL SUMMARY

Skills Exam Objective Objective Number

Creating crosstab queries Create a crosstab query. 3.1.2

Creating a subquery Add fields.
Remove fields.
Group data by using comparison operators.

3.2.2
3.2.3
3.3.4

Saving a filter as a query Set filtering criteria. 3.3.2

Creating action queries Create an action query. 3.1.4

Understanding advanced query 
modification

Group data by using comparison operators.
Create a multi-table query.
Add calculated fields.
Add calculated fields.
Format fields within queries. 
Group data by using arithmetic and logical operators.
Group and summarize data.

3.3.4
3.1.5
3.3.1
5.3.2
3.2.6
3.3.5
3.3.3

CREATING CROSSTAB QUERIES 
Queries are powerful tools that you use to retrieve exactly the data you need from your database, 
showing only the relevant records. Depending on the information you want to display, these 
advanced queries can help refine the results of your search or perform the actions you want. A 
crosstab query calculates a sum, average, count, or other type of total on records, and then groups 
the results by two types of information: one down the left side of the datasheet and the other across 
the top. When you summarize data using a crosstab query, you select values from specified fields 
or expressions as column headings so you can view data in a more compact format than with a 
select query.

Creating Crosstab Queries
A crosstab query is a special type of query that displays its results in a grid similar to an Excel 
worksheet. Crosstab queries summarize your values and then group them by two sets of facts: a set 
of row headers down the side and a set of column headers across the top. A crosstab query typically 
includes data from more than one table and always includes three types of data: the data used as 
row headings, the data used as column headings, and the values that you want to sum or other-
wise compute. A crosstab query does not always populate all the fields in the result set because the 
tables that you use in the query do not always contain values for every possible data point. In this 
exercise, you create a crosstab query.

The easiest way to create a crosstab query is to use the Crosstab Query Wizard. To run a crosstab 
query, double-click it in the Navigation Pane or click it and then press Enter. When you run a 
crosstab query, the results are displayed in Datasheet view.
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STEP BY STEP Create Crosstab Queries

GET READY. Before you begin these steps, make sure that your computer is on. Sign on, if 
necessary, and start Access.

1. OPEN the Importers database from the data files for this lesson and then SAVE it as 
Importers-final.

2. On the Create tab, in the Queries group, click the Query Wizard button to display the 
New Query dialog box.

3. Click Crosstab Query Wizard and then click OK to display the Crosstab Query Wizard, 
shown in Figure 12-1.

4. Click Table: Used Cars Sold and then click Next to display the Select Fields screen.

5. In the Available Fields box, double-click Sold By to move it to the Selected Fields box 
and then click Next. The next screen appears, asking which values you want to use as 
column headings.

6. Click Date Sold and then click Next. The next screen appears, asking how you want to 
group your Date/Time column information.

7. Click Month and then click Next The next screen appears, asking you what number you 
want calculated for each column and row intersection.

8. In the Fields box, click Sales Price, and in the Functions box, click Sum, as shown in 
Figure 12-2. 

Figure 12-1

Crosstab Query Wizard, first 
screen

Figure 12-2

Crosstab Query Wizard, fifth 
screen
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9. Click Next to display the final screen. Keep the default name (Used Cars Sold_Crosstab) 
and selection (View the query).

10. Click Finish to display the results of the crosstab query, as shown in Figure 12-3.

 

Take Note A crosstab query does not always populate all the fields in the result set because the tables used do 
not always contain values for every possible data point.

11. CLOSE the Used Cars Sold_Crosstab query.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING A SUBQUERY 
You can use a subquery to limit the amount of data returned by a query. A subquery is a 
SELECT statement that is inside another select or action query. A SELECT statement is a 
Structured Query Language (SQL) command that instructs the Microsoft Access database engine 
to return information from the database as a set of records. This type of statement invokes con-
ditional logic using expressions that evaluate to true or false; if true, Access returns a result that 
meets the condition that you have specified; if false, Access can return a different result depending 
on what you’ve specified. For example, you can use a conditional expression to create a new field 
that displays an adjusted salary with a 3% bonus for all employees who had annual sales revenue 
of $50,000 or more and display a message like “Not Bonus Eligible” for everyone else. The data 
that appears after the expression can be communicated on reports to provide useful information 
to employees who make decisions in your organization.

At a minimum, the syntax for a SELECT statement is:

SELECT fields FROM table

You can use an asterisk (*) to select all the fields in a table. The following example selects all the 
fields in the Inventory table:

SELECT * FROM Inventory

Figure 12-3

Crosstab query results
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You can use clauses such as WHERE and ORDER BY in a SELECT statement to restrict and 
organize your returned data. Table 12-1 shows some SELECT statements and the results that are 
returned.

SELECT statement Result

SELECT [FirstName], [LastName] FROM 
[Employees] WHERE [LastName] = “Cooper”;

Displays the values in the FirstName and LastName 
fields for employees whose last name is Cooper.

SELECT [ProductID], [ProductName] FROM 
[Products] WHERE [CategoryID] = Forms. 
[New Products].[CategoryID];

Displays the values for ProductID and ProductName 
in the Products table for records in which the 
CategoryID value matches the CategoryID value 
specified in an open New Products form.
Note: “Forms.[New Products].[Category ID]” 
references the New Products form and the Category-
ID field on the form in case a New Products table and 
field also exist. The “.” character is used to substanti-
ate these form and field relationships.

SELECT Avg([ExtendedPrice]) AS [Average 
Extended Price] FROM [Order Details 
Extended] WHERE [ExtendedPrice] > 1000;

Displays the average extended price of orders for 
which the value in ExtendedPrice field is more than 
1,000 in a field named Average Extended Price.

SELECT [CategoryID], Count([ProductID]) AS 
[CountOfProductID] FROM [Products] 
GROUP BY [CategoryID] HAVING 
Count([ProductID]) > 10;

Displays the total number of products for categories 
with more than 10 products in a field named 
CountOfProductID.

You can enter a SELECT statement in a field or criteria cell in Design view. If you need more 
space in which to enter the SELECT statement in a field or criteria cell, press Shift+F2 and enter 
the statement in the Zoom box. You can see the entire SQL statement by changing to SQL view.

In a subquery, you use a SELECT statement to provide a set of one or more specific values to eval-
uate in the WHERE or HAVING clause expression. A subquery has three parts:

• Comparison: An expression and a comparison operator that compares the expression with the 
results of the subquery

• Expression: An expression for which the result set of the subquery is searched
• Sqlstatement: A SELECT statement, following the same format and rules as any other SE-

LECT statement. It must be enclosed in parentheses.

Creating a Subquery
In this exercise, you create a subquery that returns only the records from the Inventory table whose 
asking price is equal to or greater than the average asking price. You also add, remove, and reposi-
tion fields while working within the query design grid.

Subqueries are created in Design view. Using the Show Table dialog box, you first need to select 
the table that contains the desired information. This will add the table window, which contains 
the table’s field list, to Design view. You can then easily add fields from the table window to the 
design grid at the bottom of the screen by either double-clicking the field name or by clicking and 
dragging the field to the query design grid. You can remove fields from the query design grid by 
moving the mouse pointer above the field name you want to remove until the pointer changes to 
a bold down arrow, clicking, and then pressing Delete on the keyboard, or by clicking the Delete 
Columns button in the Query Setup group on the Design tab. You can rearrange fields on the grid 
by moving the mouse pointer above the field you want to move until the pointer changes to a bold 
down arrow, and then clicking and dragging the field to any position on the grid using the vertical 
placeholder bar that appears as a guide. 

Table 12-1

Select statements with 
returned results
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STEP BY STEP Create a Subquery

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design. The query design grid 
opens, and the Show Table dialog box appears, as shown in Figure 12-4.

Query design grid  

2. On the Tables tab, click Inventory, click Add, and then click Close. The table field list 
appears as a window in the upper section of the query design grid.

3. In the list of table fields, double-click Year, Make, Model, Trim, and AskingPrice to add 
those fields to the design grid at the bottom of the page, as shown in Figure 12-5.

Fields added to the query design grid Table field list

Figure 12-4

The query design grid and 
Show Table dialog box

Figure 12-5

Fields added to design grid
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4.  Move the insertion point above the Trim field on the design grid until it turns into a 
bold down arrow. Click to select and highlight the Trim column.

5. Press the Delete key on the keyboard and the Trim column is deleted. The AskingPrice 
field moves to the left to replace the Trim column. 

6. Move the insertion point above the Model field on the design grid until it turns into a 
bold down arrow. Click to select and highlight the Model column.

7. On the Design tab, in the Query Setup group, click the Delete Columns button. The 
Model column is deleted.

8. In the table field list in the Inventory table window, double-click the Model field to add 
it back to the query design grid as the last column.

9. Move the insertion point above the Model field on the design grid until it turns into 
a bold down arrow. Click to select and highlight the Model column. Click and hold 
the mouse button down and drag the Model field to the left until the black vertical 
placeholder bar is positioned between the Make and AskingPrice fields and then 
release the mouse button. Your screen should resemble Figure 12-6.

10. Place the insertion point in the Criteria row of the AskingPrice field and then press 
Shift+F2 to display the Zoom dialog box.

Take Note The Zoom dialog box is used to create a larger workspace to help you focus on expressions and 
limit typing errors.

11. Type the following expression in the Zoom dialog box, as shown in Figure 12-7, to have 
the query eventually return all car makes that have an asking price greater or equal to 
the average asking price for all car makes:
>=(SELECT Avg(AskingPrice) FROM Inventory WHERE Make = Inventory.Make)

Take Note Because you are already working inside the Inventory table, the reference in the expression to the 
Inventory table preceding the Make field can be omitted and the expression can also be construct-
ed as follows: >=(SELECT Avg(AskingPrice) FROM Inventory WHERE Make = Make)

12. Click OK to insert the expression in the Criteria row of the AskingPrice field.

13. On the Design tab, in the Results group, click the lower half of the View button and 
then click SQL View to see the entire expression, as shown in Figure 12-8.

Figure 12-6

Query design grid

Figure 12-7

Zoom dialog box with 
expression
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14. On the Design tab, in the Results group, click Run. The query results are displayed, as 
shown in Figure 12-9.

15. Click the File tab and then click Save.

16. In the Save As dialog box, type Subquery as the query name and then click OK.

17. CLOSE the Subquery query.

PAUSE. LEAVE the database open to use in the next exercise.

SAVING A FILTER AS A QUERY 
A filter can be saved as a query so it can be run again anytime you want. If you often work with 
certain filters, you might want to save these filters so you don’t waste time defining them each 
time. You cannot save more than one filter for each table, query, or form; but you can save a filter 
as a query and then apply the query as a filter when and where you want.

Saving a Filter as a Query
In this exercise, you create a simple select query, filter it, and then save it.

When you want to save a filter as a query, you first use the Query Wizard to create a new query 
using all the fields from a table or another query. You then use the Filter by Form command to 
choose the data by which to filter the newly created query and then apply the filter. Next, on the 
Home tab, in the Sort & Filter group, you click the Advanced button and then click Advanced 
Filter/Sort. The new query design grid appears. It automatically includes all of the fields you’ve 
previously chosen to filter. On the Home tab, in the Sort & Filter group, click the Advanced but-
ton and then click Save As Query. Type a name for the query and then click OK.

To apply the query as a filter, click the Advanced button, select Load from Query (see Figure 12-
10), and then click it to display the Applicable Filter dialog box.

Figure 12-8

Subquery WHERE clause in 
SQL View 

Figure 12-9

Subquery results
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Only queries that are based on the same table or query as the form or datasheet will appear in the 
dialog box. Select the filter, click OK, and then apply the filter.

STEP BY STEP Save a Filter as a Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and then click OK.

3. In the Tables/Queries drop-down list, click Table: Used Cars Sold.

4. Click the >> button to move all the fields from the Available Fields box to the Selected 
Fields box and then click Next.

5. Click Next again to accept the default Detail and then click Finish to display a simple 
select query.

6. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Filter by Form.

7. In Filter by Form view, click the Year field down arrow and then select 2010, as shown in 
Figure 12-11. Click 2010.

8. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the 
filter. Only 2010 vehicles are shown in the results.

9. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Advanced Filter/Sort to display the new query filter design grid and tab, as shown in 
Figure 12-12.

Figure 12-10

Load from Query on the 
Advanced menu

Figure 12-11

Filter by Form
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New query filter tab 

New query design grid  

10. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Save As Query. The Save As Query dialog box appears.

11. Type Filter Query in the Query Name box and then click OK.

12. Click the Close button to close the Used Cars Sold QueryFilter1 query.

13. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to remove the 
filter.

14. Click the Close button to close the Used Cars Sold Query and save the changes when 
prompted. If another dialog box appears informing you that another user may have 
changed the data, click Yes.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING ACTION QUERIES 
An action query changes the data in its datasource or creates a new table. There are four types 
of action queries—append, delete, update, and make table—and except for the make table query, 
action queries make changes to the data in the tables on which they are based. 

As their name suggests, action queries make changes to the data in the tables they are based on 
(except for make table queries, which create new tables). There are four types of action queries:

• Append query: Adds the records in the query’s result set to the end of an existing table
• Delete query: Removes rows matching the criteria that you specify from one or more tables
• Update query: Changes a set of records according to criteria that you specify
• Make table query: Creates a new table and then creates records in it by copying records from 

an existing table

Figure 12-12

New query filter design grid 
and tab
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Changes made by action queries cannot be easily undone, so if you later decide you didn’t want to 
make those changes, usually you will have to restore the data from a backup copy. For this reason, 
you should always make sure you have a current backup of the underlying data before running an 
action query.

To minimize the risk involved in running an action query, you can first preview the data that 
will be acted upon by viewing the action query in Datasheet view before running it. When you 
are ready to run an action query, double-click it in the Navigation Pane or click it and then press 
Enter. Or, on the Design tab, in the Results group, click Run.

Creating an Append Query
An append query adds a set of records from one or more source tables (or queries) to one or 
more destination tables. Typically, the source and destination tables reside in the same database, 
but they don’t have to. For example, suppose you acquire some new customers and a database that 
contains a table of information about those customers. To avoid entering that new data manually, 
you can append it to the appropriate table in your database. In this exercise, you practice creating 
an append query to append inventory data to the Used Cars Sold.

You can also use append queries to append fields that are based on criteria. For example, you might 
want to append only the names and addresses of customers who have outstanding orders. Or you 
can use append queries to append records when some of the fields in one table don’t exist in the 
other table. For example, suppose that your Customers table has 10 fields, and the fields in the 
Clients table in another database match 8 of your 10 fields. You can use an append query to add 
only the data in the matching fields and ignore the others.

You cannot use append queries to change the data in individual fields in existing records. To do 
that type of task, you use an update query. You can only use append queries to add rows of data.

STEP BY STEP Create an Append Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Design button.

2. In the Show Table dialog box, double-click Inventory to add it to the upper section of 
the query design grid.

3. Click Close to close the Show Table dialog box.

4. In the list of table fields, double-click Year, Make, Model, and Asking Price to add those 
fields to the design grid. 

5. On the Design tab, in the Results group, click Run. Verify that the query returned the 
records that you want to append, as shown in Figure 12-13.
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Take Note If you need to add or remove fields from the query, go to Design view and double-click to add 
fields or select the fields that you don’t want and then press Delete to remove them from the query.

6. Right-click the document tab (titled Query1) for the open query and then choose Design 
View on the shortcut menu.

7. On the Design tab, in the Query Type group, click Append. The Append dialog box 
appears, as shown in Figure 12-14.

8. In the Table Name box, click the down arrow and then click Used Cars Sold. This is the 
table you want to append to. The Current Database option button should be selected.

9. Click OK. Access automatically adds the names of the destination fields that match the 
source field names to the Append To row in the design grid. Because the Asking Price 
field doesn’t have a match, Access leaves that field blank.

10. Click the blank field in the Append To row under the AskingPrice cell and then select 
Sales Price as the destination field, as shown in Figure 12-15.

Figure 12-13

Records to be appended

Figure 12-14

Append dialog box
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Sales Price chosen 

11. Right-click the document tab for the query and then choose Datasheet View to preview 
your changes.

12. Right-click the document tab for the query and then choose Design View.

13. On the Design tab, in the Results group, click Run. An alert message appears asking if 
you are sure you want to append the selected rows.

14. Click Yes.

15. Double-click the Used Cars Sold table in the Navigation Pane to open it and scroll down 
to see that the records from the Inventory table have been appended to the end, as 
shown in Figure 12-16.

Original records

Appended records

Figure 12-15

Source and destination fields 
matched

Figure 12-16

Results of append query
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16. CLOSE the Used Cars Sold table.

17. SAVE the query as Append Query.

18. CLOSE the Append Query query.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Make Table Query
A make table query is an action query that creates a new table and then creates records in it by 
copying records from an existing table. You use a make table query when you want to create a new 
table based on query criterion or criteria from an existing table. For example, you may work for 
a telecommunications provider and be provided with a table with thousands of cellphone service 
customers who live in various states. You may find it easier to work with a subset of customers from 
New York, New Jersey, and Connecticut who have had cellphone service for less than one year, 
since you need to contact and produce reports on only those individuals. A make table query can 
be advantageous in this example, especially if you want to ensure the data is stored in a separate 
table (for example, you want to export the data as a table to a new database). If you run a make 
table query with no criterion or criteria, Access will make a duplicate of the table titled after the 
name you provide. This is helpful when you need to copy the data in a table or to archive data, 
especially before you run an append, update, or delete query in case it amends the table data in 
a way that you don’t want. In this exercise, you practice creating a make table query to create a 
backup of a table.

STEP BY STEP Create a Make Table Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and then click OK.

3. In the Tables/Queries drop-down list, click Table: Sales Team.

4. Click the >> button to move all the fields from the Available Fields to the Selected Fields 
box and then click Next.

5. Click Finish to display a simple select query.

6. Right-click the Sales Team Query document tab and then choose Design View to 
display the query in Design view.

7. On the Design tab, in the Query Type group, click Make Table. The Make Table dialog 
box appears, as shown in Figure 12-17.

8. In the Table Name box, type Sales Team Backup. If it isn’t already selected, click 
Current Database and then click OK.

9. On the Design tab, in the Results group, click Run. An alert message appears asking if 
you are sure you want to create a new table with the selected records.

10. Click Yes. A new table named Sales Team Backup appears in the Navigation Pane.

11. Double-click Sales Team Backup: Table in the Navigation Pane to open the new table, 
as shown in Figure 12-18.

Figure 12-17

Make Table dialog box
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New table   

12. CLOSE the Sales Team Backup table and the Sales Team query. SAVE the changes 
when prompted.

PAUSE. LEAVE the database open to use in the next exercise.

Creating an Update Query
An update query is an action query that changes a set of records according to specified criteria. 
Use an update query when you need to add, change, or delete the data in one or more existing 
records. You can think of update queries as a powerful form of the Find and Replace dialog box. 
In this exercise, you practice making an Update Query.

When making an update query, you enter a select criterion and an update criterion. Unlike the 
Find and Replace dialog box, update queries can accept multiple criteria. You can use them to 
update a large number of records in one pass and to change records in more than one table at one 
time. You can also update the data in one table with data from another—as long as the data types 
for the source and destination fields match or are compatible.

To create an update query, first create or open a select query. On the Design tab, in the Query 
Type group, click Update. Access adds the Update To row in the query design grid. Locate the 
field that contains the data you want to change and then type your change criteria in the Update 
To row for that field.

You can use any valid expression in the Update To row. Table 12-2 shows some common valid 
expressions and explains how they change data.

Figure 12-18

New table
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Expression Result

“Chicago” In a Text field, sets a text value to Chicago.

#9/25/15# In a Date/Time field, changes a date value to 25-Sept-15.

Yes In a Yes/No field, changes a No value to Yes.

“PN” & [PartNumber] In the PartNumber field, adds “PN” to the beginning of 
each specified part number.

[UnitPrice] * [Quantity] Sets a Total field to the result of multiplying values in fields 
named UnitPrice and Quantity.

[Shipping] * 1.5 In the Shipping field, increases values by 50 percent.

DSum(“[Quantity] * [UnitPrice]”, “Order 
Details”, “[ProductID] =”& [ProductID])

Where the ProductID values in the current table match 
the ProductID values in a table named Order Details, this 
expression updates sales totals when specified in the 
SalesTotal field by multiplying the values in a field named 
Quantity by the values in a field named UnitPrice. The 
expression uses the DSum function because it can 
operate against more than one table and table field.

Left([PostalCode],5) In the PostalCode field, removes the rightmost characters 
in a text or numeric string and leaves the 5 leftmost 
characters.

IIf(IsNull([SalesPrice]), 0, [SalesPrice]) In the SalesPrice field, changes a null (unknown or 
undefined) value to a zero (0) value.

STEP BY STEP Create an Update Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and then click OK.

3. In the Tables/Queries drop-down list, click Table: Inventory.

4. Click the >> button to move all the fields from the Available Fields to the Selected Fields 
box.

5. Click Trim and then the < button to move it back to the Available Fields box. Click Color 
and then the < button to move it back to the Available Fields box. Click Next.

6. Click Next again and then click Finish to display a simple select query in Datasheet 
view.

7. Right-click the Inventory Query document tab and then choose Design View to display 
the query in Design view. 

8. Type 2012 in the Criteria row of the Year field.

9. On the Design tab, in the Query Type group, click Update. Access adds the Update To 
row in the query design grid, as shown in Figure 12-19.

Table 12-2

Expressions and how they 
change data
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Update To row added 

10. In the Update To row of the AskingPrice field, type [AskingPrice] + 500. The design grid 
should look similar to Figure 12-20.

Update criteria  

Figure 12-19

Select query in Design view

Figure 12-20

Select and update criterion
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11. On the Design tab, in the Results group, click Run. An alert message appears asking if 
you are sure you want to update the records.

12. Click Yes.

13. Right-click the Inventory Query document tab and then choose Datasheet View to 
display the update query results, as shown in Figure 12-21. The query contains fields 
that you don’t update, so Access does not display those fields in the results.

14. CLOSE the Inventory query and then SAVE the changes when prompted.

15. Double-click Inventory: Table in the Navigation Pane to open it. Notice that the asking 
price for all 2012 cars has been increased by $500.

16. CLOSE the Inventory table.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Delete Query
A delete query is an action query that removes rows matching the criteria that you specify from 
one or more tables. A delete query is used to delete entire records from a table, along with the key 
value that makes a record unique. Typically, delete queries are used only when you need to change 
or remove large amounts of data quickly. To remove a small number of records, open the table in 
Datasheet view, select the fields or rows that you want to delete, and then press Delete.

To create a delete query, first create or open a select query and add criteria to return the records 
you want to delete. On the Design tab, in the Query Type group, click Delete. Access changes the 
select query to a delete query, hides the Show row in the lower section of the design grid, and adds 
the Delete row. The word Where appears in the Delete row for all fields of the query.

When you click Run, Access prompts you to confirm the deletion. Click Yes to delete the data and 
then open the table to see that the records have been deleted.

Figure 12-21

Update query results
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STEP BY STEP Create a Delete Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Wizard.

2. In the New Query dialog box, click Simple Query Wizard and then click OK.

3. In the Tables/Queries drop-down list, click Table: Used Cars Sold.

4. Click the >> button to move all the fields from the Available Fields to the Selected Fields 
box and then click Next.

5. Click Next again.

6. Type Delete Query as the title and then click Finish to display the results of the simple 
select query.

7. Right-click the Delete Query document tab and then choose Design View to display the 
query in Design view.

8. Type <#3/31/2016# in the Criteria row of the Date Sold field, as shown in Figure 12-22.

9. On the Design tab, in the Results group, click Run to display the records to be deleted, 
as shown in Figure 12-23.

10. Right-click the Delete Query document tab and then choose Design View to display the 
query in Design view.

11. On the Design tab, in the Query Type group, click Delete. Access hides the Show row in 
the lower section of the design grid and adds the Delete row, as shown in Figure 12-24.

Figure 12-22

Date Sold criteria

Figure 12-23

Records to be deleted
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Delete row added  

12. On the Design tab, in the Results group, click Run. An alert message appears, asking if 
you are sure you want to delete the selected records.

13. Click Yes.

14. Double-click Used Cars Sold: Table in the Navigation Pane to open it. Notice that all 
the records for cars sold before March 31, 2016, have been deleted, as shown in Figure 
12-25.

15. CLOSE the Used Cars Sold table and Delete Query. SAVE the changes when prompted.

PAUSE. LEAVE the database open to use in the next exercise.

UNDERSTANDING ADVANCED QUERY MODIFICATION
After a query has been created, you can modify it in various ways to suit your purposes—by cre-
ating a join, creating calculated fields, or using aggregated functions.

Creating a Join 
Relational databases consist of tables that have logical relationships to each other. You use rela-
tionships to connect tables based on fields they have in common. A relationship between identical 
fields in different tables is represented by a join in Design view. When you include multiple tables 
in a query, you use joins to help you get the results you want. A join helps a query return only the 
records from each table you want to see based on how those tables are related to other tables in the 
query. When you add tables to a query, Access creates joins that are based on relationships that 

Figure 12-24

Delete row in design grid

Figure 12-25

Table with records deleted
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have been defined between the tables. You can manually create joins known as ad hoc relation-
ships in queries, even if they do not represent relationships that have already been defined. In this 
exercise, you create a join between tables.

Take Note If the relationship is one-to-many, Access displays a “1” above the join line to show which table is 
on the “one” side and an infinity symbol (∞) to show which table is on the “many” side.

The four basic types of joins are inner joins, outer joins, cross joins, and unequal joins. An 
inner join includes rows in the query only when the joined field matches records in both tables. 
Inner joins are the most common type of join. Most of the time, you don’t need to do anything 
to use an inner join. Access automatically creates inner joins if you add two tables to a query and 
those tables each have a field with the same name and the same or compatible data type and one 
of the join fields is a primary key.

An outer join includes all of the rows from one table in the query results and only those rows 
from the other table that match the join field in the first table. You create outer joins by modify-
ing inner joins. To create an outer join, double-click the line joining the tables to display the Join 
Properties dialog box. In the Join Properties dialog box, Option 1 represents an inner join. Option 
2 is a left outer join, where the query includes all of the rows from the table on the left and only 
those records from the table on the right that match the join field in the left table. Option 3 is a 
right outer join, where the query includes all of the rows from the table on the right and only 
those rows from the table on the left that match the join field in the right table.

Because some of the rows on one side of an outer join will not have corresponding rows from the 
other table, some of the fields returned in the query results from the other table will be empty 
when the rows do not correspond.

Take Note To tell which table is the left table or the right table in a given join, double-click the join to view 
the Join Properties dialog box.

In a cross join, each row from one table is combined with each row from another table. Any time 
you run a query that has tables that are not explicitly joined, a cross join is produced. Cross joins 
are usually unintentional, but there are cases where they can be useful. A cross join can be used if 
you want to examine every possible combination of rows between two tables or queries.

If you want to combine the rows of two sources of data based on field values that are not equal, you 
use an unequal join. Typically, unequal joins are based on either the greater than (>), less than (<), 
greater than or equal to (>=), or less than or equal to (<=) comparison operators. Unequal joins are 
not supported in Design view. If you wish to use them, you must do so in SQL view.

Troubleshooting If you create a join by mistake, for example, a join between two fields that have dissimilar data 
types, you can delete it. In the query design grid, click the join you want to remove and then 
press Delete.

STEP BY STEP Create a Join

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2. In the Show Table dialog box, double-click Sales Team and Used Cars Sold to add them 
to the design grid.

3. Click Close.

4. In the Sales Team field list, double-click E-mail Address.

5. In the Used Cars Sold field list, double-click Year, Make, Model, and Sales Price. Your 
screen should look similar to Figure 12-26.
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Join line  

6. Double-click the join line between the tables, indicating which fields are joined. The 
Join Properties dialog box opens, as shown in Figure 12-27.

Inner join option

Right outer  
join option

Left outer  
join option

 

7. Click the option button for option 2: and then click OK to create a left outer join.

8. On the Design tab, in the Results group, click Run.

9. The results of the query are displayed, as shown in Figure 12-28. Results include all of 
the rows from the first table and only those records from the second table that match 
the join field in the first table.

Figure 12-26

New query

Figure 12-27

Join Properties dialog box
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10. SAVE the query as Join Query and then CLOSE the query.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Calculated Query Field 
You can create a new field that displays the results of a calculation you define with an expression 
or that manipulates field values. A calculated field is a column in a query that results from 
an expression. For example, you can calculate a value; combine text values, such as first and last 
names; or format a portion of a date. You can also format the calculated field value by choosing 
an appropriate format in the Property Sheet pane. In this exercise, you use the Expression Builder 
to create a calculated query by subtracting two fields to determine a markup price in both U.S. 
dollars and Euros.

You can use expressions that perform arithmetic operations in calculated fields using basic operators 
(+,-,*,/) to add, subtract, multiply, and divide the values in two or more fields. You can also perform 
arithmetic operations on dates or use expressions that manipulate text. Table 12-3 shows examples of 
expressions and basic operators that you can use in calculated fields. The results can then be format-
ted by selecting the calculated field and then selecting a format in the Format box of the Property 
Sheet pane. For example, a number can be formatted in several different ways, including as Currency 
or Scientific values. The Property Sheet button in the Show/Hide group on the Design tab displays 
the Property Sheet pane.

Figure 12-28

Left outer join
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Expression Description

PrimeShip: [Ship] * 1.1 Creates a field called PrimeShip, and then displays shipping charges 
plus 10 percent in the field.

OrderAmount: [Quantity] * 
[Price]

Creates a field called OrderAmount, and then displays the product 
of the values in the Quantity and Price fields.

LeadTime: [RequiredDate] - 
[ShippedDate]

Creates a field called LeadTime, and then displays the difference (in 
number of days) between the values in the RequiredDate and 
ShippedDate fields.

TotalInventory: [UnitsInStock] + 
[UnitsOnOrder]

Creates a field called TotalInventory, and then displays the sum of 
the values in the UnitsInStock and UnitsOnOrder fields.

FullName: [FirstName] & “ “ & 
[LastName]

Creates a field called FullName that displays the values in the 
FirstName and LastName fields, separated by a space. (“&” is called 
the concatenation operator and is used to put strings together.)

Address2: [City] & “ “ & [Region] 
& “ “ & [PostalCode]

Creates a field called Address2 that displays the values in the City, 
Region, and PostalCode fields, separated by spaces. (“&” is called the 
concatenation operator and is used to put strings together.)

A well-designed database does not store simple calculated values in tables. For example, a table 
might store an employee’s hire date, but not how long she has worked for the company. If you 
know both today’s date and the employee’s date of hire, you can always calculate her employment 
length, so there is no need to store that in the table. Instead, you create a query that calculates 
and displays the pertinent value. The calculations are made every time you run the query, so if the 
underlying data changes, so do your calculated results.

To create a calculated field, first open or create a query and then change to Design view. In the 
Field row of the first blank column in the design grid, type the expression. You can use the Zoom 
box to access a larger screen area to help you enter the expression or, as you learned in Lesson 8, 
you can use the Expression Builder to easily select the elements of the expression (fields, operators, 
and built-in functions) from menus. To name the field, type a name followed by a colon before 
the expression. If you do not supply a name, Access uses a generic name for the field, for example, 
EXPR1. The string following the colon is the expression that supplies the values for each record. 
To see the SQL code, you can change to SQL View.

STEP BY STEP Create a Calculated Query Field

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2. In the Show Table dialog box, double-click Inventory to add the table to the design grid.

3. Click Close.

4. In the Inventory field list, double-click Year, Make, Model, AskingPrice, and 
TradeInValue.

5. Click the Field cell in the first blank column (to the right of the TradeInValue field) and 
then click the Builder button in the Query Setup group to open the Expression Builder 
dialog box.

6. In the blank area of the dialog box, type the following:
Markup: [AskingPrice]

7. In the Expression Elements category, click Operators. 

Table 12-3

Expressions that can be used 
in calculated fields
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8. In the Expression Values category, double-click the minus sign (-). The minus sign 
should appear in the expression and next to the AskingPrice field.

9. In the Expression Elements category, click the expand button next to Importers-final.
accdb. Tables, Queries, Forms, and Reports should appear under Importers-final.accdb.

10. In the Expression Elements category, click the expand button next to Tables to expand 
it. The available table names appear. Click Inventory. The available fields from the 
Inventory table should appear in the Expression Categories box. 

11. In the Expression Categories box, double-click TradeInValue; [Inventory]! 
[TradeInValue] should appear in the expression and next to the minus sign (-). Your 
screen should resemble Figure 12-29.

 

Take Note The part of the expression that reads [Inventory]![TradeInValue] specifies that the TradeInValue 
field originates from the Inventory table; however, even though Access automatically formats it 
this way, this expression format is not required since you’re already referencing the Inventory table 
in the Table row of the design grid.

12. Click OK.

13. Click the Field cell in the first blank column (to the right of the newly created calculated 
field) and then click the Builder button in the Query Setup group to open the 
Expression Builder dialog box.

14. In the blank area of the dialog box, type the following:
Markup in Euros: ([AskingPrice] - [TradeInValue]) * .92

15. Click OK. Make sure your cursor is still in the Markup in Euros cell.

16. On the Design tab, in the Show/Hide group, click the Property Sheet button. The 
Property Sheet pane for the Markup in Euros expression is displayed.

17. Click the empty cell next to the Format box, and then click the down arrow to display 
the Format menu, as shown in Figure 12-30. Select Euro from the options that appear 
to format the expression result as Euro. 

Figure 12-29

Expression Builder with 
Expression Elements expanded 
and expression complete
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Format box  

18. On the Design tab, in the Results group, click Run. The query with the new calculated 
Markup and Markup in Euros fields is displayed, as shown in Figure 12-31.

New field

Figure 12-30

Format menu

Figure 12-31

Calculated field query results
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19. SAVE the query as Calculated Query and then CLOSE the query.

20. Select the Calculated Query in the Navigation Pane.

21. On the Create tab, in the Reports group, click Report.

22. Select File, Print, and then click Print Preview. Change the layout to Landscape. 

23. Click OK on the dialog box about report width.

24. SAVE the report as Calculated Query and then CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Creating Aggregated Queries 
An aggregate function performs a calculation on a set of values and then returns a single val-
ue, so it “groups” data. You can add, count, or calculate other aggregate values and display them in 
a special row, called the Total row, which appears below the asterisk (*) row in Datasheet view. You 
can use a different aggregate function for each column and you can also choose not to summa-
rize a column. You can use aggregated functions to count the data returned by a query, calculate 
average values, and find the smallest, largest, earliest, and latest values using a feature called the 
Total row, which doesn’t alter the design of your query. You can work with the Total row in both 
query Design and query Datasheet views. In this exercise, you create an aggregated query using 
the Total row in both query Design and query Datasheet views. You will use both arithmetic and 
logical operators to group data.

Take Note The arithmetic operators were mentioned earlier. The logical operators are And, Eqv (equivalent), 
Not, Or, and Xor (exclusive or).

You can also apply aggregated functions in Design view where you have the ability to use the 
Group By function in the Total row on the design grid. The Group By function can be used in 
combination with other fields and aggregated functions. For example, if you’re managing a human 
resource database, you can group by employees’ gender and display the average salary per group.

The following aggregated functions are available in both Datasheet view and Design view:

• Count: Counts the number of items in a column
• Sum: Sums a column of numbers
• Average: Averages a column of numbers
• Maximum: Finds the highest value in a column
• Minimum: Finds the lowest value in a column
• Standard Deviation: Measures how widely values are dispersed from an average value (a 

mean) in a column
• Variance: Measures the statistical variance of all values in a column

The following additional aggregated functions are available in Design view:

• First: Finds the first value in a field
• Last: Finds the last value in a field
• Expression: Groups data based on an expression you can specify
• Where: Groups data based on criteria you can specify

Take Note Many of the aggregated functions work only on data fields set to specific data types. For example, 
if you are in a column that only displays text values, some functions—such as Sum or Average—
are not relevant, and are therefore not available.
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STEP BY STEP Create an Aggregated Query

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2. In the Show Table dialog box, double-click Inventory to add the table’s field list window 
to the design grid.

3. Click Close.

4. In the Inventory field list, double-click Year, Make, Model, Mileage, AskingPrice, and 
TradeInValue to add them to the design grid.

5. On the Design tab, in the Results group, click Run.

6. On the Home tab, in the Records group, click the Totals button. Scroll down, if 
necessary, to see the Total row at the bottom of the result set.

7. In the Total cell of the Year field, click the down arrow to display the menu and then 
click Count. Notice the cell displays 26, denoting 26 values (years) in the Year column.

8. Click the down arrow in the Total cell of the Mileage field and then click Average.

9. Click the down arrow in the Total cell of the AskingPrice field and then click Maximum.

10. Click the down arrow in the Total cell of the TradeInValue field and then click Sum. Your 
Total row should appear similar to Figure 12-32.

Count Average Maximum Sum  

Take Note You can’t see the formulas in the fields but you are using arithmetic operators to group this data. 

11. Change to Design view and remove the Model, Mileage, AskingPrice, and TradeInValue 
fields from the design grid. The Year and Make fields should be the only ones 
remaining on the grid.

12. On the Design tab, in the Show/Hide group, click the Totals button. A new Totals row 
should appear below the Table row on the design grid.

13. Click the Group By cell below the Make field cell and then click the down arrow to 
display the aggregate function menu.

14. Select the Count aggregate function from the menu, as shown in Figure 12-33. Click 
Count.

Figure 12-32

Aggregate function results
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Aggregate function menu in Total row

15. Change to Datasheet view. Your screen should resemble Figure 12-34. Notice the 
records in the Make field are grouped by Year and counted with the results appearing 
in a new column named CountOfMake. Also notice the Year field is grouped and each 
year remains counted as applied from the aggregate function we created previously in 
Datasheet view.

16. SAVE the query as Aggregated Query and then CLOSE the query.

PAUSE. LEAVE the database open for the next exercise.

STEP BY STEP Use Arithmetic and Logical Operators to Group Data

GET READY. USE the Importers-final database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2. In the Show Table dialog box, double-click Inventory to add the table’s field list window 
to the design grid.

3. Click Close.

4. In the Inventory field list, double-click Year, Make, Model, Mileage, AskingPrice, and 
TradeInValue to add them to the design grid.

5. Click the Field cell in the first blank column (to the right of the TradeInValue field) and 
then click the Builder button in the Query Setup group to open the Expression Builder 
dialog box.

6. In the blank area of the dialog box, type the following or use the Expression Elements 
to create the following formula, as shown in Figure 12-35:
Flag: ([AskingPrice]-[TradeInValue] <4000 And [Mileage] <20000) Or ([AskingPrice]-
[TradeInValue] >4000 And [Mileage] >20000)

Figure 12-33

Aggregate function menu in 
Design view

Figure 12-34

Aggregate function results
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Take Note In the expression, you will notice a combination of operators. The And and Or operators are logical 
operators, whereas the – is an arithmetic operator, and the < and > signs are comparison operators. 

7. This expression flags the cars that cost more than $4000 ([AskingPrice] - 
[TradeInValue]) and have a mileage of more than 20,000 miles ([Mileage]), and the cars 
that cost less than $4,000 and have less than 20,000 miles. Click OK.

8. On the Design tab, in the Show/Hide group, click the Totals button. A new Totals row 
should appear below the Table row on the design grid.

9. Select Sum from the Group By menu in the Total row of the Flag field.

10. Click the Field cell in the Total column of the new Flag field.

11. On the Design tab, in the Results group, click Run.

12. If the total row does not appear, click Totals on the Records tab of the Home tab, and 
then select Sum from the Flag fields Total drop down. The Flag expression field has a 
0 where the expression is false and a -1 where the expression is true. At the bottom of 
the Flag column, you see that there are 11 cars that fulfill the expression, as shown in 
Figure 12-36.

Figure 12-35

Logical and arithmetic 
operators in an expression

Figure 12-36

Cars that fulfill the expression
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13. To make it easier to see which cars are selected, select the Flag column, click Selection 
in the Sort & Filter group, and then select Does Not Equal 0. Now you can see all 
high-mileage cars that may be overpriced (since there are no low mileage cars that are 
underpriced).

14. SAVE the query as Mileage Query and then CLOSE the query. 

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1. A(n) ____________ removes rows matching the criteria you specify from one or more 
tables.

2. To minimize the risk of running an action query, you can first preview the data that will 
be acted upon by viewing the action query in ____________  view before running it.

3. You can use the Group By function in the ____________ row on the design grid in query 
Design view. 

4. A(n) ____________  query always includes three types of data: the data used as row 
headings, the data used as column headings, and the values that you want to sum or 
otherwise compute.

5. To be able to apply a filter when and where you want, save the filter as a(n) ___________ .

Multiple Choice
Select the best response for the following statements or questions.

1. Which type of query displays its results in a grid similar to an Excel worksheet?
a. Crosstab
b. Append
c. Aggregated
d. Subquery

2. Which of the following is not a type of join?
a. Inner join
b. Exterior join
c. Cross join
d. Unequal join

3. Which of the following is not an aggregated function?
a. Lowest
b. Sum
c. Average
d. Count

4. Which of the following is pressed to open the Zoom box, which provides you with 
more space in which to enter the SELECT statement in a field or criteria cell?
a. Shift+F2
b. Ctrl+2
c. Shift+Enter
d. Ctrl+Spacebar

5. To display the pane used to format a calculated value in query Design view, click the 
____________  button in the Show/Hide group on the Design tab of the Ribbon.
a. Undo
b. Property Sheet
c. Datasheet View
d. Totals
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Projects

Project 12-1: Creating a Calculated Query Field

In your job as a travel agent at Margie’s Travel, you are frequently asked the length of various trips. 
So that you don’t have to calculate it mentally, you will create a calculated field that will give you 
this information.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the M Travel database from the data files for this lesson and then SAVE the 
database as M Travel-final.

2. On the Create tab, in the Queries group, click Query Design.

3. In the Show Table dialog box, double-click Events to add the table to the design grid.

4. Click Close.

5. In the Inventory field list, double-click Event, StartDate, and EndDate to add the fields 
to the design grid.

6. Click the Field cell in the first blank column after EndDate and then press Shift+F2 to 
open the Zoom dialog box.

7. In the Zoom dialog box, type the following expression:
TripLength: [EndDate] - [StartDate]

8. Click OK.

9. On the Design tab, in the Results group, click Run. The query is displayed, with a new 
TripLength field calculating the number of days for each trip.

10. SAVE the query as Calculated Query and then CLOSE the query.

11. CLOSE the database.

PAUSE. LEAVE Access running for the next project.

Project 12-2: Saving a Filter as a Query and Creating a Subquery

As sales manager for Fourth Coffee, you frequently run the same filters on the database. Now that 
you have learned to save a filter as a query, you can save yourself some time. You are also interested 
in extracting specific information about monthly sales for all Fourth Coffee stores from the data-
base. Create a subquery to determine which months and corresponding stores have sales that are 
above average. 

GET READY. LAUNCH Access if it is not already running.

1. OPEN Fourth Coffee from the data files for this lesson and then SAVE the database as 
Fourth Coffee-final.

2. On the Create tab, in the Queries group, click the Query Wizard button.

3. In the New Query dialog box, click Simple Query Wizard and then click OK.

4. In the Tables/Queries drop-down list, click Table: Order Summary.

5. Click the >> button to move all the fields from the Available Fields to the Selected Fields 
box and then click Next.

6. Click Next again and then click Finish to display a simple select query.

7. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Filter by Form.

8. In the Filter by Form, click the down arrow in the Status field and then click Completed.

9. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the 
filter. The results are displayed.

10. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Advanced Filter/Sort to display the new query design grid.
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11. On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Save As Query. The Save As Query dialog box appears.

12. Type Filter Query in the Query Name box and then click OK.

13. CLOSE the Order Summary QueryFilter1 query.

14. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to remove the 
filter.

15. CLOSE the Order Summary Query and SAVE the changes when prompted. If presented 
with a message box stating the query has been changed, click Yes.

16. On the Create tab, in the Queries group, click Query Design.

17. Use the Show Table dialog box to add the Monthly Sales by Store table to the upper 
section of the query design grid and then close the Show Table dialog box.

18. Add the Month, Store, and Sales fields to the design grid.

19. Place the insertion point in the Criteria row of the Sales field and display the Expression 
Builder.

20. Type the following expression in the Expression Builder, using the available categories 
and menus:
> (SELECT AVG([Sales]) FROM [Monthly Sales by Store])

21. Click OK.

22. Use the Property Sheet pane to change the calculated field format to Euro.

23. On the Design tab, in the Results group, click Run to display the query results.

24. SAVE the query as Subquery and then CLOSE the query.

STOP. CLOSE the database and then EXIT Access.
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SKILL SUMMARY

Skills Exam Objective Objective Number

Creating a Chart Using the Chart Wizard Add report controls. 5.2.3

Formatting a Chart Modify data sources. 5.2.2

Saving a Database Object as Another File Type Save a query. 3.1.6

Printing a Database Object Print reports. 1.5.1

CREATING A CHART USING THE CHART WIZARD 
Charts are often used in the business world to give a visual representation of numeric data. Because 
a picture is worth a thousand words, charts play an important role in reports and presentations. In 
Access 2016, you can insert a chart into a new or existing form or report using the Chart control.

Creating a Chart Using the Chart Wizard
The Chart control lets you insert a chart into a new or existing report or form using a table or 
query as your data source. This allows you to insert a pictorial view of the data along with the 
numbers. Once a chart has been inserted, the Chart Wizard asks you questions about the chart 
you want and then creates the chart based on your answers. In this exercise, you will insert a chart 
into the Page Footer section of a report because it is a one-page report and it is helpful to show the 
data at the bottom of the page after the columnar data.

Take Note Charts and graphs are terms used synonymously in Microsoft Access. For example, the Chart 
control inserts a chart into reports or forms; however, a chart is referred to as a graph in Visual 
Basic for Applications (VBA) code.

A chart is a graphical representation of data. Although charts can contain various components 
used to help make data more meaningful, most are made up of two basic parts; the body and the 
legend. The chart body is the main area that displays the chart. The legend displays a list of 
the colors, shapes, or patterns used as categories in a chart.

Once a chart has been inserted into a report or form using the Chart control, the Chart Wizard 
asks you questions to quickly create a customized chart. Once you insert a chart, you may need to 
resize it later; you can do so by clicking and dragging the selection handles to increase or decrease 
the height or width.

You can also place the chart in the Detail section of the report and set the chart to change with 
each record by enabling this option within the Chart Wizard. This allows you to have a report that 
displays the record data and a chart for each record.

You can create 20 different charts using the Chart Wizard, including column, bar, area, line, XY 
scatter, pie, bubble, and doughnut charts.

Access makes it easy to delete a chart as well. Simply, right-click it in Design view and then choose 
Delete from the shortcut menu.
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STEP BY STEP Create a Chart

GET READY. Before you begin these steps, be sure to turn on and/or sign on to your 
computer and start Access.

1. OPEN Blue Yonder Airlines from the data files for this lesson and then SAVE the 
database as Blue Yonder Airlines-final.

2. Double-click the Income & Expenses report in the Navigation Pane to open it.

3. Change to Design view.

4. Expand the Page Footer section. On the Report Design Tools Design tab, in the Controls 
group, click the Chart button. The pointer changes to a plus sign with a chart icon.

5. Click in the upper-left corner of the Page Footer section, hold the mouse button, and 
drag to the lower-right corner to create a rectangular placeholder where the chart will 
be inserted, as shown in Figure 13-1.

Chart button

Draw a rectangle for the chart

6. Release the mouse button. The first Chart Wizard dialog box appears asking you which 
table or query you would like to use to create your chart.

7. Select the Income & Expenses Summary table as your data source and then click the 
Next button. The second Chart Wizard dialog box appears.

8. Click the >> button to move all the fields to the Fields for Chart box and then click the 
Next button. The third Chart Wizard dialog box appears, which shows you the chart 
type options.

9. Click the 3D Column Chart button—the second icon in the first row. Notice that the 
description of the chart type is displayed on the right, as shown in Figure 13-2.

Figure 13-1

Report in Design view
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10. Click the Next button. The fourth Chart Wizard dialog box appears.

11. Click and drag the Income field button to the upper left of the chart and drop on the 
SumofExpenses data list. Both the SumofExpenses and SumofIncome fields should be 
listed, as shown in Figure 13-3.

12. Click the Preview Chart button. The Sample Preview dialog box appears, displaying a 
sample of your chart.

13. Click the Close button. The Sample Preview dialog box closes.

14. Click the Next button. The fifth Chart Wizard dialog box appears. 

15. Click the down arrow in the Report Fields menu and then select <No Field> since you 
don’t want to display a chart for each record in the data source.

16. Click the down arrow in the Chart Fields menu and then select <No Field> again, since 
you don’t want to display a chart for each record in the data source.

17. Click the Next button. The sixth Chart Wizard dialog box appears

18. Type 2008-2017 Income and Expenses in the Title box.

Figure 13-2

Chart Wizard dialog box with 
3D Column Chart selected

Figure 13-3

Chart Wizard dialog box with 
the Income field moved

Clip art courtesy of Microsoft

Clip art courtesy of Microsoft
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19. Yes, display a legend should be selected. If not, select it and then click the Finish 
button. Access inserts your chart. Notice that Design view displays sample data and 
not the actual data from your chart.

20. Click the chart to select it.

21. On the Report Design Tools Design tab, in the Tools group, click the Property Sheet 
button, if necessary.

22. Click the Data tab of the Property Sheet. Click the down arrow at the end of the Enabled 
cell and then select Yes. This enables the chart to accurately display the associated 
table data.

23. CLOSE the Property Sheet.

24. Change to Report view.

Troubleshooting If your chart is not displaying correctly (for example, the text looks stretched), you need to in-
crease or decrease the width and/or height of the placeholder. In Design view, click the resize 
handles in the center of the vertical borders and drag to increase or decrease the size until the 
text looks right. Drag the resize handles on the horizontal borders to change the height. Then, 
change back to Report view to see the results.

25. On the Home tab, in the Records group, click the Refresh All button to ensure the chart 
displays the latest table data.

26. Scroll to the bottom of the report to view your chart, which should look similar to 
Figure 13-4.

 

27. SAVE the report.

Take Note When you try to save the report, you may see a dialog box that says, “The object is locked. Any 
changes you make will be discarded when the form is closed.” Click OK whenever you see this 
dialog box throughout this lesson.

PAUSE. LEAVE the report open to use in the next exercise.

Figure 13-4

Report with 3D bar chart

Clip art courtesy of Microsoft
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FORMATTING A CHART 
You can use Microsoft Graph to change the formatting of charts created with the Chart Wizard. 
You can change chart options such as how the title and labels are displayed and where you want 
the legend located. You can also change formatting options such as the color of the chart’s back-
ground and the color and size of the data blocks in the chart. 

After you create a chart using the Chart Wizard, you can edit it using Microsoft Graph, which 
is a component of Office 2016. To launch Microsoft Graph, double-click a chart in Design view. 
Microsoft Graph displays the chart and datasheet. You can choose commands from the menu bar 
or the toolbar.

After you make changes to the chart, it is important to save the changes using the Save command 
on the File menu. After you save a chart, Microsoft Graph closes and changes you back to Design 
view.

Changing Chart Options
The Chart Options dialog box has six tabs with options for changing the look and layout of a 
chart. You can access the Chart Options dialog box from the Chart menu or by right-clicking the 
white Chart Area and then choosing Chart Options from the shortcut menu. In this exercise, you 
will change chart options using Microsoft Graph.

STEP BY STEP Change Chart Options

GET READY. USE the Blue Yonder Airlines-final database and Income & Expenses report 
that are open from the previous exercise.

1. Change to Design view.

2. Double-click the chart. The Microsoft Graph software launches, displaying the chart in 
a view similar to Design view, as shown in Figure 13-5.

Chart Objects menu Menu bar WallsChart title Toolbar

Chart area Data seriesDatasheet  

Figure 13-5

Chart displayed in 
Microsoft Graph
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3. Click Chart on the menu bar and then select Chart Options from the menu that 
appears. The Chart Options dialog box appears, as shown in Figure 13-6.

4. Click the Axes tab to display the options on the tab.

5. Click the Value (Z) axis check box to remove the check mark. Notice that the values on 
the Z axis are removed.

6. Click the Value (Z) axis check box again to insert the check mark.

7. Click the Gridlines tab to display the options on the tab.

8. Select the Major gridlines check box in the Category (X) axis section. Notice that 
gridlines are added to the preview, as shown in Figure 13-7.

9. Click the Legend tab to display the options on the tab.

10. Click the Show legend check box to remove the check mark. Notice that the legend is 
removed from the chart.

11. Click the Show legend check box again to insert the check mark. The legend is 
displayed in the preview.

12. Click the Bottom option button to move the legend to the bottom of the chart.

13. Click the Data Labels tab to display the options on the tab.

Clip art courtesy of Microsoft

Figure 13-6

Titles tab on the Chart Options 
dialog box

Figure 13-7

Gridlines tab of the Chart 
Options dialog box

Clip art courtesy of Microsoft



Lesson 13 250

14. Click the Value check box to insert a check mark. Notice that values are added to the 
columns in the chart.

15. Click the Value check box again to remove the check mark.

16. Click the Data Table tab to display the options on the tab

17. Click the Show data table check box to insert a check mark. Notice that the datasheet is 
added to the bottom of the chart.

18. Click the Show data table check box again to remove the check mark.

19. Click OK.

20. Click the File menu and then select Save. The Microsoft Graph software closes and the 
report is changed back to Design view.

PAUSE. LEAVE the report open to use in the next exercise.

Take Note Microsoft Graph has its own Help system. To access it, double-click a chart to launch Microsoft 
Graph and choose Microsoft Graph Help from the Help menu or press F1.

Changing Format Options
Microsoft Graph makes it easy to format a chart. Each part of the chart is an independent object, 
so you can simply right-click the chart object that you want to change and choose Format [Chart 
Object] from the shortcut menu. A dialog box appears with the formatting choices available for 
that object. In this exercise, you will format the chart you have been creating.

If you prefer to use the menus, you can click on the chart object to select it or choose it from the 
Chart Objects list box on the toolbar. Once you have specified the object you want to change, 
click the Format menu and choose Selected [Chart Object] from the menu to launch the dialog 
box of available options.

STEP BY STEP Change Format Options

GET READY. USE the Blue Yonder Airlines-final database and Income & Expenses report 
that are open from the previous exercise.

1. In Design view, double-click the chart to open Microsoft Graph.

2. Click the Chart Area, the white background of the chart, to select it. The Chart Area 
should be displayed in the Chart Objects list box in the upper-left corner of the toolbar.

3. Click the Format menu and then click Selected Chart Area. The Format Chart Area 
dialog box appears.

4. Click the Fill Effects button. The Fill Effects dialog box appears.

5. Click the Horizontal option button in the Shading styles section and then click OK.

6. Click OK in the Format Chart Area dialog box. Notice the shading style of the chart 
background changes to your selection.

7. Right-click any of the purple Data Series columns in the chart to display the shortcut 
menu. Notice that Series “SumOfIncome” is displayed in the Chart Objects list box.

8. Choose Format Data Series from the shortcut menu. The Format Data Series dialog 
box appears.

9. Select the Green color (second row, fourth from the left) as shown in Figure 13-8.
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Green color selected

10. Click OK in the Format Data Series dialog box.

11. Right-click the gray grid background of the chart, called the Walls, and choose Format 
Walls from the shortcut menu.

12. Click the Fill Effects button.

13. Click the From center button in the Shading styles section and then click OK.

14. Click OK in the Format Walls dialog box.

15. Right-click the Legend and choose Format Legend from the shortcut menu. The Format 
Legend dialog box appears. Select the Font tab if it is not already displayed. The Font 
tab of the dialog box appears, as shown in Figure 13-9.

16. Select 12 in the Size: menu and then click OK. Notice the font size of the legend text has 
increased. 

17. Right-click on the left axis that shows the number of dollars and choose Format Axis.

18. Click the Number tab, select Currency from the Category section, and then click OK.

19. Click the File menu and then click Save. Change to Report view to view your changes.

20. SAVE the report.

PAUSE. LEAVE the report open to use in the next exercise.

Figure 13-8

Format Data Series dialog box

Figure 13-9

Font tab of the Format Legend 
dialog box

Clip art courtesy of Microsoft

Clip art courtesy of Microsoft
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Refreshing Data in a Chart
The Refresh All button can be a useful tool when working with charts. When you make a change 
to the data source of a chart, be sure to save the new data in the table or query. When you change 
back to the form or report containing your chart, click Refresh All to update the data in the chart 
with the modified data. In this exercise, you will make a change to a table record and then refresh 
the data in a chart to view the change.

STEP BY STEP Refresh Data in a Chart

GET READY. USE the Blue Yonder Airlines-final database and Income & Expenses report 
that are open from the previous exercise.

1. Double-click the Income & Expenses Summary table in the Navigation Pane to open it.

2. In the first row, in the Income column, select the data, type 9004523, and then press 
Enter].

3. SAVE and CLOSE the table.

4. Click the Income & Expenses report tab. Notice that the numbers in the report data and 
the numbers in the chart have not changed.

5. On the Home tab, in the Records group, click the Refresh All button. The data in the 
report and in the chart are updated.

6. SAVE the report.

PAUSE. LEAVE the report open to use in the next exercise.

CHANGING CHART TYPES 
Access provides many different chart types and variations of those chart types for you to choose 
from in the Chart Type dialog box. Access makes it easy to experiment with different configu-
rations before you decide on the chart that best displays the data you want to emphasize. In this 
exercise, you will change the type of chart with which you have been working.

Changing Chart Types
The key is to choose a chart that displays your data in a meaningful way. Often, you have a spe-
cific chart in mind that you want to use, but sometimes it requires experimentation, choosing and 
changing chart types until you get the results you want.

STEP BY STEP Change Chart Types

GET READY. USE the Blue Yonder Airlines-final database and Income & Expenses report 
that are open from the previous exercise.

1. Change to Design view.

2. Double-click the chart. Microsoft Graph opens.

3. Click the By Row button on the toolbar. The chart is changed to show all the expenses 
together and all the income together, as shown in Figure 13-10.
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By Row button By Column button Chart Type button

 

4. Click the By Column button on the toolbar to change it back to the original chart.

5. Click the Chart Type drop-down arrow in the toolbar and then select 3D Area Chart 
from the menu. The chart changes to an area chart.

6. Click the Chart menu and then click Chart Type. The Chart Type dialog box appears.

7. On the Standard Types tab, click Pie in the Chart type list. In the Chart sub-type section, 
click Pie with a 3D visual effect, the second icon on the first row, as shown in Figure 
13-11.

Figure 13-10

Microsoft Graph toolbar

Figure 13-11

Select the Pie with a 3D visual 
effect pie chart

Clip art courtesy of Microsoft

Clip art courtesy of Microsoft
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8. Click and hold the Press and Hold to View Sample button to see a preview of the chart.

9. Click the Custom Types tab.

10. Click Colored Lines in the Chart type: list and then click OK.

11. Click the File menu and then click Save. Your screen should resemble Figure 13-12.

12. Change to Report view to view your changes. 

13. SAVE and CLOSE the report.

PAUSE. LEAVE the database open to use in the next exercise.

SAVING A DATABASE OBJECT AS ANOTHER FILE TYPE 
Microsoft Access 2016 allows you to save database objects, such as tables, forms, and queries, as 
other types of objects using the Save Object As command. For example, you can save a table as 
a report. Although you can save tables, forms, and queries as at least one other type of database 
object, Access doesn’t allow you to save reports as other object types; however, you can save all 
database objects as Portable Document Format (PDF) or XML Paper Specification (XPS) file for-
mats. You might already be familiar with PDF files from documents you view on the Internet or 
share via emails. The PDF file format maintains the exact layout of the original file and can easily 
be shared. An alternative to PDF, the XPS file format preserves document formatting; can be 
easily shared, printed, and archived; and is more secure. The Save Object As command also gives 
you the option of saving a database object as a client object. Saving an object as a client object is 
used when you want to save a web-based Access object as one that can be accessed and modified 
in the Access application installed on your computer. 

Saving a database object as another file type allows you to share data with other users or repurpose 
the data in other ways. Since you can create Access objects to be used on the web, you can also 
save all web-based database objects as the same object of a different type called a client object. For 
example, you can save a web-based table object as a client table object type, but you cannot direct-
ly save the web-based table object as a form object until after it’s saved as a client table object. A 
client object is an object that can be accessed and modified in the Access application installed 
on your computer.

You can access the Save As menu by selecting the Save As command on the File tab. In this exer-
cise, you save a table object as a new query object.

Figure 13-12

Line chart in Report 
Design view
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STEP BY STEP Save a Database Object as Another File Type 

GET READY. USE the Blue Yonder Airlines-final database that is open from the previous 
exercise.

1. Double-click the Income & Expenses Summary table in the Navigation Pane to open it.

2. Click the File tab and then click the Save As tab to display the Save As menu. Click the 
Save Object As command in the File Types category, as shown in Figure 13-13.

 

3. Notice the Save Object As option is already highlighted in the Save the current 
database object category. Click the Save As button. The Save As dialog box appears.

4. Type Summary Query in the Save box.

5. Click the down arrow on the As menu and then select Query, as shown in Figure 13-14. 
Notice that you can also save this table as a duplicate table (for example, to back up a 
table), a Form, or a Report.

 

6. Click OK. The table object is saved as a query object and the new Summary Query 
appears in Datasheet view.

7. CLOSE the Summary Query.

8. Click the File tab and then click the Save As. 

9. Click the Save Object As command in the File Types category and then click Save As. 

10. Type Summary Report in the Save box.

11. Click the down arrow on the As menu, select Report, and then click OK.

12. The report opens. SAVE the report.

PAUSE. LEAVE the report open to use in the next exercise.

Figure 13-13

Save Object As command

Figure 13-14

Save As dialog box
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PRINTING A DATABASE OBJECT 
You are probably already familiar with printing various kinds of documents from your computer. 
Printing a database object uses the same print options and settings you use with other types of 
documents.

You can choose various printing options before sending your document to the printer, such as the 
number of copies, size of the paper, or the range of pages to print. In this exercise, you will learn 
about some of the options available in the Print dialog box when you print a database object.

You can print reports just by right-clicking the object in the Navigation Pane and choosing Print 
from the shortcut menu. An alternate way to print reports, and to print other objects like tables, 
queries, forms, or macros, is to use the Print tab on the File tab. The Print tab displays available 
print options that you can modify before you print an object. To print charts, you must open ei-
ther the form or report that contains the chart or the table that is its record source. Changes that 
you make in the Print dialog box will only be applied to that particular document.

Take Note When printing lengthy reports, you can choose other options, such as printing a range of pages, 
collating the pages, or printing multiple pages per sheet.

STEP BY STEP Print a Database Object

GET READY. USE the Blue Yonder Airlines-final database and Summary Report report that 
are open from the previous exercise.

1. Click the File tab and then click the Print tab on the menu. The Print tab displays 
available options.

2. Click the Print button. The Print dialog box appears. 

3. Click the Properties button. The Properties dialog box appears. The Properties dialog 
box differs depending on the type of printer you have. You can change the quality, 
paper, printing, and orientation options available for your printer in this dialog box. 
Click the Cancel button.

4. Click the Setup button. The Page Setup dialog box appears, as shown in Figure 13-15. 
Click the Cancel button.

Figure 13-15

Page Setup dialog box
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5. In the Copies section of the Print dialog box, click the up arrow in the Number of Copies 
menu to change the number of copies to 2.

6. Click OK to print two copies of the report, or click Cancel (if you choose not to Print).

7. CLOSE the report and table.

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Legend a.  Contains six tabs with options for changing the look 
and layout of a chart

2. Chart Options dialog box b.  A component of Access 2016 used to make changes 
to a chart created by the Chart Wizard

3. Refresh All button c.  Displays a list of the colors, shapes, or patterns used 
as categories in a chart

4. Microsoft Graph d.  Allows you to save objects as other file formats like 
PDF and XPS and as other database objects

5. Save Object As command  e. Updates the data in a chart

True/False
Circle T if the statement is true or F if the statement is false.

T F 1. The Chart Wizard is a control.

T F 2. A legend can be displayed only on the right side of a chart.

T F 3. The Refresh All button updates data in a chart with data modified in the 
underlying data source.

T F 4. You can save a table as a report.

T F 5. An Axis is a type of chart.
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Projects

Project 13-1: Creating a Chart and Changing the Chart Type

The City Power & Light human resources department is reviewing the salary budgets for the 
office. In this project, your supervisor asks you to create a pie chart within a report to show the 
distribution of funds for each employee. Then, you decide to create a variation of the pie chart that 
will more clearly show the salary amounts in relationship to each other.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the City Power & Light database and then SAVE the database as City Power & 
Light-final.

2. Double-click the Salary report in the Navigation Pane to open it and then change to 
Design view.

3. Click the Chart button and draw a large rectangle in the space provided in the Page 
Footer section. The Chart Wizard dialog box appears.

4. Click the Next button.

5. Move the Employee ID and Salary fields to the Fields for Chart list and then click Next.

6. Click the Pie chart button and then click Next.

7. Drag and drop the Salary field button to the data box that says SumofEmployee ID box. 
SumofEmployee ID is replaced with SumOfSalary

8. Drag and drop the Employee ID field button to the Series box. Series is replaced with 
Employee ID.

9. Click the Preview Chart button.

10. Click Close.

11. Click Finish. Resize the chart if necessary if the text is too large.

12. Click the Data tab of the Property Sheet and set the Enabled property to Yes.

13. Change to Report view.

14. Click the Refresh All button.

15. SAVE the Report.

16. Double-click the Salary report in the Navigation Pane to open it in Report view if it’s not 
already open.

17. Click the File tab and then click Save As.

18. Click the Save Object As button.

19. Click the Save As button.

20. Type Salary Line Chart in the “Save ’Salary’ to:” box and then click OK.

21. Change to Design view.

22. Double-click the chart to launch Microsoft Graph.

23. Click the Chart menu and then click Chart Type from the menu.

24. Click Line in the Standard types list.

25. In the Chart subtype list, if not already selected, click the Line with markers displayed 
at each data value button.

26. Click OK.

27. Click the Chart menu and then click Chart Options from the menu.

28. Click the Legend tab and then click the Bottom option button.

29. Click OK.

30. SAVE the chart and then view the chart in Report view.

31. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 13-2: Creating and Formatting an Expenses Chart

You created a chart representing the Income & Expenses Summary table for Blue Yonder Airlines 
earlier. Now you need to create a chart solely for the expenses.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Blue Yonder Airlines-final that you saved in an earlier exercise.

2. Double-click the Expenses Detail table in the Navigation Pane to open it.

3. Click the File tab and then click Save As.

4. Click the Save Object As button.

5. Click the Save As button.

6. Type Expenses Detail in the “Save ’Expenses Detail’ to:” box, select Report from the 
As menu, and then click OK.

7. Double-click the Expenses Detail report in the Navigation Pane to open it and then 
change to Design view. 

8. Expand the Page Footer section by moving the Report Footer section down.

9. Create a chart in the Page Footer section using the Expenses Detail table as the data 
source.

10. Move the Amount and Yr fields to the Fields for Chart list and then click Next.

11. Click the Doughnut chart type button and then click Next.

12. Drag and drop the Yr field button to the Axis box (where it says Series) and then click 
Next.

13. Select <No Field> in the Report Fields and Chart Fields drop-down boxes and then click 
Next.

14. Click Finish.

15. Click the Property Sheet button.

16. Click the Data tab of the Property Sheet and then change the Enabled cell to Yes.

17. View the chart in Report view.

18. Change to Design view and double-click the chart to launch Microsoft Graph.

19. Click the Chart menu and then select Chart Options from the menu.

20. Click the Data Labels tab and then select the Percentage check box.

21. Click OK.

22. SAVE the chart.

23. View the chart changes in Report view.

24. CLOSE the report.

STOP. CLOSE the database and then EXIT Access.



260

Importing and Exporting Data14
SKILL SUMMARY

Skills Exam Objective Objective Number

Importing Data Import data into tables.
Append records from external data.
Import tables from other databases.
Create a database by using import objects or data 
from other sources.
Create linked tables from external sources.

2.1.2
2.3.4
2.1.4
1.1.3

2.1.3

Exporting Data Export to alternate formats. 1.5.4

SOFTWARE ORIENTATION

External Data Tab

The External Data tab shown in Figure 14-1 contains commands that you will use to import and 
export data in various formats. When you import or export data, you can save that data and access 
it later using the Saved Imports and Saved Exports commands, respectively. 

Figure 14-1
External Data tab

IMPORTING DATA 
To store data from an external source in Access, you can import the data into a new or existing 
database. After you run an import operation, you can save the import settings for reuse. You can 
also link to data from an external source without actually maintaining a copy of the data in the 
database.

Importing Data from a Specific Source
You can import data from a variety of sources into an Access database—either an existing database 
or a new database. When you import data into a new database, a new table is created in that blank 
database. 

When you import data into an existing database, Access creates a copy of the data in a new or ex-
isting table without altering the source file. Before you start the import operation, decide whether 
you want to store the data in a new or existing table. If you choose to store the data in a new table, 
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Access creates a table and adds the imported data to this table. If a table with the specified name 
already exists, Access overwrites the contents of the table with the imported data. If you choose 
to add the data to an existing table, the imported data is appended to the specified Access table. 
In this exercise, you will import data from an Excel worksheet into a new Access table. You then 
import a table from another Access database into the current Access database as a new table.

You can also import data from other specific sources besides Excel, such as a SharePoint list, a 
Word file, another Access database, or a text file. The same general process is used for importing 
data, regardless of the source. On the External Data tab, in the Import & Link group, click the 
More button to see additional formats that you can import from or link to.

Take Note You can import only one Excel worksheet at a time during an import operation. To import data 
from multiple worksheets, repeat the import operation for each worksheet.

Before you import, you should always review the source data and make any necessary modifica-
tions, as described in Table 14-1.

Element Description

Number of columns You cannot import more than 255 source columns, because Access does not 
support more than 255 fields in a table.

Skipping columns and 
rows

It is good practice to include only the rows and columns that you want to 
import in the source worksheet or named range. Note that you cannot filter or 
skip rows during the import operation. If you choose to add the data to an 
existing table, you cannot skip columns during the import operation either.

Tabular format Ensure that the cells are in tabular format. If the worksheet or named range 
includes merged cells, the contents of the cell are placed in the field that 
corresponds to the leftmost column, and the other fields are left blank.

Blank columns, rows, 
and cells

Delete all unnecessary blank columns and blank rows in the worksheet or range. 
If the worksheet or range contains blank cells, try to add the missing data. If you 
are planning to append the records to an existing table, ensure that the 
corresponding field in the table accepts null (missing or unknown) values. A field 
will accept null values if its Required field property is set to No and its Validation 
Rule property setting does not prevent null values.

Error values If one or more cells in the worksheet or range contains error values, such as 
#NUM and #DIV, correct them before you start the import operation. If a 
source worksheet or range contains error values, Access places a null value in 
the corresponding fields in the table.

Data type Ensure that each source column contains the same type of data in every row. It 
is good practice to format each source column in Excel and assign a specific data 
format to each column before you start the import operation—especially if a 
column includes values of different data types.

First row If the first row in the worksheet or named range contains the names of the 
columns, you can specify that Access treat the data in the first row as field 
names during the import operation. If your source worksheet or range does not 
include the names, it is a good idea to add them to the source before you start 
the import operation. 

Take Note If you plan to append the data to an existing table, ensure that the name of each column exactly 
matches the name of the corresponding field. If the name of a column is different from the name 
of the corresponding field in the table, the import operation will fail. To see the names of the 
fields, open the table in Design view in Access.

Table 14-1

Source data elements



Lesson 14262

Troubleshooting Always close the file you want to import before beginning the import operation. Keeping the 
source file open can result in data conversion errors. After an import operation, you should 
review the contents and structure of the table to ensure that everything looks correct before 
you start using the table. If you see the message “An error occurred trying to import file,” the 
import operation failed. If the data imports and you find just a few missing values, you can 
add them directly to the table. However, if you find that entire columns or a large number of 
values are either missing or were not imported properly, use Access Help to troubleshoot the 
results and correct the problem in the source file. After you have corrected all known prob-
lems, repeat the import operation.

STEP BY STEP Import Data from Excel

GET READY. Before you begin these steps, be sure to turn on and/or sign on to your 
computer and LAUNCH Access.

1. OPEN the Tailspin database from the data files for this lesson and then SAVE the 
database as Tailspin-final.

2. On the External Data tab, in the Import & Link group, click Excel. The Get External Data 
– Excel Spreadsheet dialog box appears, as shown in Figure 14-2.

3. Click Browse to open the File Open dialog box to locate the source file.

4. Use the File Open dialog box to locate the New_Employees spreadsheet file and then 
click Open.

5. Notice the three options you have when importing data. Select the option button for 
Import the source data into a new table in the current database and then click OK. The 
Import Spreadsheet Wizard appears, as shown in Figure 14-3.

Figure 14-2

Get External Data – Excel 
Spreadsheet dialog box

Figure 14-3

Import Spreadsheet Wizard, 
first screen
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Take Note To create a new database using external data, you would follow these same steps but in Step 1, you 
would simply create a new blank database, save it with your desired filename, and then follow steps 
2-5 to import the data into the new database.

Take Note In the Get External Data – Excel Spreadsheet dialog box, Access also allows you to append a copy 
of the records to an existing table in the database. You can choose Append a copy of the records to 
the table and then select an available table from the drop-down list. 

6. Click Next to display the next screen and then select the First Row Contains Column 
Headings check box. Access uses these column headings to name the fields in the 
table.

7. Click Next to display the next screen where the wizard prompts you to review the field 
properties.

8. Click the ZIP column header to display the corresponding field properties.

9. Click the Data Type down arrow and then click Short Text, as shown in Figure 14-4.

Take Note Access reviews the first eight rows in each column to suggest the data type for the correspond-
ing field. If the column contains different types of values, the wizard suggests a data type that is 
compatible with all of the values in the column—usually the Short Text data type. Although you 
can choose a different data type, values that are not compatible with the chosen data type will be 
ignored or converted incorrectly during the import process.

10. Click Next to display the next screen, which is where you choose the primary key. Keep 
the default selection, which lets Access add the primary key.

11. Click Next. The final screen appears, which is where you decide where to import the 
table. In the Import to Table box, type New Employees, as shown in Figure 14-5.

Figure 14-4

Change field properties

Figure 14-5

Import Spreadsheet Wizard, 
final screen
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12. Click Finish and when the Save Import Steps prompt appears, click Close.

13. In the Navigation Pane, double-click the New Employees: Table to open the new table 
with imported data, as shown in Figure 14-6.

14. CLOSE the New Employees table.

PAUSE. LEAVE the database open to use in the next exercise.

STEP BY STEP Import Table Data from Another Access Database

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. On the External Data tab, in the Import & Link group, click Access. The Get External 
Data – Access Database dialog box appears. 

2. Click Browse to open the File Open dialog box.

3. Use the File Open dialog box to locate the Minute Insurance Access database file and 
then click Open.

4. In the Get External Data – Access Database dialog box, click OK. The Import Objects 
dialog box appears. Notice the Tables object tab is selected by default.

5. In the Import Objects dialog box, click Minute Employees, as shown in Figure 14-7, to 
select the table you wish to import. 

Take Note You can import a variety of Access database objects into another Access database. Use the objects 
tabs (Tables, Queries, Forms, Reports, Macros, and Modules) at the top of the Import Objects 
dialog box.

Figure 14-7

Import Objects dialog box

Figure 14-6

New table with imported data
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6. Click OK to return to the Get External Data – Access Database dialog box and then click 
Close. Notice the newly imported Minute Employees table appears in the Navigation 
Pane. 

7. In the Navigation Pane, double-click the Minute Employees: Table to open the new 
table with imported data.

8. CLOSE the Minute Employees table.

PAUSE. LEAVE the database open to use in the next exercise.

Linking to an External Data Source
By linking an Access database to data in another program, you can use the querying and reporting 
tools that Access provides without having to maintain a copy of the external data in your database. 
You can also link to other external data sources, such as linking tables in another Access database 
(although you cannot link to queries, forms, or reports), HTML documents, or text files. In this 
exercise, you will link to an Excel spreadsheet.

When you link to an Excel worksheet, Access creates a new table that is linked to the source cells, 
called a linked table. The table shows the data in the source worksheet, but it does not actually 
store the data in the database. Any changes you make to the source cells in Excel appear in the 
linked table. However, you cannot edit the contents or structure of the corresponding table in 
Access. If you want to add, edit, or delete data, you must make the changes in the source file.

Take Note If you don’t want to link to the entire worksheet, define a range in Excel that includes only the 
cells to which you want to link. To create a named range, select the cells, and then right-click and 
choose Define Name. In the New Name dialog box, type a name for the range and then click OK.

After linking, you should open the linked table and review the fields and data to ensure that you 
see the correct data in all the fields. If you see error values or incorrect data, use Access Help to 
troubleshoot the source data and then try linking again.

STEP BY STEP Link to an External Data Source

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. On the External Data tab, in the Import & Link group, click Excel to open the Get 
External Data – Excel Spreadsheet dialog box.

2. Click Browse to open the File Open dialog box.

3. Use the File Open dialog box to locate the Benefit_Providers spreadsheet file and then 
click Open.

4. Click Link to the data source by creating a linked table and then click OK. The Link 
Spreadsheet Wizard appears (which looks similar to Figure 14-3 shown earlier).

5. Click Next to display the next screen.

6. Select the First Row Contains Column Headings check box to use the first row of data 
as field names in the table.

7. Click Next to display the next screen.

8. In the Linked Table Name box, type Benefit_Providers.

9. Click Finish. A Link Spreadsheet Wizard message appears informing you that Access 
finished linking. 

10. Click OK.

Troubleshooting If the table with the name you specified already exists, you are asked if you want to overwrite 
the existing file. Click Yes if you want to overwrite the file; click No to specify a different file-
name.
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11. In the Navigation Pane, notice the linked Excel icon next to Benefit_Providers. Double-
click Benefit_Providers to open the new linked table, shown in Figure 14-8. Notice that 
there is not an Add New Field column because of the structure of a linked table. 

Excel icon  

12. Click the Close button on the Benefit_Providers tab to close the table. 

Troubleshooting If you don’t close this table, you will not be able to edit the data in the spreadsheet. You will 
get a “data is locked for editing” error message.

13. LAUNCH Excel and then OPEN the Benefit_Providers spreadsheet.

14. Type the following data in a new row, as shown in Figure 14-9.

Company: Litware, Inc.

Address: 866 Hickory Road

City: Wichita

State: KS

ZIP: 66013

Phone: 302-555-9897

Website: www.litwareinc.com

New data

15. SAVE and CLOSE the spreadsheet.

Figure 14-8

New linked table cannot be 
changed

Figure 14-9

New Excel data



Importing and Exporting Data 267

16. CLOSE Excel.

17. In the Navigation Pane of Access, double-click Benefit_Providers to open the linked 
table. Notice that the new row of data has been added, as shown in Figure 14-10.

New data

18. CLOSE the Benefit_Providers table.

PAUSE. LEAVE the database open to use in the next exercise.

SAVING AND RUNNING IMPORT SPECIFICATIONS 
Saving the details of an import operation as a specification allows you to repeat the operation at 
any time. A specification contains all the information Access needs to repeat an import or ex-
port operation without user input. When you run an import wizard, you can save the settings you 
used as a specification so that you can repeat the operation at any time without having to provide 
any additional input. 

A specification is flexible. For example, you can change the name of the source file or the destina-
tion file before you run the specification again. This way, you can use a single specification with 
several different source or destination files.

Take Note If you regularly repeat this saved operation, you can create an Outlook task that reminds you when 
it is time to perform this operation by clicking the Create Outlook Task check box in the import 
wizard.

To use a text file as a source file for importing, the contents of the file must be organized in such 
a way that the Import Wizard can divide the contents into a set of records (rows) and each record 
into a collection of fields (columns). Two types of text files that are organized for importing are 
delimited files and fixed-width files.

In a delimited file, each record appears on a separate line and the fields are separated by a single 
character, called the delimiter. The delimiter can be any character that does not appear in the 
field values, such as a tab, semicolon, comma, space, and so on. The following is an example of a 
comma-delimited file:

ID, Company Name, Employee Name, Position

1, Fourth Coffee, Lauren Halian, Sales Manager

Figure 14-10

New Excel data added to 
linked table
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2, Woodgrove Bank, Michael Damato, Vice President

3, Wingtip Toys, Karl Vogelmann, Owner

In a fixed-width file, each record appears on a separate line and the width of each field remains 
consistent across records. For example, the first field of every record is always 9 characters long, 
the second field of every record is always 14 characters long, and so on. If the actual length of a 
field’s value varies from record to record, the values that fall short of the required width must be 
padded with trailing space characters. The following is an example of a fixed-width text file where 
the first field is said to be 3 characters, the second field is said to be 15 characters, the third field is 
said to be 13 characters, the fourth field is said to be 12 characters, the fifth field is said to be 11 
characters, and the sixth field is said to be 11 characters:

ID CompanyName EmpFirstName EmpLastName PositionF1 PositionF2

1 Fourth Coffee Lauren Halian Sales Manager

2 Woodgrove Bank Michael Damato Vice President

3 Wingtip Toys Karl Vogelmann Owner

Saving Specifications
You can save an import or export operation involving any of the file formats supported in Access, 
but you cannot save the details of a linking operation or an operation where you export only a 
portion of a datasheet. In this exercise, you will import a text file and then save the import spec-
ifications.

STEP BY STEP Save Import Specifications

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. On the External Data tab, in the Import & Link group, click Text File to open the Get 
External Data – Text File dialog box.

2. Click Browse to open the File Open dialog box.

3. Use the File Open dialog box to locate the applicants text file and then click Open.

4. Click Import the source data into a new table in the current database and then click 
OK. The Import Text Wizard appears, as shown in Figure 14-11. Notice the Delimited 
option button is selected and the data preview of the file contains fields separated by 
commas. In this case, you will keep the delimited selection.

Figure 14-11

Import Text Wizard, first 
screen
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5. Click Next to display the next screen. Comma should be selected as the delimiter. 

6. Select the First Row Contains Field Names check box to use the first row of data as 
field names in the table.

7. Click Next to display the next screen where you can specify field information.

8. Click Next to accept the default settings and display the next screen where you can 
define a primary key. Leave the default selection that lets Access add the primary key.

9. Click Next to display the final screen.

10. Click Finish to accept the default table name. A Save Import Steps screen appears.

11. Select the Save import steps check box to display the specification details.

12. In the Description box, type Import text file with job applicant contact information, as 
shown in Figure 14-12.

13. Click Save Import.

14. In the Navigation Pane, double-click the Applicants: Table to open the new table with 
imported data.

15. CLOSE the Applicants table.

PAUSE. LEAVE the database open to use in the next exercise.

Running Import Specifications
To run a saved specification, on the External Data tab, in the Import & Link group, click Saved 
Imports. In the Manage Data Tasks dialog box, on the Saved Imports tab, click the specification 
that you want to run. In this exercise, you will run import specifications.

If you want to change the source file, click the path of the file to edit it. The new file you specify 
must satisfy all the requirements essential for successfully completing the operation.

Before you click Run, make sure that the source and destination files exist, that the source data is 
ready for importing, and that the operation will not accidentally overwrite any data in your des-
tination file. Do everything that you would do to ensure the success of a wizard-driven operation 
before running any saved specification and then click Run.

If you no longer need to perform a specific operation, you can delete the specification by selecting 
it and then clicking Delete.

Figure 14-12

Save Import Steps screen
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STEP BY STEP Run Import Specifications

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. On the External Data tab, in the Import & Link group, click Saved Imports to open the 
Manage Data Tasks dialog box.

2. Click the file path and edit it by changing the source file name to march_applicants.txt, 
as shown in Figure 14-13.

Edit file name

3. Click Run. A message appears asking if you want to overwrite the existing table.

4. Click Yes. A message appears confirming that all objects were successfully imported.

5. Click OK.

6. Click Close to close the Manage Data Tasks dialog box.

7. In the Navigation Pane, double-click the Applicants: Table to open the table. The 
existing data has been replaced with new imported data, as shown in Figure 14-14.

8. CLOSE the Applicants table.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 14-13

Changing the source file name

Figure 14-14

Table with new imported data
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EXPORTING DATA 
To use Access data in another program, you can use the various commands in the Export group of 
the External Data tab to export the selected object in the format you want. 

Exporting from a Table to Excel and Other Formats
When you export data from a table to Excel, Access creates a copy of the data and then stores the 
copy in an Excel worksheet. In this exercise, you will export data from an Access table to an Excel 
worksheet.

Besides exporting to Excel, you can also export data to other destinations, such as a SharePoint 
list, a Rich Text Format file, another Access database, a text file, an XML or HTML file, PDF or 
XPS files, or Email. The process for exporting data is similar, regardless of the destination. The 
Export group contains all the formats Access can export to. The More button on the Export group 
has even more exportable formats from which you can choose.

If the source object is a table or a query, decide whether you want to export the data with or with-
out its formatting. By default, Access exports table and query objects without formatting; all fields 
and records in the underlying object are exported and the Format property settings are ignored 
during the operation. You can also choose to export a table or query object with formatting; only 
the fields and records displayed in the current view are exported and the Format property settings 
are maintained.

If the source object is a form or report, you don’t have the option to export the data without its 
formatting since a form or report object contains, by definition, a formatted layout of fields.

Table 14-2 summarizes the options for creating or overwriting an Excel workbook.

Destination 
Workbook

Source Object Data Exported Result

Does not exist Table, query, form, or 
report

With (for tables, 
queries, forms, or 
reports) or 
without (for tables 
or queries) 
formatting

Workbook is created during the 
export operation.

Already exists Table or query (Forms 
and reports cannot be 
exported without 
their formatting)

Without format-
ting

The workbook is not overwritten. A 
new worksheet is added to the 
workbook and is given the name of 
the object from which the data is 
being exported. If a worksheet having 
that name already exists in the 
workbook, Access prompts you to 
either replace the contents of the 
corresponding worksheet or specify 
another name for the new sheet.

Already exists Table, query, form, or 
report

With formatting The workbook is overwritten by the 
exported data. All existing work-
sheets are removed, and a new work-
sheet having the same name as the 
exported object is created. The data 
in the Excel worksheet inherits the 
format settings of the source object.

Table 14-2 

Destination workbook options
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You can export a table, query, form, or report to Excel. You can only export one database object in 
a single export operation. However, you can merge the data in multiple worksheets in Excel after 
completing the individual export operations. The data is always added in a new worksheet. You 
cannot append the data to an existing worksheet.

STEP BY STEP Export from a Table to Excel and Other Formats

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. In the Navigation Pane, select the Part-Time Employees: Table.

2. On the External Data tab, in the Export group, click Excel. The Export - Excel 
Spreadsheet dialog box appears, as shown in Figure 14-15.

3. If you want to specify a different destination, click Browse to open the File Save dialog 
box. Choose a folder and then click Save.

4. Select the Export data with formatting and layout check box and then select the Open 
the destination file after the export operation is complete check box.

5. Click OK. Excel opens and the new worksheet with exported data is displayed, as 
shown in Figure 14-16.

Figure 14-15

Export - Excel Spreadsheet 
dialog box

Figure 14-16

Excel worksheet with exported 
data
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6. CLOSE the worksheet and then CLOSE Excel.

7. Go back to Access.

8. On the Save Export Steps screen, click Close.

9. In the Navigation Pane, select the Part-Time Employees: Table if it is not already 
selected.

10. Click PDF or XPS on the External Data tab. The Publish as PDF or XPS dialog box 
appears.

11. Select a location for the file and then click Publish. (Leave the default name Part-Time 
Employees.pdf.)

12. The table opens as a PDF or XPS. CLOSE the file and return to Access.

PAUSE. LEAVE the database open to use in the next exercise.

Exporting from a Query to Word
You can export data from an Access query to a variety of formats, just as you can export data from 
an Access table. In this exercise, you will export a query to Word.

You can export a table, query, form, or report to Word. When you export an object to Word, Ac-
cess creates a copy of the object’s data in a Microsoft Word Rich Text Format file (*.rtf), and the 
visible fields and records appear as a table, with the field names in the first row.

Take Note Pictures or attachments that are part of the source data are not exported to Word. Expressions are 
not exported either, but the results are.

When you export from Access to a Word document, the Export Wizard always exports formatted 
data and the data is always exported into a new Word file. You cannot append data to an existing 
Word document.

STEP BY STEP Export from a Query to Word

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. In the Navigation Pane, select the Part-Time Employees Query.

2. On the External Data tab, in the Export group, click the More button. On the menu that 
appears, click Word. The Export - RTF File dialog box appears.

3. If you want to specify a different destination, click Browse to open the File Save dialog 
box. Choose a folder and then click Save.

4. Select the Open the destination file after the export operation is complete check box.

5. Click OK. Word opens and the new document with exported data is displayed, as 
shown in Figure 14-17.
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6. CLOSE the document and then CLOSE Word.

7. Go back to Access.

8. On the Save Export Steps screen, click Close.

PAUSE. LEAVE the database open to use in the next exercise.

SAVING AND RUNNING EXPORT SPECIFICATIONS 
In the Export Wizard Save as box, type a name for the export specification. Optionally, type a 
description in the Description box. If you want to perform the operation at fixed intervals, such as 
weekly or monthly, select the Create Outlook Task check box. Doing this creates an Outlook task 
that lets you run the specification by clicking a button.

Once these details are saved, you can use the Saved Exports command in the Export group on the 
External Data tab on the Ribbon to repeat the operation. Once clicked, the Manage Data Tasks 
dialog box appears.

In the Manage Data Tasks dialog box, you can change the name of the specification, its descrip-
tion, and the path and file name of the destination file by clicking and making changes in the text 
box and then pressing Enter. Repeat an operation by clicking the specification and then clicking 
Run. If you are exporting data with formatting and layout, you are asked to choose the encoding 
to be used for saving the file. When the operation is complete, you will see a message that commu-
nicates the status of the operation.

Although you can export Access data in various formats, sometimes you might need to export data 
to a program that uses a file format that Access does not support. In that case, if the destination 
program can use text (*.txt) files, you can export your data as a text file and open the resulting 
file with the second program. When you export the contents of a table or query to a text file with 
formatting and layout, hyphens (-) and pipe characters (|) are used to organize the content in a 
grid in the text file. The records appear as rows, fields appear as columns, and field names appear 
in the first row.

When exporting without formatting or layout, the Export Wizard gives you the option of creating 
a delimited file or a fixed-width file.

Figure 14-17

Word document with exported 
data
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The choice you make usually depends on the system that works with the exported files. If users 
need to look at the data, a fixed-width file can be much easier to read than a delimited file.

Saving Export Specifications
After you have performed an export operation, you are given the opportunity to save it for future 
use. Saving the details helps you repeat the same export operation in the future without having to 
step through the wizard each time. In this exercise, you will export data from Access to a text file 
and then save the export specification. 

STEP BY STEP Save Export Specifications

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. In the Navigation Pane, select the New Employees: Table.

2. On the External Data tab, in the Export group, click Text File. The Export - Text File 
dialog box appears

3. If you want to specify a different destination, click Browse to open the File Save dialog 
box. Choose a folder and then click Save.

4. Select the Export data with formatting and layout check box and then select the Open 
the destination file after the export operation is complete check box.

5. Click OK. The Encode ‘New Employees’ As dialog box is displayed, as shown in Figure 
14-18.

6. Windows (default) should be selected. Click OK. Notepad opens and the new file with 
exported data is displayed, as shown in Figure 14-19.

 

7. CLOSE Notepad.

8. Go back to Access.

9. On the Save Export Steps screen, select the Save export steps check box to display the 
specification details.

10. In the Description box, type Export new employee information to a text file.

11. Click Save Export.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 14-18

Encode ‘New Employees’ As 
dialog box

Figure 14-19

Notepad with exported data
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Running Export Specifications
When you run the Export Wizard, you can save the operation as a specification for future use. In 
this exercise, you will run the export specifications you just saved.

STEP BY STEP Run Export Specifications

GET READY. USE the Tailspin-final database that is open from the previous exercise.

1. In the Navigation Pane, double-click the New Employees: Table to open it, if necessary.

2. Add another record with the following information:

First Name: Rachel

Last Name: Valdez

Address: 39 Vista Drive

City: Roanoke

State: VA

ZIP: 94510

Phone Number: 607.555.1218

3. CLOSE the table.

4. On the External Data tab, in the Export group, click Saved Exports to open the Manage 
Data Tasks dialog box.

5. Click the file path and edit it by changing the destination file name to New Employees2.
txt, as shown in Figure 14-20.

Edit file name

6. Click Run. Notepad opens and the new file with exported data is displayed.

7. Go back to Access. A message confirms that the export operation was successful.

8. Click OK and then click Close to close the Manage Data Tasks dialog box.

9. CLOSE Notepad.

STOP. CLOSE the database and then EXIT Access.

Figure 14-20

Edit destination file
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Knowledge Assessment

Fill in the Blank
Complete the following sentences by writing the correct word or words in the blanks provided.

1. When you link to an Excel worksheet, Access creates a new table, called a(n) 
___________ , that is linked to the source cells.

2. In a(n) ___________ file, each record appears on a separate line and the fields are 
separated by a single character.

3. In a(n) ___________ file, each record appears on a separate line and the width of each 
field remains consistent across records.

4. When you export the content of a table or query to a text file with ___________ and 
___________ , hyphens (-) and pipe characters (|) are used to organize the content in a 
grid.

5. When exporting to Excel, the data is always added in a new ___________.

Multiple Choice
Select the best response for the following statements or questions.

1. If you want to add, edit, or delete data in a linked table, you must make the changes in 
which of the following? 
a. First row of data
b. Access object
c. Field headers
d. Source file

2. You can save an import or export operation involving any of the file formats supported 
in Access, but you cannot save the details of which of the following?
a. Linking operation
b. Text file import operation
c. Query export operation
d. Fixed-width file

3. When you export an object to Word, Access creates which type of file?
a. MS-DOS text
b. Rich Text Format
c. HTML
d. Linked

4. Which of the following does Access do if you choose to store imported data in a new 
table?
a. It links the new table to an existing table.
b. It overwrites the data in the existing table.
c. It creates a table and adds the imported data to this table.
d. It gives you an error message.

5. Which of the following is an advantage of linking an Access database to data in another 
program?
a. Maintaining a copy of the external data in Access
b. Being able to use Access querying and reporting tools
c. Being able to edit the linked table in Access
d. Easily being able to change the structure of the Access table
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Projects

Project 14-1: Importing and Exporting Data 

In this project, you are the purchasing manager for Fourth Coffee and an associate has provided 
some information about exotic coffees that are being considered for the monthly coffee club. The 
data is in an Excel worksheet and will need to be imported into the database. Your supervisor also 
wants a list of customer information in a Word file. So you use the Customers table in the Access 
database to export the data to a Rich Text Format file.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Fourth Coffee database from the data files for this lesson and then SAVE the 
database as Fourth Coffee-final.

2. On the External Data tab, in the Import & Link group, click Excel to display the Get 
External Data – Excel Spreadsheet dialog box.

3. Click Browse to open the File Open dialog box.

4. Use the File Open dialog box to locate the Coffee_Exotic spreadsheet file and then click 
Open.

5. Click Import the source data into a new table in the current database and then click 
OK. The Import Spreadsheet Wizard appears.

6. Click Next to display the next screen.

7. Select the First Row Contains Column Headings check box if it is not already selected.

8. Click Next to display the next screen where the wizard prompts you to review the field 
properties.

9. Click the column headings to display the corresponding field properties.

10. Click Next to display the next screen.

11. Click Next to let Access add the primary key. The final screen appears.

12. In the Import to Table box, type Coffee_Exotic and then click Finish. When the Save 
Import Steps screen appears, click Close.

13. In the Navigation Pane, double-click the Coffee_Exotic: Table to open the new table 
with imported data.

14. CLOSE the Coffee_Exotic table.

15. In the Navigation Pane, select the Customers: Table.

16. On the External Data tab, in the Export group, click the More button. On the menu that 
appears, click Word to display the Export - RTF File dialog box.

17. If you want to specify a different destination, click Browse to open the File Save dialog 
box. Choose a folder and then click Save.

18. Select the Open the destination file after the export operation is complete check box.

19. Click OK. Word opens and the new file with exported data is displayed. (You may need 
to adjust the margins and columns and then change the orientation to layout to get the 
content to actually fit if you want to print the report.)

20. CLOSE the file and then CLOSE Word.

21. Go back to Access.

22. On the Save Export Steps screen, click Close.

23. CLOSE the database.

PAUSE. LEAVE Access open for the next project.
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Project 14-2: Exporting Data to a New Database

In this project, you are the manager at Southridge Video. You have created a new database to store 
information about new video games. You want to export the Games table to the new database. 
You have exported an Access table to other destinations, but not to another Access database. Use 
Access Help if you need more information.

GET READY. LAUNCH Access if it is not already running.

1. Create a new database called New Games-final.

2. CLOSE the New Games-final database.

3. OPEN Sale Games from the data files for this lesson and then SAVE the database as 
Sale Games-final.

4. On the External Data tab, in the Export group, click the Access button. The Export – 
Access Database dialog box appears.

5. Click Browse and navigate to the location where you saved the New Games-final 
database. Select it and then click Save.

6. Click OK. The Export dialog box appears.

7. Leave the default settings and then click OK.

8. Click Close in the Export -Access Database dialog box.

9. CLOSE the Sales Games-final database.

10. OPEN the New Games-final database, double-click the Games table to open it, and 
then verify that the data was successfully exported.

11. CLOSE the Games table.

12. On the External Data tab, in the Import & Link group, click Excel. The Get External Data 
– Excel Spreadsheet dialog box appears.

13. Click Browse and then open the Games to Add.xlsx spreadsheet in the data files for 
this lesson.

14. Select the Append a copy of the records to the table Games radio button and then click 
OK.

15. Click Next, click Finish, and then click Close. 

16. Double-click the Games table in the Navigation Pane to open it. Notice there are now 
more items in the table (two new NBA Live games and one new College Hoops game).

17. CLOSE the Games table. Click Yes if you’re asked to save it. 

STOP. CLOSE the database and then EXIT Access.
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Database Tools15 
SKILL SUMMARY

Skills Exam Objective Objective Number

Maintaining a Database Back up a database.
Recover data from backup.
Compact a database.
Repair a database.

1.4.3
1.4.6
1.4.1
1.4.2

Saving a Database as a Template Save a database as a template. 1.5.3

Encrypting a Database Encrypt a database with a password. 1.4.5

Configuring Database Options Set a form as the startup option. 1.3.3

Using Database Tools Split a database. 1.4.4

MAINTAINING A DATABASE 
You can perform some important database maintenance tasks by using the commands on the Info 
menu and Save As menu on the File tab. Although the commands available on these menus might 
not seem as important as the actual data in your database, these commands allow you to provide 
protection for all the data in the file, and that is important. You can use the options on the Info 
menu to compact and repair your database, set database properties, and protect your database 
using encryption. The options on the Save As menu let you save your database in other file formats 
and back up your database.

Backing Up a Database
After all the work you have put into a database, you start to depend on being able to access and 
update the data and the information in it on a regular basis. It is a good idea to create backup files 
of all your databases and back them up regularly to protect your work. A backup is a copy of a 
file. When you back up your database, you are essentially making another copy of the database 
that you can store on your computer, on a network drive, or in another safe location to prevent the 
loss of your data. In this exercise, you back up a database.

You can store a backup copy in the same place as your original file, such as on your computer. 
However, if something happened to your computer, both files would be affected. A better solution 
is to save a backup copy to a network drive or removable media that is stored in a different physical 
location. For example, some companies that maintain sensitive client data have elaborate process-
es in place to store backup copies on computers or other media in another part of the city or in 
another part of the country. If an entire office building is destroyed by fire or a city is involved in 
a natural disaster, the backup files containing client data are safe in another location. It is a good 
idea to consider the appropriate precautions needed for even a small company’s data.

When backing up a database, Access automatically adds the date to the filename. You can keep 
this filename as an identifier for the backup file or change the filename to something else. Just keep 
in mind that you need a new name or location so that you don’t overwrite your original file. In the 
Save In box, choose the location where you want to save the file.
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STEP BY STEP Back Up a Database

GET READY. Before you begin these steps, be sure to turn on and/or sign on to your 
computer and then start Access.

1. OPEN Fabrikam from the data files for this lesson and then SAVE the database as 
Fabrikam-final.

2. Click the File tab and then click Save As. The Save As menu appears, as shown in 
Figure 15-1.

Save As button Back Up Database option

3. In the Advanced category, click Back Up Database and then click the Save As 
button. The Save As dialog box appears, as shown in Figure 15-2. Notice that Access 
automatically adds the current date to the end of the filename.

Figure 15-1

Save As menu

Figure 15-2

Save As dialog box
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4. Click the Save button to accept the generated filename and save location. You could 
also navigate to an external drive to save the database to an external location to 
increase its physical security. You can recover the data by simply opening the database 
backup file you just created.

PAUSE. LEAVE the database open to use in the next exercise.

Saving as a Previous Version
Access 2016 allows you to save a database in a previous Access file format so that those using earlier 
versions of the software can use the database. When you save a database file—or any computer 
file—in an earlier file format, you’re maintaining backward compatibility. However, some features 
of Access 2016 cannot be converted into a file format prior to Access 2007. Access will alert you 
when this is the case, and you can always remove that feature in order to save the database as a 
previous version. Before you can save a database in a previous file format, you should open the 
database and make sure all objects are closed. In this exercise, you save an Access 2016 database as 
a previous version so a user who has an earlier version of Access can open your document without 
any difficulty.

When you save a new, blank database in Microsoft Access 2016, you are prompted to give it a 
filename. Although you may have created the database in Access 2016, it is saved in the Access 
2007–2016 Default database file format by default, which gives it the .accdb extension. The Access 
2007–2016 format is not readable by earlier versions of Access. If you need to share a database with 
others using earlier versions of the software, the Save As command allows you to save the database 
in the Access 2000 format or the Access 2002–2003 format, both of which have the extension 
.mdb. When you use the Save As command to save a database in an earlier format, it preserves the 
original database file in its native format and creates a copy in the format you choose.

STEP BY STEP Save as a Previous Version

GET READY. USE the Fabrikam-final database that is open from the previous exercise.

1. Click the File tab and then click Save As. The Save As menu appears.

2. In the Database File Types category, click Access 2002–2003 Database and then click 
the Save As button. The Save As dialog box appears. Notice that Microsoft Access 
Database (2002–2003) is displayed in the Save as type: box.

3. Type Fabrikam2002-2003 in the file name box.

4. Click the Save button. Notice the filename and format change is displayed in the title 
bar, as shown in Figure 15-3.

File format displayed in the title bar

Figure 15-3

Database saved in Access  
2002–2003 format

PAUSE. LEAVE the database open to use in the next exercise.

Take Note If an Access 2016 database file contains complex data, offline data, or attachments created in Ac-
cess 2013, you will not be able to save it in a format earlier than Access 2007.
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Compacting and Repairing a Database
The Compact and Repair command on the Info menu on the File tab optimizes files and fixes 
minor problems in the file structure that may result from normal, everyday use of a database 
file. In this exercise, you compact and repair a database.

As records or objects in a database are deleted, the empty space within the file might not be re-
placed right away, leaving the file fragmented or with large empty spaces within the file structure. 
In databases with many records and objects, these issues can affect the database’s performance 
over time. In the same way, minor errors can occur in any file, especially when it is shared by many 
different users on a network drive. Using the Compact and Repair command on a regular basis 
will help optimize the file and repair minor problems before they become major ones.

Take Note Before you use this command on a shared file, make sure no one else has the file open.

STEP BY STEP Compact and Repair a Database

GET READY. USE the Fabrikam2002-2003 database that is open from the previous exercise.

1. Click the File tab and then click Info (if the Info menu doesn’t already appear). Select 
Compact & Repair Database on the Info menu that appears, as shown in Figure 15-4. 
Click Compact & Repair Database. Access compacts and repairs the database.

2. CLOSE the database.

PAUSE. LEAVE Access open to use in the next exercise.

SAVING A DATABASE AS A TEMPLATE
You may find it useful to reuse a database you or others have spent a lot of time creating. 
For example, you may have created the structure of a database, including relevant tables, 
queries, forms, and reports—with or without sample data—and may want to save this un-
derlying structure to reuse or to share with others. In this exercise, you create a database as 
a template.

Figure 15-4

Info menu
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Access allows you to create a database template, a file (extension type *. accdt) that can be 
used to create a new, prefabricated database. You can even share database templates with the Ac-
cess community or with your colleagues—simply provide them with the file Access creates after 
you save the template. Besides saving databases as templates, you can also save and reuse prede-
signed applications parts and pre-constructed tables, forms, and other objects. These predesigned 
objects can then be directly inserted into a pre-existing database. You can also create data type 
templates, which are elements you can use to create new fields or field combinations. You can also 
share application parts and data type templates with others. 

You can save a database as a database template or create a new application part by using 
the commands on the Save As menu. You can access the Save As menu by selecting Save As 
on the File tab. The Database File Types category includes the option to save the database 
as a template. Once this option is chosen and you click the Save As button, the Create New 
Template from This Database dialog box appears with the options described in Table 15-1. 

Option Description

Name Required text that identifies the template or application part being saved.

Description Text that describes the contents or purpose of the template or application part. 

Category Used for application parts. Defaults to the User Templates category which has 
the application part show up under User Templates on the Ribbon.

Icon Optional. The icon displayed on the appropriate Access menu for the template 
or application part. 

Preview Optional. The preview image that shows when you click on the database 
template on the Access menu.

Primary Table Used for application parts. The table used by default to relate the application 
part to other tables in a database to which the part is added. A wizard is started 
when the application part is first used, and this table is the first that is presented 
to the user to relate to other objects in the database.

Instantiation Form Form that opens as a startup form when databases made by this template are 
first opened.

Application Part Used to select database as an application part. When not selected, database is 
used as a template.

Include Data in 
Template

Used to include sample data in the database as part of the template to share 
with users who create new databases from this template.

Take Note Data type templates can be created when a table is open by using the Save Selection as New Data 
Type command located on the More Fields menu in the Add & Delete group on the Table Tools 
Fields tab. You first need to select a field or combination of fields from the open table to execute 
this  command. 

Take Note Database templates, applications parts, and data type template files that you create are saved to the 
following folder in both Windows 8 and Windows 10: C:\Users\<username>\AppData\Roaming\
Microsoft\Templates\Access\. Others can share these files with you and you can put them in this 
folder to use them from within Access. Similarly, you can share your template files with others by 
providing them with copies from this folder.

Take Note To use a newly created database template from within Access, click the Personal link on the New 
menu after clicking New on the File tab. The newly created application part can be accessed on 
the Application Parts menu in the Templates group on the Create tab on the Ribbon. The data 
type template can be accessed by opening the table in which you want to create the field and then 
clicking the newly created data type template on the More Fields menu in the Add & Delete group 
on the Table Tools Fields tab on the Ribbon.

Table 15-1 

Create New Template from 
This Database options
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STEP BY STEP Save a Database as a Template

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Graphic Art database from the data files for this lesson.

2. Click the File tab. 

3. Click Save As to display the Save As menu. Click the Template option in the Database 
File Types category.

4. Click the Save As button. The Create New Template from This Database dialog box 
appears, as shown in Figure 15-5.

5. Type Photo Exhibit in the Name box.

6. Type This template contains a standard photo exhibit table with standardized fields 
and a related form in the Description box. Review the other boxes and options in the 
Create New Template from This Database dialog box. 

7. Click OK. Notice the file path and name of the saved template in the message box that 
appears. Click OK to close the message box.

8. Click the File tab and then click New to display the New menu. Click the PERSONAL link 
to the right of the FEATURED link. The newly created Photo Exhibit database template 
appears, as shown in Figure 15-6.

Figure 15-5

Create New Template from 
This Database dialog box

Figure 15-6

Photo Exhibit database 
template
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9. CLOSE the database.

PAUSE. LEAVE Access open to use in the next exercise.

MERGING DATABASES
Sometimes you will have a situation where you need to merge the data from several data-
bases into one. In this case, you will need to import several Access database objects—or an 
entire database—into another database. In this exercise, you import several objects from 
one Access database in to another. 

You may experience a situation in business where each department maintains their own 
employee records in separate databases stored in separate tables using separate queries, 
forms, and reports. Using the Access button in the Import & Link group on the External Data 
tab on the Ribbon, you can import tables, queries, forms, and reports into the current data-
base. The Import Objects dialog box, which appears before the import process, allows you 
to choose all or some of the objects you’d like to import. You can also choose to import ob-
ject relationships, table definitions and actual data (or just table definitions), and other tools. 

STEP BY STEP Merge Databases

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Alpine database from the data files for this lesson, and then SAVE the 
database as Alpine-final.

2. On the External Data tab, in the Import & Link group, click the Access button. The Get 
External Data – Access Database dialog box appears.

3. Click Browse to open the File Open dialog box.

4. Use the File Open dialog box to locate the Northwind database file and then click Open. 
The File Open dialog box closes.

5. Notice the two options you have when importing data. Click Import tables, queries, 
forms, reports, macros, and modules into the current database and then click OK. 
The Import Objects dialog box appears. Click the Options button to display additional 
import options, as shown in Figure 15-7. Review the available options but keep the 
default options.

Figure 15-7

Import Objects dialog box
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6. Click the Select All button on the Tables tab. 

7. Click the additional object tab for queries, forms, and reports, and then click the Select 
All button as the contents for each tab are displayed to select all the objects in the 
Northwind database.

8. Click OK. 

9. When the Save Import Steps screen appears, click Close.

10. Notice the Navigation Pane now includes objects imported from the Northwind 
database, as shown in Figure 15-8. The databases have been merged.

 

11. CLOSE the database.

PAUSE. LEAVE Access open to use in the next exercise.

SETTING DATABASE PROPERTIES 
Database properties are details about a file that describe or identify it. Using database prop-
erties makes it easier to organize and identify databases later. Some properties can be specified 
by you and some are automatically updated by Access. You can search to find files that contain 
certain properties, such as keywords, file size, or creation date. Standard properties are those such 
as author, title, and subject that are associated with a document by default. In this exercise, you set 
database properties that will help you identify and organize it later.

Table 15-2 describes each Standard property on the Summary tab of the Properties dialog box. 
These properties can all be changed by the user; however, some properties on the General, Statis-
tics, and Contents tabs—such as the file size and date the document was created or updated—are 
automatically updated by Access and cannot be changed. On the Custom tab, you can define 
Custom properties by assigning text, time, numeric, or yes/no values to custom properties.

Figure 15-8

Navigation Pane with 
imported Northwind 
database objects 
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Property Name Description

Title Title of the database

Subject Topic of the contents in the database

Author Name of the individual who has authored the database

Manager Name of the manager who is responsible for the database

Company Name of the company that owns the database

Category Category in which the database can be classified

Keywords A word or set of words that describes the database

Comments Summary or abstract of the contents of the database

Hyperlink base Path to the destination of the file; the path may point to a location on your hard 
drive, a network drive, or the Internet

STEP BY STEP Set Database Properties

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Fabrikam-final database that you saved in an earlier exercise.

2. Click the File tab and then click Info, if necessary. On the Info menu that appears, click 
the View and edit database properties link. The Fabrikam-final.accdb Properties dialog 
box appears, as shown in Figure 15-9.

 

3. Type Fall Collection in the Title box.

4. Type preview in the Subject box.

5. Select the text in the Author box and then type [Your Name] (where Your Name is your 
name).

6. Type Britta Simon in the Manager box.

7. Type Fabrikam, Inc. in the Company box

8. Click the General tab. Notice that this tab displays the file type, location, and size as 
well as the dates the file was created, modified, and accessed.

9. Click the Contents tab to view a list of the types of objects within the database file.

Table 15-2

Standard Database Properties

Figure 15-9

Summary Tab of the 
Fabrikam-final.accdb 
Properties dialog box
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10. Click OK.

PAUSE. LEAVE the database open to use in the next exercise.

ENCRYPTING A DATABASE 
Encrypting a database means to scramble the data in a way that can only be reconverted by an 
authorized user who has the password. When you use a database password to encrypt a database, 
you make all data unreadable by other tools and you force users to enter a password to use the 
database. Encrypting a database can provide security for sensitive data. You can use the Decrypt 
Database command to change the password on a regular basis or to remove it. 

Take Note Use strong passwords that combine uppercase and lowercase letters, numbers, and symbols. Weak 
passwords do not mix these elements. Strong password: W5!dk8@R. Weak password: CAR381. 
Passwords should be 8 or more characters in length. A pass phrase that uses 14 or more characters 
is better.

When you open an encrypted database, the Password Required dialog box appears where you type 
the password. Passwords are case sensitive, meaning you can use uppercase and lowercase letters 
as well as numbers and symbols, but you must enter them exactly as they were entered when the 
password was set in order for there to be a match. It is very important for you to remember your 
password, because if you forget it Microsoft cannot retrieve it for you. Write down the password 
and store it in a safe location or use a password manager.

Encrypting and Decrypting a Database
To encrypt a database, you first need to open it in Exclusive mode. Decrypting a database is 
removing the password from a file that has been encrypted. In this exercise, you help secure a 
database by encrypting it and then unsecure it by decrypting it.

If you want to remove a password, open the database in Exclusive mode, click the Decrypt Data-
base button from the Database Tools group, and then type the password in the Unset Database 
Password dialog box exactly as it was entered to encrypt the database.

STEP BY STEP Encrypt and Decrypt a Database

GET READY. USE the Fabrikam-final database that is open from the previous exercise.

1. Click the File tab and then click Info, if necessary. On the Info menu that appears, click 
the Encrypt with Password button. A Microsoft Office Access message box appears 
saying you must open the database in Exclusive mode.

2. Click OK.

3. CLOSE the database but don’t close Access.

4. Click Open on the File tab. The Open menu appears.

5. Navigate to the data files for this lesson and then select Fabrikam-final. 

6. Click the down arrow on the Open button and then select Open Exclusive from the 
menu, as shown in Figure 15-10. Click Open Exclusive. The Fabrikam-final database file 
opens in exclusive mode.
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7. On the File tab, on the Info menu, click the Encrypt with Password button. The Set 
Database Password dialog box appears.

8. Type $Fabrikam09fc in the Password box.

9. Type $Fabrikam09fc in the Verify box, as shown in Figure 15-11.

Troubleshooting Type the passwords exactly as printed throughout this exercise to avoid error messages.

10. Click OK. If you get another message box informing you that an option will be ignored, 
click OK. The database is now encrypted with a password.

11. CLOSE the database.

12. OPEN the database in Exclusive mode again. The Password Required dialog box 
appears.

Take Note You only need to open the database in Exclusive mode if you are going to set or unset a password. 
The database will be protected with the password in any mode.

13. Type $Fabrikam09fc and then click OK. The database opens.

14. On the File tab, on the Info menu, click the Decrypt Database button. (If you hadn’t 
opened the database in Exclusive mode, you would get a message prompting you to 
do so.) The Unset Database Password dialog box appears.

15. Type $Fabrikam09fc and then click OK. The database is now decrypted.

16. CLOSE the database.

Figure 15-10

Open menu

Figure 15-11

Set Database Password 
dialog box
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17. OPEN the database in regular mode. Notice that a password is no longer required to 
open the file.

18. CLOSE the database. 

PAUSE. LEAVE Access open to use in the next exercise.

CONFIGURING DATABASE OPTIONS
The Access Options dialog box provides many ways to customize your copy of Access by allowing 
you to change popular options to other unique options. Through the Access Options dialog box, 
you can enable error checking, show/hide the Navigation Pane, and select a startup display form. 

If you want a form to be displayed automatically when you open a database, the Display Form 
menu lets you choose from available forms in the database. You can choose none if you do not 
wish to display a form.

The Display Navigation Pane option is turned on by default, but if you don’t want the Navigation 
Pane to be displayed when you open your database, click the Display Navigation Pane check box 
to remove the check mark. You must close and reopen the current database for these settings to 
take effect.

Enable Error Checking, located in the Object Designers options, is another feature you can 
change. Error checking is on by default, but you can clear the check box to disable all types of 
error checking in forms and reports. For example, Access places error indicators in controls that 
encounter one or more types of errors. The indicators appear as triangles in the upper-left or up-
per-right corner of the control, depending on text direction. The default indicator color is green, 
but you can change that to another color if you choose.

Configuring Database Options
The Access Options dialog box lets you customize certain aspects of Access and your databases. 
The Access Options dialog box has 11 sections of customizable options, including General, Cur-
rent Database, Datasheet, Object Designers, Proofing, and Language. In this exercise, you use 
the Access Options dialog box to set a form as the startup option and hide the Navigation Pane.

STEP BY STEP Configure Database Options

GET READY. LAUNCH Access if it is not already running.

1. OPEN Fabrikam Inc from the data files for this lesson and then SAVE the database as 
Fabrikam Inc-final.

2. Click the File tab and then click Options. The Access Options dialog box appears.

3. Click the Current Database button on the left to display the Current Database menu of 
the Access Options dialog box.

4. In the Application Options section, click the Display Form down arrow and then select 
Showroom Contact Form from the menu to display the form at startup.

5. In the Navigation section, notice that the Display Navigation Pane is turned on by 
default.

6. Click the Display Navigation Pane check box to remove the check mark, as shown in 
Figure 15-12, and then click OK. A Microsoft Access message box appears saying you 
need to close and reopen the database for the changes to take effect.
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Display Form menuDisplay Navigation Pane checkbox  

7. Click OK.

8. CLOSE the database.

9. OPEN the Fabrikam Inc-final database. Notice that the Navigation Pane is not visible 
and the Showroom Contact Form is displayed at startup, as shown in Figure 15-13.

 

10. Click the File tab and then click Options.

11. Click the Current Database button on the left, if it’s not already selected.

12. In the Application Options section, click the Display Form down arrow and then select 
(none) from the menu.

Figure 15-12

Access Options dialog box, 
Current Database menu

Figure 15-13

Showroom Contact form
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13. In the Navigation section, click the Display Navigation Pane check box to insert a check 
mark.

14. In the Navigation section, click the Navigation Options button. The Navigation Options 
dialog box appears, as shown in Figure 15-14. Notice the grouping and display options 
that are available and then click Cancel.

 

15. Click the Object Designers button on the left.

16. Scroll to the bottom of the window to see the Error checking section. The Enable Error 
Checking options are turned on by default.

17. Click OK. The Microsoft Access dialog box appears again.

18. Click OK.

19. CLOSE the database.

20. OPEN the Fabrikam Inc-final database. Notice the Navigation Pane is displayed and the 
form is not.

PAUSE. LEAVE the database open to use in the next exercise.

USING DATABASE TOOLS 
The Database Tools tab has advanced commands for maintaining databases. Using this tab, 
you can do such things as identify object dependencies, create object reports with the Da-
tabase Documenter, and split a database.

Identifying Object Dependencies
Object dependencies describe how objects in a database rely on other components to func-
tion properly. The Object Dependencies task pane helps you manage a database by displaying how 
all of its components interact. This can be helpful if you want to delete a table or form. It allows 
you to see which objects you may need to change so they will function without the deleted table. 
In this exercise, you identify object dependencies.

The Object Dependencies task pane displays how database objects, such as tables or forms, use 
other objects. This process helps keep databases running smoothly by preventing errors that could 
result when changes or deletions are made to objects in a database. The Object Dependencies task 
pane works only for tables, forms, queries, and reports in an Access database.

Figure 15-14

Navigation Options dialog box
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STEP BY STEP Identify Object Dependencies

GET READY. USE the Fabrikam Inc-final database that is open from the previous exercise.

1. Click the Product Placements: Table in the Navigation Pane to select it.

2. On the Database Tools tab, in the Relationships group, click the Object Dependencies 
button. The Object Dependencies task pane displays dependency information for the 
selected table, as shown in Figure 15-15. Widen the pane if necessary. Notice that the 
Objects that depend on me option button is selected.

 

3. Click the Objects that I depend on option button. Notice the changes in the Reports 
section.

4. Click the Objects that depend on me option button. Click the right-pointing triangle 
beside the Showroom Contact table to see the tables and forms that depend on the 
Showroom Contact table.

5. Click the Showroom Contact link to display it in Design view where you could make 
any necessary changes

6. CLOSE the Showroom Contact table.

7. CLOSE the Object Dependencies task pane.

PAUSE. LEAVE the database open to use in the next exercise.

Using the Database Documenter
The Database Documenter provides detailed information about a database and presents it 
as a report that can be printed. Use the Database Documenter when you need to have a printed 
record of this information, such as for record-keeping purposes or as insurance in case you have 
to re-create the database or object. In this exercise, you use the Database Documenter to create a 
report about the objects included in the database.

The Database Documenter creates a report that shows details, or definitions, about a selected ob-
ject and opens it in Print Preview. You can view the properties for a form as well as properties for 
each section of the form and each label, button, or control on the form. The Documenter dialog 
box contains tabs for each type of object as well as a tab that displays all objects. Select the object 
whose definitions you want to view or print. The Options button lets you further specify the fea-
tures of the object for which you want to view the definitions.

Figure 15-15

Object Dependencies task 
pane
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STEP BY STEP  Use the Database Documenter

GET READY. USE the Fabrikam Inc-final database that is open from the previous exercise.

1. On the Database Tools tab, in the Analyze group, click the Database Documenter 
button. The Documenter dialog box appears, as shown in Figure 15-16.

2. Click the All Object Types tab.

3. Click the Tables tab.

4. Select the Showroom Contact check box in the Tables list.

5. Click the Options button. The Print Table Definition dialog box appears, as shown in 
Figure 15-17.

 

6. Click OK to close the Print Table Definition dialog box.

7. Click OK to close the Documenter dialog box. The Object Definition report appears in 
Print Preview.

8. Click the Zoom button in the Zoom group to view the report. At this point, you could 
print the report or make any changes to the layout and then print it.

9. Click the Next Page button on the page navigation bar until you reach page 4. Notice 
the relationship diagram included in the report, as shown in Figure 15-18.

Figure 15-16

Documenter dialog box

Figure 15-17

Print Table Definition dialog 
box
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10. Click the Close Print Preview button.

PAUSE. LEAVE the database open to use in the next exercise.

Take Note Some object definitions can be several pages long, so it is a good idea to check the length of the 
report before printing.

Splitting a Database
It can be difficult for many people to use the data in a database at the same time. Synchronizing 
data can be difficult and time consuming. To avoid slowing down the network because of con-
stant changes being made to a database, the Database Splitter wizard can split the database 
into two files: one that contains the tables, called the back-end file; and one that contains the 
queries, forms, reports, and other objects created from the tables, called the front-end file. Us-
ers who need to access the data can customize their own forms, reports, pages, and other objects 
while maintaining a single source of data on the network. Essentially, the back-end database tables 
are dynamically linked to the front-end database tables, so a change of record data in one table 
will automatically change the same data in the corresponding table in the other database. It is a 
good idea to back up the database before splitting it. In this exercise, you use the Database Splitter 
wizard to split a database.

STEP BY STEP Split a Database

GET READY. USE the Fabrikam Inc-final database that is open from the previous exercise.

1. On the Database Tools tab, in the Move Data group, click the Access Database button. 
The Database Splitter Wizard appears.

2. Click the Split Database button. The Create Back-end Database dialog box appears, as 
shown in Figure 15-19. Notice that is has already given the file a file name. 

Figure 15-18

Object Definition report
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3. Navigate to the location where you want to save the back-end file and then click Split. 
After a few moments, the Database Splitter message box appears stating that the 
database was successfully split.

4. Click OK.

5. CLOSE the database.

6. OPEN Fabrikam Inc-final_be. Notice that it contains only the tables for the database.

STOP. CLOSE the database and then EXIT Access.

Knowledge Assessment

Matching
Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Back-end file a.  In a split database, the file that contains the queries, forms, 
reports, and other objects created from the tables

2. Front-end file b.  Optimizes files and fixes minor problems in the file structure 
of a database

3.  Compact and  c. To scramble data in a way that can only be reconverted by an

Repair command     authorized user who has the correct password 

4. Encrypting d.  Creates a report that shows details, or definitions, about a 
selected object database and opens it in Print Preview

5.  Database  e. The file that contains the tables in a split database 
Documenter 

Figure 15-19

Create Back-end Database 
dialog box
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True/False
Circle T if the statement is true or F if the statement is false.

T F 1. Backing up files on a regular basis is really not necessary.

T F 2. Compacting and repairing a database leaves the file fragmented.

T F 3. The .accdb extension is for the Access 2002–2003 file format.

T F 4. If you forget a password for a database, Microsoft can retrieve it for you.

T F 5. It is a good idea to back up a database before splitting it.

Competency Assessment

Project 15-1: Setting Database Properties, and Encrypting and Decrypting a Database

As an investor relations specialist for Blue Yonder Airlines, you need to maintain and safeguard 
the databases that you use. In this project, you will set the database properties and compact and 
repair the Income and Expenses database. Then, set the Income chart to open on startup and 
create a password to protect the data in the Income and Expenses database. Once the protection 
is no longer needed, remove the encryption from the Blue Yonder Income and Expenses database.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Blue Yonder database from the data files for this lesson and then SAVE the 
database as Blue Yonder-final.

2. Click the File tab, click Info (if necessary), and then select the View and edit database 
properties link.

3. Type Income and Expenses in the Subject box.

4. Type [Your Name] in the Author box.

5. Type Andrew Lan in the Manager box.

6. Type BlueYonder Airlines in the Company box.

7. Click OK.

8. Click File and then select Compact & Repair Database.

9. Click File and then click Options. 

10. Click the Current Database link on the left.

11. Select Income Chart from the Display Form menu. 

12. Click OK and then click OK again.

13. CLOSE the database.

14. OPEN the Blue Yonder-final database in Exclusive mode.

15. Click the File tab, and on the Info menu click the Encrypt with Password button.

16. Type #1BlueYonder$87 in the Password box.

17. Type #1BlueYonder$87 in the Verify box.

18. Click OK. Click OK if you receive a warning dialog box.

19. CLOSE the database.

20. OPEN the database.

21. Type #1BlueYonder$87 in the Enter database password box and then click OK.

22. Open the Database Documenter.

23. Select the Income & Expenses Summary table and then click OK to view the report.

24. Print the report or close Print Preview.

25. CLOSE the database and then reopen it in Exclusive mode.

26. Type #1BlueYonder$87 in the Enter database password box and then click OK.

27. Click File and then click Decrypt Database.
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28. Type #1BlueYonder$87 and then click OK.

29. Click File and then Save As. 

30. Click Back Up Database. 

31. Use the generated file name, and SAVE it in the same location as the original version.

32. CLOSE the database.

PAUSE. LEAVE Access open to use in the next project.

Project 15-2: Merging, Backing Up, and Splitting the WingTip Database

As part of your maintenance of database files at WingTip Toys, you decide to merge a database 
with another database with similar data to consolidate the two databases. In this project, you will 
also create a backup of a database and split it so that others in the company can create their own 
forms and reports using the data in the tables.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Wingtip database from the data files for this lesson and then SAVE the 
database as Wingtip-final.

2. On the External Data tab, in the Import & Link group, click the Access button.

3. Click Browse to open the File Open dialog box.

4. Locate the Toys database file and then click Open.

5. The Import tables, queries, forms, reports, macros, and modules into the current 
database option should be selected. Click OK.

6. Click the Select All button on each tab in the Import Object dialog box to import all 
objects into the current database. Click OK.

7. When the Save Import Steps screen appears, click Close. 

8. Click the File tab, click Save As, and then select Back Up Database.

9. Click the Save As button and then, using the generated file name with the date, click 
Save. (Change the destination location if you want.)

10. On the Database Tools tab, in the Move Data group, click the Access Database button.

11. Click the Split Database button.

12. Accept the Wingtip-final_be file name and then click Split.

13. Click OK.

STOP. CLOSE the database and then EXIT Access.
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EXAM 77-730: ACCESS 2016

Objective 
Number Matrix skill

Lesson 
Number

Create and Manage a Database

1.1 Create and Modify Databases

1.1.1 Create a blank desktop database 2

1.1.2 Create a database from a template 2

1.1.3 Create a database by using import objects or data from other 
sources

2, 14

1.1.4 Delete database objects 4

1.2 Manage Relationships and Keys

1.2.1 Create and modify relationships 3

1.2.2 Set the primary key 3

1.2.3 Enforce referential integrity 3

1.2.4 Set foreign keys 3

1.2.5 View relationships 3

1.3 Navigate through a Database

1.3.1 Navigate specific records 3

1.3.2 Create and modify a navigation form 10

1.3.3 Set a form as the startup option 15

1.3.4 Display objects in the Navigation Pane 1

1.3.5 Change views of objects 1

1.4 Protect and Maintain Databases

1.4.1 Compact a database 15

1.4.2 Repair a database 15

1.4.3 Back up a database 15

1.4.4 Split a database 15

1.4.5 Encrypt a database with a password 15

1.4.6 Recover data from backup 15

1.5 Print and Export Data
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Objective 
Number Matrix skill

Lesson 
Number

1.5.1 Print reports 11, 13

1.5.2 Print records 11

1.5.3 Save a database as a template 15

1.5.4 Export objects to alternative formats 14

Build Tables

2.1 Create Tables

2.1.1 Create a table 2, 9

2.1.2 Import data into tables 14

2.1.3 Create linked tables from external sources 14

2.1.4 Import tables from other databases 14

2.1.5 Create a table from a template with application parts 2

2.2 Manage Tables

2.2.1 Hide fields in tables 3

2.2.2 Add total rows 9

2.2.3 Add table descriptions 4

2.2.4 Rename tables 4

2.3 Manage Records in Tables

2.3.1 Update records 3

2.3.2 Add records 3

2.3.3 Delete records 3

2.3.4 Append records from external data 14

2.3.5 Find and replace data 3

2.3.6 Sort records 3

2.3.7 Filter records 3

2.4 Create and Modify Fields

2.4.1 Add fields to tables 4

2.4.2 Add validation rules to fields 4

2.4.3 Change field captions 4

2.4.4 Change field sizes 4

2.4.5 Change field data types 1

2.4.6 Configure fields to auto-increment 9

2.4.7 Set default values 4
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Objective 
Number Matrix skill

Lesson 
Number

2.4.8 Using input masks 4

2.4.9 Delete fields 4

Create Queries

3.1 Create a Query

3.1.1 Run a query 7

3.1.2 Create a crosstab query 12

3.1.3 Create a parameter query 7

3.1.4 Create an action query 12

3.1.5 Create a multi-table query 7, 12

3.1.6 Save a query 7, 13

3.2 Modify a Query

3.2.1 Rename a query 7

3.2.2 Add fields 12

3.2.3 Remove fields 12

3.2.4 Hide fields 7

3.2.5 Sort data within queries 7

3.2.6 Format fields within queries 12

3.3 Create Calculated Fields and Grouping within Queries

3.3.1 Add calculated fields 12

3.3.2 Set filtering criteria 12

3.3.3 Group and summarize data 12

3.3.4 Group data by using comparison operators 12

3.3.5 Group data by using arithmetic and logical operators 12

Create Forms

4.1 Create a Form

4.1.1 Create a form 5, 10

4.1.2 Create a form from a template with application parts 10

4.1.3 Save a form 5

4.2 Configure Form Controls

4.2.1 Move form controls 8

4.2.2 Add form controls 8

4.2.3 Modify data sources 8
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Objective 
Number Matrix skill

Lesson 
Number

4.2.4 Remove form controls 8

4.2.5 Set form control properties 8

4.2.6 Manage labels 8

4.2.7 Add sub-forms 10, 11

4.3 Format a Form

4.3.1 Modify tab order 8

4.3.2 Configure print settings 8

4.3.3 Sort records by form field 5

4.3.4 Apply a theme 5

4.3.5 Control form positioning 8

4.3.6 Insert backgrounds 8

4.3.7 Insert headers and footers 8

4.3.8 Insert images 8

Create Reports

5.1 Create a Report

5.1.1 Create a report based on the query or table 6

5.1.2 Create a report in Design view 6

5.1.3 Create a report by using a wizard 6

5.2 Configure Report Controls

5.2.1 Group and sort fields 6, 11

5.2.2 Modify data sources 8, 13

5.2.3 Add report controls 8, 13

5.2.4 Add and modify labels 8

5.3 Format a Report

5.3.1 Format a report into multiple columns 8

5.3.2 Add calculated fields 12

5.3.3 Control report positioning 8

5.3.4 Format report elements 8

5.3.5 Change report orientation 11

5.3.6 Insert header and footer information 8

5.3.7 Insert images 8

5.3.8 Apply a theme 6
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Index

SYMBOLS
1NF (First Normal Form)  19
2NF (Second Normal Form)  19
3D Column Chart button  245
3NF (Third Normal Form)  19

A
Access button  286
Access Options dialog box  292
Access startup screen  22
Account command (Backstage view)  13
action queries  220–230

append  221–224
delete  228–230
make table  224–225
update  225–228

Add & Delete group  69
Add Existing Fields button  96, 130
adding controls

bound controls  130–133
button controls  138–140
calculated controls  133–135
Control Wizard  135–138
unbound controls  128–129

ad hoc relationships  231
Adobe Portable Document Format (PDF)  

30
Advanced Filter/Sort command  102
advanced forms

Application Parts Blank Forms  185–187
multi-item forms  178–179
Navigation forms  187–190
split forms  179–183
subforms  183–185

advanced queries
action  220–230

append  221–224
delete  228–230
make table  224–225
update  225–228

crosstab  212–214
modifying

aggregated queries  237–241
calculated query fields  233–237
joins  230–233

saving filters as  218–220
subqueries  214–218

advanced reports
aggregate fields  199–200
creating labels with Label Wizard  

206–209

creating Print Layout  202–206
defining groups  193–199

changing group options  198–199
group headers and footers  196–197
Report Wizard  193–196

subforms  201–202
advanced sort criteria  121
advanced tables

creating custom tables  164–167
summarizing table data  171–173
Table Analyzer Wizard  167–171

aggregated queries  237–241
aggregate fields, advanced reports  199–200
Aggregate function menu  239
aggregate functions  171–172, 199
Align button  156
alignment, controls  154–157
Align To Grid command  154
Allow Zero Length field property  64
Alternate Row Color menu  144
Anchoring button  148, 150
Anchoring menu  150
Append dialog box  222
appending data  263
Append Only field property  64
append queries  220–224
Applicable Filter dialog box  218
Application Part option (Create New Tem-

plate from This Database)  284
Application Parts  26–28
Application Parts Blank Forms  185–187
Application Parts button  177
Application Parts Gallery, 26–27
Application Parts menu  177
Apply Currency Format command  144
applying themes, reports  99–100
arithmetic operators  237
arrangement tools, formatting controls  

151–153
Arrange tab  148
arranging layout, controls  148–151
ascending order, sorting data  45
Assets template database  25
attaching documents, records  43–44
Attachment data type  16
Author (database property)  288
AutoNumber data type  16
Auto Order button  140
Average aggregate function  172, 237

B
back-end files  296
Background group  143
Background Image button  145
backing up databases  280–282
Backstage view  11

Account command  13
Close command  13
Feedback command  13
Info command  13
New command  13
Open command  13
Options command  13
Save As command  13
Save command  13
Save Object As command  30
selecting tools/commands  12–14

backups, defined  280
blank columns/rows/cells (source data 

element)  261
blank databases

creating  25–26
opening screen  1

Blank Forms, creating  185–187
Blank Form tool  81
Blank Report button  148
bound controls  130–133
Bring to Front command  155
Button button  138
button controls, adding with Control Wiz-

ard  138–140
By Column button  253
By Row button  252

C
calculated controls  133–135
Calculated data type  16
calculated query fields, creating  233–237
CanGrow property (controls)  143
CanShrink property (controls)  143
Caption field property  64, 68–69
captions  68–69
cascade options, Edit Relationships dialog 

box  53
categories (database objects)  7
Category (database property)  288
Category option (Create New Template 

from This Database)  284
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changing. See also editing, modifying
chart types  252–254
formatting options  250–253
views  10

chart body  244
Chart control  244
Chart Options dialog box  248–250
charts

creating, Chart Wizard  244–247
defined  244
deleting  244
formatting  248–253

changing chart options  248–250
changing formatting options  250–252
Refresh All button  252–253

Chart Type dialog box  252
Chart Wizard, creating charts  244–247
Chart Wizard dialog box  246
Clear All Filters command  102
Click to Add column, creating fields  69
Click to Add menu  18
client objects  254
Close command (Backstage view)  13
collating pages, printing  256
columns (tables)  14
Combo Box Wizard  137
comma-delimited file  267
Command Button Wizard  138
commands  10–14. See also tools

Backstage view  12–14
Account  13
Close  13
Feedback  13
Info  13
New  13
Open  13
Options  13
Save  13
Save As  13
Save Object As  30

Compact and Repair  283
Decrease Horizontal  155
Decrease Vertical  155
Decrypt Database  289
defined  10
Equal Horizontal  155
Equal Vertical  155
Filter by Form  218
Group  155
Hide Details  198
Increase Horizontal  155
Increase Vertical  155
Quick Print  202
Ribbon  11–12
Save Object As  254
Size to Fit  155
Size to Grid  155
Size to Narrowest  155
Size to Shortest  155
Size to Tallest  155
Size to Widest  155

SQL (Structured Query Language)  214
Themes  83–84
Totals  200
Ungroup  155

Comments (database property)  288
common filters  85-86
Compact and Repair command  283
compacting databases  283
Company (database property)  288
comparisons (subqueries)  215
composite keys  41
conditional formatting, controls  146–148
Conditional Formatting Rules Manager 

dialog box  146
conditional logic  214
configuring database options  291–293
constants (expressions)  133
Control Formatting group  143
control layouts  148
Control Margins button  150-151
Control Margins menu  150
Control Padding button  150-151
Control Padding menu  150
controls

adding  128–140
bound controls  130–133
button controls  138–140
calculated controls  133–135
Control Wizard  135–138
unbound controls  128–129

alignment, size, and position  154–157
Chart  244
defined  128
formatting  142–154

adding, moving, and removing  
151–152

arrangement tools  151–153
arranging control layout  148–151
conditional formatting  146–148
forms  145–146
reports  143–145

tab order  140–142
Controls group  127, 201
Control Source property  133
Control Wizard, adding controls  135–140
Control Wizards command  136
Count aggregate function  237
Count (Total row aggregate function)  172
Create Back-end Database dialog box  297
Create New Template from This Database 

dialog box  284
Create Relationship dialog box  60
Create tab  148

Forms group  77
Queries group  107
Reports group  91
Templates group  26

criteria, adding to queries  117–119
cross joins  231
crosstab queries, creating  212–214
Crosstab Query Wizard, creating crosstab 

queries  212–214

Ctrl+Down Arrow keyboard command, 
navigating records  36

Ctrl+End keyboard command, navigating 
records  36

Ctrl+Home keyboard command, navigating 
records  36

Ctrl+Up Arrow keyboard command, navi-
gating records  36

Currency data type  16
Current Database menu  292
Current Record box  37
Custom Filter dialog box  86, 102
Custom Order list (Tab Order dialog box)  

140
Custom tab  287
custom tables, creating  164–167

D
data

displaying and sharing
changing chart types  252–254
creating charts, Chart Wizard  

244–247
formatting charts  248–253
printing database objects  256–258
saving databases objects as another file 

type  254–255
exporting  271–276

export specifications  275
query data to Word  273–275
tables to Excel  271–273

filtering
queries  121–122
reports  102–103
tables  47–49

finding and replacing
records  42–44
reports  103–104

grouping, reports  100–102
importing  260–270

import specifications  267–270
linking to external data sources  

265–267
source data elements  260–265

redundant, Table Analyzer Wizard  167
sorting

forms  85–88
queries  119–121
reports  100–102
tables  45–46

summarizing table data  171–173
Database Documenter  294–296
Database File Types category  284
database management system (DBMS)  2
database objects

printing  256–258
saving as another file type  254–255

database properties, setting  287–289
databases

blank databases, opening screen  1
configuring options  291–293



Index 307

creating
blank databases  25–26
templates  23–25

Database Tools tab
Database Documenter  294–296
Database Splitter wizard  296–297
Object Dependencies task pane  

293–294
defined  2
design  14–19

defining and modifying data types for 
fields  15–18

defining database tables  18–19
reviewing database fields  15

encrypting  289–291
maintenance tasks

backing up  280–282
compacting and repairing  283
saving as previous version  282

merging  286–287
opening  4–6
saving objects  30–31
setting properties  287–289
tables  58–62

Database Splitter wizard  296–297
database templates  283–286
Database Tools tab

Database Documenter  294–296
Database Splitter wizard  296–297
Object Dependencies task pane  293–294

Data Labels tab (Chart Options dialog box)  
249

Datasheet form  83
Datasheet Formatting dialog box  11
datasheets  10
Datasheet view  10

creating split forms  179–183
field properties  64

data types
defined  15
defining and modifying  15–18
importing data  263
setting data validation rules  67
source data element  261

data validation rules  67–68
Date and Time controls  129
Date and Time dialog box  129
Date/Time data type  16
DBMS (database management system)  2
Decimal Places field property  64
Decrease Horizontal command  155
Decrease Vertical command  155
Decrypt Database command  289
decrypting database files  289–291
Default Value field property  64
Default View table property  60
defining

groups
changing group options  198–199
group headers and footers  196–197
Report Wizard  193–196

input masks  65–67
primary keys  40–41
table relationships  51–53

Delete Columns button  215
Delete menu  39
delete queries  220, 228–230
Delete Rows command  166
deleting. See also removing

charts  244
forms  78
joins  231
records  38–39
reports  92–94
tables  61–62

delimited files  267
delimiter  267
descending order, sorting data  45
Description control  143
Description option (Create New Template 

from This Database)  284
Description table property  60
design, databases  14–19

defining and modifying data types for 
fields  15–18

defining database tables  18–19
reviewing database fields  15

Design tab
Form Design Tools/Form Layout Tools  

127
Report Design Tools/Report Layout 

Tools  127
Design view  10

creating custom tables  164–167
creating forms  79–81
creating reports  96–99
field properties  62
group headers  197

destination workbook options, Excel  271
detaching documents, records  43–44
Detail section, Design view reports  96
dialog boxes

Access Options  292
Append  222
Applicable Filter  218
Chart Options  248–250
Chart Type  252
Chart Wizard  246
Conditional Formatting Rules Manager  

146
Create Back-end Database  297
Create New Template from This Database  

284
Create Relationship  60
Custom Filter  86, 102
Datasheet Formatting  11
Date and Time  129
Documenter  295
Edit Relationships  52-53
Export - Excel Spreadsheet  272
Export - RTF File  273

Expression Builder  67–68, 134, 234–235
File Open  286
Fill Effects  250
Find  103–104
Find and Replace  43
Format Chart Area  250
Format Data Series  250
Format Legend  251
Get External Data – Access Database  

286
Get External Data - Excel Spreadsheet  

262
Grouping Intervals  195
Import Objects  264, 286
Insert Hyperlink  131
Insert Picture  128
Join Properties  231, 232
Label Wizard  206–207
Make Table  224
Manage Data Tasks  269-270, 276
Navigation Options  293
New Formatting Rule  147
New Name  265
New Query  108, 213
Page Numbers  129
Page Setup  205, 256
Password Required  289
Paste As  203
Paste Table As  29
Print  202, 256
Print Table Definition  295
Properties  256, 287
Publish as PDF or XPS  273
Report Wizard  194
Sample Preview  246
Save As  31, 255, 281
Set Database Password  290
Show Table  52, 115, 215
Table Analyzer Wizard  168
Tab Order  140
Unset Database Password  289
Zoom  217

dialog box launchers  11
Display Form menu  291
displaying data

charts
changing chart types  252–254
Chart Wizard  244–247
formatting charts  248–253

printing database objects  256–258
saving databases objects as another file 

type  254–255
Display Navigation Pane option  291
Documenter dialog box  295
documents, attaching/detaching to records  

43–44
Down Arrow keyboard command, navigat-

ing records  36
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E
Edit/Delete shortcut menu  54
editing records  38-39. See also changing, 

modifying
Edit Relationships dialog box  52-53
Enable Error Checking  291
encrypting databases  289–291
Encrypt with Password button  290
End keyboard command, navigating 

records  36
entering

captions  68
records  38–39

Equal Horizontal command  155
Equal Vertical command  155
error checking  291
Error Checking Options menu  204
error values (source data element)  261
Excel

destination workbook options  271
exporting table data to  271–273
importing data from  262–264
linking to an external data source  

265–267
Exclusive mode, encrypting databases  289
existing databases, opening  4–6
Export - Excel Spreadsheet dialog box  272
Export group  271
exporting data  271–276

query data to Word  273–275
saving export specifications  275
tables to Excel  271–273

Export - RTF File dialog box  273
export specifications

running  276
saving  275

Export Wizard  273
Expression aggregate function  237
Expression Builder  133, 233–237
Expression Builder dialog box  67–68, 134, 

234–235
Expression field property  64
expressions  133

calculated fields  233–237
subqueries  215
update queries  226

external data sources, importing data  
265–267

External Data tab  26, 261, 286
import commands  26

F
Feedback command (Backstage view)  13
Field List

adding fields from tables to Navigation 
forms  187

creating Blank Forms  185–187
Field List pane  80, 96, 98, 130
fields

captions  68–69
creating  69–71
data validation rules  67–68

defined  14
defining input masks  65–67
multivalued lookup fields  72–74
properties  62

setting  63–65
validation rules  67

reviewing  15
selection with Report Wizard  94
size, setting validation rules  67
tables

freezing/unfreezing  49–51
hiding/unhiding  49–51

zero-length strings  66–67
Field Size field property  64
File Name box  24
File Open dialog box  286
File tab

Backstage view  12
Info menu  280
Save As menu  280

Fill Effects dialog box  250
Filter by Form command  218
Filter by Form tool  86–88
Filter Indicator  37
filtering data

forms  85–88
queries  121–122
reports  102–103
tables  47–49

Filter menu  47
Filter On Load table property  60
filters

defined  47
removing, records  49
saving as queries  218–220

Filter table property  60
Find and Replace dialog box  43
Find command  103
Find dialog box  103–104
Find Duplicates Query Wizard  110–111
finding data

records  42–44
reports  103–104

Find Unmatched Query Wizard  113–115
First aggregate function  237
First Normal Form (1NF)  19
First record button  37
first row (source data element)  261
fixed-width files  267
Font Color button  145
Fonts menu  100
Font tab (Format Legend dialog box)  250
footers, adding group footers  196–197
foreign key  40
Format Chart Area dialog box  250
Format Data Series dialog box  250
Format field property  64
Format Legend dialog box  251
Format menu  236
Format Painter button  143
Format tab  142
formatting

charts

changing chart options  248–250
changing formatting options  250–252
Refresh All button  252–253

controls  142
adding, moving, and removing  

151–152
arrangement tools  151–153
arranging control layout  148–151
conditional formatting  146–148
forms  145–146
reports  143–145

Form Design button  79
Form Design Tools  127

Arrange tab  148
Design contextual tab  80

Form Layout Tools  127, 148
forms

adding controls  128–140
bound controls  130–133
button controls  138–140
calculated controls  133–135
Control Wizard  135–138
unbound controls  128–129

advanced forms
Application Parts Blank Forms  

185–187
multi-item forms  178–179
Navigation forms  187–190
split forms  179–183
subforms  183–185

creating  77–84
Design view  79–81
Form Wizard tool  82–83
Layout view  81–82

Datasheet  83
defined  6
formatting controls  145–146
page margins/page orientation  157–159
saving as another type of object  254
sorting and filtering data within  85–88

Forms group  77, 177
Form tool  77–79
Form view  81, 179–183
Form Wizard

creating forms  82–83
creating subforms  183–185

freezing fields, tables  49–51
front-end files  296
functions (expressions)  133

G
Get External Data - Access Database dialog 

box  286
Get External Data - Excel Spreadsheet dialog 

box  262
graphs. See charts
Gridlines tab (Chart Options dialog box)  

249
<Group> footer section, Design view reports  

96
<Group> header section, Design view 

reports  96
Group command  155
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group footers  196–197
group headers  196–197
grouping

data, reports  100–102
fields  193
intervals  193, 198
levels  193
options  198–199

Grouping Intervals dialog box  195
Grouping Options button  193
Grouping & Totals group  196
group intervals (grouping option)  198
Group On menu  196
groups  7

Add & Delete  69
Background  143
Control Formatting  143
Controls  127, 201
defined  11
defining  193–199

changing group options  198–199
group headers and footers  196–197
Report Wizard  193–196

Export  271
Forms  177
Grouping & Totals  196
Header/Footer  127-128
Import & Link  261, 286
Merge/Split  153
Number  143
Page Size  157
Position  148
Queries  107
Query Setup  115, 215
Reports  91
Rows & Columns  150
Show/Hide  233
Sizing & Ordering  154
Sort & Filter  46, 85, 100, 121
Templates  177
Text Formatting  11
Tools  127

Group, Sort, and Total pane  100–101, 193
adding aggregate functions to fields  200
adding group headers and footers  

196–197
changing grouping options  198–199

Group & Sort button  196

H
Header/Footer group  127-128
headers, adding group headers  196–197
Help, Microsoft Office Access Help  1
Hide Details command  198
hiding fields, tables  49–51
hierarchical forms  183
Home Inventory template  23
Home keyboard command, navigating 

records  36
Home tab

changing views  10
Sort & Filter group  85

Hyperlink base (database property)  288

Hyperlink button  131
Hyperlink data type  16

I
Icon option (Create New Template from 

This Database)  284
identifiers (expressions)  133
ID field control  131
IME Mode field property  64
IME Sentence Mode field property  64
import commands (External Data tab)  26
importing data  260–270

import specifications  267–270
linking to external data sources  265–267
source data elements  260–265

Import & Link group  261, 286
Import Objects dialog box  264, 286
import specifications

running  269–270
saving  268–269

Import Spreadsheet Wizard  262
Import Text Wizard  268
Include Data in Template option (Create 

New Template from This Database)  284
Increase Horizontal command  155
Increase Vertical command  155
indented levels (grouping levels)  193
Indexed field property  64
Info command (Backstage view)  13
Info menu  280, 283
inner joins  231
innermost field  45
In Production control  131
Input Mask field property  64
input masks  65–67
Input Mask Wizard  65
Insert Hyperlink dialog box  131
Insert Image button  131
Insert Page Break control  131
Insert Picture dialog box  128
Insert Rows command  166
Instantiation Form option (Create New 

Template from This Database)  284
IntelliSense (Expression Builder)  133

J
Join Properties dialog box  231-232
joins, modifying advanced queries  230–233

K
keyboard, navigating records  35–37
key combinations (keyboard), navigating 

records  35–36
keys (keyboard), navigating records  35–36
Keywords (database property)  288

L
labels

controls  130
creating with Label Wizard  206–209
reports  91

Labels button  91

Label Wizard, creating label-sized reports  
206–209

Label Wizard dialog box  206–207
Landscape button  158, 205
landscape orientation  158
Last aggregate function  237
Last record button  37
layout

controls  148–152
Navigation forms  187

Layout view
creating forms  81–82
Multiple Items forms  179
Navigation forms  188

Left Arrow keyboard command, navigating 
records  36

left outer joins  231
legend (charts)  244
line chart  253
Link Child Fields table property  60
linked tables  265
linking to external data sources, importing 

data  265–267
Link Master Fields table property  60
Link Spreadsheet Wizard  265
logical operators  237
Long Text data type  16
Lookup & Relationship button  72
Lookup Wizard  72–74

M
main forms  183
main reports  201
maintenance tasks, databases

backup  280–282
Compact and Repair command  283
saving as previous version  282

Make Table dialog box  224
make table queries  220, 224–225
Manage Data Tasks dialog box  269–270, 

276
Manager (database property)  288
Margins button  158
master/detail forms  183
Match Case box  42
Match menu  42
Maximum aggregate function  237
Maximum (Total row aggregate function)  

172
menus

Aggregate function  239
Alternate Row Color  144
Anchoring  150
Application Parts  177
Click to Add  18
Control Margins  150
Control Padding  150
Current Database  292
Delete  39
Display Form  291
Edit/Delete shortcut  54
Error Checking Options  204
Filter  47
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Fonts  100
Format  236
Group On  196
Info  280, 283
Match  42
More Fields  44, 70–71
More Forms  178
Navigation  177
Navigation Pane  7
Number of Copies  257
Record Shortcut  38
Save As  254, 280-281
Totals  200

Merge/Split group  153
merging databases  286–287
Message bar, opening screen  1
Microsoft Graph, formatting charts

changing chart options  248–250
changing formatting options  250–253

Microsoft Graph toolbar  253
Microsoft Office Access Help  1
Minimum aggregate function  237
Minimum (Total row aggregate function)  

172
modifying. See also changing, editing

advanced queries
aggregated queries  237–241
calculated query fields  233–237
joins  230–233

Navigation forms  187–190
queries

adding criteria  117–119
adding tables  115–117

table relationships  53–54
tables

deleting  61–62
properties  58–60
renaming  60–61

More Fields menu  44, 70–71
More Forms button  178
More Forms menu  178
moving controls in a layout  151–152
multi-field primary keys  41–42
multi-item forms  178–179
Multiple Items tool  178–179
multivalued lookup fields  72–74

N
Name option (Create New Template from 

This Database)  284
navigating records

keyboard  35–37
navigation buttons  37–38

Navigation button  177
navigation buttons  37–38
Navigation forms

adding fields from tables  187
creating and modifying  187–190
layouts  187
Layout view  188

Navigation menu  177
Navigation Options dialog box  293
Navigation pane  1, 6, 287

Navigation Pane menu  7
New (blank) Record button  37
New command (Backstage view)  13
New Formatting Rule dialog box  147
New Name dialog box  265
New Query dialog box  108, 213
New Rule button  147
New Values field property  64
Next record button  37
normal forms  19
normalization  19, 167
null value  117
Number data type  16
Number group  143
number of columns (source data element)  

261
Number of Copies menu  257

O
Object Definition report  296
object dependencies, identifying  293–294
Object Dependencies task pane  293–294
objects

defined  6
saving  30–31

object tabs, user interface  9
ObjectType category  7
OLE Object data type  16
one-to-many relationships  231
Open command (Backstage view)  13
opening existing databases  4–6
opening screen  1
operations (expressions)  133
Options command (Backstage view)  13
Order By On Load table property  60
Order By On table property  60
Order By table property  60
order, control tab order  140–142
orientation (page orientation), printing 

reports and forms  157–159
Orientation table property  60
orphan records  53
outer joins  231
outermost field  45

P
Page footer section, Design view reports  96
Page header section, Design view reports  96
page margins, printing reports and forms  

157–159
Page number control  129
Page Numbers dialog box  129
page orientation, printing reports and forms  

157–159
Page Setup dialog box  205, 256
Page Size group  157
parameter queries  117
parent/child forms  183
Password Required dialog box  289
passwords

encrypting databases  289
strong passwords  289

Paste As dialog box  203

Paste Table As dialog box  29
PDF (Portable Document Format)  30, 254
Personal templates  23
Photo Exhibit table  80
pie charts  252
Portable Document Format (PDF)  30, 254
Portrait button  205
portrait orientation  158
position, controls  154–157
Position group  148
Precision field property  64
Press and Hold to View Sample button, 

chart preview  254
Preview Chart button  246
Preview option (Create New Template from 

This Database)  284
Previous record button  37
Price control  131
primary key

defined  14
modifying multi-field primary keys  

41–42
records  40–41

Primary Table option (Create New Template 
from This Database)  284

Print Data Only checkbox  158
Print dialog box  202, 256
printing

database objects  256–258
forms  157–159
reports  157–159
table relationships  54–55

Print Layout, advanced reports  202–206
Print Options tab  205
Print Preview  202
Print Preview screen  158
Print Preview tab  157
Print Report Button control  144
Print tab  256
Print Table Definition dialog box  295
priority up and down arrows  193
properties

fields  62–65
setting  63–65
setting validation rules  67

setting database properties  287–289
split forms  179–180
tables  58–60, 67

Properties dialog box  256, 287
Property Sheet, binding controls  130
Property Sheet button  233
Property Sheet pane  58–59, 233
Publish as PDF or XPS dialog box  273

Q
queries  10

action  220–230
append  221–224
delete  228–230
make table  224–225
update  225–228
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creating
Find Duplicates Query Wizard  

110–111
Find Unmatched Query Wizard  

113–115
multiple tables  111–113
tables  107–110

crosstab queries  212–214
defined  6
exporting data to Word  273–275
filtering data  121–122
modifying

adding criteria  117–119
adding tables  115–117
aggregated queries  237–241
calculated query fields  233–237
joins  230–233

saving as other type of object  254
saving filters as  218–220
sorting data  119–121
subqueries  214–218

Queries group  107
query criterion  117
query design grid  216–217
Query Setup group  115, 215
Query Tools Design tab  115
Query Wizard button  107, 213
Quick Access toolbar  1
Quick Print command  202
Quick Start  26–27, 69
Quick Styles button  145

R
range, defining when importing data  265
records

attaching/detaching documents  43–44
defined  14
deleting  38–39
editing  38-39
entering  38-39
filtering data within a table  47–49
finding and replacing data  42–44
groups. See groups
navigating

keyboard  35–37
navigation buttons  37–38

orphan  53
primary keys  39–42

defining  40–41
modifying multi-field primary keys  

41–42
removing filters  49
sorting data within a table  45–46

Record Selector box  38
Records group  38
Record Shortcut menu  38
record source

queries  107
reports  92

redundant data
defined  19
Table Analyzer Wizard  167

referential integrity  53

Refresh All button  247, 252–253
relational databases

defined  18
subforms  201

Relationship Report  55
relationships, tables  51–55

defining  51–53
modifying  53–54
printing  54–55
viewing  54-55

Relationship Tools  51
Remove Layout button  152, 155
Remove Sort button  100
removing. See also deleting

controls from a layout  151–152
filters, records  49

renaming tables  60–61
repairing databases  283
replacing data, records  42–44
Report button, creating simple reports  92
Report Design button  97
Report Design Tools  127

Arrange tab  148
Format tab  142

Report footer section, Design view reports  
96

Report header section, Design view reports  
96

Report Layout Tools  92-93, 127
Arrange tab  148
Design tab, Themes group  99

Report Layout view  103
reports

adding controls  128–140
bound controls  130–133
button controls  138–140
calculated controls  133–135
Control Wizard  135–138
unbound controls  128–129

aggregate fields  199–200
applying themes  99–100
creating  91

Design view  96–99
Report Wizard  94–96
simple reports  92–94

creating labels with Label Wizard  
206–209

creating Print Layout  202–206
defined  6, 91
defining groups

changing group options  198–199
group headers and footers  196–197
Report Wizard  193–196

filtering data  102–103
finding data within  103–104
formatting controls  143–145
grouping data  100-102
Object Definition  296
page margins/page orientation  157–159
printing  256
saving  92
sorting data  100–102
subforms  201–202

Reports group  91
Report view  103
Report Wizard

creating reports  94–96
defining groups  193–196
Grouping screen  95
Layout screen  95

Report Wizard dialog box  194
Required field property  64
Restore Down button  49
Result Type field property  64
Ribbon

opening screen  1
selecting tools/commands  11–12

Right Arrow keyboard command, navigating 
records  36

right outer joins  231
Rows & Columns group  150
rows (tables)  14
.rtf (Word Rich Text Format) file format  

273
Ruler button  157
running

export specifications  276
import specifications  269–270

S
Sample Preview dialog box  246
Save As command (Backstage view)  13
Save As dialog box  31, 255, 281
Save As menu  254, 280, 281
Save command (Backstage view)  13
Saved Imports tab  269
Save Import Steps screen  269
Save Object As command  30, 254
Save Splitter Bar Position property (split 

forms)  180
saving

database objects  30–31, 254–255
databases

previous versions  282
templates  283–286

export specifications  275
filters as queries  218–220
import specifications  268–269
reports  92

Scale field property  64
search bars  8
Search box  37
Search Fields As Formatted check box  42
Second Normal Form (2NF)  19
selecting tools/commands  10–14

Backstage view  12–14
Ribbon  11–12

select queries  107
SELECT statements  214–215
Send to Back command  155
Set Database Password dialog box  290
setting

database properties  287–289
data validation rules  67–68
field properties  63–65

sharing data
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charts
changing chart types  252–254
Chart Wizard  244–247
formatting charts  248–253

printing database objects  256–258
saving databases objects as another file 

type  254–255
Shift+Tab keyboard command, navigating 

records  36
Short Text data type  16
Show/Hide group  233
Show Margins checkbox  158
Show Table button  115
Show Table dialog box  52, 115, 215–216
Shutter Bar Open/Close button  8
simple forms  78
Simple Query Wizard  107–109
simple reports  92–94
size, controls  154–157
Size/Space button  155
Size to Fit command  155
Size to Grid command  155
Size to Narrowest command  155
Size to Shortest command  155
Size to Tallest command  155
Size to Widest command  155
Sizing & Ordering group  154
skipping columns/rows (source data ele-

ment)  261
Snap to Grid  155
Sort & Filter group  46, 85, 100, 121
sorting data

forms  85–88
queries  119–121
reports  100–102
tables  45–46

sort order  85
grouping option  198
reports  100

source data
importing data  260–265
linking to external data sources  265–267

specifications
export  274

running  276
saving  275

import  267
running  269–270
saving  268–269

Split Form Datasheet property (split forms)  
180

Split Form Orientation property (split 
forms)  180

Split Form Printing property (split forms)  
180

split forms  179–183
Split Form Size property (split forms)  180
Split Form Splitter Bar property (split forms)  

180
Split Horizontally button  153
splitting databases, Database Splitter wizard  

296–297
Sqlstatement (subqueries)  215

SQL (Structured Query Language) com-
mands  214

Stacked button  148
stacked layouts  148
standard database properties  287
Standard Deviation aggregate function  237
Standard Deviation (Total row aggregate 

function)  172
starting Access

Windows 8  4
Windows 10  2–3

startup screen  22
Status bar, opening screen  1
strong passwords  289
Structured Query Language (SQL) com-

mands  214
Subdatasheet Expanded table property  60
Subdatasheet Height table property  60
Subdatasheet Name table property  60
subforms  178, 183–185, 201–202
Subject (database property)  288
subqueries  214–218
subreports  201
Subreport Wizard  201
Sum aggregate function  237
summarizing table data  171–173
Summary tab  287
Sum (Total row aggregate function)  172
syntax, SELECT statements  214–215

T
Tab keyboard command, navigating records  

36
Table Analyzer Wizard  167–171
Table Analyzer Wizard dialog box  168
Table Design button  164
tables  14

adding to queries  115–117
creating

Application Parts Gallery and Quick 
Start  26–27

creating a table from a table  28–30
creating queries from  107–113
custom  164–167
defined  6
defining database tables  18–19
exporting to Excel  271–273
filtering data  47–49
freezing/unfreezing fields  49–51
hiding/unhiding fields  49–51
importing data from other databases  

264–265
linked tables  265
modifying

deleting  61–62
properties  58–60
renaming  60–61

properties  67
relationships

defining  51–53
modifying  53–54
printing  54–55
viewing  54-55

saving  30–31
saving as other type of object  254
sorting data  45–46
summarizing data  171–173
Table Analyzer Wizard  167–171

Tables and Related Views category  7
tab order, controls  140–142
Tab Order dialog box  140
tabs

Arrange  148
Create  148

Forms group  77
Queries group  107
Reports group  91
Templates group  26

Custom  287
Database Tools

Database Documenter  294–296
Database Splitter wizard  296–297
Object Dependencies task pane  

293–294
Design

Form Design Tools/Form Layout Tools  
127

Report Design Tools/Report Layout 
Tools  127

External Data  26, 261, 286
File

Backstage view  12
Info menu  280
Save As menu  280

Format  142
Form Design Tools Design contextual  80
Home

changing views  10
Sort & Filter group  85

object tabs  9
opening screen  1
Print  256
Print Options  205
Print Preview  157, 202
Query Tools Design  115
Report Layout Tools Design  99
Saved Imports  269
Summary  287

Tabular button  148
tabular format (source data element)  261
tabular layouts  148
templates

creating databases  23–25
defined  23
saving databases as  283–286

Templates group  26, 177
Text Align field property  64
Text Box button  134
Text Format field property  64
Text Formatting group  11
themes, applying to reports  99–100
Themes command  83–84
Themes gallery  84, 99
Third Normal Form (3NF)  19
Title (database property)  288
Title (grouping option)  198
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Titles tab (Chart Options dialog box)  249
Toggle Filter button  102, 121
tools  10–14. See also commands

Backstage view  12–14
Blank Form  81
Database Tools tab

Database Documenter  294–296
Database Splitter wizard  296–297
Object Dependencies task pane  

293–294
Filter by Form  86–88
Form  77–79
Form Wizard  82–83
Multiple Items  178–179
Report Layout  92–93
Ribbon  11–12

Tools group  127
Total row  171–173, 237
Totals button  172
Totals command  200
Totals (grouping option)  198
Totals menu  200

U
unbound controls  128–129
unequal joins  231
unfreezing fields, tables  49–51
Ungroup command  155
unhiding fields, tables  49–51
Unicode Compression field property  64
Unset Database Password dialog box  289
Up Arrow keyboard command, navigating 

records  36
update queries  220, 225–228
Use Control Wizards command  128, 136
user interface  1

changing views  10
Navigation pane  6
object tabs  9

V
Validation Rule field property  64
validation rules  67–68
Validation Rule table property  60
validation text  67
Validation Text field property  64
Validation Text table property  60
Variance aggregate function  237
Variance (Total row aggregate function)  172
VBA (Visual Basic for Applications) pro-

gram  138
View Code button  138
viewing table relationships  54–55
views

changing  10
Datasheet

creating split forms  179–183
field properties  64

Design
creating custom tables  164–167
creating forms  79–81
creating reports  96–99
field properties  62
group headers  197

Form  81, 179–183
Layout

creating forms  81–82
Multiple Items form  179
Navigation forms  188

Report  103
Report Layout  103

Visual Basic for Applications (VBA) pro-
gram  138

W
weak passwords  289
Where aggregate function  237
wildcard characters  42
Windows 8, starting Access  4
Windows 10, starting Access  2–3
with/without footer (grouping option)  198
with/without header (grouping option)  198
Word, exporting query data to  273–275
Word Rich Text Format (.rtf ) file format  

273

X
XML Paper Specification (XPS)  30, 254
XPS (XML Paper Specification)  30, 254

Y
Yes/No data type  16

Z
zero-length strings  66–67
Zoom dialog box  217
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